Subject: [IMRG] Help us test GeoLIM

From: "Mark Crovella" <[email-masked]>
Date: Tue, 3 May 2005 15:31:16 -0400

Dear  Colleague,

We are developing the GeoLIM project
(http://planetlab-01.ipv6.lip6.fr:10000/cbg.php
<http://planetlab-01.ipv6.lip6.fr:10000/cbg.php> ) which aims at
providing the geographic location of an Internet host  based solely on
its IP address. The key element of GeoLIM is its ability to transform
delay measurements between landmarks (probe machines) and a target host
into geographic distance constraints. It uses multilateration - like GPS
- to estimate the geographic location of the target host. 

We're seeking your help.   We ask you to test the geolocation solution
through the web page. This will take you no more than 3 minutes!

In particular, we are looking for people to test the accuracy of  our
methods on various host  types.  For instance, with the same IP address,
estimate your location when you access the internet through a low or
high-speed line (telephone or DSL/LAN).  

We're also looking for more Landmark nodes (nodes used to provide the
coordinates of the system).    Therefore, we need the name of the node
and its latitude/longitude.    We' d  be glad if you could provide us
with the name and location of such a host.

Do not hesitate to distribute this mail to colleagues interested.

The test is carried out on Planetlab (http://www.planet-lab.org/). 

We thank you for your contribution. More details about our algorithm can
be found at
(http://rp.lip6.fr/~gueye/articles/imc04-geolocation-full.pdf
<http://rp.lip6.fr/%7Egueye/articles/imc.pdf> ) 

Contact : [email-masked] 
-- 
Bamba Gueye
http://rp.lip6.fr/~gueye <http://rp.lip6.fr/%7Egueye> 
_______________________________________________
IMRG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/imrg

---

From: "Cottrell, Les" <[email-masked]>
Date: Wed, 4 May 2005 12:20:38 -0700

The idea is great. I would like to use it to find hosts that are hard to find and/or to verify conceptions of where hosts are located (e.g. using the TLD or  http://www.ip2location.com/ or whois etc.)  However, so far it has not worked well for me. My guess is that I am trying to find hosts in Africa, S. Asia and S. America and you have few landmarks that cover these regions. This may be deliberate since you mention planetLab. However, it reduces the usefulness of the tool.  I may be able to help with providing landmark sites in Africa, Pakistan, Bangalore, Brazil which might improve your accuracy and help me get better localization. Contact me (off the list) if interested.

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Crovella
Sent: Tuesday, May 03, 2005 12:31 PM
To: [email-masked]
Subject: [IMRG] Help us test GeoLIM

Dear  Colleague,

We are developing the GeoLIM project (http://planetlab-01.ipv6.lip6.fr:10000/cbg.php <http://planetlab-01.ipv6.lip6.fr:10000/cbg.php> ) which aims at providing the geographic location of an Internet host  based solely on its IP address. The key element of GeoLIM is its ability to transform delay measurements between landmarks (probe machines) and a target host into geographic distance constraints. It uses multilateration - like GPS - to estimate the geographic location of the target host. 

We're seeking your help.   We ask you to test the geolocation solution through the web page. This will take you no more than 3 minutes!

In particular, we are looking for people to test the accuracy of  our methods on various host  types.  For instance, with the same IP address, estimate your location when you access the internet through a low or high-speed line (telephone or DSL/LAN).  

We're also looking for more Landmark nodes (nodes used to provide the coordinates of the system).    Therefore, we need the name of the node and its latitude/longitude.    We' d  be glad if you could provide us with the name and location of such a host.

We thank you for your contribution. More details about our algorithm can be found at (http://rp.lip6.fr/~gueye/articles/imc04-geolocation-full.pdf <http://rp.lip6.fr/%7Egueye/articles/imc.pdf> )