Subject: [imss] STORM BOF: Presentations posted

From: [email-masked]
Date: Tue, 24 Mar 2009 12:58:34 -0400

The presentations for the STORM BOF on Thursday are now
posted at:

https://datatracker.ietf.org/meeting/74/materials.html

Scroll that page down to find the STORM BOF in the
Transport Area.

IMPORTANT: If you cannot attend the BOF in person and
think that a WG should be formed, please say so on the list.

My advice is that if you believe that any of the proposed
work should be done, then a WG is a *very good* idea because
a WG enables IETF's "rough consensus" techniques to be
applied (ensures work won't bog down in design issues).

I've done a "brain dump" into the main slide set - there
are a number of small items listed on the slides that have
been pointed out to me as worthy of attention.

One new item that I want to call attention to is that once
upon a time (2000), an IP Protocol Number was allocated for
what I believe to have been a precursor to the FCIP protocol.
FCIP does not use its own IP Protocol Number because it
uses TCP.  It would be a "good thing" for the new STORM WG
to investigate whether this number is actually unused and
hence can be returned to IANA for reassignment (these
numbers are a scarce resource).

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

---

From: [email-masked]
Date: Tue, 24 Mar 2009 16:32:08 -0400

Paul,

Here are the details on that one:

  This is useful for a target appliance which serves a large number of
  concurrent sessions with unsolicited data and adjusts the transport
  windows on a dynamic basis. In particular, inactive sessions (i.e.,
  those which have not issued any SCSI commands for a reasonable time)
  may have their window reduced to reassign resources to the active
  sessions.

  One method is as follows. The target issues an Asynchronous Message - 
  "target requests parameter negotiation" to provoke the initiator into
  consuming a command. The target responds to the Text request with an
  empty Text response and repeats the procedure until the window has
  been reduced to the desired level.

If this is considered important ("this is not a problem in practice"
opinions are welcome), there are obvious opportunities for improvement.

Thanks,
--David

> -----Original Message-----
> From: Paul Koning [mailto:[email-masked]] 
> Sent: Tuesday, March 24, 2009 3:12 PM
> To: Black, David
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Ips] STORM BOF: Presentations posted
> 
> David,
> 
> On your slides:
> 
> Page 7 mentions "CmdSN window size reduction".  Could you elaborate?
> 
>      paul
> 
> 
>

---

From: Paul Koning <[email-masked]>
Date: Tue, 24 Mar 2009 15:12:15 -0400

David,

On your slides:

     paul