Subject: RE: [INDEP] Workload management ( was Re: Queue time? )

From: "Gray, Eric" <[email-masked]>
Date: Thu, 8 Jun 2006 16:24:23 -0400

Leslie,

	Thanks for the reference.

--
Eric

--> -----Original Message-----
--> From: Leslie Daigle [mailto:[email-masked]] 
--> Sent: Thursday, June 08, 2006 3:58 PM
--> To: Gray, Eric
--> Cc: John C Klensin; Joel M. Halpern; [email-masked]
--> Subject: Re: [INDEP] Workload management ( was Re: Queue time? )
--> 
--> 
--> Eric,
--> 
--> See Section 3.1 of
--> 
--> http://www.ietf.org/internet-drafts/draft-iab-rfc-editor-00.txt
--> 
--> The documents you describe are covered in the "IETF Stream".
--> 
--> John's document goes to Section 3.4 of that document -- independent
--> submission stream.
--> 
--> Leslie.
--> 
--> Gray, Eric wrote:
--> > John,
--> > 
--> > 	Your draft may indeed state things that way.  However
--> > there has always been a process for independently submitting
--> > a standards track document previously.  As an author of one
--> > such submission, I know.
--> > 
--> > 	However, that's a distraction to the point.  If the 
--> > discussion on this list is meant to deal with informational
--> > ID submissions - intended for publication as an RFC - then
--> > much of the discussion has been off-target.
--> > 
--> > 	Soundness, consensus, etc. are irrelevant to the idea
--> > of reporting of factual information.
--> > 
--> > --
--> > Eric
--> > 
--> > --> -----Original Message-----
--> > --> From: John C Klensin [mailto:[email-masked]] 
--> > --> Sent: Thursday, June 08, 2006 3:05 PM
--> > --> To: Gray, Eric; Joel M. Halpern
--> > --> Cc: [email-masked]
--> > --> Subject: RE: [INDEP] Workload management ( was Re: 
--> Queue time? )
--> > --> 
--> > --> 
--> > --> 
--> > --> --On Thursday, 08 June, 2006 14:47 -0400 "Gray, Eric"
--> > --> <[email-masked]> wrote:
--> > --> 
--> > --> > 	I suspect that the measures that need to be applied in
--> > --> > "informational" - or even BCP - independent submissions is
--> > --> > accuracy and relevance.  Soundness - on the other hand - is
--> > --> > a reasonable measure for independent standard's submissions,
--> > --> > again long with relevance.
--> > --> > 
--> > --> > 	Also, relevance - particularly in a standards submission
--> > --> > - has at least two dimensions: is it relevant to 
--> the Community 
--> > --> > served by the RFC process and is it more relevant 
--> there than 
--> > --> > anywhere else.
--> > --> 
--> > --> I am getting confused.   There is no such thing as an
--> > --> "independent standards submission".  The independent 
--> submission
--> > --> process cannot be used for standards track documents: such
--> > --> documents must be submitted to, and processed by, the IESG.
--> > --> Independent submissions are possible only for 
--> Informational or,
--> > --> occasionally, Experimental documents. 
--> > --> 
--> > --> I thought the document made that clear.  If it isn't; 
--> text would
--> > --> be appreciated.
--> > --> 
--> > -->     john
--> > --> 
--> > 
--> > _______________________________________________
--> > INDEPENDENT mailing list
--> > [email-masked]
--> > https://www1.ietf.org/mailman/listinfo/independent
--> > 
--> 

_______________________________________________
INDEPENDENT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/independent

---

From: "Gray, Eric" <[email-masked]>
Date: Thu, 8 Jun 2006 16:21:09 -0400

Joel,

	While you're technically correct, most of the informational 
RFCs that document protocols, document either proprieary protocols 
or protocols developed elsewhere.

	For example, it has often been the case that IANA asked for
an informational RFC before assigning a number (or name).  Such
submissions might not be subjected to "soundness" on their own
merit - though they might be subjected to some scrutiny on the 
basis of their potential for interaction with other activities.
Usually the policy that applies in such a case is meant to be
established when a name-space is defined for IANA.

	In the event that no documentation is required to obtain a
number or name from IANA, any document voluntarily offered by an
individual should be accepted as is.  Subjecting it to unecessary
"process" will invariably lead to retraction, loss of information
and discouragement of future efforts to provide more than minimal
required information.

	The same applies generally to informational submissions to
document what a proprietary protocol or implementation does.  And
the same could be said for catch-up documentation that reports
on the details of something that has become a de-facto standard.

	We should avoid giving the impression that all things are
subject to approval, concensus, etc.  What they are subject to 
should be a simpler test of whether or not this is the place to
talk about them.

--
Eric

--> -----Original Message-----
--> From: Joel M. Halpern [mailto:[email-masked]] 
--> Sent: Thursday, June 08, 2006 3:40 PM
--> To: Gray, Eric
--> Cc: [email-masked]
--> Subject: RE: [INDEP] Workload management ( was Re: Queue time? )
--> 
--> Many Informational RFCs document protocols, behaviors, or thoughts 
--> that are not "factual information."  This is true of many 
--> independent 
--> submissions to the RFC Editor.
--> As such, soundness definitely does apply to such documents.
--> 
--> Yours,
--> Joel M. Halpern
--> 
--> At 03:18 PM 6/8/2006, Gray, Eric wrote:
--> >         However, that's a distraction to the point.  If the
--> >discussion on this list is meant to deal with informational
--> >ID submissions - intended for publication as an RFC - then
--> >much of the discussion has been off-target.
--> >
--> >         Soundness, consensus, etc. are irrelevant to the idea
--> >of reporting of factual information.
--> >
--> >--
--> >Eric
-->

---

From: "Gray, Eric" <[email-masked]>
Date: Thu, 8 Jun 2006 17:56:08 -0400

Keith,

	Okay.

	This makes the concern over document/idea quality relevant,
but it also makes me wonder - once again - how "independent" is
different from "individual" and also to wonder how we will deal 
with those documents that are more aimed at becoming a standard
but not important (or big) enough to warrant the BoF/WG process. 

	If we are allowing all sorts of individual ID submissions 
to be treated as "independent" informational RFCs, we're fuzzing
the line even worse than it was previously.  We seem to encourage
submission of "ideas" (as opposed to information) as independent
submissions - potentially causing us to spend much more time on
these independent submissions than we will spend on regular IETF
submissions.

	As for the reference to RFCs as "requests for comment", I
am reasonably sure that it would be perfectly acceptable to follow
any information RFC with another one that "comments" on it.  Hence
if an idea is published in the guise of information and we then 
find the idea is without merit, we can certainly comment on it in
another RFC.

	The real trial is then keeping the stream relevant.

--
Eric

--> -----Original Message-----
--> From: Keith Moore [mailto:[email-masked]] 
--> Sent: Thursday, June 08, 2006 5:45 PM
--> To: Gray, Eric
--> Cc: [email-masked]
--> Subject: Re: [INDEP] Workload management ( was Re: Queue time? )
--> 
--> > Keith,
--> > 
--> > 	I agree.  However, Informational RFCs are presumably about
--> > information. 
--> 
--> and they're presumably requests for comments, also.
--> somehow the two concepts "information" and "RFC" seem mutually
--> exclusive.
--> 
--> I don't think we're accustomed to insisting that 
--> Informational RFCs be
--> purely informational, nor do I think it would serve our purposes to
--> insist on it.
-->

---

From: Bob Braden <[email-masked]>
Date: Fri, 9 Jun 2006 14:56:14 -0700 (PDT)

Joe Touch:

As noted in the RFC Editor report at IETF 65:

Nov 2006 - Feb 2006:
Submissions: (count of documents)
	IETF submissions:      121
	Independent submissions: 7

These numbers are fairly typical of recent history.

RFC Editor/bb