Subject: [Insipid] FW: I-D Action: draft-jones-insipid-session-id-reqts-02.txt

From: "Paul E. Jones" <[email-masked]>
Date: Sun, 17 Jun 2012 19:33:00 -0400

Folks,

I posted a revised version of the requirements document.  This version moves
the use cases in front of the actual requirements.

We discussed having more fleshed out use cases.  I'm happy to insert those
if somebody will provide the appropriate text.

Also, there are two requirements that we reviewed on the last call that need
further input.

REQ1a: This is intended to be a requirement like REQ1, but focused on
non-dialog creating transactions.  If we wish to introduce this requirement,
please provide appropriate text.

REQ6: This was changed and we discussed merging it with REQ5.  I'm OK with
that approach, but the original requirement was to not provide any hint that
a middlebox changed anything.  I know Partha is favorable to a merge and
dropping REQ6 entirely.  Hadriel, what's your preference?  Others?

Paul

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of [email-masked]
> Sent: Sunday, June 17, 2012 7:25 PM
> To: [email-masked]
> Subject: I-D Action: draft-jones-insipid-session-id-reqts-02.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
> 	Title           : Requirements for an End-to-End Session
> Identification in IP-Based Multimedia Communication Networks
> 	Author(s)       : Paul E. Jones
>                           Gonzalo Salgueiro
>                           James Polk
>                           Parthasarathi Ravindran
>                           Laura Liess
>                           Roland Jesske
>                           Salvatore Loreto
>                           Hadriel Kaplan
> 	Filename        : draft-jones-insipid-session-id-reqts-02.txt
> 	Pages           : 9
> 	Date            : 2012-06-17
> 
> Abstract:
>    This document specifies the requirements for an end-to-end session
>    identifier in IP-based multimedia communication networks.  This
>    identifier would enable endpoints, intermediate devices, and
>    management and monitoring systems to identify a session end-to-end,
>    associate multiple endpoints with a given multipoint conference,
>    track communication sessions when they are redirected, and associate
>    one or more media flows with a given communication session.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-jones-insipid-session-id-reqts
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-jones-insipid-session-id-reqts-02
> 
> A diff from previous version is available at:
> http://tools.ietf.org/rfcdiff?url2=draft-jones-insipid-session-id-reqts-02
> 
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: James Polk <[email-masked]>
Date: Mon, 18 Jun 2012 14:29:45 -0500

During the last interim, we discussed making the requirements draft a 
WG item. IMO, this version satisfies each of the comments well enough 
to propose this document move forward as a WG item, especially 
considering the timeframes this WG has to work under (i.e., get the 
solution doc done by December `12). I believe what's left to resolve 
in the requirements draft is minor and can be worked on while a WG 
item over the next few months to the point of consensus. Agreed?

James

At 06:33 PM 6/17/2012, Paul E. Jones wrote:
>insipid mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/insipid

---

From: Laura Liess <[email-masked]>
Date: Mon, 25 Jun 2012 13:57:33 +0200

Paul,

If more detailed text for the use cases is needed, I think the best
way to provide the text is if people provide use case  text for the
requirements  they are interested in. I could try to provide the  use
case  text for REQ1, REQ4, REQ5 and REQ7.  But it is not clear for me
if this is needed or not.

Thanks
Laura

2012/6/18 Paul E. Jones <[email-masked]>:
> the use cases in front of the actual requirements.>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 25 Jun 2012 14:03:59 +0000

Hi,

I already provided text for the recording use case see http://www.ietf.org/mail-archive/web/insipid/current/msg00127.html.

Regarding the comments I made in the 01 draft and the response from Paul I don't think any related changes have found their way in to the 02 draft (See http://www.ietf.org/mail-archive/web/insipid/current/msg00124.html). 

For example the proposed change to the wording of the use case "Identification of devices taking part in the same multipoint conference" to something like "Association of sessions taking part in the same multipoint conference" has not been made.

For me the main problem area is likely to be the forwarding/transfer use case which could potentially open up a lot of issues so I would like to see some use cases in this area to understand in more details what scenarios the authors want to cover. 

Regarding adoption then I don't see any reason to hold up adoption and will try to contribute once it is adopted.

Regards
Andy

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Laura Liess
> Sent: 25 June 2012 07:58
> To: Paul E. Jones
> Cc: [email-masked]; Hadriel Kaplan
> Subject: Re: [Insipid] FW: I-D Action: draft-jones-insipid-session-id-
> reqts-02.txt
> 
> Paul,
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 25 Jun 2012 11:57:35 -0400

Andrew,

Thanks. I put that in my current draft.  I'm not sure how to organize it
right now, but perhaps section 3.x might be "Use Cases" and then 3.1 would
be "Session Recording" (containing your text) and 3.2 might be another
detailed use case.  I'm open to suggestions.

Do we need to indicate "Derived Requirements" as was done for the RTCWeb
requirements document?

Paul

> From: Hutton, Andrew [mailto:[email-masked]]
> Sent: Monday, June 25, 2012 10:04 AM
> To: Laura Liess; Paul E. Jones
> Subject: RE: [Insipid] FW: I-D Action: draft-jones-insipid-session-id-
> reqts-02.txt
> 
> Hi,
> 
> I already provided text for the recording use case see
> http://www.ietf.org/mail-archive/web/insipid/current/msg00127.html.
> 
> Regarding the comments I made in the 01 draft and the response from Paul I
> don't think any related changes have found their way in to the 02 draft
> (See http://www.ietf.org/mail-archive/web/insipid/current/msg00124.html).
> 
> For example the proposed change to the wording of the use case
> "Identification of devices taking part in the same multipoint conference"
> to something like "Association of sessions taking part in the same
> multipoint conference" has not been made.
> 
> For me the main problem area is likely to be the forwarding/transfer use
> case which could potentially open up a lot of issues so I would like to
> see some use cases in this area to understand in more details what
> scenarios the authors want to cover.
> 
> Regarding adoption then I don't see any reason to hold up adoption and
> will try to contribute once it is adopted.
> 
> Regards
> Andy
> 
> > > the use cases in front of the actual requirements.> We discussed
> > > having more fleshed out use cases.  I'm happy to insert
> > those
> > > REQ1a: This is intended to be a requirement like REQ1, but focused
> > > on non-dialog creating transactions.  If we wish to introduce this
> > requirement,
> > > REQ6: This was changed and we discussed merging it with REQ5.  I'm
> > > OK
> > with

---

From: Laura Liess <[email-masked]>
Date: Mon, 25 Jun 2012 18:02:54 +0200

> Do we need to indicate "Derived Requirements" as was done for the RTCWeb

I think this could be usefull in later discussions an ist not
difficult to do for the guy describing the use case. I think we should
do it.

Thanks
Laura

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 25 Jun 2012 16:32:16 +0000

+1 it would be nice if we could do this.

Andy

> From: Laura Liess [mailto:[email-masked]]
> Sent: 25 June 2012 12:03
> To: Paul E. Jones
> Cc: Hutton, Andrew; [email-masked]; Hadriel Kaplan
> >> (See http://www.ietf.org/mail-
> archive/web/insipid/current/msg00124.html).
> >>
> >> > > Also, there are two requirements that we reviewed on the last
> call
> >> > that need
> >> > > further input.
> >> > >
> >> > > that approach, but the original requirement was to not provide
> any
> >> > hint that
> >> > > a middlebox changed anything.  I know Partha is favorable to a
> merge
> >> > and
> >> > >>    management and monitoring systems to identify a session end-
> to-
> >> > end,
> >> > >> https://datatracker.ietf.org/doc/draft-jones-insipid-session-
> id-
> >> > reqts
> >> > >>
> >> > >> http://tools.ietf.org/rfcdiff?url2=draft-jones-insipid-session-
> id-
> >> > reqts-02
> >> > >>
> >> > >>