Subject: [Insipid] draft-ietf-insipid-logme-marking-02.txt: comments

From: Jörgen Axell <[email-masked]>
Date: Fri, 8 May 2015 12:31:39 +0000

In general, I believe this functionality is useful to be able to trace faults in a network. Having a signalling based activation is a simple way to follow the path in a network.  I have a few comments:

Section 3: I assume the Network A, B, C has no connection to Country A, B, C. Maybe numbers or different letters is clearer.

REQ-6: I understand that if the SIP proxy marks a response for logging because the UAS did not echo the log-me marker, then it needs to remember that the marker was present in the request. It is harder to understand what the SIP proxy needs to remember if it decides to mark a request that the UA did not mark. Is this rather configuration than remembering something?

6.2.1 The text following "Activating a debug mode" contains a number of "it" which I find hard to read. I assume "it" refers to the activation request but I don't think that is clear from the text.

On the nit side, REQ-1 contains a "log me", which I believe should be "log-me".

Regards,
Jörgen

-----Original Message-----
From: insipid [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 27 February 2015 14:21
To: [email-masked]
Cc: [email-masked]
Subject: [Insipid] I-D Action: draft-ietf-insipid-logme-marking-02.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the INtermediary-safe SIP session ID Working Group of the IETF.

        Title           : Marking SIP Messages to be Logged
        Author          : Peter Dawes
	Filename        : draft-ietf-insipid-logme-marking-02.txt
	Pages           : 14
	Date            : 2015-02-27

Abstract:
   SIP networks use signalling monitoring tools to diagnose user
   reported problems and for regression testing if network or user agent
   software is upgraded.  As networks grow and become interconnected,
   including connection via transit networks, it becomes impractical to
   predict the path that SIP signalling will take between user agents,
   and therefore impractical to monitor SIP signalling end-to-end.

   This document describes an indicator for the SIP protocol which can
   be used to mark signalling as of interest to logging.  Such marking
   will typically be applied as part of network testing controlled by
   the network operator and not used in regular user agent signalling.
   However, such marking can be carried end-to-end including the SIP
   user agents, even if a session originates and terminates in different
   networks.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-insipid-logme-marking/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-insipid-logme-marking-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-insipid-logme-marking-02

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
insipid mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/insipid

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Mon, 11 May 2015 05:23:09 +0000

Thanks for your review, Jorgen.  I will let Peter, as editor of the document, respond to your review but I am updating the subject since it is misleading as it is a review is for the requirements document and not the ‘logme’ solution document.

Cheers,

Gonzalo
<as chair>

> On May 8, 2015, at 8:31 AM, Jörgen Axell <[email-masked]> wrote:
>

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Mon, 11 May 2015 05:24:56 +0000

Cheers,

Gonzalo
<as chair>

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Mon, 11 May 2015 05:25:14 +0000

Cheers,

Gonzalo
<as chair>

---

From: "Dawes, Peter, Vodafone Group" <[email-masked]>
Date: Mon, 11 May 2015 11:45:41 +0000

Hello Jörgen, thanks very much for your review and for identifying these issues in the current text of the requirements draft. I suggest some resolutions below. 

Regarding Section 3, I agree that not using the letters A, B, C for both would more clearly distinguish between countries and networks, I will change this in the next version.

Regarding REQ6:, you make a good point that "It is harder to understand what the SIP proxy needs to remember if it decides to mark a request that the UA did not mark ". The solutions draft proposes that marking is always on a per-dialog granularity, i.e. marking always starts with the dialog-creating SIP request, which makes the proxy behaviour easier to understand. A proxy may mark the dialog-creating request (if the UA didn't do it) and any subsequent in-dialog requests sent in the originating to terminating direction. It might be worth including a REQ9: as follows to put clearer boundaries on the behaviour.

REQ9: "log me" marking of requests and responses MUST be applied on a per-dialog granularity. If applied, "log me" marking MUST begin with the dialog-creating request and SHOULD continue to the dialog end. "log me" marking MUST NOT be stopped and re-started on a given dialog.

perhaps this would be better placed between REQ7: and REQ8:

Regarding Section 6.2.1, I will replace each occurrence of "it" in the next version (new text between asterisks) as follows.

The "log me" marker is not sensitive information, although (it) *the "log me" marker* 
will sometimes be inserted because a particular device is experiencing problems.

Activating a debug mode affects the operation of a terminal,
   therefore (it) *debugging configuration* must be supplied by an authorized server to an
   authorized terminal, (it) *debugging configuration* must not be altered in transit, and (it) must
   not be readable by an unauthorized third party.

Logged signalling is privacy-sensitive data, therefore (it) *signalling logs* must be
   passed to an authorized server, (it) *signalling logs* must not be altered in transit,
   and (it) must not be readable by an unauthorized third party.

Best regards,
Peter

-----Original Message-----
From: Gonzalo Salgueiro (gsalguei) [mailto:[email-masked]] 
Sent: 11 May 2015 06:25
To: Jörgen Axell
Cc: [email-masked]; Dawes, Peter, Vodafone Group
Subject: Review of draft-ietf-insipid-logme-reqs-02 [[WAS: Re: [Insipid] draft-ietf-insipid-logme-marking-02.txt: comments]]

Cheers,

Gonzalo
<as chair>