Subject: [Insipid] I-D Action: draft-ietf-insipid-session-id-17.txt

From: [email-masked]
Date: Mon, 08 Feb 2016 09:39:47 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the INtermediary-safe SIP session ID of the IETF.

        Title           : End-to-End Session Identification in IP-Based Multimedia Communication Networks
        Authors         : Paul E. Jones
                          Gonzalo Salgueiro
                          Chris Pearce
                          Paul Giralt
	Filename        : draft-ietf-insipid-session-id-17.txt
	Pages           : 39
	Date            : 2016-02-08

Abstract:
   This document describes an end-to-end Session Identifier for use in
   IP-based multimedia communication systems that enables endpoints,
   intermediary devices, and management systems to identify a session
   end-to-end, associate multiple endpoints with a given multipoint
   conference, track communication sessions when they are redirected,
   and associate one or more media flows with a given communication
   session.

   This document also describes a backwards compatibility mechanism for
   an existing session identifier implementation (RFC 7239) that is
   sufficiently different from the procedures defined in this document.

   This document obsoletes RFC 7239.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-insipid-session-id/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-insipid-session-id-17

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-insipid-session-id-17

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Paul Giralt (pgiralt)" <[email-masked]>
Date: Mon, 8 Feb 2016 17:45:22 +0000

INSIPID WG, 

I have posted the -17 version to address Brett’s concerns regarding the handling of remote UUID changes, especially in the cases of mid-dialog re-INVITEs that result in an error. 

Please review and let me know if these changes address your concerns. 

Thanks, 
-Paul

> On Feb 8, 2016, at 12:39 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> insipid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/insipid

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 8 Feb 2016 13:27:28 -0500

Section 3 replaced a reference to 7206 with one to 2119. But the text 
still says that this reference supplies requirements and use cases, and 
definitions of "session identifier" and "communication session", which 
is not so.

I guess a reference to 2119 should have been *added*, rather than 
replacing the reference to 7206.

And then a formatting nit:

There seems to have been a global change:

    s/[RFCnnnn]/RFC nnnn [RFCnnnn]/

I find this pretty ugly to read. Rather than repeat the rfc number in 
this way, I think it would read better to use numeric reference numbers. 
E.g., "RFC nnn [mm]".

	Thanks,
	Paul

---

From: "Paul Giralt (pgiralt)" <[email-masked]>
Date: Mon, 8 Feb 2016 18:42:13 +0000

Thanks. I actually converted the whole document from Word to XML in this revision and looks like I made a copy/paste error with the 2119 reference. Thanks for catching that. It should have been 7206 as you pointed out. 

The previous draft was actually inconsistent in referencing other RFC’s. Sometimes it was RFC nnnn [RFCnnnn] and sometimes it was [RFCnnnn] so when I converted to XML I went with the former consistently throughout the draft. I agree it’s ugly to read. I can switch it to consistently follow the [RFCnnnn] format as it was in parts of the previous draft. I think this would be better than numeric references. 

Thanks for the feedback. 

-Paul

> On Feb 8, 2016, at 1:27 PM, Paul Kyzivat <[email-masked]> wrote:
> 
> Section 3 replaced a reference to 7206 with one to 2119. But the text still says that this reference supplies requirements and use cases, and definitions of "session identifier" and "communication session", which is not so.
> 
> I guess a reference to 2119 should have been *added*, rather than replacing the reference to 7206.
> 
> I find this pretty ugly to read. Rather than repeat the rfc number in this way, I think it would read better to use numeric reference numbers. E.g., "RFC nnn [mm]".
> 
> 	Thanks,
> 	Paul
>

---

From: "Paul Giralt (pgiralt)" <[email-masked]>
Date: Mon, 8 Feb 2016 21:43:13 +0000

Abstract should say RFC 7329, not RFC 7239. This will be resolved in the next revision. 

-Paul