Subject: RE: [Int-area] Architectural reasons why tunnelling is an indicationof a failure

From: "Bound, Jim" <[email-masked]>
Date: Tue, 20 Sep 2005 08:42:21 -0400

Layer 3 is not recursive.  All the layers are virtual that is what OSI
misssed and the entire notion of N+1 view of passing information, in
addition to a poor architecture reference model.  The virtualization for
tunnels are actually done on most implementations in a layer that is
developing above transport called the infrastructure layer.

My .25 cents.  I see no issue with using tunnels the entire issue of not
using them is absurd.

/jim 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Brian E 
> Carpenter
> Sent: Monday, August 08, 2005 10:44 AM
> To: James Kempf
> Cc: Internet Area; IAB
> Subject: Re: [Int-area] Architectural reasons why tunnelling 
> is an indicationof a failure
> 
> James Kempf wrote:
> > Pekka,
> > 
> > I agree with Joe and Tony. Tunnels are a tool for 
> virtualizing the address
> > space. If you are going to propose that they are a flawed 
> tool, then I think
> > you need to propose an alternative that has "better" (for 
> some sense of the
> > word)  properties. The only alternative I can think of (swapping IP
> > addresses in the header, i.e. NAT) is worse,  but maybe 
> there are other
> > alternatives.
> 
> There is at least one, i.e. the approach taken by shim6, 
> which explicitly
> virtualizes the address ("identifier") seen by upper layers, and
> uses a variety of addresses ("locators") at a slightly less virtual
> level known as Layer 3, which by the way was invented to virtualize
> Layer 2 addresses about 30 years ago.
> 
> If we are thinking forward, I would like to repeat a remark I've made
> a number of times, in all seriousness: the flaw in the OSI model is
> that it has a finite number of layers instead of being recursive.
> It seems that we need to make "Layer 3" recursive to have a clean
> virtualization approach. Tunnels slot naturally enough into a 
> recursive
> view of the nextwork layer.
> 
>     Brian
> 
> 
> 
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/int-area
> 

_______________________________________________
Int-area mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/int-area

---

From: Joe Touch <[email-masked]>
Date: Tue, 20 Sep 2005 14:17:13 -0700

Some comments below, though I agree with most of what Jim posted:

Bound, Jim wrote:
> Layer 3 is not recursive. 

I agree; there can be recursive L3's, which rely on L3 service below and
provide L3 service above. We developed such a layer, composed of two
internal layers of headers, in our Virtual Internet Architecture and
deploy them in our X-Bone system.

> All the layers are virtual that is what OSI
> misssed 

FYI, this was proposed in a number of projects, notably SuperNet and
MorphNet about 10 years ago, although both stopped shy of a virtual
physical layer (I don't really understand what a L1VPN is). Refs are
available in our X-bone publications.

> and the entire notion of N+1 view of passing information, in

I'm not sure what that layer is. Our architecture has network layers
built on top of network layers; tunnels are part of that, the way that
links are part of a network (they won't work without routers and hosts,
and we won't work without virtual routers and virtual hosts).

Tunnels on top of transport layers invite unncessary inefficiency, and
exist largely to circumnavigate security mechanisms that prevent
unprivileged users from creating IP tunnels.

Joe