Subject: [Int-area] Fwd: I-D ACTION:draft-bagnulo-multiple-hash-cga-00.txt

From: marcelo bagnulo braun <[email-masked]>
Date: Fri, 9 Jun 2006 10:41:45 +0300

Hi,

we have submitted the following draft. It is an individual submission  
and since there is not related to a specific wg, perhaps it could be  
discussed here.

The goal of the document is to analyze the impact of new collision  
attacks in CGAs and to update the CGA spec to support multiple hash  
functions.

Comments are welcome

thanks, marcelo

Inicio mensaje reenviado:

> De: [email-masked]
> Fecha: 8 de junio de 2006 22:50:01 GMT+03:00
> Para: [email-masked]
> Cc: Asunto: I-D ACTION:draft-bagnulo-multiple-hash-cga-00.txt
> Responder a: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts  
> directories.
>
>
> 	Title		: Support for Multiple Hash Algorithms in Cryptographically  
> Generated Addresses (CGAs)
>
> 	Author(s)	: M. Bagnulo, J. Arkko
> 	Filename	: draft-bagnulo-multiple-hash-cga-00.txt
> 	Pages		: 9
> 	Date		: 2006-6-8
> 	
> This document analyzes the implications of recent attacks on commonly
> used hash functions on Cryptographically Generated Addresses (CGAs)
> and updates the CGA specification to support multiple hash
> algorithms.
>
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-bagnulo-multiple-hash-cga 
> -00.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of  
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
>
> Internet-Drafts are also available by anonymous FTP. Login with the  
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-bagnulo-multiple-hash-cga-00.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-bagnulo-multiple-hash-cga-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
Int-area mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/int-area

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Fri, 9 Jun 2006 08:52:35 -0700

Regarding the collision attack possibility, this was discussed last year
on the HIP mailing list, since it similarly pertains to host identifier
tags:
http://www1.ietf.org/mail-archive/web/hipsec/current/msg01277.html

I think your draft reaches similar conclusions.

Tom 

> -----Original Message-----
> From: marcelo bagnulo braun [mailto:[email-masked]] 
> Sent: Friday, June 09, 2006 12:42 AM
> To: Internet Area
> Subject: [Int-area] Fwd: I-D 
> ACTION:draft-bagnulo-multiple-hash-cga-00.txt 
> 
> Hi,
>

---

From: marcelo bagnulo braun <[email-masked]>
Date: Mon, 12 Jun 2006 10:16:12 +0300

Hi Tom,

thanks for the pointer,

Yes, i think that the same conclusion/reccomendation is in the draft, 
this is indeed reassuring

thanks, marcelo