Subject: Re: [Int-area] FW: [RRG] Subnetwork Encapsulation and AdaptationLayer (SEAL)

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 4 Mar 2008 08:14:56 -0800

Iljitsch,

>But the part that really bothers me is that there will ALWAYS be  
>fragmentation even when the source host would have been perfectly  
>capable of reducing its packet size.

Turning back to this, the current SEAL draft is silent
on behavior in the face of persistent fragmentation. From
"Fragmentation Considered Harmful", the pain point is gross
fragmentation in the presence of congestion, since the loss
of a single fragment will result in the whole packet being
retransmitted causing yet further congestion. Approaches to
handling this include 1) drop large packets, and tell sources
to start sending smaller ones, 2) treat the loss of fragments
as a congestion indication, 3) some combination of the two.

1) will always result in loss, and can saddle sources with a
too-small packet size indefinitely (or for 10min's at least).
Plus, there may be sources that cannot reduce their packet
sizes below a certain threshold, in particular 1280 bytes for
IPv6. 2) seems like a more tenable approach, but the best
answer may lie somewhere in-between, i.e., approach 3). The
next SEAL draft version will discuss this.

Fred
[email-masked]

>
>Iljitsch
>_______________________________________________
>Int-area mailing list
>[email-masked]
>http://www.ietf.org/mailman/listinfo/int-area
>
_______________________________________________
Int-area mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-area

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Wed, 5 Mar 2008 10:21:29 +0100

> as a congestion indication, 3) some combination of the two.

If I were an implementer, what I'd probably look at is making a  
separate, shorter queue for packets that cause the encapsulated packet  
to be fragmented and send too bigs for those if there is a tail drop.
_______________________________________________
Int-area mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-area

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 5 Mar 2008 08:38:12 -0800

Iljitsch, 

>-----Original Message-----
>From: Iljitsch van Beijnum [mailto:[email-masked]] 
>Sent: Wednesday, March 05, 2008 1:21 AM
>To: Templin, Fred L
>Cc: Internet Area
>Subject: Re: [Int-area] FW: [RRG] Subnetwork Encapsulation and 
>AdaptationLayer (SEAL)
>

>to be fragmented and send too bigs for those if there is a tail drop.

Maybe you could say more about this; one thing for sure
we do not want is gross reordering of packets.

Fred