Subject: [Int-area] Fwd: Combine WGs for NAT66 discussion re internet area open meeting agenda

From: "Eric Klein" <[email-masked]>
Date: Wed, 12 Nov 2008 17:17:04 +0200

Jari,

As the NAT66 discussion seems to be happening in several WGs at once, it
seems to me (and Tim) that you should try to hold some sort of joint meeting
in INT-AREA to get some sort of consensus yes or no for NAT in v6 or at
least to do a gap analysis

Current Groups working on it are v6OPS, BEHAVE, Softwires, RRG, and now v6.

Thanks,
Eric

---------- Forwarded message ----------
From: Tim Chown <[email-masked]>
Date: Wed, Nov 12, 2008 at 5:07 PM
Subject: Re: Combine WGs for NAT66 discussion
To: Eric Klein <[email-masked]>

Well the ASRG has 'invaded' the main ietf list, I think nat66 is best
placed there... as ULAs and other issues were.    And yes I suspect nat66
could usefully be discussed in Minneapolis in int-area, v6man and behave,
but int-area would be a nice 'cross wg' place to hold a general discussion,
so ask the chair(s) :)

On Wed, Nov 12, 2008 at 04:59:22PM +0200, Eric Klein wrote:
>
>    thanks.  I  suspect  that this should have its own cross WG session in
>    Minneapolis.
>    On Wed, Nov 12, 2008 at 4:53 PM, Tim Chown <[1][email-masked]>
wrote:
>
>      You can always try [2][email-masked] ;)
>
>    On Wed, Nov 12, 2008 at 04:43:23PM +0200, Eric Klein wrote:
>    >
>    >    Cross posted to several lists
>    >
>    >    Can we keep the NAT66 discussion to less than WGs at a time?
>    >
>    >    I am trying to keep up with multiple threads on this and trying to
>    explain
>    >    that we do not have a valid requirement for NAT66 defined on any
of the
>    >    mailing lists (v6OPS, BEHAVE, Softwires, RRG, and now v6).
>    >
>    >    Le's get this to one group (maybe we need a new mailing list just
for
>    NAT66
>    >    discussions, but this is getting out of hand.
>    >
>    >    Until now the simple response is that "the IETF does not support
NAT in
>    the
>    >    v6 architecture." If this needs changing lets do it right with
proper
>    gap
>    >    analysis and needs assement, and then seeing if there is a
solution
>    (several
>    >    have been proposed that are not NAT) or if we need to create one,
and
>    if
>    >    those fail then see about changing the architecture of IPv6.
>    >
>    >    Eric
>    >    On   Fri,   Oct   31,   2008   at   10:09   AM,   Rémi
 Denis-Courmont
>
>    >    <[1][3][email-masked]> wrote:
>    >
>    >    On Fri, 31 Oct 2008 15:31:27 +1300, Brian E Carpenter
>
 >    >    <[2][4][email-masked]> wrote:
>    >    >> Well I'm not completely certain whether involving users here
would
>    >    >> provide very good experience,
>    >    >
>    >    > I see your argument, but failing silently doesn't seem like a
>    >    > good idea.
>    >
>    >      It is only worse. What will actually happen then is, NAPT66.
>    >
>    >    >> and certainly operators would not be happy
>    >    >> to see vendors' devices complaining about limitations of their
>    network:)
>    >    >
>    >    > Too bad. This is actually a consumer protection issue;
>    >    > it seems completely appropriate to require that the
>    >    > reason for failure should be notified to the paying user.
>    >
>    >      Failing silently or loudly are no options. You cannot blame the
>    operator
>    >      if
>    >      you expect him to subsidized your device sale. You cannot fail
if
>    your
>    >      competitor "just works" by using NAPT66.
>    >      Unfortunately, users are notoriously bad at appreciating good
and
>    clean
>    >      engineering over functional and ugly hacks.
>    >
>    >    >> I would not like to see IPv6 NAPT, but I see that as a real
risk if
>    >    >> network is using DHCPv6 for allocating hosts just /128
addresses but
>    at
>    >    >> the same time is not willing to delegate prefixes on demand.
>    >    >
>    >    > Agreed.
>    >
>    >      Pardon my ignorance. Is there a concrete case of this in some
access
>    >      network standard?
>    >      (I heard some rumors thereabout)
>    >      --
>    >      Rémi Denis-Courmont
>    >
>    >
 --------------------------------------------------------------------
>    >    IETF IPv6 working group mailing list
>
>      >    [3][5][email-masked]
>      >    Administrative Requests:
>      [4][6]https://www.ietf.org/mailman/listinfo/ipv6
>      >
 --------------------------------------------------------------------
>      >
>      > References
>      >
>      >    1. mailto:[7][email-masked]
>      >    2. mailto:[8][email-masked]
>      >    3. mailto:[9][email-masked]
>      >    4. [10]https://www.ietf.org/mailman/listinfo/ipv6
>
>    > --------------------------------------------------------------------
>    > IETF IPv6 working group mailing list
>    > [11][email-masked]
>    > Administrative Requests: [12]
https://www.ietf.org/mailman/listinfo/ipv6
>    > --------------------------------------------------------------------
>
>      --
>      Tim
>
> References
>
>    1. mailto:[email-masked]
>    2. mailto:[email-masked]
>    3. mailto:[email-masked]
>    4. mailto:[email-masked]
>    5. mailto:[email-masked]
>    6. https://www.ietf.org/mailman/listinfo/ipv6
>    7. mailto:[email-masked]
>    8. mailto:[email-masked]
>    9. mailto:[email-masked]
>   10. https://www.ietf.org/mailman/listinfo/ipv6
>   11. mailto:[email-masked]
>   12. https://www.ietf.org/mailman/listinfo/ipv6

--
Tim
_______________________________________________
Int-area mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-area

---

From: Jari Arkko <[email-masked]>
Date: Fri, 14 Nov 2008 10:57:45 +0200

Eric,
 
> As the NAT66 discussion seems to be happening in several WGs at once, 
> it seems to me (and Tim) that you should try to hold some sort of 
> joint meeting in INT-AREA to get some sort of consensus yes or no for 
> NAT in v6 or at least to do a gap analysis
>  

We considered this, but at the end decided that its better to keep the 
biggest nat66 discussion in one place, and that is going to be BEHAVE. 
They have enough time for it, and many people will be attending. I hope 
people from this list will, too.

I am aware that there will be some other discussions as well. It might 
be that a full BOF next time might the best place to make decisions.

Jari

---

From: "Eric Klein" <[email-masked]>
Date: Fri, 14 Nov 2008 11:10:05 +0200

Hi Jari,

Thanks, holding it in BEHAVE is fine provided that everyone with a vested
interest participates. Otherwise we will continue to have the same problem.

Eric

On Fri, Nov 14, 2008 at 10:57 AM, Jari Arkko <[email-masked]> wrote:

> biggest nat66 discussion in one place, and that is going to be BEHAVE. They
> have enough time for it, and many people will be attending. I hope people
> from this list will, too.
>
> I am aware that there will be some other discussions as well. It might be
> that a full BOF next time might the best place to make decisions.
>
> Jari
>
>