Subject: [Int-area] draft-shirasaki-isp-shared-addr and Class E networks

From: Roque Gagliano <[email-masked]>
Date: Fri, 21 Nov 2008 15:02:02 -0600

After the presentation on the intarea session yesterday I though about  
something that was said ( I do not remember the person that did the  
comment) in the last NANOG meeting during the panel: " What Would Jon  
have Done About the Addressing Challenges Currently Facing Us?".

The comment was about what Jon Postel did with the cable companies and  
the 24/8 network. He allocated the address block but forced the cable  
companies to test CIDR. In that sense he gave something and got  
something.

I wonder if we could take that example for the "shared address" case  
and re-activate the re-definition of the Class E space as "for private  
use" (draft-wilson-class-e-02) in order to be able to be use for this  
architectures if the ISP are willing to do so.

Roque
_______________________________________________
Int-area mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-area

---

From: Dave Thaler <[email-masked]>
Date: Mon, 24 Nov 2008 12:04:37 -0800

It's been pointed out several times in the past regarding class E
space that you cannot expect a host/app to work if you try to give
it a class E address.

So class E addresses can only be safely used in networks for which
you have complete control/confidence over all the devices/apps
in that network.

It might be usable between routers in an ISP.
It is not really usable to assign a general-purpose PC acting as a CPE.

-Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Roque Gagliano
> Sent: Friday, November 21, 2008 1:02 PM
> To: [email-masked]
> Subject: [Int-area] draft-shirasaki-isp-shared-addr and Class E
> networks
>
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.8 (Darwin)
>
> iEYEARECAAYFAkknIcoACgkQnk+WSgHpbO4kVwCgpHb6F3WO+9UHYQRyyeDhd44G
> JzgAn34S3xolZmhopok7ZtLgTt4mPZP7
> =DzEa
> -----END PGP SIGNATURE-----

---

From: Brian Haberman <[email-masked]>
Date: Mon, 24 Nov 2008 20:22:19 -0500

Dave,
      Wasn't the comment made at the mike focused on having the class E 
address space be used between the two layers of NAT?

Regards,
Brian

---

From: Shin Miyakawa <[email-masked]>
Date: Tue, 25 Nov 2008 16:02:38 +0900 (JST)

Folks,

This is Shin Miyakawa from Tokyo.

From: Dave Thaler <[email-masked]>
Subject: Re: [Int-area] draft-shirasaki-isp-shared-addr and Class E networks
Date: Mon, 24 Nov 2008 12:04:37 -0800
> It is not really usable to assign a general-purpose PC acting as a CPE.

sure. (At least, in Japan,) now so many PCs are running as a CPE device. 

Also, if a PC behind CPE in home network need to contact
any machine in a network X between LNS and CPE (see below),
and the network X is using Class E, 
PC in the home can not send/receive any packets 
to machines in the network X.

This is not good, because we should save any status on a LNS 
as much as possible....

Please understand that we must needs to have new space
to keep exising devices in the home.

 to/from the Internet
         |
         |
+--------+--------+
| Large Scale NAT |
+--------+--------+         +------------------------+
         |                  |SOME SERVICE such as DNS|
         |                  +------+-----------------+ 
         |                         |
---------+-------------------------+--------- <- Network X 
         |
         |
    +----+-----+
    |  CPE     |
    +----+-----+
         |
         |
---------+------------ HOME NETWORK
         |
    +----+-----+
    |  PC      |
    +----------+

Best regards,

Shin Miyakawa

---

From: Roque Gagliano <[email-masked]>
Date: Tue, 25 Nov 2008 15:04:16 -0200

Dave,
> It might be usable between routers in an ISP.

Which is the exact application on NAT444 that was presented at the  
intarea. We are talking about the 4 "in the middle" and only for new  
builds.

Roque