Subject: Re: [Int-area] [dhcwg] DHCPv6 router option

From: Ralph Droms <[email-masked]>
Date: Mon, 23 Mar 2009 17:08:42 -0700

I'm moving this conversation to the int-area mailing list as it is of  
interest to the Internet Area as a whole, not just the dhc WG.   
Previous correspondents are bcc'ed...

- Ralph

On Mar 23, 2009, at 4:59 PM 3/23/09, <[email-masked]> wrote:

> INHO it's not a cable operator kind of questions. AFAIK also DSL  
> providers are asking for such kind of solution. And it may be that  
> the SP does not safe money with it's concrete network implementation  
> but he can definitely re-use the biggest part of its provisioning  
> and business supporting systems.
>
> Olaf
>
> -----Ursprüngliche Nachricht-----
> Von: Hemant Singh (shemant) [mailto:[email-masked]]
> Gesendet: Dienstag, 24. März 2009 00:50
> An: Bonneß, Olaf; Bernie Volz (volz); [email-masked]
> Cc: [email-masked]; [email-masked]; Ralph Droms (rdroms)
> Betreff: RE: [dhcwg] DHCPv6 router option
>
> All I am asking for is justification from cable operators because it  
> seems one of them has fostered this idea.  It's not clear yet that  
> the cable SP is saving money nor clear that all cable SPs would  
> agree to making changes to cable IPv6 standards to accommodate such  
> new work.
>
> Hemant
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, March 23, 2009 7:38 PM
> To: Hemant Singh (shemant); Bernie Volz (volz); [email-masked]
> Cc: [email-masked]; [email-masked]; Ralph Droms (rdroms)
> Subject: AW: [dhcwg] DHCPv6 router option
>
> Hi Hemant,
>
> it's not necessary to dive into the tons of emails that have been  
> written about this in between.
> You've seen the presentation by Thomas and he clearly stated that  
> some ISPs want to operate their networks in that way in order to   
> safe the money they have already invested in their networks and  
> provisioning systems.
>
> I can not say that I like this approach very much from an  
> architectural point of view, but from an ISP perspective its the  
> easiest and cheapest way to implement IPv6 without major re- 
> structuring of products / processes and major costs.
>
> So give the ISP the choice to chose which approach it implements and  
> what it has to pay for offering IPv6 to its customers.
>
> Only my 2 cent
> 	Olaf (working for an ISP)
>
> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] Im  
> Auftrag von Hemant Singh (shemant)
> Gesendet: Dienstag, 24. März 2009 00:18
> An: Bernie Volz (volz); Thomas Narten
> Cc: [email-masked]; Ted Lemon; Ralph Droms (rdroms)
> Betreff: Re: [dhcwg] DHCPv6 router option
>
> Ralph,
>
> Besides Alain Durand who has been asking for this potentially broken
> idea to add a router option in DHCPv6, who else is a SP who asked for
> this work? Alain also does not represent other cable vendors like
> Time-Warner, or Cablevision etc.  For that matter, Alain himself  
> says "I
> don't even represent Comcast", so who else from Comcast can speak up  
> and
> say this work is needed?
>
> Let me also bring folks up to speed on Cable IPv6 standards from the
> CableLabs.  We finished our Cable IPv6 standards more than three years
> back and consumer devices like cable modems already follow the RA  
> model
> to get default rtr info and use DHCPv6 as well for ipv6 address
> acquisition and other parameters like DNS etc.  A consumer device  
> like a
> cable modem has a huge inertia to changing any feature.   Likewise a
> CMTS router that terminates the cable modems, being a Service Provide
> box, has its own inertia to changing core features.  I spent two years
> of my life between 2005=2007 nursing cable modem vendors to fix very
> simple and core IPv6 bugs in their chips and I do consider this  
> draft to
> be rocking that boat.  The Provisioning system also changes. Then I  
> and
> Wes spent time finding show stopper bugs in hosts behind cable modems
> and discovered that most operating systems were broken in some core  
> data
> forwarding behavior for IPv6 for a specific RA.  I do not like any  
> IPv6
> boat rocked even an iota unless there is compelling justification.
>
> So let's not go backward.  Alain and Ralph, please explain what is the
> problem in the cable broadband network that this draft is needed?
> Please be super specific as to what the problem is.  Sorry, if the  
> good
> reasons have been given to the mailer - I have not caught up to  
> mails on
> this thread yet.  One year back when we discussed this issue with  
> Alain,
> I didn't hear any compelling reason.  What has changed since then?
>
> Thanks,
>
> Hemant
>
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Mon, 23 Mar 2009 17:48:05 -0700

Please respond only to the [email-masked] and leave off dhcwg on  
any responses.

- Ralph

On Mar 23, 2009, at 5:08 PM 3/23/09, Ralph Droms wrote:

> I'm moving this conversation to the int-area mailing list as it is  
> of interest to the Internet Area as a whole, not just the dhc WG.   
>> the SP does not safe money with it's concrete network  
>> implementation but he can definitely re-use the biggest part of its  
>> provisioning and business supporting systems.
>>
>> Olaf
>>
>> All I am asking for is justification from cable operators because  
>> it seems one of them has fostered this idea.  It's not clear yet  
>> that the cable SP is saving money nor clear that all cable SPs  
>> would agree to making changes to cable IPv6 standards to  
>> accommodate such new work.
>>
>> Hemant
>>
>> So give the ISP the choice to chose which approach it implements  
>> and what it has to pay for offering IPv6 to its customers.
>>
>> Only my 2 cent
>> don't even represent Comcast", so who else from Comcast can speak  
>> up and
>> say this work is needed?
>>

---

From: Mohsen Souissi <[email-masked]>
Date: Tue, 24 Mar 2009 03:53:22 +0100

And you could add to those populations site administrators
(enterprises) who would love to find a certain v4-v6 functional
parity.

That would/should not diminish in any way the interest in RA from
people who are already applying it. And there are many situations
where RA is really cool and outbeats DHCPv6.

But let's admit that there are also situations where DHCPv6 may be
much more practicle than RA. And here's an example : in an enterprise
dual-stack environment where the administrator wishes that all
workstations of identified users be auto-configured with a predefined
and dedicated address (for example matching the IPv4 address which is
on its turn matched with the MAC address), one may prefer asking a
DHCPv6 server for all pieces of information once and for all: IPv6
assigned address, prefix information, default router, DNS info... And
that way, those workstations will not rely on a yet another equipment.

Hope this further illustrates the need for this option and gives a
concrete example.

Mohsen.

 On 23 Mar, Ralph Droms wrote:
 | I'm moving this conversation to the int-area mailing list as it is of  
 | interest to the Internet Area as a whole, not just the dhc WG.   
 | Previous correspondents are bcc'ed...
 | 
 | - Ralph
 | 
 | On Mar 23, 2009, at 4:59 PM 3/23/09, <[email-masked]> wrote:
 | 
 | >INHO it's not a cable operator kind of questions. AFAIK also DSL  
 | >providers are asking for such kind of solution. And it may be that  
 | >the SP does not safe money with it's concrete network implementation  
 | >but he can definitely re-use the biggest part of its provisioning  
 | >and business supporting systems.
 | >
 | >Olaf
 | >
 | >-----Ursprüngliche Nachricht-----
 | >Von: Hemant Singh (shemant) [mailto:[email-masked]]
 | >Gesendet: Dienstag, 24. März 2009 00:50
 | >An: Bonneß, Olaf; Bernie Volz (volz); [email-masked]
 | >Cc: [email-masked]; [email-masked]; Ralph Droms (rdroms)
 | >Betreff: RE: [dhcwg] DHCPv6 router option
 | >
 | >All I am asking for is justification from cable operators because it  
 | >seems one of them has fostered this idea.  It's not clear yet that  
 | >the cable SP is saving money nor clear that all cable SPs would  
 | >agree to making changes to cable IPv6 standards to accommodate such  
 | >new work.
 | >
 | >Hemant
 | >
 | >-----Original Message-----
 | >From: [email-masked] [mailto:[email-masked]]
 | >Sent: Monday, March 23, 2009 7:38 PM
 | >To: Hemant Singh (shemant); Bernie Volz (volz); [email-masked]
 | >Cc: [email-masked]; [email-masked]; Ralph Droms (rdroms)
 | >Subject: AW: [dhcwg] DHCPv6 router option
 | >
 | >Hi Hemant,
 | >
 | >it's not necessary to dive into the tons of emails that have been  
 | >written about this in between.
 | >You've seen the presentation by Thomas and he clearly stated that  
 | >some ISPs want to operate their networks in that way in order to   
 | >safe the money they have already invested in their networks and  
 | >provisioning systems.
 | >
 | >I can not say that I like this approach very much from an  
 | >architectural point of view, but from an ISP perspective its the  
 | >easiest and cheapest way to implement IPv6 without major re- 
 | >structuring of products / processes and major costs.
 | >
 | >So give the ISP the choice to chose which approach it implements and  
 | >what it has to pay for offering IPv6 to its customers.
 | >
 | >Only my 2 cent
 | >	Olaf (working for an ISP)
 | >
 | >-----Ursprüngliche Nachricht-----
 | >Von: [email-masked] [mailto:[email-masked]] Im  
 | >Auftrag von Hemant Singh (shemant)
 | >Gesendet: Dienstag, 24. März 2009 00:18
 | >An: Bernie Volz (volz); Thomas Narten
 | >Cc: [email-masked]; Ted Lemon; Ralph Droms (rdroms)
 | >Betreff: Re: [dhcwg] DHCPv6 router option
 | >
 | >Ralph,
 | >
 | >Besides Alain Durand who has been asking for this potentially broken
 | >idea to add a router option in DHCPv6, who else is a SP who asked for
 | >this work? Alain also does not represent other cable vendors like
 | >Time-Warner, or Cablevision etc.  For that matter, Alain himself  
 | >says "I
 | >don't even represent Comcast", so who else from Comcast can speak up  
 | >and
 | >say this work is needed?
 | >
 | >Let me also bring folks up to speed on Cable IPv6 standards from the
 | >CableLabs.  We finished our Cable IPv6 standards more than three years
 | >back and consumer devices like cable modems already follow the RA  
 | >model
 | >to get default rtr info and use DHCPv6 as well for ipv6 address
 | >acquisition and other parameters like DNS etc.  A consumer device  
 | >like a
 | >cable modem has a huge inertia to changing any feature.   Likewise a
 | >CMTS router that terminates the cable modems, being a Service Provide
 | >box, has its own inertia to changing core features.  I spent two years
 | >of my life between 2005=2007 nursing cable modem vendors to fix very
 | >simple and core IPv6 bugs in their chips and I do consider this  
 | >draft to
 | >be rocking that boat.  The Provisioning system also changes. Then I  
 | >and
 | >Wes spent time finding show stopper bugs in hosts behind cable modems
 | >and discovered that most operating systems were broken in some core  
 | >data
 | >forwarding behavior for IPv6 for a specific RA.  I do not like any  
 | >IPv6
 | >boat rocked even an iota unless there is compelling justification.
 | >
 | >So let's not go backward.  Alain and Ralph, please explain what is the
 | >problem in the cable broadband network that this draft is needed?
 | >Please be super specific as to what the problem is.  Sorry, if the  
 | >good
 | >reasons have been given to the mailer - I have not caught up to  
 | >mails on
 | >this thread yet.  One year back when we discussed this issue with  
 | >Alain,
 | >I didn't hear any compelling reason.  What has changed since then?
 | >
 | >Thanks,
 | >
 | >Hemant
 | >
 | >
 | >_______________________________________________
 | >dhcwg mailing list
 | >[email-masked]
 | >https://www.ietf.org/mailman/listinfo/dhcwg
 | 
 | _______________________________________________
 | Int-area mailing list
 | [email-masked]
 | https://www.ietf.org/mailman/listinfo/int-area

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 24 Mar 2009 12:58:42 -0400

While it is still early for me to tell exactly what the semantics around
these option(s) will be, I think there are other technologies (even
Cable) where this could be extremely beneficial.

The reason is that it could eliminate periodic RAs. And for
non-broadcast technologies (Cable, 3GPP, DSL, etc), that could be a big
win. The client can be given the router information with the DHCP
transaction and renewed when the lease is renewed.

For non-broadcast networks, having to send an RA to each "client" every
N seconds is costly (especially if you have thousands or millions of
devices connected). Consider also the fact that sometimes the device
connecting is doing so via Ethernet emulation, so it can't be told that
seeing RAs once is a blue moon is OK.

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, March 24, 2009 10:51 AM
To: [email-masked]
Cc: [email-masked]; Hemant Singh (shemant); Bernie Volz (volz);
[email-masked]; [email-masked]; [email-masked];
[email-masked]; Ralph Droms (rdroms)
Subject: Re: [dhcwg] DHCPv6 router option

> Like I said earlier we need to understand who or what type of provider
is
> making this request.  I am not aware of cable providers making this
request,
> I have not.

I work for a DSL provider. We would very much like to have a DHCPv6
router option. As mentioned this has been discussed extensively on 
the dhcwg list. Our reasons for wanting a DHCPv6 router option are
mainly:

- We would like to have *all* the dynamic configuration in one place,
specifically DHCP. DHCP hands out much more info than RA (RA alone
cannot do it).

- We already have an extensive DHCP based infrastructure, which ties
in with other operational support systems.

- We much prefer to have *one* mechanism to distribute information to
CPEs (has to do with support, debugging, documentation etc).

There is also the argument that some kind of "DHCPv6 guard" is needed
independently of whether a DHCPv6 router option exists or not.

Steinar Haug, Nethelp consulting, [email-masked]

---

From: John Jason Brzozowski <[email-masked]>
Date: Tue, 24 Mar 2009 10:10:23 -0700

Bernie,

While I agree that the option *could* be beneficial it is important to note
that it is not required.

Further, from an implementation point of view there will be some equipment
that will not support this option in the near term and as such some
deployments will have to proceed without it.

The decision to use this option will be made on a case by case basis.

John
=========================================
John Jason Brzozowski
Comcast Corporation
e) mailto:[email-masked]
m) 609-377-6594
=========================================

> From: Bernie Volz <[email-masked]>
> Date: Tue, 24 Mar 2009 12:58:42 -0400
> To: <[email-masked]>, "Brzozowski, John"
> <[email-masked]>
> Cc: <[email-masked]>, Hemant Singh <[email-masked]>, Thomas Narten
> <[email-masked]>, <[email-masked]>, dhc WG <[email-masked]>, Ted Lemon
> <[email-masked]>, Ralph Droms <[email-masked]>
> Subject: RE: [dhcwg] DHCPv6 router option
>

---

From: John Jason Brzozowski <[email-masked]>
Date: Tue, 24 Mar 2009 10:23:48 -0700

Thanks for the feedback, much appreciated.

> in with other operational support systems.

Can you clarify how the absence or presence of the default router option
will impact OSS systems?

John

> From: <[email-masked]>
> Date: Tue, 24 Mar 2009 10:51:15 -0400
> To: "Brzozowski, John" <[email-masked]>
> Cc: <[email-masked]>, Hemant Singh <[email-masked]>, Bernie Volz
> <[email-masked]>, Thomas Narten <[email-masked]>, <[email-masked]>, dhc
> WG <[email-masked]>, Ted Lemon <[email-masked]>, Ralph Droms
> <[email-masked]>
>> Like I said earlier we need to understand who or what type of provider is
>> making this request.  I am not aware of cable providers making this request,
>> I have not.
>

---

From: John Jason Brzozowski <[email-masked]>
Date: Mon, 23 Mar 2009 17:26:53 -0700

I do not think anyone has suggested that cable standards be changed at this
time to accommodate this option.  I for one am not hearing or seeing this
point being made.

John

> From: Hemant Singh <[email-masked]>
> Date: Mon, 23 Mar 2009 19:49:57 -0400
> To: <[email-masked]>, Bernie Volz <[email-masked]>, Thomas Narten
> <[email-masked]>
> Cc: dhc WG <[email-masked]>, Ted Lemon <[email-masked]>, Ralph Droms
> <[email-masked]>
> All I am asking for is justification from cable operators because it seems one
> of them has fostered this idea.  It's not clear yet that the cable SP is
> saving money nor clear that all cable SPs would agree to making changes to
> cable IPv6 standards to accommodate such new work.
> 
> Hemant
> 
> it's not necessary to dive into the tons of emails that have been written
> about this in between.
> You've seen the presentation by Thomas and he clearly stated that some ISPs
> want to operate their networks in that way in order to  safe the money they
> have already invested in their networks and provisioning systems.
> 
> I can not say that I like this approach very much from an architectural point
> of view, but from an ISP perspective its the easiest and cheapest way to
> implement IPv6 without major re-structuring of products / processes and major
> costs.
> 
> So give the ISP the choice to chose which approach it implements and what it
> has to pay for offering IPv6 to its customers.
> 
> Only my 2 cent
> Von: [email-masked] [mailto:[email-masked]] Im Auftrag von
> Hemant Singh (shemant)
> Time-Warner, or Cablevision etc.  For that matter, Alain himself says "I
> don't even represent Comcast", so who else from Comcast can speak up and
> say this work is needed?
> 
> back and consumer devices like cable modems already follow the RA model
> acquisition and other parameters like DNS etc.  A consumer device like a
> simple and core IPv6 bugs in their chips and I do consider this draft to
> be rocking that boat.  The Provisioning system also changes. Then I and
> and discovered that most operating systems were broken in some core data
> forwarding behavior for IPv6 for a specific RA.  I do not like any IPv6
> Please be super specific as to what the problem is.  Sorry, if the good
> reasons have been given to the mailer - I have not caught up to mails on
> this thread yet.  One year back when we discussed this issue with Alain,

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Mon, 23 Mar 2009 20:33:08 -0400

I have a private email where it was mentioned to me that such an option may change the DOCSIS MULPI.  I'll be happy to unicast that email to you and the ADs.  That is why I am asking questions.

Hemant

-----Original Message-----
From: John Jason Brzozowski [mailto:[email-masked]] 
Sent: Monday, March 23, 2009 8:27 PM
To: Hemant Singh (shemant); [email-masked]; Bernie Volz (volz); Thomas Narten; [email-masked]
Cc: dhc WG; Ted Lemon; Ralph Droms (rdroms)
Subject: Re: [dhcwg] DHCPv6 router option

John

---

From: John Jason Brzozowski <[email-masked]>
Date: Mon, 23 Mar 2009 17:34:12 -0700

John

> From: <[email-masked]>
> Date: Mon, 23 Mar 2009 19:59:54 -0400
> To: Hemant Singh <[email-masked]>, Bernie Volz <[email-masked]>, Thomas
> Narten <[email-masked]>
> INHO it's not a cable operator kind of questions. AFAIK also DSL providers are
> asking for such kind of solution. And it may be that the SP does not safe
> money with it's concrete network implementation but he can definitely re-use
> the biggest part of its provisioning and business supporting systems.
> 
> Olaf
>

---

From: [email-masked]
Date: Tue, 24 Mar 2009 15:51:15 +0100 (CET)

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Tue, 24 Mar 2009 13:50:52 -0400

May I also suggest a path moving forward for this draft.  Let the work
continue since the draft is already out - we will hammer out the
details.  However, I suggest if DSL SPs support a certain piece of IETF
work, the onus is upon them to talk to their DSL standards folks who are
the Broadband Forum.  It's not efficient for the IETF to see DSL SPs
speaking they support this draft while David Miles who works in the
Broadband Forum gets up during this draft prezo and says the DSL
standards for IPv6 are close to completion and they were not planning on
using draft for their deployment.  IETF should not take up work if a
deployment has its SP's saying one thing, but the deployment's standards
folks say another thing.  It is best if the DSL SPs talk to their
standards folks in the Broadband Forum and then that Forum liaisons on a
formal basis to the IETF.  

This is also how Cable standards work.  We have all Cable SPs sitting on
the Cable standards committee which decides as one voice and if the
standards need any IETF work, the committee comes to the IETF with
issues. 

To start a technical discussion from me on this draft, I am warning of
pitfalls if one router option is added to DHCPv6 like this one, knowing
DHCPv6, more options will follow.  Already a WPI IT person is asking for
a router list option.  With each new option there is some serious
thinking involved for how does each new option work with both ND and
DHCPv6.  The draft also has an uphill battle because hosts
implementation are heavily entrenched in IPV6 as per the ND RA
architecture mixed with DHCPv6 or SLAAC.  For example, a Windows host on
every network interface re-init issues a DHCPv4 new transaction.
However, for IPv6, Win Vista does initiate DHCPv6 when the network
interface is initialized for the first time.  On a subsequent re-init of
the same interface, unlike IPV4, Vista DOES NOT issue a new DHCPv6 - on
the re-init Vista just sends a NS (DAD) each for the link-local and the
global address.  Do you see how such behavior by this Vista host throw a
monkey wrench in this draft's work that may rely on Vista issuing DHCPv6
on every network init.  This is only tip of the iceberg.  I can
certainly provide more gothcas, each at the cable modem, the cable
router, and the cable provisioning system.  After all we are one
broadband network.  

Regards to all.

Hemant

-----Original Message-----
From: John Jason Brzozowski [mailto:[email-masked]] 
Sent: Tuesday, March 24, 2009 1:24 PM
To: [email-masked]
Cc: [email-masked]; Hemant Singh (shemant); Bernie Volz (volz);
Thomas Narten; [email-masked]; Ted Lemon; Ralph Droms (rdroms)
Subject: Re: [dhcwg] DHCPv6 router option

John

request,

---

From: John Schnizlein <[email-masked]>
Date: Wed, 25 Mar 2009 09:18:03 -0700

The IETF is open to proposals from anyone.  It is not necessary to  
take proposals through a broadband forum of any kind.

Many of us struggling to get IPv6 more widely deployed find "hosts  
implementation are heavily entrenched in IPV6 as per the ND RA
architecture mixed with DHCPv6 or SLAAC." ironic.  Heavily entrenched  
is not a reason to block specifying options for interoperability that  
have the potential to remove barriers to deployment of IPv6.

I hope "we are one broadband network " is not intended to imply  
subordinating IETF standards to what is pre-decided in some broadband  
forum.

John

On 2009Mar24, at 10:50 AM, Hemant Singh (shemant) wrote:

> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 26 Mar 2009 05:24:21 +1300

Certainly, we should decide this on its merits. There are many places
where it might be useful besides the broadband provider scenario.

   Brian

On 2009-03-26 05:18, John Schnizlein wrote:
> The IETF is open to proposals from anyone.  It is not necessary to take
> proposals through a broadband forum of any kind.
> 
> architecture mixed with DHCPv6 or SLAAC." ironic.  Heavily entrenched is
> not a reason to block specifying options for interoperability that have
> the potential to remove barriers to deployment of IPv6.
>

---

From: Maglione Roberta <[email-masked]>
Date: Wed, 25 Mar 2009 17:33:09 +0100

Hello,
        I'm not going to express an opinion on this draft now, but I'd like to comment on the following sentence as a Broadband Forum member.

> May I also suggest a path moving forward for this draft.  Let the work continue since > the draft is already out  - we will hammer out the details.  However, I suggest if DSL > SPs support a certain piece of IETF work, the onus is upon them to talk to their DSL > standards folks who are the Broadband Forum.  It's not efficient for
> the IETF to see DSL SPs speaking they support this draft while David Miles who
> works in the Broadband
> Forum gets up during this draft prezo and says the DSL standards for IPv6 are
> close to completion and
> they were not planning on using draft for their deployment.

I would say, but David please correct me if I'm wrong, that IPv6 specifications in the Broadband forum are making good progress, but I would not say they are completed yet. It is fair to say the option described in this draft is not part of current IPv6 proposed specification in BBF, but I would not say BBF has excluded this type of mechanism.
BBF tries to follow IETF guidelines and to re-use protocols, mechanisms and options that IETF produces, thus in opinion one reason why this option is not part of current BBF proposed specs is it has not been presented/discussed in BBF yet.

Best Regards,
Roberta

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hemant Singh (shemant)
Sent: Tuesday, March 24, 2009 6:51 PM
To: John Jason Brzozowski; [email-masked]
Cc: Thomas Narten; [email-masked]; [email-masked]; Bernie Volz (volz); Ted Lemon
Subject: Re: [Int-area] [dhcwg] DHCPv6 router option

Regards to all.

Hemant

-----Original Message-----
From: John Jason Brzozowski [mailto:[email-masked]]
Sent: Tuesday, March 24, 2009 1:24 PM
To: [email-masked]
Cc: [email-masked]; Hemant Singh (shemant); Bernie Volz (volz);

John

request,

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

---

From: "Chris Donley" <[email-masked]>
Date: Wed, 25 Mar 2009 10:41:57 -0600

Hemant,

You seem to be implying that this work is being driven by the cable
industry, and that CableLabs is behind this change. Just to clarify,
CableLabs is not driving it, and we currently do NOT have any plans to
include this router option in DOCSIS. That said, it's an interesting
proposal, and we could consider incorporating it in the future if there
is sufficient interest from our members. 

Chris 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Hemant Singh (shemant)
Sent: Tuesday, March 24, 2009 11:51 AM
To: John Jason Brzozowski; [email-masked]
Cc: Thomas Narten; [email-masked]; [email-masked]; Bernie
Volz (volz); Ted Lemon
Subject: Re: [Int-area] [dhcwg] DHCPv6 router option

Regards to all.

Hemant

-----Original Message-----
From: John Jason Brzozowski [mailto:[email-masked]] 
Sent: Tuesday, March 24, 2009 1:24 PM
To: [email-masked]
Cc: [email-masked]; Hemant Singh (shemant); Bernie Volz (volz);

John

request,

---

From: John Jason Brzozowski <[email-masked]>
Date: Wed, 25 Mar 2009 09:48:28 -0700

Roberta,

Clarifying question, has or will the absence of this option impacted the
ability of DSL providers to adopt or deploy IPv6?  This would be useful
context as work on this option is pursued particularly if the answer is yes,
how would be good for us to understand IMO.

John

> From: Maglione Roberta <[email-masked]>
> Date: Wed, 25 Mar 2009 12:33:09 -0400
> To: Hemant Singh <[email-masked]>, "Brzozowski, John"
> <[email-masked]>, <[email-masked]>
> Cc: Thomas Narten <[email-masked]>, <[email-masked]>,
> <[email-masked]>, Bernie Volz <[email-masked]>, Ted Lemon
> <[email-masked]>
>         I'm not going to express an opinion on this draft now, but I'd like to
> comment on the following sentence as a Broadband Forum member.
> 
>> continue since > the draft is already out  - we will hammer out the details.
>> However, I suggest if DSL > SPs support a certain piece of IETF work, the
>> onus is upon them to talk to their DSL > standards folks who are the
>> Broadband Forum.  It's not efficient for
> I would say, but David please correct me if I'm wrong, that IPv6
> specifications in the Broadband forum are making good progress, but I would
> not say they are completed yet. It is fair to say the option described in this
> draft is not part of current IPv6 proposed specification in BBF, but I would
> not say BBF has excluded this type of mechanism.
> BBF tries to follow IETF guidelines and to re-use protocols, mechanisms and
> options that IETF produces, thus in opinion one reason why this option is not
> part of current BBF proposed specs is it has not been presented/discussed in
> BBF yet.
> 
> Best Regards,
> Roberta
> 
> Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle
> persone indicate. La diffusione, copia o qualsiasi altra azione derivante
> dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora
> abbiate ricevuto questo documento per errore siete cortesemente pregati di
> darne immediata comunicazione al mittente e di provvedere alla sua
> distruzione, Grazie.
> 
> This e-mail and any attachments is confidential and may contain privileged
> information intended for the addressee(s) only. Dissemination, copying,
> printing or use by anybody else is unauthorised. If you are not the intended
> recipient, please delete this message and any attachments and advise the
> sender by return e-mail, Thanks.
>

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 25 Mar 2009 10:08:46 -0700

> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Wednesday, March 25, 2009 9:24 AM
> To: John Schnizlein
Volz (volz); Hemant Singh
> (shemant); Ted Lemon; [email-masked]

I can certainly envision many enterprise network secnarios in
which this new capability would be useful. Similar to the point
about keeping all configuration information in a single place.

RAs are still there and useful for certain enterprise
scenarios (e.g., low-end systems on edge networks). But,
DHCPv6-based would IMHO be appreciated in core enterprise
production networks.

Fred
[email-masked]

> > The IETF is open to proposals from anyone.  It is not necessary to
take
> >> From: John Jason Brzozowski
[mailto:[email-masked]]

---

From: Maglione Roberta <[email-masked]>
Date: Wed, 25 Mar 2009 18:18:25 +0100

John,
        I'm afraid I'm not in the position to give you a clear yes or no for DSL Providers.
What I'm saying is that having or not having this option has impacts on the possible architectural models currently under definition in BBF.
BBF has not selected one model SLAAC vs DHCPv6 for address allocation, both options are currently considered in the proposed specifications; the idea behind this
approach is that each SP is then free to choose the model that better fits his needs, based on his requirements.

Regards,
Roberta

-----Original Message-----
From: John Jason Brzozowski [mailto:[email-masked]]
Sent: Wednesday, March 25, 2009 5:48 PM
To: Maglione Roberta; Hemant Singh; [email-masked]
Cc: Thomas Narten; [email-masked]; [email-masked]; Bernie Volz; Ted Lemon
Subject: Re: [dhcwg] DHCPv6 router option

Roberta,

John

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Wed, 25 Mar 2009 13:18:55 -0400

Chris,

Thanks for the formal email from a CableLabs person.  No, my intent was
never to imply that CableLabs is actively pursuing this work.  All I was
trying to find out if anyone who works in cable standards was trying to
take this work into cable standards and if so, I would nip that in the
bud for the current cable IPv6 certification process and the cable IPv6
standards.

Hemant

-----Original Message-----
From: Chris Donley [mailto:[email-masked]] 
Sent: Wednesday, March 25, 2009 12:42 PM
To: Hemant Singh (shemant); John Jason Brzozowski; [email-masked]
Cc: Thomas Narten; [email-masked]; [email-masked]; Bernie
Volz (volz); Ted Lemon
Subject: RE: [Int-area] [dhcwg] DHCPv6 router option

Hemant,

Chris 

-----Original Message-----

Regards to all.

Hemant

-----Original Message-----
From: John Jason Brzozowski [mailto:[email-masked]] 
Sent: Tuesday, March 24, 2009 1:24 PM
To: [email-masked]
Cc: [email-masked]; Hemant Singh (shemant); Bernie Volz (volz);

John

request,

---

From: Mohsen Souissi <[email-masked]>
Date: Wed, 25 Mar 2009 18:15:10 +0100

Hear, hear!

 On 25 Mar, Templin, Fred L wrote:
 | 
 | 
 | > -----Original Message-----
 | > From: Brian E Carpenter [mailto:[email-masked]]
 | > Sent: Wednesday, March 25, 2009 9:24 AM
 | > To: John Schnizlein
 | > Cc: Thomas Narten; [email-masked]; [email-masked]; Bernie
 | Volz (volz); Hemant Singh
 | > (shemant); Ted Lemon; [email-masked]
 | > Subject: Re: [Int-area] [dhcwg] DHCPv6 router option
 | > 
 | > Certainly, we should decide this on its merits. There are many places
 | > where it might be useful besides the broadband provider scenario.
 | 
 | I can certainly envision many enterprise network secnarios in
 | which this new capability would be useful. Similar to the point
 | about keeping all configuration information in a single place.
 | 
 | RAs are still there and useful for certain enterprise
 | scenarios (e.g., low-end systems on edge networks). But,
 | DHCPv6-based would IMHO be appreciated in core enterprise
 | production networks.
 | 
 | Fred
 | [email-masked]