Subject: Re: [Int-area] Reviews of "IP Router Alert Considerations" document

From: Roland Bless <[email-masked]>
Date: Wed, 03 Nov 2010 17:58:39 +0100

Hi,

I've got some more comments on
draft-ietf-intarea-router-alert-considerations-02.txt before WGLC:
Section 3:
>  Secondly, some protocols requiring punting may be
>    carried over a transport protocol (e.g., TCP or UDP) possibly because
>    they require the services of that transport protocol or perhaps
>    because the protocol does not justify allocation of a scarce next
>    level protocol value. 

You may add that one also gets discouraged using other protocols by
anticipated deployment problems due to firewalls and NATs filtering
"unknown" protocols.

> Therefore,
>    it is generally not possible to ensure that only the IP Router Alert
>    packets of interest are punted to the slow path while other IP Router
>    Alert packets are efficiently forwarded (i.e., in fast path).

This statement is IMHO misleading, because the following paragraph
actually points out that considering the value field is such a possibility.

> However, only one
>    value (zero) was defined in [RFC2113] and no IANA registry for IPv4
>    Router Alert values was available until recently. 

You may add a reference to [RFC5350] here:
was available until recently [RFC5350].

Regards,
 Roland

---

From: Francois Le Faucheur <[email-masked]>
Date: Sun, 7 Nov 2010 05:26:46 +0800

Hi Roland,

Thanks for the review. Responses embedded:

> anticipated deployment problems due to firewalls and NATs filtering

Fair point.

> actually points out that considering the value field is such a possibility.

I see. 
We can replace:
"Therefore, it is generally not possible to ensure that only the IP Router Alert
   packets of interest ..."
by
"Therefore, it is generally not possible to ensure that only the IP Router Alert
   packets for next level protocol of interest ..."

> was available until recently [RFC5350].

Yes.

Tx

Francois

> Roland

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html