Subject: Re: [Int-area] intarea status update before IETF-81

From: Scott Brim <[email-masked]>
Date: Tue, 28 Jun 2011 19:33:06 -0400

On Jun 28, 2011 7:02 PM, "Templin, Fred L" <[email-masked]>
wrote:
>
> Noel,
>
> > -----Original Message-----
> > From: Noel Chiappa [mailto:[email-masked]]
> > Sent: Tuesday, June 28, 2011 11:28 AM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: Re: [Int-area] intarea status update before IETF-81
> >
> >     > From: Scott Brim <[email-masked]>
> >
> >     > You want a way forward for IRON. You need to drum up
> > support and get
> >     > collaborators.
> >
> > Agreed. Trying to make the IETF the dog doesn't work - it
> > needs to be the
> > tail,
>
> Maybe, but it seems like the IETF should at least know
> which dog is doing the wagging - and whether that is
> even the best dog to be attached to or whether there
> is a better dog.

We could repeat what RRG tried to do but if we start from where we are now
we would take the same amount of time with no guarantee that we would get
better results.  What does a WG have that an RG does not? Dave Clark said
"if it has to work when you're done it's engineering, not research." I think
the main asset of a WG is applicability requirements to measure against. If
you could get three operators to say they would deploy your approach right
away if they could, that would be great. If you're trying to get "the IETF"
to proclaim what's best for the Internet we won't be able to reach a
conclusion. Imho.

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 29 Jun 2011 09:56:30 -0700

Hi Scott,

________________________________
From: Scott Brim [mailto:[email-masked]]
Sent: Tuesday, June 28, 2011 4:33 PM
To: Templin, Fred L
Cc: [email-masked]; Noel Chiappa
Subject: Re: [Int-area] intarea status update before IETF-81

On Jun 28, 2011 7:02 PM, "Templin, Fred L" <[email-masked]<mailto:[email-masked]>> wrote:
> > From: Noel Chiappa [mailto:[email-masked]<mailto:[email-masked]>]
> > To: [email-masked]<mailto:[email-masked]>
> > Cc: [email-masked]<mailto:[email-masked]>
> >     > From: Scott Brim <[email-masked]<mailto:[email-masked]>>
> >

We could repeat what RRG tried to do but if we start from where we are now we would take the same amount of time with no guarantee that we would get better results.

No, I'm not looking for a repeat of the RRG experience. What came out of the RRG was that two solution alternatives were developed within the framework of the group, while a third cut out of the process early in the game to go off and do their own thing. But, cutting out early doesn't necessarily mean that the solution was the best.

What does a WG have that an RG does not?

Workers? Or, at least a community of engineers with interest in practical matters.

 Dave Clark said "if it has to work when you're done it's engineering, not research."

My job title is "research Engineer", but I spell it with a little 'r' and a big 'E'. I don't get involved with work that I'm not convinced can be applied in operational practice. I develop prototype code to test the concepts, however I no longer work for a major host/router manufacturer and hence have no direct path into shipping implementations. As with anyone else, my capabilities are finite - hence, I need to have workers who are willing to help come on board. And, what better place to find workers than in a working group?

 I think the main asset of a WG is applicability requirements to measure against.

I have published three documents that talk about use-case scenarios (RFC6139, draft-templin-iron-pm, and draft-templin-ironmike). I am fairly sure there would be something in those which most operators can identify with.

 If you could get three operators to say they would deploy your approach right away if they could, that would be great. If you're trying to get "the IETF" to proclaim what's best for the Internet we won't be able to reach a conclusion. Imho.

I agree that it would be great to have the operators come alongside this work and at least give it a closer look. The operators might want to also ask whether they can form their own opinions on what solutions are best suited to their needs or whether they need to defer to vendors who are pushing solutions that may or may not be well suited.

Thanks - Fred