Subject: [Int-area] Call for adoption of draft-carpenter-flow-label-balancing-02

From: Suresh Krishnan <[email-masked]>
Date: Tue, 18 Dec 2012 07:45:47 -0500

Hi all,
  This draft has been presented at intarea face to face meetings and has
received a bit of discussion. It has been difficult to gauge whether the
wg is interested in this work or not. This call is being initiated to
determine whether there is WG consensus towards adoption of
draft-carpenter-flow-label-balancing-02 as an intarea WG draft. Please
state whether or not you're in favor of the adoption by replying to this
email. If you are not in favor, please also state your objections in
your response. This adoption call will complete on 2013-01-04.

Regards
Suresh & Julien

---

From: "George, Wes" <[email-masked]>
Date: Wed, 19 Dec 2012 12:25:44 -0500

support

Thanks,

Wes George

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Suresh Krishnan
> Sent: Tuesday, December 18, 2012 7:46 AM
> To: Internet Area
> Cc: Julien Laganier; Ralph Droms
> Subject: [Int-area] Call for adoption of draft-carpenter-flow-label-
> balancing-02
>
> Hi all,
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 21 Dec 2012 01:38:48 +0000

I'm in favor of it. It's a good use case of flow label for L3/4 load balancing.

Thanks

B.R.
Bing

> Sent: Tuesday, December 18, 2012 8:46 PM
> To: Internet Area
> Subject: [Int-area] Call for adoption of
> draft-carpenter-flow-label-balancing-02
> 
> Hi all,

---

From: joel jaeggli <[email-masked]>
Date: Thu, 20 Dec 2012 18:37:32 -0800

On 12/20/12 5:38 PM, Liubing (Leo) wrote:
> I'm in favor of it. It's a good use case of flow label for L3/4 load balancing
RFC 6437 did not go nearly far enough in my opinion make the flow label 
suitable for this application.

The fact of the matter is if I attempted to use the flow label today as 
part of a load balancing scheme it would provide zero additional 
entropy, and what's more I still have to look at the upper layer header.

Furthermore the document proposes the use of flow label across muliple 
flows as a common "session key" across multiple flows which I personally 
feel is inconsistent with the notion of a flow, is certainly embedding 
upper layer (notionally above the l4 header) session information in the 
layer-3  header and suffers from the exposures described in section 6 of 
6437 and making no attempt to ameliorate them.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 21 Dec 2012 08:30:48 +0000

Joel,

> entropy, and what's more I still have to look at the upper layer header.

Have you read the latest version? That is discussed. The point is to
provide a path to fixing that problem.

> flows as a common "session key" across multiple flows 

No, you definitely haven't read the latest version. It absolutely
does not propose that. If you want to discuss that point, please
comment on draft-tarreau-extend-flow-label-balancing, which is
*not* proposed for adoption at this time.

    Brian

which I personally

---

From: Warren Kumari <[email-masked]>
Date: Mon, 31 Dec 2012 12:51:23 -0500

[ Replying midway through the thread as somehow my MUA et the original…] 

>> your response. This adoption call will complete on 2013-01-04.

Support.

I was originally opposed to this draft (and /may/ have thrown a bit of a hissy fit at Brian about it), but my major concerns have been addressed in this version and I now support adoption…

I have a few comments / notes that I promise to ship over to the authors sometime…

W

--
"Have you got any previous convictions?"

"Well, I dunno... I suppose I used to believe very firmly that a penny saved is a penny earned--"
-- Terry Pratchett