Subject: Re: [Int-area] Call for adoption of draft-nachum-sarp-06.txt

From: "Xialiang (C)" <[email-masked]>
Date: Mon, 2 Sep 2013 03:48:28 +0000

Hi all,
I have read through this draft. And I think it's a good and feasible solution for resolving the FDB exploration problem whether in tradition or virtualized DC network. So I support it to be adopted as a WG draft.

B.R.
Frank

---

From: David Allan I <[email-masked]>
Date: Tue, 3 Sep 2013 14:04:20 +0000

HI Linda:

I understand the example you are providing, but I would assume that these multiple instances are load balanced which means if individual app instances in a subnet are poorly located traffic could be ping ponging all over the place as any localization between the different component instances (web/app/db) can no longer be guaranteed. The web server could be in one rack, the app in another, and the db in another if each set of instances was treated as a common pool. You would have to carve it up at a finer granularity to hit all the criteria of goodness in the deployment of such an app...

Cheers
Dave

-----Original Message-----
From: Linda Dunbar [mailto:[email-masked]] 
Sent: Friday, August 30, 2013 1:25 PM
To: David Allan I; [email-masked]
Subject: RE: Call for adoption of draft-nachum-sarp-06.txt

> -----Original Message-----
> VM placement affinity rules would NEVER see absolutely every local VM 
> belonging to a different tenant network and requiring connectivity 
> only to remote VMs.

[Linda] Being in one VLAN (or subnet) doesn't mean that those hosts (or applications) have higher traffic among themselves. For a typical Data Center, you may have many instances of WebServer in one subnet (typical one VLAN), many instances of AppServer in another subnet (VLAN), and many instances of DBServer in yet another subnet. The Subnet is only for policy enforcement and load balance purposes. The amount of traffic between "WebServer Instances" <-> "AppServer instances" <-> "DB server instances" is magnitude higher than the heartbeat traffic among all instances of one function. 
For some DC operators who want to optimize their traffic across racks, placing instances from different subnets in one rack can eliminate a lot of traffic traversing among racks. 

Linda