Subject: Re: [Int-area] Call for adoption of draft-pignataro-intarea-gre-ipv6-01

From: Andrew Yourtchenko <[email-masked]>
Date: Mon, 1 Dec 2014 12:53:08 +0100

When I've read this document my initial reaction was "wait, does it 
mean it is not defined anywhere *yet*?" - because there's a nontrivial 
amount of running code already operating in this fashion.

As such, the formal document would definitely be useful and I'd 
be in favor for adopting this.

--a

On Fri, 21 Nov 2014, Zuniga, Juan Carlos wrote:

> 
> Hi all,
>
> 
> 
> At the Int-Area WG meeting in Honolulu there was strong support to adopt draft-pignataro-intarea-gre-ipv6-01 as WG draft. We are
> now starting a call on the list to confirm its adoption.
>
> 
> 
> http://tools.ietf.org/html/draft-pignataro-intarea-gre-ipv6-01
>
> 
> 
> If you are in favor or against adopting this draft, please reply to this email stating your opinion. The call will finish on
> Friday 2014-12-05.
>
> 
> 
> Regards,
>
> 
> 
> Juan Carlos & Suresh
>
> 
> 
> 
>

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 1 Dec 2014 17:45:07 +0000

Hi,

I have some questions on text in Section 4 of this document:

>    However, the IPv6 Destination Options Header MUST
>    NOT be inserted between the GRE delivery header and the GRE header.

Why can't an IPv6 DO header be inserted? 

>    However, a GRE ingress node MAY simply restrict itself to sending
>    packets no larger than 1280 octets, and omit implementation of PMTUD.

That is incorrect. The GRE ingress MUST accommodate payload packets up
to 1280 bytes in length. That means that the delivery packet will be up to
1280 bytes plus the length of the GRE header plus the length of the IPv6
header plus any extension headers. So, a minimal delivery packet to
accommodate an 1280 byte payload packet would be 1324 bytes.

If a 1324 byte payload packet cannot be accommodated in the IPv6 path
between the GRE ingress and egress, the ingress has no choice but to
perform IPv6 fragmentation on the delivery packet. The document
needs to say that.

Thanks - Fred
[email-masked]

---

From: Joe Touch <[email-masked]>
Date: Tue, 02 Dec 2014 14:17:37 -0800

I read this draft.

IMO, it's fine as long as it is updated to indicate that it reflects
current deployments.

I would be a lot more comfortable if this were BCP as a result.
Otherwise, we'll open the can of worms about what GRE SHOULD be doing,
and that would impede documenting what's deployed as a baseline.

Joe

On 11/20/2014 8:34 PM, Zuniga, Juan Carlos wrote:
> Hi all,
> 
>  
> 
> At the Int-Area WG meeting in Honolulu there was strong support to adopt
> draft-pignataro-intarea-gre-ipv6-01 as WG draft. We are now starting a
> call on the list to confirm its adoption.
> 
>  
> 
> If you are in favor or against adopting this draft, please reply to this
> email stating your opinion. The call will finish on Friday 2014-12-05.
> 
>  
> 
> Regards,
> 
>  
> 
> Juan Carlos & Suresh
> 
>  
> 
> 
> 
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 2 Dec 2014 23:26:57 +0000

Hi Joe,

> -----Original Message-----
> From: Int-area [mailto:[email-masked]] On Behalf Of Joe Touch
> Sent: Tuesday, December 02, 2014 2:18 PM
> To: Zuniga, Juan Carlos; [email-masked]
> Subject: Re: [Int-area] Call for adoption of draft-pignataro-intarea-gre-ipv6-01
> 
> I read this draft.
> 

You said you read it, but you didn't notice the broken parts?

Thanks - Fred

---

From: Joe Touch <[email-masked]>
Date: Tue, 02 Dec 2014 15:40:07 -0800

> You said you read it, but you didn't notice the broken parts?

I wasn't approving it as-written. Once it's a WG doc and we know the
scope of the discussion, we can all engage in a useful discussion on the
details of its content.

E.g., if it's strictly limited to what is deployed, then it certainly
should document all the parts - including the broken ones.

Joe

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 2 Dec 2014 23:46:33 +0000

Hi Joe,

> From: Joe Touch [mailto:[email-masked]]
> Sent: Tuesday, December 02, 2014 3:40 PM
> To: Templin, Fred L; Zuniga, Juan Carlos; [email-masked]

I would like to see my questions addressed before the document could be
adopted:

http://www.ietf.org/mail-archive/web/int-area/current/msg04101.html

> should document all the parts - including the broken ones.

What is written in the document can't work in real deployments; it does
not support the IPv6 minimum MTU.

Thanks - Fred

---

From: Joe Touch <[email-masked]>
Date: Tue, 02 Dec 2014 15:48:53 -0800

> not support the IPv6 minimum MTU.

Even if it's broken, documenting it as deployed is important.

Joe

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 2 Dec 2014 23:56:32 +0000

Hi Joe,

> Sent: Tuesday, December 02, 2014 3:49 PM

But, that's not what this document is doing. It is saying "MAY/SHOULD/MUST"
do things that are broken. That is language for a functional specification, and
quite different than an Informational document.

Also, you skipped the part about my questions that need to be addressed:

Thanks - Fred

---

From: Joe Touch <[email-masked]>
Date: Tue, 02 Dec 2014 16:06:14 -0800

On 12/2/2014 3:56 PM, Templin, Fred L wrote:
> But, that's not what this document is doing.

Agreed; that's why I stated my position as I did.

> Also, you skipped the part about my questions that need to be addressed:

I already said I didn't want to discuss the details of a future
specification.

Again, I'm OK with documenting what IS - only what IS.

If we're talking about documenting what SHOULD BE, then that's a
different, larger discussion that shouldn't happen for IPv6 GRE in
isolation. It should include IPv4 too, at least, and it will require a
lot more discussion.

Joe

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 3 Dec 2014 16:08:32 +0000

Hi Joe,

> Sent: Tuesday, December 02, 2014 4:06 PM

OK, but then doesn't that mean that we need to see a revised version
of the document before we can approve it as a wg item?

Thanks - Fred

---

From: Joe Touch <[email-masked]>
Date: Wed, 03 Dec 2014 09:26:50 -0800

> Hi Joe,
...
> of the document before we can approve it as a wg item?

We first need to decide what the focus of the doc should be; asking for
a revision without indicating what to change isn't productive.

IMO, first things first - the focus needs to be clear. THEN we can
decide what else needs to be fixed, in what order.

Joe

---

From: "Zuniga, Juan Carlos" <[email-masked]>
Date: Tue, 9 Dec 2014 04:10:45 +0000

Hi all,

At this moment the call for adoption has finished. It is clear that there is WG interest in the document, so it will be adopted as WG draft.

There has been some discussion about the scope of the document (Standards Track vs. BCP) and the group needs to decide on the scope so that correct wording can be used.

As stated by Ron, the current authors' intention is to update RFC 2784 and therefore make it a Standards Track.

If you have any views about the scope, please state your opinion.

Regards,

Juan Carlos & Suresh

From: Zuniga, Juan Carlos
Sent: Thursday, November 20, 2014 11:34 PM
To: [email-masked]
Cc: Suresh Krishnan
Subject: Call for adoption of draft-pignataro-intarea-gre-ipv6-01

Hi all,

At the Int-Area WG meeting in Honolulu there was strong support to adopt draft-pignataro-intarea-gre-ipv6-01 as WG draft. We are now starting a call on the list to confirm its adoption.

If you are in favor or against adopting this draft, please reply to this email stating your opinion. The call will finish on Friday 2014-12-05.

Regards,

Juan Carlos & Suresh

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 9 Dec 2014 06:06:15 +0000

Hi Juan Carlos,

This document intends to update RFC 2784, and as such it seems appropriate to retain the Standards Track.

If it helps with scope, we could add a sentence to the Intro similar to RFC 2784:
   Finally this specification describes the intersection of IPv6 GRE
   currently deployed by multiple vendors.

This is not a dissertation on fragmentation, I think Andrew Yourtchenko summarized it best at https://www.ietf.org/mail-archive/web/int-area/current/msg04100.html.

Thanks,

Carlos.

On Dec 9, 2014, at 5:10 AM, Zuniga, Juan Carlos <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

As stated by Ron, the current authors’ intention is to update RFC 2784 and therefore make it a Standards Track.

Regards,

Juan Carlos & Suresh

From: Zuniga, Juan Carlos
Sent: Thursday, November 20, 2014 11:34 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Suresh Krishnan
Subject: Call for adoption of draft-pignataro-intarea-gre-ipv6-01

Hi all,

Regards,

Juan Carlos & Suresh

_______________________________________________
Int-area mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/int-area