Subject: [Int-area] I-D Action: draft-ietf-intarea-gre-ipv6-09.txt

From: [email-masked]
Date: Thu, 25 Jun 2015 09:07:16 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Internet Area Working Group Working Group of the IETF.

        Title           : IPv6 Support for Generic Routing Encapsulation (GRE)
        Authors         : Carlos Pignataro
                          Ron Bonica
                          Suresh Krishnan
	Filename        : draft-ietf-intarea-gre-ipv6-09.txt
	Pages           : 10
	Date            : 2015-06-25

Abstract:
   Generic Routing Encapsulation (GRE) can be used to carry any network-
   layer payload protocol over any network-layer delivery protocol.  GRE
   procedures are specified for IPv4, used as either the payload or
   delivery protocol.  However, GRE procedures are not specified for
   IPv6.

   This document specifies GRE procedures for IPv6, used as either the
   payload or delivery protocol.  It updates the GRE specification, RFC
   2784.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-intarea-gre-ipv6/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-intarea-gre-ipv6-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-intarea-gre-ipv6-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Lucy yong <[email-masked]>
Date: Thu, 25 Jun 2015 17:15:38 +0000

Some comments:

Section 2.1 description is not right. GRE checksum can't detect a mis-delivered packet and neither the checksum function in the payload. GRE checksum only provides integrity check on GRE header and GRE payload. 

Only IPv4 payload has the equivalent payload integrity check as of GRE checksum. GRE does not directly carry TCP or UDP. When GRE payload protocol is not IPv6, the payload still can carry TCP or UDP. For example, GRE payload is either Ethernet or MPLS that carries IP/TCP/UDP flows. This satisfies "the payload carries TCP or UDP"; in this case, TCP and UDP checksum does not provide the same integrity check as of GRE checksum. 

GRE can be used in many ways. These examples seem not sufficient for the justification of GRE checksum zero. 

Since Ipv6 has flow label, it would be good for the draft to describe use of flow label in IPv6 header.

Regards,
Lucy

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, June 25, 2015 11:07 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Int-area] I-D Action: draft-ietf-intarea-gre-ipv6-09.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Int-area mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-area