Subject: Re: [Int-area] Fwd: New Version Notification for draft-nordmark-intarea-ippl-03.txt

From: Erik Nordmark <[email-masked]>
Date: Tue, 5 Apr 2016 14:24:54 -0300

On 3/29/16 7:53 AM, Sowmini Varadhan wrote:
>
>
> On Mon, Mar 21, 2016 at 4:15 PM, Erik Nordmark <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>     URL:
>     https://www.ietf.org/internet-drafts/draft-nordmark-intarea-ippl-03.txt
>
>
>  aiui, the problem statement here is that you can have one
> IP subnet broken into islands of isolated/community vlans
> that are not necessarily in the same IP bcast domain, so
> IP-based protocols have to factor in that consideration.
>
> Is DHCP another example of such a protocol that might have
> similar caveats (e.g., if a node in a community vlan gets
> some info from the dhcp server, then the info for the default
> router needs to be on the node's community vlan or a
> promisc vlan)?
For the DHCP server/relay to be reachable it needs to be on a 
promiscuous port. We can make that more clear. (Actually, we should also 
make it clear that the routers are on promiscuous ports.)

I don't know if there is DHCP information returned to the host which 
could conflict with the IPPL configuration. For DHCPv6 if L=0 is 
advertised by the routers then the DHCPv6 server shouldn't return a /64 
as being on-link.
> There may also be some rules around icmp
> redirect generation that cannot be based purely on IP subnet
> mask checks?
Good point. For IPv6 the routers (in addition to setting L=0 for IPv6 
prefixes) need to disable sending ICMP redirects on the link.
For IPv4 there is no on-link redirect hence leaving redirects enabled 
shouldn't cause any harm AFAICT (as long as the redirect target is on a 
promiscious port.)

    Erik

> --Sowmini

---

From: 神明達哉 <[email-masked]>
Date: Tue, 5 Apr 2016 11:41:30 -0700

At Tue, 5 Apr 2016 14:24:54 -0300,

> advertised by the routers then the DHCPv6 server shouldn't return a /64

What do you mean by "return a /64 as being on-link"?  As far as I know
there's no DHCPv6 standard equivalent to the prefix information option
of RA in the first place, if that's what you meant.

--
JINMEI, Tatuya

---

From: Erik Nordmark <[email-masked]>
Date: Wed, 6 Apr 2016 00:48:42 -0300

> of RA in the first place, if that's what you meant.
I was under the (perhaps mistaken) assumption that a prefix length had 
been added to DHCPv6.
I know it was discussed at some point(s) in time.

I also don't know if draft-ietf-mif-dhcpv6-route-option-03 is going 
anywhere; in section-3.2 it has support for on-link routes.

    Erik