Subject: Re: [Int-area] New Version Notification for draft-liu-intarea-ipipv4-tunnel-yang-02.txt

From: wangzitao <[email-masked]>
Date: Tue, 5 Jul 2016 01:16:46 +0000

Hi WG,

There was discussion in Yokohama meeting, and during several months off line discussion and work, we prepare a new revision of the draft. 
In this version, we redesign the ip tunnel data model, close some open issues, and address some comments:
# the new model can cover the “IPv4 in IPv4”, ” IPv6 in IPv4”, ” IPv6 to IPv4” in default format. And it also can provide an optional solution for extending to the other IP-based tunnel models.
# define a single list keyed using tunnel name and tunnel type to displace multiple lists.
# define a individual module using leafref to bind with interface yang model, rather than augment interface yang model.
# make the attribute names align with the ip tunnel mib [RFC4087].

Please review it. Comments, questions, and input are welcome!

Best Regards!
-Michael

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2016年7月4日 10:24
收件人: Adam Mate Foldes; Zhengguangying (Walker); Zhuangyan (Yan); wangzitao; Ying Liu; Zhuangyan (Yan); Ying Liu; Adam Mate Foldes; Aijun Wang
主题: New Version Notification for draft-liu-intarea-ipipv4-tunnel-yang-02.txt

A new version of I-D, draft-liu-intarea-ipipv4-tunnel-yang-02.txt
has been successfully submitted by Zitao Wang and posted to the IETF repository.

Name:		draft-liu-intarea-ipipv4-tunnel-yang
Revision:	02
Title:		Yang Data Model for IPIPv4 Tunnel
Document date:	2016-07-03
Group:		Individual Submission
Pages:		15
URL:            https://www.ietf.org/internet-drafts/draft-liu-intarea-ipipv4-tunnel-yang-02.txt
Status:         https://datatracker.ietf.org/doc/draft-liu-intarea-ipipv4-tunnel-yang/
Htmlized:       https://tools.ietf.org/html/draft-liu-intarea-ipipv4-tunnel-yang-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-liu-intarea-ipipv4-tunnel-yang-02

Abstract:
   This document defines a YANG data model for the management of IP
   based tunnels.  The data model includes configuration data and state
   data.  In default format, it describes managed attributes used for
   managing tunnels of IPv4 or IPv6 over IPv4 tunnels.  And it can also
   serve as a base model which can be augmented with technology-specific
   details in other Ip based tunnel models.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Joe Touch <[email-masked]>
Date: Thu, 7 Jul 2016 13:28:30 -0700

> Please review it. Comments, questions, and input are welcome!

IP in IP usually cites RFC2003, which is standards-track, rather than 1853.

2003 is IPv4 in IPv4; IPv6 wasn't spec'd until 457 RFCs later. IPv6 in
IPv6 is 2473.

The references are incomplete.

Clear-df is ambiguous - tunnel ingresses MUST be able to source-fragment
encapsulated packets. The decision on whether to fragment the "inner"
packet (transiting the tunnel, i.e., the TTP per draft-intarea-tunnels)
is made by the associated router, not at the (virtual tunnel) interface
(i.e., corresponding to the ingress).

Nearly every parameter for this model of a tunnel interface really ought
to parallel that for other L2 interfaces.

Joe