Subject: [Int-area] Continuing IPv10 I-D discussion.

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Mar 2017 13:16:46 +0000

Hello,

Let's continue the IPv10 I-D discussion here as there was no opportunity to discuss it at the IETF 98 as it was clear in front of all of you that there were technical issues related to remote participation.

I think all of you now know about IPv10 and what is the problem and how IPv10 can solve it and how it can be deployed in a short time.

You can ask any question and I'll do my best to give you answers to make it clear for everyone so the IPv10 I-D can go forward through the IETF standardization process and be published.

All of you know that the migration process to IPv6 took longer than we expected and we shouldn't keep waiting more than that after the depletion of the IPv4 address space.

If there is a better solution for this problem I can participate freely on its discussion.

Best regards,

Khaled Omar

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Thu, 30 Mar 2017 17:02:57 +0200

Dear Omar,

Am 30.03.2017 um 15:16 schrieb Khaled Omar:
> I think all of you now know about IPv10 and what is the problem and how
> IPv10 can solve it and how it can be deployed in a short time.

- Your IPv10 proposal doesn't solve the IPv6 deployment problems, you
  basically get an additional IPv10 deployment problem.
- IPv10 doesn't allow an IPv6-only host to communicate to an IPv4-only
  host and vice versa as stated in the I-D. Hint: an IPv4-only host
  has got no idea what an IPv6 address is, let alone an "IPv10 address".
- As others already pointed out: the proposal is technically flawed
  and does not work.

> You can ask any question and I’ll do my best to give you answers to make
> it clear for everyone so the IPv10 I-D can go forward through the IETF
> standardization process and be published.

Repeating this over and over again does not work. IMHO you only can
move forward with a _technically sound_ proposal, otherwise many
people will regard it as waste of time.

> If there is a better solution for this problem I can participate freely

There are various WGs in the IETF that try to work towards better
solutions. You may not like them, but they are at least rough
community consensus.

Best,
 Roland

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Mar 2017 15:39:22 +0000

I forgot to tell you that I was waiting for a replacement solution for 3 years but after a short time I found IPv10 is the best.

Best Regards,

-----Original Message-----
From: Khaled Omar 
Sent: Thursday, March 30, 2017 5:26 PM
To: 'Bless, Roland (TM)'
Subject: RE: [Int-area] Continuing IPv10 I-D discussion.

Hi Roland,

This way too is not working, keeping repeating same answers to the same questions is ridiculous.

 > Your IPv10 proposal doesn't solve the IPv6 deployment problems, you

IPv10 does not depends on clients (ISPs or Enterprises) like IPv6 migration process, it depends on software modification on all hosts' OSs and routers' OSs to be able to encapsulate both IP version on the same IP header.

> IPv10 doesn't allow an IPv6-only host to communicate to an IPv4-only

Think about a host treats a different version destination as a host in a different subnet, it will send the packet to the gateway, the gateway (router) will check the destination packet, and based on its version (whether it is an IPv4 packet or and IPv6 packet) it will checks its IP routing table (whether the IPv4 routing or the IPv6 routing table respectively) to make a routing decision, and each router on the road to the destination will do the same till reaching the destination. 

> As others already pointed out: the proposal is technically flawed
  and does not work.

Please speak with your own tongue, others who stated that had no full information about how IPv10 works, later they believed it is the best solution for IPv4 and IPv6 coexistence until reaching a full migration to IPv6.

> Repeating this over and over again does not work. IMHO you only can move forward with a _technically sound_ proposal, otherwise many people will regard it as waste of time.

Simply, if IPv10 is not of your interest, peacefully don't participate in the discussion, as I stated on my proposal, the internet will be divided into two divisions, and that will not be good for all of us when some new users will be assigned (or already assigned) IPv6 only addresses and has no access to all internet resources or a limited access(Google and Facebook).

> There are various WGs in the IETF that try to work towards better solutions. You may not like them, but they are at least rough community consensus.

Science doesn't understand consensus, science understands ideas, better ideas and the best idea, that can technically deployed easily and in a short time, I can make a solution like IPv6 and think about forcing people to migrate, but this will not work practically in a short time, and this is what we are experiencing, also, thinking about a solution that requires giving training everywhere to let people deploy it is not a good solution, because still depends on clients (users), but to make a solution that depends on a few number of companies developing networking OSs and can be deployed in a short time with no interventions of a helping technology (like protocol translation or asking DNS for more efforts).

Eventually, IMHO, you will never reach a full consensus by all IETF members, so it is the time for the responsible ADs and Chairs with some help from interested participants to make a good impact for all.

Best regards,

Khaled Omar 

-----Original Message-----
From: Bless, Roland (TM) [mailto:[email-masked]]
Sent: Thursday, March 30, 2017 5:03 PM
To: Khaled Omar; [email-masked]
Subject: Re: [Int-area] Continuing IPv10 I-D discussion.

Dear Omar,

> You can ask any question and I'll do my best to give you answers to 
> make it clear for everyone so the IPv10 I-D can go forward through the 
> IETF standardization process and be published.

Repeating this over and over again does not work. IMHO you only can move forward with a _technically sound_ proposal, otherwise many people will regard it as waste of time.

> freely on its discussion.

There are various WGs in the IETF that try to work towards better solutions. You may not like them, but they are at least rough community consensus.

Best,
 Roland

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 30 Mar 2017 11:01:29 -0500

On Thu, Mar 30, 2017 at 05:02:57PM +0200,
 Bless, Roland (TM) <[email-masked]> wrote 
 a message of 36 lines which said:

> - IPv10 doesn't allow an IPv6-only host to communicate to an
>   IPv4-only host and vice versa as stated in the I-D. Hint: an
>   IPv4-only host has got no idea what an IPv6 address is, let alone
>   an "IPv10 address".

Same issue with the routers in the path. IPv10 would require *all* of
them to be upgraded for the new packet header format. 

> - As others already pointed out:

Indeed, it has been said several times to the author but he keeps not
listening. I wonder why there was a slot at the IETF meeting.

---

From: Joe Touch <[email-masked]>
Date: Thu, 30 Mar 2017 09:11:56 -0700

> listening. I wonder why there was a slot at the IETF meeting.
The IETF is a place that lets a thousand flowers bloom, but has
historically been less adept at pruning.

A good garden requires both. IMO, that's a lesson for the evaluation of
all proposals.

Joe

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 30 Mar 2017 11:24:33 -0500

On Thu, Mar 30, 2017 at 09:11:56AM -0700,
 Joe Touch <[email-masked]> wrote 
 a message of 58 lines which said:

> A good garden requires both

Yes, but there is a big assymetry: writing a good proposal is hard,
and takes time, while writing stupid things can be done at
high-rate. If we allow everything, we'll have more bad proposals than
good.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Mar 2017 16:29:43 +0000

What will happen with one router from a specific company will happen with all routers from the same vendors, inserting updates is not that hard, but the case is will they work or not, and my idea works fine but the IETF needs to make up official decisions before the explosion of the Internet :-) the reason why is to get out from an I-D to another one and make a progress.

Best,

Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Mar 2017 16:33:14 +0000

> I don't see the point of discussing privately with you, I already told you you're just a waste of time. Either post your messages to the IETF mailing list, or abstain.

Come on guys, if you think it is out of your interest, SIMPLY do not reply and show your interest, instead of using such a disrespectful words.

-----Original Message-----
From: Stephane Bortzmeyer [mailto:[email-masked]] 
Sent: Thursday, March 30, 2017 6:23 PM
To: Khaled Omar
Cc: Stephane Bortzmeyer
Subject: Re: [Int-area] Continuing IPv10 I-D discussion.

On Thu, Mar 30, 2017 at 04:07:45PM +0000,  Khaled Omar <[email-masked]> wrote  a message of 33 lines which said:

> True, all routers in the path are products of a little number of 
> networking companies, meaning their networking OSs can be upgraded 
> simply based on the number of people working on every AS.

I don't see the point of discussing privately with you, I already told you you're just a waste of time. Either post your messages to the IETF mailing list, or abstain.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Mar 2017 16:58:24 +0000

From: Int-area [mailto:[email-masked]] On Behalf Of Joe Touch
Sent: Thursday, March 30, 2017 6:12 PM
To: Stephane Bortzmeyer; Bless, Roland (TM)
Cc: [email-masked]
Subject: Re: [Int-area] Continuing IPv10 I-D discussion.

Maybe the IETF should fix that or that will be a waste of time for all.

listening. I wonder why there was a slot at the IETF meeting.
The IETF is a place that lets a thousand flowers bloom, but has historically been less adept at pruning.

A good garden requires both. IMO, that's a lesson for the evaluation of all proposals.

Joe

---

From: Ignas Bagdonas <[email-masked]>
Date: Thu, 30 Mar 2017 18:12:05 +0100

On 30/03/2017 17:29, Khaled Omar wrote:
> What will happen with one router from a specific company will happen with all routers from the same vendors, inserting updates is not that hard,

Khaled,

Please try to view your proposal from the operational side too. 
Designing a protocol wire representation and implementing that for some 
platform is quite trivial compared to the changes that are needed for 
the network support systems, the effort required for validation of that 
new functionality before the deployment, and the feasibility of doing 
the actual flag day deployment. For any practically sized operator that 
would be an exercise of years with associated costs of very substantial 
nature. Please make yourself more familiar with network operational 
realities.

Ignas

---

From: Karsten Thomann <[email-masked]>
Date: Thu, 30 Mar 2017 10:16:13 -0700 (PDT)

Am Donnerstag, 30. März 2017, 16:29:43 schrieb Khaled Omar:
> What will happen with one router from a specific company will happen with
> all routers from the same vendors, inserting updates is not that hard,...

Just a small comment, as I don't like this discussion, too.
That "is not hard" might be true for the installation at home users and small 
businesses, but exactly the opposite of "not hard" at every other location.
If you can convince the vendors to redesign their whole hardware designs to 
support a new protocol in the forwarding plane to get a acceptable forwarding 
rate AND the ISP's/MSP's to buy new hardware for many $$$, we can start 
discussing again, but in the meanwhile no one wants to support a third 
protocol.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Mar 2017 17:19:48 +0000

> If you can convince the vendors to redesign their whole hardware designs to support a new protocol in the forwarding plane to get a acceptable forwarding rate AND the ISP's/MSP's to buy new hardware for many $$$, we can start discussing again, but in the meanwhile no one wants to support a third protocol.

IPv10 requires software development, this is what most participants don't want to understand, it will have no cost if they will not upgrade their routers' OSs.

-----Original Message-----
From: Karsten Thomann [mailto:[email-masked]] 
Sent: Thursday, March 30, 2017 7:16 PM
To: [email-masked]
Cc: Khaled Omar
Subject: Re: [Int-area] Continuing IPv10 I-D discussion.

Am Donnerstag, 30. März 2017, 16:29:43 schrieb Khaled Omar:
> What will happen with one router from a specific company will happen 
> with all routers from the same vendors, inserting updates is not that hard,...

Just a small comment, as I don't like this discussion, too.
That "is not hard" might be true for the installation at home users and small businesses, but exactly the opposite of "not hard" at every other location.
If you can convince the vendors to redesign their whole hardware designs to support a new protocol in the forwarding plane to get a acceptable forwarding rate AND the ISP's/MSP's to buy new hardware for many $$$, we can start discussing again, but in the meanwhile no one wants to support a third protocol.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Mar 2017 17:20:14 +0000

Ignas,

> Please try to view your proposal from the operational side too.

If they will not accept these changes they will face the division problem, they are the customer facing authorities, so if they will not make those changes, they will find another problem from the other side.

> For any practically sized operator that would be an exercise of years with associated costs of very substantial nature. Please make yourself more familiar with network operational realities.

Upgrading routers' OSs will take a short time if they are organizing their work and distributing assignments clearly.

-----Original Message-----
From: Ignas Bagdonas [mailto:[email-masked]] 
Sent: Thursday, March 30, 2017 7:12 PM
To: Khaled Omar
Cc: [email-masked]
Subject: Re: [Int-area] Continuing IPv10 I-D discussion.

On 30/03/2017 17:29, Khaled Omar wrote:
> with all routers from the same vendors, inserting updates is not that 
> hard,

Khaled,

Please try to view your proposal from the operational side too. 
Designing a protocol wire representation and implementing that for some platform is quite trivial compared to the changes that are needed for the network support systems, the effort required for validation of that new functionality before the deployment, and the feasibility of doing the actual flag day deployment. For any practically sized operator that would be an exercise of years with associated costs of very substantial nature. Please make yourself more familiar with network operational realities.

Ignas

---

From: Roland Bless <[email-masked]>
Date: Fri, 31 Mar 2017 00:35:54 +0200

Hi Khaled,

see comments inline.

> same questions is ridiculous.

Since your proposal hasn't changed, I can only give the same answers to
the same questions...

> IPv10 does not depends on clients (ISPs or Enterprises) like IPv6
> migration process, it depends on software modification on all hosts'
> OSs and routers' OSs to be able to encapsulate both IP version on the
> same IP header.

How is this different from IPv6? Moreover, for high speed routers,
firewalls
and so on, IPv6 also required new hardware (so will "IPv10"), thus a
router OS update isn't enough in this case.

> host and vice versa as stated in the I-D. Hint: an IPv4-only host has
> got no idea what an IPv6 address is, let alone an "IPv10 address".

> Think about a host treats a different version destination as a host
> in a different subnet, it will send the packet to the gateway, the
> gateway (router) will check the destination packet, and based on its
> version (whether it is an IPv4 packet or and IPv6 packet) it will
> checks its IP routing table (whether the IPv4 routing or the IPv6
> routing table respectively) to make a routing decision, and each
> router on the road to the destination will do the same till reaching
> the destination.

This isn't the problem I was referring to. An IPv4-only host cannot
simply use an IPv6/IPv10 address as destination address since it doesn't
have any notion of such addresses.

> Please speak with your own tongue, others who stated that had no full
> information about how IPv10 works, later they believed it is the best
> solution for IPv4 and IPv6 coexistence until reaching a full
> migration to IPv6.

I already spoke out for myself
(https://mailarchive.ietf.org/arch/msg/ipv6/zyoQNbqFLFP_dgXyBKbnWyI5I3U),
but several others seemed to have found the same issues, just reread the
thread.

> Simply, if IPv10 is not of your interest, peacefully don't
> participate in the discussion, as I stated on my proposal, the

Sorry, I tried to help politely - but if you prefer to dismiss any well
intended advice and are not open to criticism of your idea, I better
stop now.

> internet will be divided into two divisions, and that will not be
> good for all of us when some new users will be assigned (or already
> assigned) IPv6 only addresses and has no access to all internet
> resources or a limited access(Google and Facebook).
> 
> Science doesn't understand consensus, science understands ideas,
> better ideas and the best idea, that can technically deployed easily

But science is based on discussion, facts, experiments and proofs.

> and in a short time, I can make a solution like IPv6 and think about
> forcing people to migrate, but this will not work practically in a
> short time, and this is what we are experiencing, also, thinking
> about a solution that requires giving training everywhere to let
> people deploy it is not a good solution, because still depends on
> clients (users), but to make a solution that depends on a few number
> of companies developing networking OSs and can be deployed in a short
> time with no interventions of a helping technology (like protocol
> translation or asking DNS for more efforts).

I still don't see why you wouldn't have exactly the same problems
for IPv10.

> Eventually, IMHO, you will never reach a full consensus by all IETF
> members, so it is the time for the responsible ADs and Chairs with
> some help from interested participants to make a good impact for
> all.

Yes, full consensus isn't required in the IETF, rough consensus
suffices. If there is enough interest in the IETF, you'll get a working
group to move this forward.

Best regards,
 Roland

> 
> -----Original Message----- From: Bless, Roland (TM)
> [mailto:[email-masked]] Sent: Thursday, March 30, 2017 5:03 PM 
> To: Khaled Omar; [email-masked] Subject: Re: [Int-area] Continuing
> IPv10 I-D discussion.
> 
> Dear Omar,
> 
>> I think all of you now know about IPv10 and what is the problem and
>>  how IPv10 can solve it and how it can be deployed in a short
>> time.
> 
> - Your IPv10 proposal doesn't solve the IPv6 deployment problems,
> you basically get an additional IPv10 deployment problem. - IPv10
> doesn't allow an IPv6-only host to communicate to an IPv4-only host
> and vice versa as stated in the I-D. Hint: an IPv4-only host has got
> no idea what an IPv6 address is, let alone an "IPv10 address". - As
> others already pointed out: the proposal is technically flawed and
> does not work.
> 
>>  make it clear for everyone so the IPv10 I-D can go forward through
>> the IETF standardization process and be published.
> 
> Best, Roland

---

From: Lee Howard <[email-masked]>
Date: Thu, 30 Mar 2017 18:30:01 -0500

On 3/30/17, 12:20 PM, "Int-area on behalf of Khaled Omar"
<[email-masked] on behalf of [email-masked]> wrote:

>If they will not accept these changes they will face the division
>problem, they are the customer facing authorities, so if they will not
>make those changes, they will find another problem from the other side.

I don¹t understand your point. We are approaching the division problem
with IPv4 and IPv6. How is a third division helpful?

We have consensus on IPv6, and we have significant deployment. Many of us
are working on deploying single-stack IPv6 networks, with IPv4 translators
at the edges if necessary.

>
>> For any practically sized operator that would be an exercise of years
>>with associated costs of very substantial nature. Please make yourself
>>more familiar with network operational realities.
>
>Upgrading routers' OSs will take a short time if they are organizing
>their work and distributing assignments clearly.

That is not realistic in a large ISP.
I drove the IPv6 deployment at a very large provider. It took us more than
five years to get code from the core to the edge. Vendors are terrible at
delivering code that doesn¹t have fundamental bugs. Minor bugs (e.g.,
IS-IS interoperability between vendors, or prefix lengths other than /64
or /128 on point to point links)  can take a long time to identify and fix.
Vendors are constantly committing patched code, but operators have to
fully test anything they consider putting on their network. Then they find
bugs and wait for updates and test again.
Once the code is approved, tools have to be updated. This includes
standards like IPFIX, and log parsing tools, and alarm generators, and
active monitoring tools.
Core routers are not updated more often than twice a year. Don¹t touch a
working box: every touch increases the odds of an outage.

You¹ve said that this only requires a software update, but you¹re talking
about adding a header to every packet. Routers use custom chips optimized
for processing known headers; anything that doesn¹t fit that pattern is
kicked to a software process, which slows everything down and costs a lot
in CPU cores and memory. Adding a header doesn¹t scale at large numbers of
packets per second.

Your draft even says, "IPv4 and IPv6 routing must be enabled on all
routers² and "All Internet connected hosts must be IPv10 hosts²
If we could update every router and host to support a new protocol, we
would already have IPv6 completely deployed.

I don¹t see any sign that your proposal is gaining consensus.

Lee

>platform is quite trivial compared to the changes that are needed for the
>network support systems, the effort required for validation of that new
>functionality before the deployment, and the feasibility of doing the
>actual flag day deployment. For any practically sized operator that would
>be an exercise of years with associated costs of very substantial nature.
>Please make yourself more familiar with network operational realities.
>
>
>Ignas
>
>
>_______________________________________________
>Int-area mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/int-area

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Mar 2017 23:44:05 +0000

-------- Original Message --------
To: Lee Howard
CC:

You can read the IPv10 I-D again and all your concerns will be obvious, I don't mind if you have already a series of new questions that will add a new value to the discussion but the time to deploy IPv10 is an important factor.

We need consensus after understanding how IPv10 works and how it will be deployed.

Best regards,

-------- Original Message --------
Subject: Re: [Int-area] Continuing IPv10 I-D discussion.
From: Lee Howard
To: Khaled Omar ,Ignas Bagdonas
CC: [email-masked]

Lee

---

From: Mikael Abrahamsson <[email-masked]>
Date: Fri, 31 Mar 2017 08:17:14 +0200 (CEST)

> We need consensus after understanding how IPv10 works and how it will be deployed.

As has been stated again and again. Your proposal would have been 
interesting if it was presented in 1995, or perhaps even in 2000.

Let me give you an IPv6 deployment timeline:

Standards were worked out in the mid 90-ties, afterwards operating system 
vendors started working on it and "real" support started cropping up in 
the early to mid 2000:nds, with a large milestone being Windows Vista in 
2006, where as far as I know this was the first widely used consumer 
operating system to implement this. It then took until Windows 7 timeframe 
around 2010 before people started moving off of Windows XP in ernest, and 
we're still seeing Windows XP in non-trivial numbers. So now in 2017 we're 
seeing most operating systems have comprehensive (albeit perhaps not as 
well-tested as we would like) support for IPv6, where the application 
ecosystem still has a way to go. We're still working on better APIs to 
handle the dual-stackedness problem.

Most likely, even if Microsoft could be convinced that IPv10 is something 
they need to support, this would only happen in Windows 10. Then we have 
the rest of the ecosystem with access routers, load balancers, 
SAVI-functionality for BCP38 compliance in access devices, core routers 
etc. Most of these will require a hardware fork-lift in order to support 
your proposal, because they do not forward packets in a CPU, they forward 
it in purpose-designed hardware that is a lot less flexible in what they 
can do.

So even if we all united now (which won't happen) around your IPv10 
proposal, it would take 5-10 years before the first devices out on the 
market had support for it. Probably 5-10 years after that before support 
is widely available.

IPv10 would delay and confuse deployment of something that is not IPv4. 
While IPv6 is not perfect, there are now hundreds of millions of devices 
on the Internet with IPv6 access. It's proven to work, it's not perfect, 
but we have a decently good idea what to do to make it better.

IPv10 is only injecting FUD into where we need to go debate, which is IPv6 
deployment for all.

Please stop.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Fri, 31 Mar 2017 09:51:09 +0200

Hi Mikael,

thanks for clarifying again, everything +1!

Regards,
 Roland

Am 31.03.2017 um 08:17 schrieb Mikael Abrahamsson:
>> You can read the IPv10 I-D again and all your concerns will be
>> obvious, I don't mind if you have already a series of new questions
>> that will add a new value to the discussion but the time to deploy
>> IPv10 is an important factor.
>>
> Standards were worked out in the mid 90-ties, afterwards operating
> system vendors started working on it and "real" support started cropping
> up in the early to mid 2000:nds, with a large milestone being Windows
> Vista in 2006, where as far as I know this was the first widely used
> consumer operating system to implement this. It then took until Windows
> 7 timeframe around 2010 before people started moving off of Windows XP
> in ernest, and we're still seeing Windows XP in non-trivial numbers. So
> now in 2017 we're seeing most operating systems have comprehensive
> (albeit perhaps not as well-tested as we would like) support for IPv6,
> where the application ecosystem still has a way to go. We're still
> working on better APIs to handle the dual-stackedness problem.
> 
> Most likely, even if Microsoft could be convinced that IPv10 is
> something they need to support, this would only happen in Windows 10.
> Then we have the rest of the ecosystem with access routers, load
> balancers, SAVI-functionality for BCP38 compliance in access devices,
> core routers etc. Most of these will require a hardware fork-lift in
> order to support your proposal, because they do not forward packets in a
> CPU, they forward it in purpose-designed hardware that is a lot less
> flexible in what they can do.
> 
> IPv10 is only injecting FUD into where we need to go debate, which is
> IPv6 deployment for all.
> 
> Please stop.

---

From: Khaled Omar <[email-masked]>
Date: Fri, 31 Mar 2017 12:13:18 +0000

> As has been stated again and again. Your proposal would have been interesting if it was presented in 1995, or perhaps even in 2000.

FYI, IPv10 will allow IPv4 to communicate to IPv6 and vice versa, how can it be interesting if it was presented before IPv6 was even developed !

> Most likely, even if Microsoft could be convinced that IPv10 is something they need to support, this would only happen in Windows 10. Then we have the rest of the ecosystem with access routers, load balancers, SAVI-functionality for BCP38 compliance in access devices, core routers etc.

Please, let's not be against ourselves, all OSs will be updated to support IPv10 which is an easy task, OSs will not require support for a new IP version like IPv6, they will just be enabled to support the encapsulation of both version on the same L3 packet header.

Also, networking devices will be upgraded to understand the new IPv10 packet, I said earlier I don't mind If the process will take some time but we should eventually reach consensus, I shouldn't list all devices that need to support IPv10, simply, anything will process a L3 packet, should understand that the IPv10 packet can contain a mixture of IPv4 and IPv6 addresses.

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Bless, Roland (TM)
Sent: Friday, March 31, 2017 9:51 AM
To: Mikael Abrahamsson
Cc: int-area
Subject: Re: [Int-area] Fw: Continuing IPv10 I-D discussion.

Hi Mikael,

Regards,
 Roland

Am 31.03.2017 um 08:17 schrieb Mikael Abrahamsson:
> system vendors started working on it and "real" support started 
> cropping up in the early to mid 2000:nds, with a large milestone being 
> Windows Vista in 2006, where as far as I know this was the first 
> widely used consumer operating system to implement this. It then took 
> until Windows
> in ernest, and we're still seeing Windows XP in non-trivial numbers. 
> So now in 2017 we're seeing most operating systems have comprehensive 
> order to support your proposal, because they do not forward packets in 
> a CPU, they forward it in purpose-designed hardware that is a lot less 
> market had support for it. Probably 5-10 years after that before 
> support is widely available.
> 
> While IPv6 is not perfect, there are now hundreds of millions of 
> devices on the Internet with IPv6 access. It's proven to work, it's 
> not perfect, but we have a decently good idea what to do to make it better.
>

---

From: Tom Herbert <[email-masked]>
Date: Fri, 31 Mar 2017 07:19:07 -0700

> Please, let's not be against ourselves, all OSs will be updated to support IPv10 which is an easy task, OSs will not require support for a new IP version like IPv6, they will just be enabled to sup…

"all OSs will be updated to support IPv10 which is an easy task"...
What makes you think it is ever an easy task to get all OSes to
uniformly support anything? Please provide an implementation so we can
evaluate the prospects.

Tom

---

From: Khaled Omar <[email-masked]>
Date: Fri, 31 Mar 2017 14:24:11 +0000

>>What makes you think it is ever an easy task to get all OSes to uniformly support anything? Please provide an implementation so we can evaluate the prospects.

For the 2nd time:

"I shouldn't list all devices that need to support IPv10, simply, anything will process a L3 packet, should understand that the IPv10 packet can contain a mixture of IPv4 and IPv6 addresses."

-----Original Message-----
From: Tom Herbert [mailto:[email-masked]] 
Sent: Friday, March 31, 2017 4:19 PM
To: Khaled Omar
Cc: Bless, Roland (TM); [email-masked]
Subject: Re: [Int-area] Fw: Continuing IPv10 I-D discussion.

"all OSs will be updated to support IPv10 which is an easy task"...
What makes you think it is ever an easy task to get all OSes to uniformly support anything? Please provide an implementation so we can evaluate the prospects.

Tom

>> cropping up in the early to mid 2000:nds, with a large milestone 
>> being Windows Vista in 2006, where as far as I know this was the 
>> first widely used consumer operating system to implement this. It 
>> then took until Windows
>> 7 timeframe around 2010 before people started moving off of Windows 
>> XP in ernest, and we're still seeing Windows XP in non-trivial numbers.
>> (albeit perhaps not as well-tested as we would like) support for 
>> IPv6, where the application ecosystem still has a way to go. We're 
>> still working on better APIs to handle the dual-stackedness problem.
>>
>> order to support your proposal, because they do not forward packets 
>> in a CPU, they forward it in purpose-designed hardware that is a lot 
>> less flexible in what they can do.
>>
>> proposal, it would take 5-10 years before the first devices out on 
>> the market had support for it. Probably 5-10 years after that before

---

From: Mikael Abrahamsson <[email-masked]>
Date: Fri, 31 Mar 2017 16:30:37 +0200 (CEST)

> FYI, IPv10 will allow IPv4 to communicate to IPv6 and vice versa, how can it be interesting if it was presented before IPv6 was even developed !

Because your ideas could possibly have been included in IPv6 and we would 
have had support for it by now. Now you're 20 years too late, and your 
energy would be better spent trying to make IPv6 more deployable without 
changing the on-wire packet format.

You're grossly underestimating the effort and time to get devices into the 
field to properly support a new packet format.

---

From: Tom Herbert <[email-masked]>
Date: Fri, 31 Mar 2017 07:35:10 -0700

> "I shouldn't list all devices that need to support IPv10, simply, anything will process a L3 packet, should understand that the IPv10 packet can contain a mixture of IPv4 and IPv6 addresses."
I don't know what "anything will process an L3 packet" means. Please
answer directly: does this proposal need changes in every OS or not?

---

From: Khaled Omar <[email-masked]>
Date: Fri, 31 Mar 2017 14:37:02 +0000

> Because your ideas could possibly have been included in IPv6 and we would have had support for it by now. Now you're 20 years too late, and your energy would be better spent trying to make IPv6 more deployable without changing the on-wire packet format.

How you would know 20 years ago that IPv6 will not be deployed in a short time so you wanted to add IPv10 to IPv6 ?!

Regarding the energy spent trying to make IPv6 more deployable, I think you can ask the RIRs for their trainings they have made worldwide to make the migration to IPv6 occurs, but in vain, so my solution IPv10 will not waste more energy as it will compensate these efforts in a short time ;-)

-----Original Message-----
From: Mikael Abrahamsson [mailto:[email-masked]] 
Sent: Friday, March 31, 2017 4:31 PM
To: Khaled Omar
Cc: [email-masked]
Subject: Re: [Int-area] Fw: Continuing IPv10 I-D discussion.

> FYI, IPv10 will allow IPv4 to communicate to IPv6 and vice versa, how can it be interesting if it was presented before IPv6 was even developed !

Because your ideas could possibly have been included in IPv6 and we would have had support for it by now. Now you're 20 years too late, and your energy would be better spent trying to make IPv6 more deployable without changing the on-wire packet format.

You're grossly underestimating the effort and time to get devices into the field to properly support a new packet format.

---

From: Khaled Omar <[email-masked]>
Date: Fri, 31 Mar 2017 14:39:47 +0000

Regarding the energy spent trying to make IPv6 more deployable, I think you can ask the RIRs for the trainings they have made worldwide to make the migration to IPv6 occurs.

---

From: Jen Linkova <[email-masked]>
Date: Fri, 31 Mar 2017 16:43:41 +0200

> "I shouldn't list all devices that need to support IPv10, simply, anything will process a L3 packet, should understand that the IPv10 packet can contain a mixture of IPv4 and IPv6 addresses."

So far many people mentioned to you that updating software on clients
and on network devices is very expensive, complicated and slow process
- and those people have been through that process before.
You believe quite the opposite, that it's easy and could be done
overnight but so far we have not seen any data supporting your point
of view.

Maybe your arguments would be more convincing if you can do the following:
- get IPv10 supported in at least one major operating system and by at
least one major routers/switches vendor
- get a canary deployment in a reasonably sized network (preferably
including 'bring-your-own' device, various access technologies and
indeed Internet access over IPv10)
- come back to IETF with the deployment success story and some data on
the deployability of your protocol and tell us about lessons learned.

Then we might continue this discussion.

-- 
SY, Jen Linkova aka Furry

---

From: Joe Touch <[email-masked]>
Date: Fri, 31 Mar 2017 07:43:46 -0700

On 3/30/2017 11:17 PM, Mikael Abrahamsson wrote:
> widely used consumer operating system to implement this.
Both trivia and context:

USC/ISI developed the first IPv6 stack for Windows NT, released publicly
for testing in 1998:
http://dl.acm.org/citation.cfm?id=1267217

It took another 8 years for a revised version to be deployed in Windows
Vista to be widely available.

Joe

---

From: Khaled Omar <[email-masked]>
Date: Fri, 31 Mar 2017 14:50:36 +0000

> I don't know what "anything will process a L3 packet" means. Please answer directly: does this proposal need changes in every OS or not?

Any networking host (PC, Laptop, Server, Cell Phone) must be able to allow the encapsulation of both IP versions in the same L3 packet header, other networking devices (Router, Firewalls, IDS, IPS, LB, etc.) must be able to understand the IPv10 packet to know what is the source IP address and what is the destination IP address.

So, for a direct answer, Yes, the recent OSs' developers are few, the deployment process will depend on how they can push new updates globally.

-----Original Message-----
From: Tom Herbert [mailto:[email-masked]] 
Sent: Friday, March 31, 2017 4:35 PM
To: Khaled Omar
Cc: [email-masked]
Subject: Re: [Int-area] Fw: Continuing IPv10 I-D discussion.

> "I shouldn't list all devices that need to support IPv10, simply, anything will process a L3 packet, should understand that the IPv10 packet can contain a mixture of IPv4 and IPv6 addresses."
I don't know what "anything will process an L3 packet" means. Please answer directly: does this proposal need changes in every OS or not?

>>> So now in 2017 we're seeing most operating systems have 
>>> comprehensive (albeit perhaps not as well-tested as we would like) 
>>> support for IPv6, where the application ecosystem still has a way to 
>>> go. We're still working on better APIs to handle the dual-stackedness problem.
>>>
>>> balancers, SAVI-functionality for BCP38 compliance in access 
>>> devices, core routers etc. Most of these will require a hardware 
>>> fork-lift in order to support your proposal, because they do not 
>>> forward packets in a CPU, they forward it in purpose-designed 
>>> hardware that is a lot less flexible in what they can do.
>>>

---

From: Khaled Omar <[email-masked]>
Date: Fri, 31 Mar 2017 15:02:07 +0000

> So far many people mentioned to you that updating software on clients and on network devices is very expensive, complicated and slow process.

SOFTWARE UPDATES are expensive, complicated and slow process !

-----Original Message-----
From: Jen Linkova [mailto:[email-masked]] 
Sent: Friday, March 31, 2017 4:44 PM
To: Khaled Omar
Cc: [email-masked]
Subject: Re: [Int-area] Fw: Continuing IPv10 I-D discussion.

> "I shouldn't list all devices that need to support IPv10, simply, anything will process a L3 packet, should understand that the IPv10 packet can contain a mixture of IPv4 and IPv6 addresses."

So far many people mentioned to you that updating software on clients and on network devices is very expensive, complicated and slow process
- and those people have been through that process before.
You believe quite the opposite, that it's easy and could be done overnight but so far we have not seen any data supporting your point of view.

Maybe your arguments would be more convincing if you can do the following:
- get IPv10 supported in at least one major operating system and by at least one major routers/switches vendor
- get a canary deployment in a reasonably sized network (preferably including 'bring-your-own' device, various access technologies and indeed Internet access over IPv10)
- come back to IETF with the deployment success story and some data on the deployability of your protocol and tell us about lessons learned.

---

From: Lee Howard <[email-masked]>
Date: Fri, 31 Mar 2017 10:35:13 -0500

On 3/31/17, 10:02 AM, "Int-area on behalf of Khaled Omar"
<[email-masked] on behalf of [email-masked]> wrote:

>>and on network devices is very expensive, complicated and slow process.
>

Yes. Years, and hundreds or thousands of hours of expensive labor.
See where I explained it yesterday at
https://www.ietf.org/mail-archive/web/int-area/current/msg05589.html

And that¹s if we stipulate that this can be done in software, which I
don¹t.

I don¹t see any evidence that you are gaining consensus. Jen¹s suggestion
was very good: develop a stack and get some deployment experience to show
it can work.

Lee

---

From: Khaled Omar <[email-masked]>
Date: Fri, 31 Mar 2017 16:05:27 +0000

> I don¹t see any evidence that you are gaining consensus. Jen¹s suggestion was very good: develop a stack and get some deployment experience to show it can work.

There are many people who likes IPv10 and support it, also I'm not a software developer who works for a company developing an OS, if you don't believe that this idea works, you have to try it by yourself and get back to me with the result and what was your problem, maybe you are not good in writing codes or whatever.

-----Original Message-----
From: Lee Howard [mailto:[email-masked]] 
Sent: Friday, March 31, 2017 5:35 PM
To: Khaled Omar; Jen Linkova
Cc: [email-masked]
Subject: Re: [Int-area] Fw: Continuing IPv10 I-D discussion.

And that¹s if we stipulate that this can be done in software, which I don¹t.

I don¹t see any evidence that you are gaining consensus. Jen¹s suggestion was very good: develop a stack and get some deployment experience to show it can work.

Lee

---

From: Terry Manderson <[email-masked]>
Date: Fri, 31 Mar 2017 16:12:19 +0000

Khaleed,

I would like to highlight a well-known idiom in the IETF, about the IETF.

"Rough consensus and running code"

The means that not only does one need to demonstrate the benefits of their idea in a working implementation (a protocol stack in this case), and really the onus is on you to have a cohort of people about you to develop that stack if you alone do not have the skills, but then also to gain consensus of the IETF as to the technology in question.

I feel like the discussion so far is diverging into an academic free-for-all without seeing something more tangible than the current state.

Cheers
Terry
INT Area AD.

    

    -----Original Message-----
    From: Lee Howard [mailto:[email-masked]] 
    Sent: Friday, March 31, 2017 5:35 PM
    To: Khaled Omar; Jen Linkova
    Cc: [email-masked]
    Subject: Re: [Int-area] Fw: Continuing IPv10 I-D discussion.

    

    
    
    Lee

---

From: joel jaeggli <[email-masked]>
Date: Fri, 31 Mar 2017 11:18:32 -0500

On 3/31/17 11:05, Khaled Omar wrote:
>> I don¹t see any evidence that you are gaining consensus. Jen¹s
>> suggestion was very good: develop a stack and get some deployment
>> experience to show it can work.
> 
> There are many people who likes IPv10 and support it, also I'm not a
> software developer who works for a company developing an OS, if you
> don't believe that this idea works, you have to try it by yourself
> and get back to me with the result and what was your problem, maybe
> you are not good in writing codes or whatever.

Ad Hominem arguments are not acceptable basis for discource here or
elsewhere in the IETF.

https://tools.ietf.org/html/rfc7154

Thanks
joel

---

From: Jen Linkova <[email-masked]>
Date: Fri, 31 Mar 2017 18:18:53 +0200

On Fri, Mar 31, 2017 at 6:05 PM, Khaled Omar
<[email-masked]> wrote:
> There are many people who likes IPv10 and support it,

Not on that (or any other IETF) mailing list obviously. I have not
seen any single support message so far but at least ten people told
you that they do not support the idea.

>also I'm not a software developer who works for a company developing an OS,

But you claim that developing/updating software is simple and can be
done very quickly...Well, then you have to find someone who is
supporting your idea and willing to prove that your idea works.

>if you don't believe that this idea works, you have to try it by yourself and get back to me with the result

LOL ;) This thread is getting more and more hilarious.

No, it's not how it works. We don't have to.
If you want you idea to be supported you need to convince the
community that the idea is good and would work. To do this you need
to demonstrate it.
If you are not willing to do that - nobody would support your idea,
IPv10 draft would not move forward and we all go back to deploying
IPv6

>and what was your problem, maybe you are not good in writing codes or whatever.

I fail to see how our ability/skills in writing code matters in this case.

---

From: Lee Howard <[email-masked]>
Date: Fri, 31 Mar 2017 11:22:44 -0500

>There are many people who likes IPv10 and support it,

We need to hear from them.

>also I'm not a software developer who works for a company developing an
>OS, if you don't believe that this idea works, you have to try it by
>yourself and get back to me with the result and what was your problem,
>maybe you are not good in writing codes or whatever.

I should spend time on something I don’t think will work?

The IETF runs on rough consensus and running code. This internet-draft has
neither. That doesn’t mean your contribution is unwelcome, but you
shouldn't become so attached to an idea that you can’t let it go when it
doesn’t have support.

Lee

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 31 Mar 2017 11:24:01 -0500

On Fri, Mar 31, 2017 at 07:19:07AM -0700,
 Tom Herbert <[email-masked]> wrote 
 a message of 102 lines which said:

> Please provide an implementation so we can evaluate the prospects.

I volunteer for the IPv10 project at the Prague hackathon :-)

---

From: Khaled Omar <[email-masked]>
Date: Fri, 31 Mar 2017 16:34:49 +0000

Terry

> I feel like the discussion so far is diverging into an academic free-for-all without seeing something more tangible than the current state.

Ask the ietf about this, I've developed IPv10 on August, 2014 before the problem takes that level after the consecutive announcements of IPv4 address space depletion.

I'm expecting +10 years for my second ID (KHALED Routing Protocol "KRP") to be standardized.

-----Original Message-----
From: Terry Manderson [mailto:[email-masked]] 
Sent: Friday, March 31, 2017 6:12 PM
To: Khaled Omar; Lee Howard
Cc: [email-masked]
Subject: Re: [Int-area] Fw: Continuing IPv10 I-D discussion.

Khaleed,

Cheers
Terry
INT Area AD.

    

    -----Original Message-----
    From: Lee Howard [mailto:[email-masked]] 
    Sent: Friday, March 31, 2017 5:35 PM
    To: Khaled Omar; Jen Linkova
    Cc: [email-masked]
    Subject: Re: [Int-area] Fw: Continuing IPv10 I-D discussion.

    

    
    
    Lee

---

From: Karsten Thomann <[email-masked]>
Date: Fri, 31 Mar 2017 11:04:38 -0700 (PDT)

Khaled,

you've already confirmed that your protocol requires changes for nearly all 
devices and we told you that it isn't possible to convince many vendor to 
support a third protocol.

We all know that IPv6 isn't perfect, but creating an additional protocol isn't 
solving any deployment problem with IPv6.

Please stop trying to convince us to further discuss your draft until there is 
a major change and a, at leat experimental, implementation from people which 
think that your idea is working.

Within the "short" time I'm reading some IETF mailing lists, I can't remember 
any draft with such strong opposition.

And I'm now stopping to discuss this draft any further until there are new 
arguments.

Am Freitag, 31. März 2017, 16:34:49 schrieb Khaled Omar:
> Terry
> 
> 
> > I feel like the discussion so far is diverging into an academic
> > free-for-all without seeing something more tangible than the current
> > state.
> 
> Ask the ietf about this, I've developed IPv10 on August, 2014 before the
> problem takes that level after the consecutive announcements of IPv4
> address space depletion.

> The means that not only does one need to demonstrate the benefits of their
> idea in a working implementation (a protocol stack in this case), and
> really the onus is on you to have a cohort of people about you to develop
> that stack if you alone do not have the skills, but then also to gain
> consensus of the IETF as to the technology in question.
 
> I feel like the discussion so far is diverging into an academic free-for-all
> without seeing something more tangible than the current state.
 
> Cheers
> Terry
> INT Area AD.
> 
> On 1/04/2017, 2:05 AM, "Int-area on behalf of Khaled Omar"
 
> software developer who works for a company developing an OS, if you don't
> believe that this idea works, you have to try it by yourself and get back
> to me with the result and what was your problem, maybe you are not good in
> writing codes or whatever.

---

From: Khaled Omar <[email-masked]>
Date: Fri, 31 Mar 2017 20:44:03 +0000

Karsten,

> you've already confirmed that your protocol requires changes for nearly all devices and we told you that it isn't possible to convince many vendor to support a third protocol.

If you mean by Vendors the few number to technology companies, then be sure that this small "update" will be easy for them to deploy based on how they work, IPv10 is not considered as a 3rd protocol, it is as mentioned in the I-D a solution, we will still have only IPv4 and IPv6, they will not disappear and no more protocol will be added to them.

> We all know that IPv6 isn't perfect, but creating an additional protocol isn't solving any deployment problem with IPv6.

IPv10 will solve the problem of IPv6 lack of deployment globally, because IPv10 will enable all Internet connected hosts from different version to be able to communicate, and let the migration process takes its time, once full migration will occur, forget about IPv10, the whole Internet will be IPv6 networks, but now, IPv10 will avoid the division of the Internet into two parts.

> Please stop trying to convince us to further discuss your draft until there is a major change and a, at leat experimental, implementation from people which think that your idea is working.

I'm not trying to convince all of you, who is seriously interested and understand the added value simply can participate, Internet is a global network that all are using, don't tell me that the division will occur for a specific people and not the others, it is a global problem that should be solved for all, if you don't care about the solution, simply don't participate, no one will force you to do something that you don't want to do.

> And I'm now stopping to discuss this draft any further until there are new arguments.

You are free to do what you want, but don't make a late decision of participation before the I-D will be published, because you will not be welcomed in that late time, so make up your decision now and your decision is welcome regardless what it is.

-----Original Message-----
From: Karsten Thomann [mailto:[email-masked]] 
Sent: Friday, March 31, 2017 8:05 PM
To: [email-masked]
Cc: Khaled Omar
Subject: Re: [Int-area] Fw: Continuing IPv10 I-D discussion.

Khaled,

you've already confirmed that your protocol requires changes for nearly all devices and we told you that it isn't possible to convince many vendor to support a third protocol.

We all know that IPv6 isn't perfect, but creating an additional protocol isn't solving any deployment problem with IPv6.

Please stop trying to convince us to further discuss your draft until there is a major change and a, at leat experimental, implementation from people which think that your idea is working.

Within the "short" time I'm reading some IETF mailing lists, I can't remember any draft with such strong opposition.

And I'm now stopping to discuss this draft any further until there are new arguments.

---

From: joel jaeggli <[email-masked]>
Date: Sat, 1 Apr 2017 00:11:01 -0500

On 3/31/17 09:24, Khaled Omar wrote:
>>> uniformly support anything? Please provide an implementation so
>>> we can evaluate the prospects.
> 
> For the 2nd time:
> 
> "I shouldn't list all devices that need to support IPv10, simply,
> anything will process a L3 packet, should understand that the IPv10
> packet can contain a mixture of IPv4 and IPv6 addresses."

Assuming for the sake of argument that I am designing a forwarding asic.
When I pass over the ethertype code in the frame, I decide what
forwarding lookup path I am going to exercise the ipv4 or ipv6 one. If i
choose door number 1 the ipv4 path  due to 0x0800  and destination mac
being me the byte offset for the source is 12 and the destination is 4
bytes later at byte offset 16. if these fields are of variable length
then a 16 byte source address overflows the fixed offset  where the
destination  is supposed and the destination address is lost to me
because it's where optional fields might otherwise be.

If I choose the v6 path due to 0x86DD then I find the source address
address at byte 8 and the destination beginning at byte 24 there, there
are of course several ways to represent a an ipv4 mapped address within
ipv6, none of them are of any use to an native ipv4 speaker.

The fields in the packet header are not self-described (they could be,
packet header could be json for example  but in the interest of
performance they were / are not), therefore  in the interestes of
clarity a new ethertype for ipv10 with either a fixed size source and
destination address size  or a whay of specifying the offset, and a bit
or multiple bit field for the AF of both the source and destination
would greatly facilitate the design of a parser that would be able to
handle the selection of AF for lookup. at the point you've go an
entirely new header which is not compatible with either V4 or V6
parsers. in practical terms that means the useful deployment of a v10
compatible parser at internet scale is approximately as hard as
deploying the the v6 compatible parser would be if we started now
instead of in 1995 when the internet was much smaller.

joel

> 
> -----Original Message----- From: Tom Herbert
> [mailto:[email-masked]] Sent: Friday, March 31, 2017 4:19 PM To:
> Khaled Omar Cc: Bless, Roland (TM); [email-masked] Subject: Re:
> [Int-area] Fw: Continuing IPv10 I-D discussion.
> 
>> FYI, IPv10 will allow IPv4 to communicate to IPv6 and vice versa,
>> how can it be interesting if it was presented before IPv6 was even
>> developed !
>> 
>>> something they need to support, this would only happen in Windows
>>> 10. Then we have the rest of the ecosystem with access routers,
>>> load balancers, SAVI-functionality for BCP38 compliance in access
>>> devices, core routers etc.
>> 
>> Please, let's not be against ourselves, all OSs will be updated to
>> support IPv10 which is an easy task, OSs will not require support
>> for a new IP version like IPv6, they will just be enabled to
>> support the encapsulation of both version on the same L3 packet
>> header.
> 
> uniformly support anything? Please provide an implementation so we
> can evaluate the prospects.
> 
> Tom
> 
>> 
>> Also, networking devices will be upgraded to understand the new
>> IPv10 packet, I said earlier I don't mind If the process will take
>> some time but we should eventually reach consensus, I shouldn't
>> list all devices that need to support IPv10, simply, anything will
>> process a L3 packet, should understand that the IPv10 packet can
>> contain a mixture of IPv4 and IPv6 addresses.
>> 
>> 
>> -----Original Message----- From: Int-area
>> [mailto:[email-masked]] On Behalf Of Bless, Roland (TM) 
>> Sent: Friday, March 31, 2017 9:51 AM To: Mikael Abrahamsson Cc:
>> int-area Subject: Re: [Int-area] Fw: Continuing IPv10 I-D
>> discussion.
>> 
>> Hi Mikael,
>> 
>> Regards, Roland
>>>>  obvious, I don't mind if you have already a series of new
>>>> questions that will add a new value to the discussion but the
>>>> time to deploy IPv10 is an important factor.
>>>> 
>>> Standards were worked out in the mid 90-ties, afterwards
>>> operating system vendors started working on it and "real" support
>>> started cropping up in the early to mid 2000:nds, with a large
>>> milestone being Windows Vista in 2006, where as far as I know
>>> this was the first widely used consumer operating system to
>>> implement this. It then took until Windows 7 timeframe around
>>> 2010 before people started moving off of Windows XP in ernest,
>>> and we're still seeing Windows XP in non-trivial numbers. So now
>>> in 2017 we're seeing most operating systems have comprehensive 
>>>  IPv6, where the application ecosystem still has a way to go.
>>> We're still working on better APIs to handle the dual-stackedness
>>> problem.
>>> 
>>> something they need to support, this would only happen in Windows
>>> 10. Then we have the rest of the ecosystem with access routers,
>>> load balancers, SAVI-functionality for BCP38 compliance in access
>>> So even if we all united now (which won't happen) around your
>>> IPv10 proposal, it would take 5-10 years before the first devices
>>> out on the market had support for it. Probably 5-10 years after
>>> that before support is widely available.
>>> 
>>> IPv10 would delay and confuse deployment of something that is not
>>> IPv4. While IPv6 is not perfect, there are now hundreds of
>>> millions of devices on the Internet with IPv6 access. It's proven
>>> to work, it's not perfect, but we have a decently good idea what
>>> to do to make it better.
>>> 
>>> IPv10 is only injecting FUD into where we need to go debate,
>>> which is IPv6 deployment for all.
>>> 
>>> Please stop.
>> 
>> _______________________________________________ Int-area mailing
>> list [email-masked] 
>> _______________________________________________ Int-area mailing
>> list [email-masked] 
> _______________________________________________ Int-area mailing
> list [email-masked]