Subject: [Int-area] [www.ietf.org/rt #163372] Liaison from IEEE 802.1 WG to IETF IntArea WG

From: Juan Carlos Zuniga <[email-masked]>
Date: Wed, 22 Mar 2017 21:30:18 +0000

Dear IntArea WG,

Please note that we have received the attached liaison letter from the IEEE 802.1 WG with respect to "IP over intentionally partially partitioned links" draft-nordmark-intarea-ippl-05.

If you have any comments, please send them to the list.

We will also allocate some time for to discuss about this during our meeting in Chicago.

Best,

Juan-Carlos & Wassim
(IntArea WG co-chairs)

From: Glenn Parsons [mailto:[email-masked]]
Sent: March 22, 2017 4:26 AM
To: [email-masked]; Juan Carlos Zuniga <[email-masked]>; Suresh Krishnan <[email-masked]>; Wassim Haddad <[email-masked]>
Cc: Paul Nikolich <[email-masked]> ([email-masked]) <[email-masked]>; John Messenger <[email-masked]>; Janos Farkas <[email-masked]>; [email-masked]
Subject: Liaison from IEEE 802.1 WG to IETF IntArea WG

Please find attached a liaison from the IEEE 802.1 WG.

I will be available to present this during the  IntArea WG meeting.  This is in regards to your agenda item #4.

Cheers,
Glenn.

--
Glenn Parsons - Chair, IEEE 802.1
[email-masked]<mailto:[email-masked]>
+1-613-963-8141

---

From: Erik Nordmark <[email-masked]>
Date: Wed, 22 Mar 2017 18:10:10 -0700

On 03/22/2017 02:30 PM, Juan Carlos Zuniga wrote:
> Dear IntArea WG,
>
>
>
> Please note that we have received the attached liaison letter from the
> IEEE 802.1 WG with respect to “IP over intentionally partially
> partitioned links” draft-nordmark-intarea-ippl-05.

I don't see the document listed on
http://www.ieee802.org/Communications.shtml#Comm_1703

Will it be added there so we can refer to it?

Some more detailed comments below:

> 1. The tone of the draft should be, "how a router can take advantage of the
> Asymmetric (Private) VLAN feature offered by 802.1Q bridges."

> 2. Modifying the section in question to describe how it works, without any
> conformance language on bridge behavior but explaining 802.1Q standard
> bridge configuration instead.

> 3. Make a normative reference to 802.1Q.

My bad; I thought I already had it as a reference.
However, I'm not sure it can be normative since both annex B and annex F 
are marked as informational in 802.1Q-1998. It wasn't clear to me that 
there is sufficient material in the normative parts of 802.1Q-1998 to 
describe the required behaviors for promiscuous, community, and isolated 
ports.

If the 802.1 group is asserting that all of those behaviors are 
(optional) parts of the 802.1Q-1998 standard it would be helpful to know 
that.

In addition, if possible, also to have more specific references to 
normative sections in 802.1Q which describe this behavior.

We'd still need some explanatory text in the draft to map between the 
802.1Q terminology and the "promiscuous, community, isolated" 
terminology that is used in industry. Before seeing the test I can't 
tell whether such text would need to have RFc2119 terms to describe the 
mapping. However, I don't think that would be a constraints on bridge 
implementations but instead statements of the form "for the purposes if 
running IP over 802.1Q we assume that promisc/community/isolated ports 
are configured as follows using the 802.1Q asymetric VLAN standard...

But that is predicated on the all the necessary "private VLAN" behaviors 
being part of the IEEE 802.1Q-1998 standard. So I'd be greatful for 
clarifications on that point before I start editing the draft.

Thanks,
     Erik

> *From:*Glenn Parsons [mailto:[email-masked]]
> *Sent:* March 22, 2017 4:26 AM
> *To:* [email-masked]; Juan Carlos Zuniga
> <[email-masked]>; Suresh Krishnan
> <[email-masked]>; Wassim Haddad <[email-masked]>
> *Cc:* Paul Nikolich <[email-masked]> ([email-masked])
> <[email-masked]>; John Messenger <[email-masked]>;
> Janos Farkas <[email-masked]>; [email-masked]
> *Subject:* Liaison from IEEE 802.1 WG to IETF IntArea WG
>
>
>
> I will be available to present this during the  IntArea WG meeting.
> This is in regards to your agenda item #4.
>
>
>
> Cheers,
>
> Glenn.
>
>
>
>
>
> --
>
> [email-masked] <mailto:[email-masked]>
>
> +1-613-963-8141
>
>
>
>
>
>
>
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Thu, 23 Mar 2017 01:41:57 +0000

Thanks for the quick response Erik.

I'm CC'ing some IEEE 802 members that are not in the IntArea mailing list. 

I hope they can provide some answers to your questions below.

Best,

Juan Carlos 

> -----Original Message-----
> From: Erik Nordmark [mailto:[email-masked]]
> Sent: March 22, 2017 8:10 PM
> To: Juan Carlos Zuniga <[email-masked]>; [email-masked];
> [email-masked]
> Subject: Re: [Int-area] [www.ietf.org/rt #163372] Liaison from IEEE 802.1 WG
> to IETF IntArea WG
> 
> > IEEE 802.1 WG with respect to "IP over intentionally partially
> > partitioned links" draft-nordmark-intarea-ippl-05.
> 
> > 1. The tone of the draft should be, "how a router can take advantage
> > of the Asymmetric (Private) VLAN feature offered by 802.1Q bridges."
> 
> > 2. Modifying the section in question to describe how it works, without
> > any conformance language on bridge behavior but explaining 802.1Q
> > standard bridge configuration instead.
> 
> are marked as informational in 802.1Q-1998. It wasn't clear to me that there
> is sufficient material in the normative parts of 802.1Q-1998 to describe the
> required behaviors for promiscuous, community, and isolated ports.
> 
> In addition, if possible, also to have more specific references to normative
> sections in 802.1Q which describe this behavior.
> 
> terminology that is used in industry. Before seeing the test I can't tell
> whether such text would need to have RFc2119 terms to describe the

---

From: Glenn Parsons <[email-masked]>
Date: Thu, 23 Mar 2017 01:48:20 +0000

Folks,

The liaison is from the IEEE 802.1 WG so will not be on the noted IEEE 802 liaison page.

I presume it will eventually show up on the IETF liaison site

Cheers,
Glenn.

-----Original Message-----
From: Juan Carlos Zuniga [mailto:[email-masked]] 
Sent: Wednesday, March 22, 2017 9:42 PM
To: Erik Nordmark <[email-masked]>; [email-masked]; [email-masked]
Cc: Glenn Parsons <[email-masked]>; Paul Nikolich <[email-masked]> ([email-masked]) <[email-masked]>; John Messenger <[email-masked]>; Janos Farkas <[email-masked]>; [email-masked]
Subject: RE: [Int-area] [www.ietf.org/rt #163372] Liaison from IEEE 802.1 WG to IETF IntArea WG

Best,

Juan Carlos 

> To: Juan Carlos Zuniga <[email-masked]>; 
> [email-masked]; [email-masked]
> Subject: Re: [Int-area] [www.ietf.org/rt #163372] Liaison from IEEE 
> 802.1 WG to IETF IntArea WG
> 
> > Please note that we have received the attached liaison letter from 
> > the IEEE 802.1 WG with respect to "IP over intentionally partially 
> > 2. Modifying the section in question to describe how it works, 
> > without any conformance language on bridge behavior but explaining 
> > 802.1Q standard bridge configuration instead.
> 
> However, I'm not sure it can be normative since both annex B and annex 
> F are marked as informational in 802.1Q-1998. It wasn't clear to me 
> that there is sufficient material in the normative parts of 
> 802.1Q-1998 to describe the required behaviors for promiscuous, community, and isolated ports.
> 
> (optional) parts of the 802.1Q-1998 standard it would be helpful to 
> know that.
> 
> tell whether such text would need to have RFc2119 terms to describe 
> the mapping. However, I don't think that would be a constraints on 
> bridge implementations but instead statements of the form "for the 
> purposes if running IP over 802.1Q we assume that 
> promisc/community/isolated ports are configured as follows using the 802.1Q asymetric VLAN standard...
> 
> But that is predicated on the all the necessary "private VLAN" 
> behaviors being part of the IEEE 802.1Q-1998 standard. So I'd be 
> greatful for clarifications on that point before I start editing the draft.
> 
> 
> Thanks,
>      Erik
> 
> >
> >
> > <[email-masked]>; John Messenger 
> > <[email-masked]>; Janos Farkas 
> > <[email-masked]>; [email-masked]

---

From: Pat Thaler <[email-masked]>
Date: Thu, 23 Mar 2017 10:29:01 -0700

Erik,

The informative annexes explain how to use 802.1Q bridges to implement
Pfivate VLANs. The capabilities that allow that are covered in the
normative body of IEEE Std 802.1Q.

The liaison includes suggested text for the ID describing details of
configuring 802.1Q bridges to accomplish that including references to
normative parts of 802.1Q.

Regads,
Pat

On Wed, Mar 22, 2017 at 6:10 PM, Erik Nordmark <[email-masked]> wrote:

> If the 802.1 group is asserting that all of those behaviors are (optional)
> parts of the 802.1Q-1998 standard it would be helpful to know that.
>
> 802.1Q terminology and the "promiscuous, community, isolated" terminology
> that is used in industry. Before seeing the test I can't tell whether such
> text would need to have RFc2119 terms to describe the mapping. However, I
> don't think that would be a constraints on bridge implementations but
> instead statements of the form "for the purposes if running IP over 802.1Q
> we assume that promisc/community/isolated ports are configured as follows
> using the 802.1Q asymetric VLAN standard...
>
>> <[email-masked]>; Wassim Haddad <[email-masked]
>> >

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 23 Mar 2017 11:40:41 -0700

> normative parts of 802.1Q.

Pat,

That's great. I initially missed those details in the liaison.

Would it be OK to take that text from the liaison and add it as 
information to the draft? And if so, should I acknowledge anybody in 
particular or just the IEEE 802.1 committee?

Thanks,
     Erik

>
>
>
> On Wed, Mar 22, 2017 at 6:10 PM, Erik Nordmark <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     <http://www.ieee802.org/Communications.shtml#Comm_1703>
>
>         without any
>     However, I'm not sure it can be normative since both annex B and
>     annex F are marked as informational in 802.1Q-1998. It wasn't clear
>     to me that there is sufficient material in the normative parts of
>     We'd still need some explanatory text in the draft to map between
>     the 802.1Q terminology and the "promiscuous, community, isolated"
>         *From:*Glenn Parsons [mailto:[email-masked]
>         <mailto:[email-masked]>]
>         *To:* [email-masked] <mailto:[email-masked]>; Juan
>         Carlos Zuniga
>         <[email-masked]
>         <mailto:[email-masked]>>; Suresh Krishnan
>         <[email-masked]
>         <mailto:[email-masked]>>; Wassim Haddad
>         <[email-masked] <mailto:[email-masked]>>
>         *Cc:* Paul Nikolich <[email-masked]
>         <mailto:[email-masked]>> ([email-masked]
>         <mailto:[email-masked]>)
>         <[email-masked] <mailto:[email-masked]>>; John
>         Messenger <[email-masked]
>         <mailto:[email-masked]>>;
>         Janos Farkas <[email-masked]
>         <mailto:[email-masked]>>; [email-masked]
>         <mailto:[email-masked]>
>         <mailto:[email-masked]
>         <mailto:[email-masked]>>
>
>         +1-613-963-8141 <tel:%2B1-613-963-8141>
>
>
>
>
>
>
>
>         [email-masked] <mailto:[email-masked]>
>         <https://www.ietf.org/mailman/listinfo/int-area>
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/int-area>
>
>

---

From: Pat Thaler <[email-masked]>
Date: Thu, 23 Mar 2017 11:46:08 -0700

I'll leave it to Glenn and Janos to answer those questions. I believe that
the text was written with the intent that it could be incorporated into the
ID.

On Thu, Mar 23, 2017 at 11:40 AM, Erik Nordmark <[email-masked]> wrote:

>>         We will also allocate some time for to discuss about this during
>> our
>>         meeting in Chicago.
>>
>>
>>
>>         Best,
>>
>>
>>
>>         Juan-Carlos & Wassim
>>
>>         (IntArea WG co-chairs)
>>
>>
>>
>>
>>