Subject: [Int-area] Benoit Claise's No Objection on draft-ietf-intarea-probe-09: (with COMMENT)

From: Benoit Claise <[email-masked]>
Date: Thu, 14 Dec 2017 06:25:18 -0800

Benoit Claise has entered the following ballot position for
draft-ietf-intarea-probe-09: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-intarea-probe/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

No objection to the publication of this document. However, some comments.

So basically you specify the same functionality as remote ping MIB in RFC4560 where
- probing interface = SNMP manager
- proxy interface = SNMP agent
- probed agent = destination
Right? So any connection with RFC4560?

I guess this mechanism is a similar functionality as RFC 6812, where
- proxy agent = sender
- responder = destination
... even the technology is not based on the ICMP extended echo
As such I believe that the RFC 6812 IPR applies here as well.
However, I'm not the one to make the call. So I will forward to the appropriate persons.

Potentially the OWAMP IPRs apply as well.
https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-ippm-owdp

---

From: Ron Bonica <[email-masked]>
Date: Thu, 14 Dec 2017 16:26:20 +0000

Hi Benoit,

Thanks for the review.

AFAICS, RFC 4560 gives the user a way to initiate legacy PING/TRACEROUTE/LOOKUP remotely, from a management station. But, are still talking about legacy PING/TRACEROUTE/LOOKUP. All of their shortcomings are still evident when initiated remotely. For example, there is no way to PING an unnumbered interface with RFC 4560.

Are you sure that the reference to RFC 6812 is correct? I don't see how that RFC is related.

I'm not qualified to comment on whether OWAMP IPR claims apply.

                                                   Ron

> -----Original Message-----
> From: Benoit Claise [mailto:[email-masked]]
> Sent: Thursday, December 14, 2017 9:25 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Luigi Iannone <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked]
> Subject: Benoit Claise's No Objection on draft-ietf-intarea-probe-09: (with
> COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Please refer to https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_iesg_statement_discuss-
> 2Dcriteria.html&d=DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=Fch9FQ82sir-BoLx84hKuKwl-
> AWF2EfpHcAwrDThKP8&m=AynMJ1Dzf-
> NhKyZnImzuXC5wMSHzVpAgxNc6oY_kJms&s=WfTrBgbi3gm4XVJHaelwKLXs
> qZgCA9TU1b7kBLY4rug&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dintarea-
> 2Dprobe_&d=DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=Fch9FQ82sir-BoLx84hKuKwl-
> AWF2EfpHcAwrDThKP8&m=AynMJ1Dzf-
> NhKyZnImzuXC5wMSHzVpAgxNc6oY_kJms&s=7JAC48ovLm_D080mPs2ZiFnfc
> 9YJrCko88elATpBbqk&e=
> 
> 
> 
> ... even the technology is not based on the ICMP extended echo As such I
> believe that the RFC 6812 IPR applies here as well.
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_ipr_search_-3Fsubmit-3Ddraft-26id-3Ddraft-
> 2Dietf-2Dippm-2Dowdp&d=DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=Fch9FQ82sir-BoLx84hKuKwl-
> AWF2EfpHcAwrDThKP8&m=AynMJ1Dzf-
> NhKyZnImzuXC5wMSHzVpAgxNc6oY_kJms&s=6AQ1PoqsbVEWizOFnRjyUCN
> g5vXkexXALSuBika7XfE&e=
>

---

From: Benoit Claise <[email-masked]>
Date: Mon, 18 Dec 2017 21:13:11 +0100

Hi Ron,
> AFAICS, RFC 4560 gives the user a way to initiate legacy PING/TRACEROUTE/LOOKUP remotely, from a management station. But, are still talking about legacy PING/TRACEROUTE/LOOKUP. All of their shortco…
ok.
>
> Are you sure that the reference to RFC 6812 is correct?
Yes.
> I don't see how that RFC is related.
>

Regards , Benoit