Subject: Re: [Int-area] Existing use of IP protocol 114 (any 0-hop protocol)

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 23 Sep 2019 08:40:37 +0000

Thank you all for your unicast, multicast replies and the educated pieces of information sent. I even went in the Internet history museum ;-)

Based on the provided information, I will recommend to the draft-zhu-intarea-gma authors:

  1.  As it is an informational independent stream with little traction, to keep using the IP protocol 114;
  2.  BUT, the I-D should be revised to specify a hop-limit of 0 for IPv6 (RFC 8200) and time-to-live of 1 for IPv4 (RFC 791). The balance of local-only packet leak prevention (HL=0) and security (HL=255) in this case should be on preventing the leak of the local-only packets outside the ‘local domain’ to the Internet or to another domain which could use this IP protocol.
  3.  Any other standard track IETF stream document (including this one may be in the future) should request a new IP protocol number if required. The last assigned IP protocol number AFAIK was for HIP in 2015 and there are more than 40% remaining.

Now, it would nice to have a volunteer to write a document to finally document those “Any bla” protocol number by putting common sense restrictions/constraints on them (protocols 9/IGP, 61/host internal, 63/local network, 68/distributed FS, 99/private encryption scheme, 114/0-hop).

Regards

-éric

From: Int-area <[email-masked]> on behalf of Eric Vyncke <[email-masked]>
Date: Thursday, 19 September 2019 at 17:07
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Int-area] Existing use of IP protocol 114 (any 0-hop protocol)

The authors of https://tools.ietf.org/id/draft-zhu-intarea-gma-03.txt would like to use IP protocol 114 as it is described as “Any 0-hop protocol” on the IANA page[1]. Alas, on the IANA page, there is no reference to this “Any 0-hop protocol”.

Obviously, we all understand that this must be a protocol using hop limit = 0 (or TTL=0 for the legacy protocol).

When there is no reference for a IANA number, this means that this number was assigned _before_ IANA, possibly by J. Postel and nobody at IANA and in the IESG know more. Hence, my questions to the community:

Q1) does anyone know about a more formal reference / specification for this protocol 114

Q2) does anyone know about a RFC or a protocol using this protocol 114 ?

Please note that I do not ask for comments/reviews on the draft itself (they are welcome though on the [email-masked]<mailto:[email-masked]> mailing list even if this is not a WG document). And it is also mostly obvious that only one transport layer can exist on the top of this protocol.

Regards,

-éric (INT AD)

[1] https://www.iana.org/assignments/protocol-numbers/protocol-numbers.xhtml

---

From: Joe Touch <[email-masked]>
Date: Sat, 28 Sep 2019 08:15:36 -0700

Hi, Eric,

> On Sep 23, 2019, at 1:40 AM, Eric Vyncke (evyncke) <[email-masked]> wrote:
> 

For the same reasons Bob mentions, I think this isn’t needed.

We don’t need to encourage playing with these code points for experiments; better a protocol designer go through the standards-track process, at which point they can either use one of these codepoints or get a new one.

Joe