Subject: [Int-area] FYI/Feedback for draft-bryant-arch-fwd-layer-ps-00

From: Toerless Eckert <[email-masked]>
Date: Tue, 24 Mar 2020 03:09:56 +0100

Dear intarea WG

We think draft https://datatracker.ietf.org/doc/draft-bryant-arch-fwd-layer-ps/
does in part touch aspects related to intarea, so we are interested in
your opinion/feedback. We think its mostly architectual through, so
maybe [email-masked] is more appropriate for overall
discussions on the topic right now.

Before Corona, we had planned to have an inoffical side-meeting to
discuss the topic, we have now set up a virtual inofficial side-meeting
instead, This wednesday 03/25/2020, 1500 UTC. Info here:

https://trac.ietf.org/trac/ietf/meeting/wiki/ietf107replacements
https://etherpad.wikimedia.org/p/v107-side-meeting

Cheers
   Toerless (for the authors)

---

From: Joseph Touch <[email-masked]>
Date: Mon, 23 Mar 2020 21:01:34 -0700

Reads like an academic white paper. Worth about as much of my attention.

Sorry, but you asked.

Joe

> On Mar 23, 2020, at 7:09 PM, Toerless Eckert <[email-masked]> wrote:
> 
> Dear intarea WG
> 
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 24 Mar 2020 13:49:18 +0000

Hello Toerless,

It seems related to intarea indeed (by reading the abstract) but possibly wider as well.

Did you consider DISPATCH (yesterday alas...) ?

May I also suggest to run a 2nd call as tomorrow is really short notice?

-éric

-----Original Message-----
From: Int-area <[email-masked]> on behalf of Toerless Eckert <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Tuesday, 24 March 2020 at 03:10
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Int-area] FYI/Feedback for draft-bryant-arch-fwd-layer-ps-00

    Dear intarea WG

    
    
    Cheers

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 24 Mar 2020 18:40:20 +0100

Thanks, Joe

Happy to take input on how to improve. This is a -00, and
a lot o the problems are not that easy to explain at their
fundamental level. And going into detail difficult to keep
the size in check.

If there are any specific issues in scope of the document,
included or not that you are interested, i'd certainly
like to hear about it from you.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 24 Mar 2020 18:52:26 +0100

Thanks, Eric

I think the main reason why we did not want to approach WGs directly
yet is because the scope is on architectural issues with lets say a 10 years
solution horizon. And in WGs there is often a rightfull concern
that work like this is premature to standardize, infeasible
for todays hardware or derailing the work of groups that already
a backlogged finalizing even shorter term protocol work.

But without a longer term architectural track doing work like this
in parallel to current WGs, it will be difficult for the IETF to really drive
innovation at the network / forwarding layer longer term.

In that respect, DISPATCH would be great if it could 
dispatch to something that was focussed on more longer term
architecture work, but i think there is no such forum today,
hence the side meetings.

Cheers
    Toerless

On Tue, Mar 24, 2020 at 01:49:18PM +0000, Eric Vyncke (evyncke) wrote:
> ???-----Original Message-----

-- 
---
[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Tue, 24 Mar 2020 13:56:01 -0400

> innovation at the network / forwarding layer longer term.

Is this something we are even competent to do?

---

From: Joseph Touch <[email-masked]>
Date: Tue, 24 Mar 2020 11:06:53 -0700

> On Mar 24, 2020, at 10:56 AM, Ted Lemon <[email-masked]> wrote:
> 
> On Mar 24, 2020, at 1:52 PM, Toerless Eckert <[email-masked] <mailto:[email-masked]>> wrote:

By person, sure.

By group, i.e., does INTAREA or any other area, or even (or especially) the IAB, IMO - NO.

Papers like this are great ways to start beer chats or kickstart panel discussions but don’t do much IMO to move the needle forward. What matter are targeted answers, and those aren’t often the result of group-think (see “the Innovator’s Dilemma”*)

Joe

* those who know me, please don’t drop over because I cited a book. ;-)

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 24 Mar 2020 23:33:01 +0100

> Is this something we are even competent to do?

Fom the know-how of the participants, i think so. For example the
core issue i am interested in, how to build and later standardize
more extensible reuseable forwarding plane packet headers through
programmable forwarding planes, that i something where AFAIK a
good amount of participants in vendors working with HW development
got insight.  Likewise now also more and more reserchers building
P4 prototypes of recent IETF protocols.  And learning limitation of P4.

That of course is just my favourite pet sub-topic. When it comes
to the evolution of "Internet" as global inter-AS paths to
metropolitan network connecting edge-clouds with subscribers
that are as varied as 5/6G towers, IoT devices and humans, i
think we also have a lot of experience.

And so on.

What we do not have is i think a strategy to coalesce discussions
about this. Eg: the gap between IRTF and IETF if you ask me.

Cheers
    Toerless

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 24 Mar 2020 23:35:32 +0100

On Tue, Mar 24, 2020 at 11:06:53AM -0700, Joseph Touch wrote:
> Papers like this are great ways to start beer chats or kickstart panel discussions but don???t do much IMO to move the needle forward. What matter are targeted answers, and those aren???t often the result of group-think (see ???the Innovator???s Dilemma???*)

Agreed. But at least to me it looks quite helpfull to even start
attempting to write down the problem statemens, because they
are not necessarily trivial.

Btw: How did you folks manage to get this thread on int-area.
I specifiy had a "Reply-To: [email-masked]" into
my first email, to avoid this segmentation of discussion along
IETF area  boundaries ;-))

Cheers
    Toerless