Subject: [Int-area] Call for WG adoption of draft-olteanu-intarea-socks-6

From: Juan Carlos Zuniga <[email-masked]>
Date: Wed, 26 Aug 2020 19:33:43 +0000

Dear IntArea WG,

Now with the summer almost over and following the strong support shown at the IETF 108 meeting, we are starting a 2-week call for adoption of the SOCKS v6 draft:
https://tools.ietf.org/html/draft-olteanu-intarea-socks-6-09

The document has been discussed for quite some time already, it has evolved significantly, and it has received positive comments. Below you also have some pointers to existing implementations.

If you have an opinion on whether this document should be adopted please indicate on the list by the end of Wednesday September 9th.

Thanks,

Juan-Carlos & Wassim

From: Int-area <[email-masked]> On Behalf Of Vladimir OLTEANU
Sent: July 27, 2020 10:38 AM
To: int-area <[email-masked]>
Subject: [Int-area] SOCKS v6 implementation

Hello,

In anticipation of the adoption call, I'd like to share the status of our SOCKS v6 implementation.

We have the following pieces of software, all released under a very permissive license:
 * A library for creating and parsing SOCKS v6 requests and responses (incl. options and sanity checks). It's feature-complete as of -08: https://github.com/45G/libsocks6msg<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2F45G%2Flibsocks6msg&data=02%7C01%7Cjuancarlos.zuniga%40sigfox.com%7C51f8ab84e7c84786990c08d8323c06b2%7Cfcbc8bb1061e4b949f703ad917b0c8d3%7C0%7C1%7C637314580675091859&sdata=Wyz1W3GTakLxxNyJ74aWeSgSeqPNAehhnCWX8Yhd5bs%3D&reserved=0>
 * A utility library: https://github.com/45G/libsocks6util<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2F45G%2Flibsocks6util&data=02%7C01%7Cjuancarlos.zuniga%40sigfox.com%7C51f8ab84e7c84786990c08d8323c06b2%7Cfcbc8bb1061e4b949f703ad917b0c8d3%7C0%7C1%7C637314580675091859&sdata=YGb3EWO1Czqhhfs8VUiwg5Nhrg7vJokwsnDNMZEEBAU%3D&reserved=0>
 * A TCP proxy and transparent proxifier. (TCP Bind, UDP and v5-style authentication are not supported yet.) Most notable features are implemented: TLS1.3 with early data, idempotence, sessions, 0-RTT authentication, TFO, MPTCP and DNS. https://github.com/45G/sixtysocks<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2F45G%2Fsixtysocks&data=02%7C01%7Cjuancarlos.zuniga%40sigfox.com%7C51f8ab84e7c84786990c08d8323c06b2%7Cfcbc8bb1061e4b949f703ad917b0c8d3%7C0%7C1%7C637314580675101854&sdata=4WqHVkKkdbv%2F4A7Fdin7g66wjsnz4zK58U8vej%2FXibE%3D&reserved=0>

Cheers,
Vlad

---

From: Bob Hinden <[email-masked]>
Date: Thu, 27 Aug 2020 12:15:05 -0700

HI,

Why is the intended status Experimental?

RFC1928 was standards track, nor do I see any mention of experiments in the draft.

Bob

> On Aug 26, 2020, at 12:33 PM, Juan Carlos Zuniga <[email-masked]> wrote:
> 
> Dear IntArea WG,
> 
>  * A library for creating and parsing SOCKS v6 requests and responses (incl. options and sanity checks). It's feature-complete as of -08: https://github.com/45G/libsocks6msg
>  * A utility library: https://github.com/45G/libsocks6util
>  * A TCP proxy and transparent proxifier. (TCP Bind, UDP and v5-style authentication are not supported yet.) Most notable features are implemented: TLS1.3 with early data, idempotence, sessions, 0-RTT authentication, TFO, MPTCP and DNS. https://github.com/45G/sixtysocks
> 
> Cheers,
> Vlad
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: Vladimir Olteanu <[email-masked]>
Date: Thu, 27 Aug 2020 22:19:20 +0300

Hi,

Oops, it should be "Standards Track". I'll fix it in the next version.

Thanks for pointing that out.

Vlad

---

From: Bob Hinden <[email-masked]>
Date: Thu, 27 Aug 2020 14:21:53 -0700

Good, thanks.

Bob

> On Aug 27, 2020, at 12:19 PM, Vladimir Olteanu <[email-masked]> wrote:
> 
> Hi,
> 
>>> From: Int-area
>>> <[email-masked]>
>>>  On Behalf Of Vladimir OLTEANU

---

From: "Iain R. Learmonth" <[email-masked]>
Date: Sat, 29 Aug 2020 20:34:50 +0100

Hi,

I've been following this draft since 2018 and I think it does address a
number of shortcomings present in SOCKS 5 nicely. I'd be happy to see
this adopted.

Thanks,
Iain.

On 26/08/2020 20:33, Juan Carlos Zuniga wrote:
>
> Dear IntArea WG,
>
>  
>
> Now with the summer almost over and following the strong support shown
> at the IETF 108 meeting, we are starting a 2-week call for adoption of
> the SOCKS v6 draft:
>
> The document has been discussed for quite some time already, it has
> evolved significantly, and it has received positive comments. Below
> you also have some pointers to existing implementations.
>
>  
>
> If you have an opinion on whether this document should be adopted
> please indicate on the list by the end of Wednesday September 9^th .
>
>  
>
> Thanks,
>
>  
>
> Juan-Carlos & Wassim
>
>  
>
>  
>
> *From:*Int-area <[email-masked]> *On Behalf Of *Vladimir
> OLTEANU
> *Sent:* July 27, 2020 10:38 AM
> *To:* int-area <[email-masked]>
> *Subject:* [Int-area] SOCKS v6 implementation
>
>  
>
> Hello,
>
>  
>
>  * A library for creating and parsing SOCKS v6 requests and responses
> (incl. options and sanity checks). It's feature-complete as of
> -08: https://github.com/45G/libsocks6msg
> <https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2F45G%2Flibsocks6msg&data=02%7C01%7Cjuancarlos.zuniga%40sigfox.com%7C51f8ab84e7c84786990c08d8323c06b2%7Cfcbc8bb1061e4b949f703ad917b0c8d3%7C0%7C1%7C637314580675091859&sdata=Wyz1W3GTakLxxNyJ74aWeSgSeqPNAehhnCWX8Yhd5bs%3D&reserved=0>
>
> <https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2F45G%2Flibsocks6util&data=02%7C01%7Cjuancarlos.zuniga%40sigfox.com%7C51f8ab84e7c84786990c08d8323c06b2%7Cfcbc8bb1061e4b949f703ad917b0c8d3%7C0%7C1%7C637314580675091859&sdata=YGb3EWO1Czqhhfs8VUiwg5Nhrg7vJokwsnDNMZEEBAU%3D&reserved=0>
>
>  * A TCP proxy and transparent proxifier. (TCP Bind, UDP and v5-style
> authentication are not supported yet.) Most notable features are
> implemented: TLS1.3 with early data, idempotence, sessions, 0-RTT
> authentication, TFO, MPTCP and DNS. https://github.com/45G/sixtysocks
> <https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2F45G%2Fsixtysocks&data=02%7C01%7Cjuancarlos.zuniga%40sigfox.com%7C51f8ab84e7c84786990c08d8323c06b2%7Cfcbc8bb1061e4b949f703ad917b0c8d3%7C0%7C1%7C637314580675101854&sdata=4WqHVkKkdbv%2F4A7Fdin7g66wjsnz4zK58U8vej%2FXibE%3D&reserved=0>
>
>  
>
> Cheers,
>
> Vlad
>
>

-- 
https://hambsd.org/