Subject: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 17 Sep 2020 18:43:40 +0000

Khaled,

As you may have guessed from other replies, it would HELP A LOT if you uploaded a revised I-D taking into account the previous comments (and not only the filename change) including those about deployment, scalability, ...

So, I am afraid that without a revised I-D addressing those problems, the discussion will go nowhere as we can see now on the intarea mailing list.

As long as there is no such revised I-D, I see no point in continuing this discussion or presenting an old version of the IPv10 draft at an IETF meeting.

Thank you in advance for a revised I-D [1] addressing the previous comments from a couple of years ago. Then, I am sure that this WG will review it.

Regards

-éric (and for information the responsible Area Director for intarea WG)

[1] and having some interns/students working on experimental code would be a big proof that your idea does work in real life.

-----Original Message-----
From: Int-area <[email-masked]> on behalf of "Eric Vyncke (evyncke)" <evyncke=[email-masked]>
Date: Thursday, 17 September 2020 at 15:46
To: Khaled Omar <[email-masked]>, int-area <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Ron Bonica <[email-masked]>
Subject: [Int-area] IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

    Hello Khaled,

    In your email, you refer to https://tools.ietf.org/html/draft-omar-ipv10-06 but may I assume that you meant the latest 2018 version https://tools.ietf.org/html/draft-omar-ipv10-11 ?

    Anyway, before presenting the draft, a revised IETF draft should be uploaded as all previous revisions are expired.

    You also have received some feedback on the mailing lists, did you incorporate them in a revision ?

    The above steps are really the critical conditions to present a draft at an IETF meeting.

    Regards

    -éric

    -----Original Message-----
    From: Khaled Omar <[email-masked]>
    Date: Wednesday, 16 September 2020 at 15:20
    To: Eric Vyncke <[email-masked]>, int-area <[email-masked]>, "[email-masked]" <[email-masked]>
    Cc: Ron Bonica <[email-masked]>, Fred Baker <[email-masked]>
    Subject: RE: [Int-area] FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10

        Sorry, IETF 98 Not 101 :-)

        -----Original Message-----
        From: Khaled Omar 
        Sent: Wednesday, September 16, 2020 3:12 PM
        To: 'Eric Vyncke (evyncke)' <[email-masked]>; int-area <[email-masked]>; [email-masked]
        Cc: Ron Bonica <[email-masked]>; Fred Baker <[email-masked]>
        Subject: RE: [Int-area] FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10

        Hi Eric,

        The IPv10 I-D was presented once at IETF 101 remotely through the IntArea and there was a technical issue prevented the draft to be presented completely.

        >> I do not see a major difference with previous drafts.

        This is because of the completion of the draft, IMHO it should be reviewed and an official decision should be taken, because the problem of the depletion of the IPv4 address space still has no recent solution applied, we cannot wait too long for IPv6 which requires tranining and this occurred actually but in vain.

        Best regards,

        Khaled Omar

        -----Original Message-----
        From: Eric Vyncke (evyncke) <[email-masked]> 
        Sent: Wednesday, September 16, 2020 3:05 PM
        To: Khaled Omar <[email-masked]>; int-area <[email-masked]>; [email-masked]
        Cc: Ron Bonica <[email-masked]>; Fred Baker <[email-masked]>
        Subject: Re: [Int-area] FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10

        Khaled,

        As the responsible AD for the intarea WG, I wonder why you are forwarding a V6OPS request to intarea ? Your draft has been already presented at intarea a couple of times and (I may be wrong) I do not see a major difference with previous drafts.

        -éric

        -----Original Message-----
        From: Int-area <[email-masked]> on behalf of Khaled Omar <[email-masked]>
        Date: Saturday, 12 September 2020 at 01:47
        To: int-area <[email-masked]>, "[email-masked]" <[email-masked]>
        Subject: [Int-area] FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10

            FYI, just to let you know so maybe you can help with something.

            Best Regards,

            Khaled Omar

            -----Original Message-----
            From: Khaled Omar 
            Sent: Saturday, September 12, 2020 1:42 AM
            To: Ron Bonica <[email-masked]>
            Cc: [email-masked]; [email-masked]
            Subject: RE: [v6ops] v6ops - New Meeting Session Request for IETF 109

            Hi Ron,

            Hope my I-D is clear for you, let me ask if we can reserve a slot for the IP-v10 I-D to be discussed during the next coming meeting so we can solve the problem that IMHO became clear for everyone even students.

            Good Luck,

            Khaled Omar 

            -----Original Message-----
            From: Khaled Omar 
            Sent: Friday, September 11, 2020 10:56 PM
            To: [email-masked]; [email-masked]
            Subject: RE: [v6ops] v6ops - New Meeting Session Request for IETF 109

            Hi V6OPS WG,

            Is it possible to reserve a slot for the IPv10 I-D to be presented completely during the v6ops wg meeting session?

            https://tools.ietf.org/html/draft-omar-ipv10-06

            Best Regards,

            Khaled Omar

            -----Original Message-----
            From: v6ops <[email-masked]> On Behalf Of IETF Meeting Session Request Tool
            Sent: Friday, September 11, 2020 10:52 PM
            To: [email-masked]
            Cc: [email-masked]; [email-masked]
            Subject: [v6ops] v6ops - New Meeting Session Request for IETF 109

            A new meeting session request has just been submitted by Fred Baker, a Chair of the v6ops working group.

            ---------------------------------------------------------
            Working Group Name: IPv6 Operations
            Area Name: Operations and Management Area Session Requester: Fred Baker

            Number of Sessions: 1
            Length of Session(s):  2 Hours
            Number of Attendees: 100
            Conflicts to Avoid: 
             Chair Conflict: spring lsr 6man intarea idr

             Key Participant Conflict: rtgwg tsvarea panrg grow tsvwg

            People who must be present:
              Fred Baker
              Ron Bonica
              Warren &quot;Ace&quot; Kumari

            Resources Requested:

            Special Requests:

            ---------------------------------------------------------

            _______________________________________________
            v6ops mailing list
            [email-masked]
            https://www.ietf.org/mailman/listinfo/v6ops

            _______________________________________________
            Int-area mailing list
            [email-masked]
            https://www.ietf.org/mailman/listinfo/int-area

    _______________________________________________
    Int-area mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/int-area

---

From: Khaled Omar <[email-masked]>
Date: Thu, 17 Sep 2020 18:48:46 +0000

Hi Eric,

Give me some time and I will revise the IPv10 I-D and I hope there will be more to add, because really the first version of this draft was uploaded in December 2016, so I listened to many positive opinions and made so many modifications till the version that I think is the best form of the draft.

Anyway, I will do what you ask for.

Best Regards,

Khaled Omar

-----Original Message-----
From: Eric Vyncke (evyncke) <[email-masked]> 
Sent: Thursday, September 17, 2020 8:44 PM
To: Khaled Omar <[email-masked]>; int-area <[email-masked]>
Cc: [email-masked]
Subject: Still need to know what has changed.... Re: [Int-area] IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Khaled,

Regards

-----Original Message-----
From: Int-area <[email-masked]> on behalf of "Eric Vyncke (evyncke)" <evyncke=[email-masked]>
Date: Thursday, 17 September 2020 at 15:46
To: Khaled Omar <[email-masked]>, int-area <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Ron Bonica <[email-masked]>
Subject: [Int-area] IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

    Hello Khaled,

    Regards

    -éric

        -----Original Message-----
        From: Khaled Omar 
        Sent: Wednesday, September 16, 2020 3:12 PM
        To: 'Eric Vyncke (evyncke)' <[email-masked]>; int-area <[email-masked]>; [email-masked]
        Cc: Ron Bonica <[email-masked]>; Fred Baker <[email-masked]>
        Subject: RE: [Int-area] FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10

        Hi Eric,

        Best regards,

        Khaled Omar

        -----Original Message-----
        From: Eric Vyncke (evyncke) <[email-masked]> 
        Sent: Wednesday, September 16, 2020 3:05 PM
        To: Khaled Omar <[email-masked]>; int-area <[email-masked]>; [email-masked]
        Cc: Ron Bonica <[email-masked]>; Fred Baker <[email-masked]>
        Subject: Re: [Int-area] FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10

        Khaled,

        -éric

        -----Original Message-----
        From: Int-area <[email-masked]> on behalf of Khaled Omar <[email-masked]>
        Date: Saturday, 12 September 2020 at 01:47
        To: int-area <[email-masked]>, "[email-masked]" <[email-masked]>
        Subject: [Int-area] FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10

            Best Regards,

            Khaled Omar

            -----Original Message-----
            From: Khaled Omar 

            Hi Ron,

            Good Luck,

            Khaled Omar 

            -----Original Message-----
            From: Khaled Omar 

            Hi V6OPS WG,

            Best Regards,

            Khaled Omar

            -----Original Message-----

            Number of Sessions: 1

            Resources Requested:

            Special Requests:

---

From: Roland Bless <[email-masked]>
Date: Thu, 17 Sep 2020 21:42:56 +0200

Hi Eric,

> Thank you in advance for a revised I-D [1] addressing the previous comments from a couple of years ago. Then, I am sure that this WG will review it.

Besides my already expressed concerns that this proposal is technically
not sound and in itself already contradicting, there has been another
(later) version that already used a different name (IPmix).
https://tools.ietf.org/html/draft-omar-ipmix-01
I actually don't know why Khaled used the old IPv10 term again,
but I know several cases where blogs and "press" took this for
a serious "IETF" proposal, causing quite some confusion at that time.
So please do NOT use the term IPv10 as it will cause lots of confusion
outside the IETF.

We have been there before...
https://mailarchive.ietf.org/arch/msg/int-area/4vhoJou8FTXJThDuRgleqDlpTT4/

So I agree that it makes no sense to discuss this even further without
an updated I-D that addresses all concerns expressed so far.

Regards,
 Roland

---

From: Khaled Omar <[email-masked]>
Date: Thu, 17 Sep 2020 21:08:00 +0000

Hi Roland,

The IPmix internet draft uses a different approach which I don't recommend.

We still can take the IPv10 to the standard level and change the name prior to the announcement, a name is not a big deal.

Regarding the confusion, the community is curious about the idea, many people support it as it solves the problem that they think they are not part of it.

Best regards,

Khaled Omar

-----Original Message-----
From: Roland Bless <[email-masked]> 
Sent: Thursday, September 17, 2020 9:43 PM
To: Eric Vyncke (evyncke) <evyncke=[email-masked]>; int-area <[email-masked]>
Cc: [email-masked]; Khaled Omar <[email-masked]>
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Hi Eric,

> Thank you in advance for a revised I-D [1] addressing the previous comments from a couple of years ago. Then, I am sure that this WG will review it.

Besides my already expressed concerns that this proposal is technically not sound and in itself already contradicting, there has been another
(later) version that already used a different name (IPmix).
https://tools.ietf.org/html/draft-omar-ipmix-01
I actually don't know why Khaled used the old IPv10 term again, but I know several cases where blogs and "press" took this for a serious "IETF" proposal, causing quite some confusion at that time.
So please do NOT use the term IPv10 as it will cause lots of confusion outside the IETF.

So I agree that it makes no sense to discuss this even further without an updated I-D that addresses all concerns expressed so far.

Regards,
 Roland

> From: Int-area <[email-masked]> on behalf of "Eric Vyncke 
> (evyncke)" <evyncke=[email-masked]>
> To: Khaled Omar <[email-masked]>, int-area 
> <[email-masked]>, "[email-masked]" 
> <[email-masked]>
> Subject: [Int-area] IPv10 draft (was Re: FW: [v6ops] v6ops - New 
> Meeting Session Request for IETF 109 - IPv10)
> 
>     Hello Khaled,
>

---

From: Fred Baker <[email-masked]>
Date: Thu, 17 Sep 2020 14:19:29 -0700

For the record, he has also requested air time in V6ops. I responded to him with a similar request, and added an additional point that I suspect should be important in int-area as well. The objective is to turn 

Sent using a machine that autocorrects in interesting ways...

> On Sep 17, 2020, at 12:43 PM, Roland Bless <[email-masked]> wrote:
> 
> Hi Eric,
>

---

From: Khaled Omar <[email-masked]>
Date: Thu, 17 Sep 2020 21:27:09 +0000

I think this is the right time to start working on the code as Eric planned.

Khaled Omar

-----Original Message-----
From: Int-area <[email-masked]> On Behalf Of Fred Baker
Sent: Thursday, September 17, 2020 11:19 PM
To: Roland Bless <[email-masked]>
Cc: Eric Vyncke (evyncke) <evyncke=[email-masked]>; int-area <[email-masked]>; [email-masked]
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

> Besides my already expressed concerns that this proposal is 
> technically not sound and in itself already contradicting, there has 
> been another
> I actually don't know why Khaled used the old IPv10 term again, but I 
> know several cases where blogs and "press" took this for a serious 
> "IETF" proposal, causing quite some confusion at that time.

---

From: Fred Baker <[email-masked]>
Date: Fri, 18 Sep 2020 03:24:27 -0700

Sent from my iPad

> On Sep 17, 2020, at 2:08 PM, Khaled Omar <[email-masked]> wrote:
> 

This statement has me a little confused. I see a lot of commentary, but I don’t see people commenting along those lines. I frankly see commentary similar to what I sent you declining a v6ops slot,

Who are these “many people”, and what problem do they see being solved?

---

From: Khaled Omar <[email-masked]>
Date: Fri, 18 Sep 2020 12:24:18 +0000

>> Who are these “many people”, and what problem do they see being solved?

Network engineers everywhere, they are waiting for the announcement of an official robust solution to the depletion of the IPv4 address space and the division that occurs recently on the Internet.

People read the draft and many wrote about it because the idea is simple and requires no intervention from their side, that’s why I ask the IETF to take the draft seriously and put personal benefits aside for now, as LATER everything will back to normal, believe me, all are in need for this.

Khaled Omar

-----Original Message-----
From: Fred Baker <[email-masked]> 
Sent: Friday, September 18, 2020 12:24 PM
To: Khaled Omar <[email-masked]>
Cc: Roland Bless <[email-masked]>; Eric Vyncke (evyncke) <evyncke=[email-masked]>; int-area <[email-masked]>; [email-masked]
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Sent from my iPad

---

From: Erik Kline <[email-masked]>
Date: Sat, 19 Sep 2020 16:04:54 -0700

As noted before: RFCs 6052, 6146, 6147, 6877, 7915, and others comprise the
solution deployed to literally hundreds of millions if not billions of
mobile devices and numerous access networks worldwide.

On Fri, Sep 18, 2020 at 5:24 AM Khaled Omar <[email-masked]>
wrote:

> Network engineers everywhere, they are waiting for the announcement of an
> official robust solution to the depletion of the IPv4 address space and the
> division that occurs recently on the Internet.
>
> People read the draft and many wrote about it because the idea is simple
> and requires no intervention from their side, that’s why I ask the IETF to
> take the draft seriously and put personal benefits aside for now, as LATER
> everything will back to normal, believe me, all are in need for this.
>
> Khaled Omar
>
> Cc: Roland Bless <[email-masked]>; Eric Vyncke (evyncke) <evyncke=
> [email-masked]>; int-area <[email-masked]>;
> [email-masked]
> Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10
> draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109
> - IPv10)
>
>
>
> Sent from my iPad
>
> > Regarding the confusion, the community is curious about the idea, many
> people support it as it solves the problem that they think they are not
> part of it.
>
> This statement has me a little confused. I see a lot of commentary, but I
> don’t see people commenting along those lines. I frankly see commentary
> similar to what I sent you declining a v6ops slot,
>

---

From: Khaled Omar <[email-masked]>
Date: Sat, 19 Sep 2020 23:18:23 +0000

But none of these transitioning solutions are widely deployed, maybe it is IPv10 time ;-)

Khaled Omar

From: Erik Kline <[email-masked]>
Sent: Sunday, September 20, 2020 1:05 AM
To: Khaled Omar <[email-masked]>
Cc: Fred Baker <[email-masked]>; Eric Vyncke (evyncke) <evyncke=[email-masked]>; int-area <[email-masked]>; [email-masked]
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

As noted before: RFCs 6052, 6146, 6147, 6877, 7915, and others comprise the solution deployed to literally hundreds of millions if not billions of mobile devices and numerous access networks worldwide.

Khaled Omar

-----Original Message-----
From: Fred Baker <[email-masked]<mailto:[email-masked]>>
Sent: Friday, September 18, 2020 12:24 PM
To: Khaled Omar <[email-masked]<mailto:[email-masked]>>
Cc: Roland Bless <[email-masked]<mailto:[email-masked]>>; Eric Vyncke (evyncke) <evyncke=[email-masked]<mailto:[email-masked]>>; int-area <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Sent from my iPad

> On Sep 17, 2020, at 2:08 PM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
>

Who are these “many people”, and what problem do they see being solved?
_______________________________________________
Int-area mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/int-area

---

From: Erik Kline <[email-masked]>
Date: Sat, 19 Sep 2020 16:23:45 -0700

> But none of these transitioning solutions are widely deployed, maybe it is

False.

>
>
> Khaled Omar
>
>
>
> *From:* Erik Kline <[email-masked]>
> *Sent:* Sunday, September 20, 2020 1:05 AM
> *To:* Khaled Omar <[email-masked]>
> *Cc:* Fred Baker <[email-masked]>; Eric Vyncke (evyncke)
> <evyncke=[email-masked]>; int-area <[email-masked]>;
> [email-masked]
> *Subject:* Re: [Int-area] Still need to know what has changed.... Re:
> IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for
> IETF 109 - IPv10)
>
>
>
> As noted before: RFCs 6052, 6146, 6147, 6877, 7915, and others comprise
> the solution deployed to literally hundreds of millions if not billions of

---

From: Fred Baker <[email-masked]>
Date: Sun, 20 Sep 2020 19:48:51 -0700

Boy. If “millions and billions” isn’t wide deployment, maybe I need to go back to grammar school.

Sent from my iPad

> On Sep 19, 2020, at 4:18 PM, Khaled Omar <[email-masked]> wrote:
> 
> 
> On Fri, Sep 18, 2020 at 5:24 AM Khaled Omar <[email-masked]> wrote:

---

From: Khaled Omar <[email-masked]>
Date: Mon, 21 Sep 2020 10:57:28 +0000

Maybe if you can provide me with all the statistics I need that shows the deployment so I can believe.

Khaled Omar

From: Fred Baker <[email-masked]>
Sent: Monday, September 21, 2020 4:49 AM
To: Khaled Omar <[email-masked]>
Cc: Erik Kline <[email-masked]>; Eric Vyncke (evyncke) <evyncke=[email-masked]>; int-area <[email-masked]>; [email-masked]
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

On Sep 19, 2020, at 4:18 PM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:

Khaled Omar

From: Erik Kline <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, September 20, 2020 1:05 AM
To: Khaled Omar <[email-masked]<mailto:[email-masked]>>
Cc: Fred Baker <[email-masked]<mailto:[email-masked]>>; Eric Vyncke (evyncke) <evyncke=[email-masked]<mailto:evyncke=[email-masked]>>; int-area <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Khaled Omar

-----Original Message-----
From: Fred Baker <[email-masked]<mailto:[email-masked]>>
Sent: Friday, September 18, 2020 12:24 PM
To: Khaled Omar <[email-masked]<mailto:[email-masked]>>
Cc: Roland Bless <[email-masked]<mailto:[email-masked]>>; Eric Vyncke (evyncke) <evyncke=[email-masked]<mailto:[email-masked]>>; int-area <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Sent from my iPad

---

From: <[email-masked]>
Date: Mon, 21 Sep 2020 12:32:45 +0000

Hi all,
Regarding the question these sources may give some hints on actual IPv6 figures although there are variations in different measurements and definition of metrics (deployed, capable, preferred … actual usage etc.) – and of course there are big deviations on IPv6 adoption between countries and regions:
https://www.worldipv6launch.org/measurements/
https://stats.labs.apnic.net/ipv6
https://labs.ripe.net/statistics/?tags=ipv6
or this article quoting the Billion … https://www.itu.int/en/myitu/News/2020/05/25/13/47/Where-are-we-in-the-transition-to-IPv6-QA-with-Latif-Ladid-President-of-IPv6-Forum
Hope it helps!
Kind regards
Dirk

From: Int-area <[email-masked]> On Behalf Of Khaled Omar
Sent: Montag, 21. September 2020 12:57
To: Fred Baker <[email-masked]>
Cc: Eric Vyncke (evyncke) <evyncke=[email-masked]>; int-area <[email-masked]>; [email-masked]
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Khaled Omar

Cc: Erik Kline <[email-masked]<mailto:[email-masked]>>; Eric Vyncke (evyncke) <evyncke=[email-masked]<mailto:evyncke=[email-masked]>>; int-area <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Khaled Omar

Khaled Omar

-----Original Message-----
From: Fred Baker <[email-masked]<mailto:[email-masked]>>
Sent: Friday, September 18, 2020 12:24 PM
To: Khaled Omar <[email-masked]<mailto:[email-masked]>>
Cc: Roland Bless <[email-masked]<mailto:[email-masked]>>; Eric Vyncke (evyncke) <evyncke=[email-masked]<mailto:[email-masked]>>; int-area <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Sent from my iPad

---

From: Khaled Omar <[email-masked]>
Date: Mon, 21 Sep 2020 12:47:29 +0000

Ok Dirk, but those are IPv6 statistics, maybe they are IPv6 only deployments, how to know if they are using the transitioning technologies? Maybe Dual stack is preferred IMHO.

Also, the article cannot be used as a reference to the billions ☺

Khaled Omar

From: [email-masked] <[email-masked]>
Sent: Monday, September 21, 2020 2:33 PM
To: [email-masked]; [email-masked]
Cc: evyncke=[email-masked]; [email-masked]; [email-masked]
Subject: RE: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Hi all,

From: Int-area <[email-masked]<mailto:[email-masked]>> On Behalf Of Khaled Omar
Sent: Montag, 21. September 2020 12:57
To: Fred Baker <[email-masked]<mailto:[email-masked]>>
Cc: Eric Vyncke (evyncke) <evyncke=[email-masked]<mailto:evyncke=[email-masked]>>; int-area <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Khaled Omar

Khaled Omar

Khaled Omar

-----Original Message-----
From: Fred Baker <[email-masked]<mailto:[email-masked]>>
Sent: Friday, September 18, 2020 12:24 PM
To: Khaled Omar <[email-masked]<mailto:[email-masked]>>
Cc: Roland Bless <[email-masked]<mailto:[email-masked]>>; Eric Vyncke (evyncke) <evyncke=[email-masked]<mailto:[email-masked]>>; int-area <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Sent from my iPad

---

From: Fred Baker <[email-masked]>
Date: Thu, 24 Sep 2020 14:44:41 -0700

> Maybe if you can provide me with all the statistics I need that shows the deployment so I can believe.

Sure. I'm using a site that Eric Vyncke has put together and can discuss with you. He uses Google (Erik Kline), Akamai (Jared Mauch), and APNIC (George Michelson/Geoff Huston) numbers; there are other services that publish statistics, he just hasn't included them. As of this instant, Google reports that requests that come to it from 73 countries exceed at least 5% of its workload from that country, and traffic from 37 countries exceed 35% of its workload in that country. Its Eric's site, but the data is from Google, and the site can get you to Akamai and APNIC data as well for the price of a mouse-click.

What I do is download the Google statistics, select the countries that exceed some cut-off, and then ask Eric's or APNIC's site to display the data.

5% cut-off
https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,de,in,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br,th,fi,mq,uy,gb,ec,ee,lk,ca,hu,ae,gp,re,nl,tt,ie,au,nz,pe,sa,ga,bo,ro,at,gt,no,ph,cz,sg,il,mo,pl,ar,sx,tg,si,np,mm,om,bt,kr,ke,fo,co,md,zw,cg,pr,is,lv,am,se,ru,li,jo,sk

35% cut-off
https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,de,in,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br

APNIC's display of its data on India is interesting
https://stats.labs.apnic.net/ipv6/CC?x=1&s=1&p=1&w=30&c=IN

If you scroll down, you will get a break-out by AS. APNIC reports that customers from 12 ASs use IPv6 when accessing APNIC with 50%+ probability ("ipv6-capable" and carrying that amount of data), and given a choice of IPv6 or IPv4, most of them are "ipv6-preferred" (eg, use IPv6 when given a choice). But about 50 ASs actually have users *using* IPv6 for some subset of their workload. In a Financial Times blog a week or two ago, the chair of India's IPv6 deployment task force argued that it should have an IPv6-only DNS Root Server on the basis of its IPv6 deployment and usage. I disagree with him (remarks available on request; they only have 38 IPv6-capable root servers in country), but the basis for the argument was interesting.

I think the APNIC data is interesting because it crosses the backbone. Google and Akamai run CDNs, which means that traffic can be between a residential subscriber and its CDN server without materially touching the ISP. APNIC runs no CDN, which means that traffic has to *also* traverse the ISP and the backbone to APNIC - there is and end-to-end path across the backbone. Think about this: when a user accesses a service using IPv6 (or IPv4 for that matter), the packet has to go from his computer, IOT device, or telephone to the site in question and the response has to come back; there has to be a complete end-to-end path in each direction. Miss one IPv6 connection in one direction, and it may as well be IPv4-only, because that's the only thing the end system will use.

From 73 countries, there is an end-to-end path of sufficient strength that a significant proportion of data *can* traverse it using IPv6, and the end system - which chooses whether to use IPv4 or IPv6 - will *choose* IPv6.

My search engine tells me "There are 195 countries in the world today. This total comprises 193 countries that are member states of the United Nations and 2 countries that are non-member observer states: the Holy See and the State of Palestine." 37% of them, 73, have significant IPv6 usage.

Define "widely deployed"? I'll add "and used?" That's pretty wide, in my book.

What prevents this from being IPv6-only? Computers and network equipment used by residential and enterprise subscribers have supported both IPv4 and IPv6 for years. The most commonly used applications are quite happy with either. The issue I see is primarily enterprise lack of IPv6 adoption in its customer-facing services. Even an "IPv6-preferred" site will use IPv4 when talking with something that will only use IPv4.

There is nothing proprietary here. Forward if you like.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 24 Sep 2020 21:59:25 +0000

Hi Fred,

That’s a powerful reply from you both, but let me try to check these statistics for 1 week and do some analysis to know whether I can depend on the result without any kind of forcing the end result, and I feel optimistic that the result will be reflecting the real case, I just need some time to be able to go with a conclusion as I have nothing to check out right now.

As you know from the IPv10 I-D, it requires the network between hosts to be IPv4/IPv6 ready, so it still can be considered, as I still think that the movement to IPv6 still need some time and arrangement to get the best result for the coming generations.

So, let me ask Eric if we can reserve a slot in the next meeting to present IPv10.

Thanks,

Khaled Omar

-----Original Message-----
From: Fred Baker <[email-masked]> 
Sent: Thursday, September 24, 2020 11:45 PM
To: Khaled Omar <[email-masked]>
Cc: Erik Kline <[email-masked]>; Eric Vyncke (evyncke) <evyncke=[email-masked]>; int-area <[email-masked]>; IPv6 Operations <[email-masked]>
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

5% cut-off

35% cut-off

APNIC's display of its data on India is interesting https://stats.labs.apnic.net/ipv6/CC?x=1&s=1&p=1&w=30&c=IN

> Cc: Erik Kline <[email-masked]>; Eric Vyncke (evyncke) 
> Subject: Re: [Int-area] Still need to know what has changed.... Re: 
> IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request 
> for IETF 109 - IPv10)
>  
> Cc: Fred Baker <[email-masked]>; Eric Vyncke (evyncke) 
> Subject: Re: [Int-area] Still need to know what has changed.... Re: 
> IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request 
> for IETF 109 - IPv10)
>  
> Cc: Roland Bless <[email-masked]>; Eric Vyncke (evyncke) 
> Subject: Re: [Int-area] Still need to know what has changed.... Re: 
> IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request 
> for IETF 109 - IPv10)
> 
> 
> 
> Sent from my iPad
> 
> This statement has me a little confused. I see a lot of commentary, 
> but I don’t see people commenting along those lines. I frankly see 
> commentary similar to what I sent you declining a v6ops slot,
>

---

From: Fred Baker <[email-masked]>
Date: Thu, 24 Sep 2020 15:14:19 -0700

Another link you may find interesting is https://stats.labs.apnic.net/ipv6/CC?x=1&s=1&p=1&w=30&c=EG.

As you scroll down, you'll find that Egypt had very promising trial IPv6 service until early 2018. I don't know what happened then, but traffic plummeted dramatically, as if someone had simply turned it off. It might be worth your while to find out what happened.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 24 Sep 2020 22:24:52 +0000

Here is Egypt we have 3 or 4 Big Providers, I attended one of the trainings held by AFRINIC in 2016 about IPv6 and guys were still unfamiliar with IPv6, I encourage AFRINIC to do another visit to check it out with them to override the implications and for sure I will be there.

They had concerns regarding the Link Locals addresses and SLAAC.

Khaled Omar

---

From: Gert Doering <[email-masked]>
Date: Fri, 25 Sep 2020 08:50:38 +0200

Hi,

> As you know from the IPv10 I-D, it requires the network between hosts to be IPv4/IPv6 ready, so it still can be considered, as I still think that the movement to IPv6 still need some time and arran…

The transit networks are all ready today.  If IPv6 is not available, it's 
the endpoints or the applications.

Gert Doering
        -- NetMaster
-- 
have you enabled IPv6 on something today...?

SpaceNet AG                      Vorstand: Sebastian v. Bomhard, Michael Emmer
Joseph-Dollinger-Bogen 14        Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen                 HRB: 136055 (AG Muenchen)
Tel: +49 (0)89/32356-444         USt-IdNr.: DE813185279

---

From: "Carsten Strotmann" <[email-masked]>
Date: Fri, 25 Sep 2020 11:07:26 +0200

Hi,

On 25 Sep 2020, at 8:50, Gert Doering wrote:

>> As you know from the IPv10 I-D, it requires the network between hosts 
>> to be IPv4/IPv6 ready, so it still can be considered, as I still 
>> think that the movement to IPv6 still need some time and arrangement 
>> to get the best result for the coming generations.
>

I did a measurement of the use of IP protocols on a large (> 1M 
customers) DNS resolver in Germany in July. More than 2/3 of all DNS 
traffic from that resolver to the Internet was over IPv6, less than 1/3 
over IPv4.

At least for DNS, IPv6 is doing pretty good.

Greetings

Carsten

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 11:36:11 +0000

Hi,

From the collection of statistics you all provided, I can come to a conclusion that around an average of 40% of the world traffic became IPv6, which is still something we cannot depend on as if you compare the time since IPv6 was firstly deployed till now, I can expect that after +10 years we can come to 70 or 75% world-wide, during this time we will have blocks of IPv6 only and blocks of IPv4, which means the clear division.

That’s why looking into the transitions solutions became a mandatory or a peaceful solution such as IPv10 that will allow both version to coexist and communicate until the full migration. 

Khaled Omar

-----Original Message-----
From: Vasilenko Eduard <[email-masked]> 
Sent: Friday, September 25, 2020 1:15 PM
To: Fred Baker <[email-masked]>; Khaled Omar <[email-masked]>
Cc: Eric Vyncke (evyncke) <evyncke=[email-masked]>; IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: RE: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

Hi all,
Fred has formalized below something like 25% of the good White Paper!

There is one recent WP on IPv6 status: https://www.etsi.org/images/files/ETSIWhitePapers/etsi_WP35_IPv6_Best_Practices_Benefits_Transition_Challenges_and_the_Way_Forward.pdf
Where some additional facts could be found.

Eduard
> From: v6ops [mailto:[email-masked]] On Behalf Of Fred Baker
> Sent: 25 сентября 2020 г. 0:45
> Cc: Eric Vyncke (evyncke) <evyncke=[email-masked]>; IPv6 
> Operations <[email-masked]>; int-area <[email-masked]>
> Subject: Re: [v6ops] [Int-area] Still need to know what has 
> changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session 
> Request for IETF 109 - IPv10)
> 
> > Maybe if you can provide me with all the statistics I need that 
> > shows the
> deployment so I can believe.
> >
> > Khaled Omar
> 
> Sure. I'm using a site that Eric Vyncke has put together and can discuss with you.
> He uses Google (Erik Kline), Akamai (Jared Mauch), and APNIC (George 
> Michelson/Geoff Huston) numbers; there are other services that publish 
> statistics, he just hasn't included them. As of this instant, Google 
> reports that requests that come to it from 73 countries exceed at 
> least 5% of its workload from that country, and traffic from 37 
> countries exceed 35% of its workload in that country. Its Eric's site, 
> but the data is from Google, and the site can get you to Akamai and APNIC data as well for the price of a mouse-click.
> 
> What I do is download the Google statistics, select the countries that 
> exceed some cut-off, and then ask Eric's or APNIC's site to display the data.
> 
> 5% cut-off
> https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,de
> ,in 
> ,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br,th,fi,mq,uy,gb,ec,ee,lk,ca,
> hu,ae,gp,re, 
> nl,tt,ie,au,nz,pe,sa,ga,bo,ro,at,gt,no,ph,cz,sg,il,mo,pl,ar,sx,tg,si,n
> p,mm,om,bt,k r,ke,fo,co,md,zw,cg,pr,is,lv,am,se,ru,li,jo,sk
> 
> 35% cut-off
> https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,de
> ,in ,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br
> 
> If you scroll down, you will get a break-out by AS. APNIC reports that 
> customers from 12 ASs use IPv6 when accessing APNIC with 50%+ 
> probability ("ipv6- capable" and carrying that amount of data), and 
> given a choice of IPv6 or IPv4, most of them are "ipv6-preferred" (eg, 
> use IPv6 when given a choice). But about
> 50 ASs actually have users *using* IPv6 for some subset of their 
> workload. In a Financial Times blog a week or two ago, the chair of 
> India's IPv6 deployment task force argued that it should have an 
> IPv6-only DNS Root Server on the basis of its IPv6 deployment and 
> usage. I disagree with him (remarks available on request; they only 
> have 38 IPv6-capable root servers in country), but the basis for the argument was interesting.
> 
> I think the APNIC data is interesting because it crosses the backbone. 
> Google and Akamai run CDNs, which means that traffic can be between a 
> residential subscriber and its CDN server without materially touching 
> the ISP. APNIC runs no CDN, which means that traffic has to *also* 
> traverse the ISP and the backbone to APNIC - there is and end-to-end path across the backbone. Think about this:
> when a user accesses a service using IPv6 (or IPv4 for that matter), 
> the packet has to go from his computer, IOT device, or telephone to 
> the site in question and the response has to come back; there has to 
> be a complete end-to-end path in each direction. Miss one IPv6 
> connection in one direction, and it may as well be IPv4-only, because that's the only thing the end system will use.
> 
> From 73 countries, there is an end-to-end path of sufficient strength 
> that a significant proportion of data *can* traverse it using IPv6, 
> and the end system - which chooses whether to use IPv4 or IPv6 - will *choose* IPv6.
> 
> My search engine tells me "There are 195 countries in the world today. 
> This total comprises 193 countries that are member states of the 
> United Nations and 2 countries that are non-member observer states: 
> the Holy See and the State of Palestine." 37% of them, 73, have significant IPv6 usage.
> 
> What prevents this from being IPv6-only? Computers and network 
> equipment used by residential and enterprise subscribers have 
> supported both IPv4 and IPv6 for years. The most commonly used applications are quite happy with either.
> The issue I see is primarily enterprise lack of IPv6 adoption in its 
> customer-facing services. Even an "IPv6-preferred" site will use IPv4 
> when talking with something that will only use IPv4.
> 
> > Boy. If “millions and billions” isn’t wide deployment, maybe I need 
> > to go back
> to grammar school.
> >
> > Sent from my iPad
> >
> >
> > On Sep 19, 2020, at 4:18 PM, Khaled Omar 
> > <[email-masked]>
> wrote:
> >
> > 
> official robust solution to the depletion of the IPv4 address space 
> and the division that occurs recently on the Internet.
> >
> > People read the draft and many wrote about it because the idea is 
> > simple and
> requires no intervention from their side, that’s why I ask the IETF to 
> take the draft seriously and put personal benefits aside for now, as 
> LATER everything will back to normal, believe me, all are in need for this.
> >
> > Khaled Omar
> >
> people support it as it solves the problem that they think they are not part of it.
> >

---

From: Mikael Abrahamsson <[email-masked]>
Date: Fri, 25 Sep 2020 14:42:52 +0200 (CEST)

On Fri, 25 Sep 2020, Khaled Omar wrote:

> That’s why looking into the transitions solutions became a mandatory or 
> a peaceful solution such as IPv10 that will allow both version to 
> coexist and communicate until the full migration.

No, any change now just resets the clock and postpones the transition by 
another 20 years.

Meaningful support for IPv6 has been available in end-devices since the 
2006-2008 timeframe when Windows Vista was released and around the same 
timeframe other end-user operating systems gained support as well.

We're now in 2020 in a situation where basically every end user device in 
use has IPv6 support, even laggards like Smart TVs have started to gain 
IPv6 support. Printers have had IPv6 support for 10+ years.

For your proposal, you have zero running code and thus zero devices 
supporting your proposal.

You keep making these statements that upgrades are easy. They are not. 
Ecosystems take a long time to build. You don't even have running code to 
be able to verify that your proposal actually works (it doesn't).

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 13:04:29 +0000

>> You don't even have running code to be able to verify that your proposal actually works (it doesn't).

Do you have a running code to state this?

Khaled Omar

-----Original Message-----
From: Mikael Abrahamsson <[email-masked]> 
Sent: Friday, September 25, 2020 2:43 PM
To: Khaled Omar <[email-masked]>
Cc: IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: Re: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

On Fri, 25 Sep 2020, Khaled Omar wrote:

> That’s why looking into the transitions solutions became a mandatory 
> or a peaceful solution such as IPv10 that will allow both version to 

No, any change now just resets the clock and postpones the transition by another 20 years.

Meaningful support for IPv6 has been available in end-devices since the
2006-2008 timeframe when Windows Vista was released and around the same timeframe other end-user operating systems gained support as well.

We're now in 2020 in a situation where basically every end user device in use has IPv6 support, even laggards like Smart TVs have started to gain
IPv6 support. Printers have had IPv6 support for 10+ years.

For your proposal, you have zero running code and thus zero devices supporting your proposal.

You keep making these statements that upgrades are easy. They are not. 
Ecosystems take a long time to build. You don't even have running code to be able to verify that your proposal actually works (it doesn't).

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Fri, 25 Sep 2020 16:37:50 +0200

Hi Khaled,

> Do you have a running code to state this?

How should one create running code out of a flawed specification?
The following picture from your draft already shows that
it definitely cannot work, thus no code needed:
an IPv4-_only_ host by definition does NOT support IPv10
and thus CANNOT send any IPv10 tunnel packets. Same for an
IPv6-_only_ host.

IPv10 Host                                         IPv10 Host
    PC-1                                                PC-2
   +----+                                              +----+
   |    |                                              |    |
   |    |                                              |    |
   +----+                                              +----+
  /    /   <--------------------------------------->  /    /
 +----+              IPv10 Header (Tunnel)           +----+
                              (3)
IPv4-Only Host                                    IPv6-Only Host

Do you see the contradiction here?

Roland

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 14:41:10 +0000

Roland, the sending host will encapsulate an extension header with two different IP versions, where is the contradiction here? I don't see it.

Khaled Omar

-----Original Message-----
From: Bless, Roland (TM) <[email-masked]> 
Sent: Friday, September 25, 2020 4:38 PM
To: Khaled Omar <[email-masked]>; Mikael Abrahamsson <[email-masked]>
Cc: IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: Re: [Int-area] [v6ops] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

Hi Khaled,

How should one create running code out of a flawed specification?
The following picture from your draft already shows that it definitely cannot work, thus no code needed:
an IPv4-_only_ host by definition does NOT support IPv10 and thus CANNOT send any IPv10 tunnel packets. Same for an IPv6-_only_ host.

IPv10 Host                                         IPv10 Host
    PC-1                                                PC-2
   +----+                                              +----+
   |    |                                              |    |
   |    |                                              |    |
   +----+                                              +----+

Roland

> We're now in 2020 in a situation where basically every end user device 
> in use has IPv6 support, even laggards like Smart TVs have started to 
> gain

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Fri, 25 Sep 2020 17:11:10 +0200

Hi Khaled,

> Roland, the sending host will encapsulate an extension header with two different IP versions, where is the contradiction here? I don't see it.

This is a bit sad, but probably one last try:
An IPv4-only host does only understand a single IP version, namely IPv4.
Inside an IPv4-only host there is NO understanding of a
different packet format (IPv10) or IP address format (neither IPv6 nor
IPv10) by definition. Consequently, it cannot encapsulate an IPv4 packet
into an IPv10 packet by lack of knowing the format and functionality.
Otherwise you have an IPv4/IPv10 _dual_ stack host, but that
is then not an IPv4-only host by definition.

Regards
 Roland

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 15:13:09 +0000

Ok, I have no energy to keep repeating, I'm sorry, read the full draft please again.

Khaled Omar

-----Original Message-----
From: Bless, Roland (TM) <[email-masked]> 
Sent: Friday, September 25, 2020 5:11 PM
To: Khaled Omar <[email-masked]>; Mikael Abrahamsson <[email-masked]>
Cc: IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: Re: [Int-area] [v6ops] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

Hi Khaled,

This is a bit sad, but probably one last try:
An IPv4-only host does only understand a single IP version, namely IPv4.
Inside an IPv4-only host there is NO understanding of a different packet format (IPv10) or IP address format (neither IPv6 nor
IPv10) by definition. Consequently, it cannot encapsulate an IPv4 packet into an IPv10 packet by lack of knowing the format and functionality.
Otherwise you have an IPv4/IPv10 _dual_ stack host, but that is then not an IPv4-only host by definition.

Regards
 Roland

> Subject: Re: [Int-area] [v6ops] Still need to know what has 
>> We're now in 2020 in a situation where basically every end user 
>> device in use has IPv6 support, even laggards like Smart TVs have 
>> started to gain

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Fri, 25 Sep 2020 17:30:05 +0200

Khaled,

> Ok, I have no energy to keep repeating, I'm sorry, read the full draft please again.

Be assured that I read the draft, but that does not solve the problem
with your draft/proposal. Unless you see the contradiction I pointed out
here, there is no common ground for ANY further discussion on this
topic. Most of us may have different views on proposals, but at least
no different views on logical inferences like this one.
  Roland

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Fri, 25 Sep 2020 20:45:46 +0000

Khaled,

You have received significant feedback from representatives of network/cloud operators, network equipment vendors, mobile device makers, academia, SW providers and developers. 

We will not consider your draft for presentation until a version of your proposal responds to the different technical issues that have been pointed out.

If you are interested in pursuing, please update your draft taking into account all these considerations. Running code with proven results would also help.

Once you get positive support on the mailing list, we will gladly consider it for presentation at the meeting.

Best regards,

Juan Carlos Zuniga & Wassim Haddad
(Internet Area WG Chairs)

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 20:52:45 +0000

I still don't see any technical concerns received from the members, all are to understand the way how IPv10 works, some had a misunderstanding that’s why I wanted to answer all these question during the meeting so no duplicated questions be received.

It is good to take all into my account but regarding the running code, is out of my hands, so without your help, nothing will go forward.

Thanks Juan,

Khaled Omar

-----Original Message-----
From: Juan Carlos Zuniga <[email-masked]> 
Sent: Friday, September 25, 2020 10:46 PM
To: Khaled Omar <[email-masked]>; Wassim Haddad <[email-masked]>
Cc: Eric Vyncke (evyncke) <evyncke=[email-masked]>; IPv6 Operations <[email-masked]>; int-area <[email-masked]>; Fred Baker <[email-masked]>; Juan Carlos Zuniga <[email-masked]>
Subject: RE: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Khaled,

Best regards,

---

From: Fred Baker <[email-masked]>
Date: Fri, 25 Sep 2020 14:14:14 -0700

> On Sep 25, 2020, at 4:36 AM, Khaled Omar <[email-masked]> wrote:
> 

I already wrote that white paper, in 2017. Numbers were a little different, but take a look at:
https://www.internetsociety.org/resources/doc/2017/state-of-ipv6-deployment-2017/

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 21:19:21 +0000

I agree, but where we can found a live statistics other than Google to keep tracking?

Khaled Omar

---

From: Erik Kline <[email-masked]>
Date: Fri, 25 Sep 2020 14:46:29 -0700

https://www.worldipv6launch.org/measurements/ has some aggregated
statistics.

On Fri, Sep 25, 2020 at 2:19 PM Khaled Omar <[email-masked]>
wrote:

> Cc: Vasilenko Eduard <[email-masked]>; Eric Vyncke (evyncke)
> <evyncke=[email-masked]>; IPv6 Operations <[email-masked]>;
> int-area <[email-masked]>
> Subject: Re: [v6ops] [Int-area] Still need to know what has changed....
> Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF
> 109 - IPv10)
>
>
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 25 Sep 2020 21:52:27 +0000

Khaled,

I fully support the intarea Working Group chairs' decision as the responsible AD for this WG.

As long as you do not execute the work of updating your draft (and I gave you last week the bare minimum things to do) it will not get a slot in any IETF WG. Its content has not really changed since last presentation.

So, when you have a new improved draft, the WG chairs and myself will reconsider the situation. But not before.

Regards

-éric

PS: and to be clear, I do not want any more discussion about presenting this draft on the intarea mailing list until it is vastly improved.

-----Original Message-----
From: Juan Carlos Zuniga <[email-masked]>
Date: Friday, 25 September 2020 at 22:46
To: Khaled Omar <[email-masked]>, Wassim Haddad <[email-masked]>
Cc: Eric Vyncke <[email-masked]>, IPv6 Operations <[email-masked]>, int-area <[email-masked]>, Fred Baker <[email-masked]>, Juan Carlos Zuniga <[email-masked]>
Subject: RE: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

    Khaled,

    Best regards,

---

From: Simon Hobson <[email-masked]>
Date: Mon, 28 Sep 2020 09:22:07 +0100

> Ok, I have no energy to keep repeating, I'm sorry, read the full draft please again.

And therein lies a big part of your problem.

Constantly repeating something which is incorrect does not make it correct - well not in our world anyway ! You can say "it's not a problem" as many times as you like, that does not make it so.

People have tried to explain to you in many ways that upgrading hosts that are easy to upgrade is not the problem - that's mostly solved.
Firewall rules/ACLs/etc do not stay the same - they must all be updated to cope with the new combinations of addresses that can be employed. Routers everywhere must be updated - believe it or not, IPv4 routers are usually hardware tied to the format of an IPv4 packet - they simply will not understand any other packet. And by requiring a different packet format end-end you are enforcing that your packet format cannot be used (reliably) until 100% of the internet has been upgraded.

And as already said, pretty well all the changes needed to support your IPv10 are much the same as needed to support IPv6. But, with IPv6 once you get there then you've reached the end-game (IPv6) rather than having reached just a milestone on the way to IPv6. And there are migration options to handle "bits" (whether that's hosts, bits of the internet, services, whatever) that still can't manage IPv6.

So, some specific questions you've been asked but refused to answer. I say refused, because saying "just read the draft again, you don't understand" is refusing to answer legitimate questions about what is in your draft. The questions asked show that people have looked at and understood your draft - they can see reasons why it cannot work, but you are failing to address those issues.

Q: In your IPv10 world, what happens when an IPv4 only host (and by that, I mean a host that cannot talk anything but plain vanilla IPv4) tries to talk to an IPv6 only host ?
A: It fails. If you believe otherwise, please explain how it works - without requiring the host to be IPv10 capable. In reality (in the absence of network based migration techniques), it'll do an A lookup in DNS, get no result, and just fail. It won't know what to do with an AAAA record.
Bonus answer: Explain how hosts that are no longer supported, or have hardware restrictions (limited RAM/ROM space), are owned/used by people who have no idea what a "firmware upgrade" is and have even less idea why they'd want to do one, etc get upgrades ?

Q: In your IPv10 world, what happens when one of your new format packets hits a router/firewall/load balancer/other network equipment that doesn't understand it ?
A: The packet gets dropped<period>. If it isn't an IPv4 packet, then an IPv4 device won't handle it - by definition, your IPv10 packets are not IPv4 packets. Your IPv10 host cannot communicate along that path. Thus it must fall back to trying either IPv4 or IPv6 - so it might as well have just used IPv4 or IPv6 in the first place. Again, if you believe my answer to be wrong, then explain in detail why - not just "you don't understand, read the draft again".

Simon

---

From: Khaled Omar <[email-masked]>
Date: Mon, 28 Sep 2020 11:18:51 +0000

Well, think of it like that, once all hosts support IPv10 (as all hosts now support IPv6) network engineers will cope up with the new header, because the destination will be from a different version, Old firewall configuration will be the same but new configuration will be addred because new IPv6 only devices will be on place (this is their normal job).

>> Q: In your IPv10 world, what happens when an IPv4 only host (and by that, I mean a host that cannot talk anything but plain vanilla IPv4) tries to talk to an IPv6 only host ?

This host must be updated, no reason not to accept the updates.

>> Q: In your IPv10 world, what happens when one of your new format packets hits a router/firewall/load balancer/other network equipment that doesn't understand it ?

These devices must be updated, that's why the word ALL answer all your questions.

Khaled Omar 

-----Original Message-----
From: Int-area <[email-masked]> On Behalf Of Simon Hobson
Sent: Monday, September 28, 2020 10:22 AM
To: IPv6 Operations <[email-masked]>
Cc: int-area <[email-masked]>
Subject: Re: [Int-area] [v6ops] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

Simon

---

From: Fernando Gont <[email-masked]>
Date: Mon, 28 Sep 2020 10:18:39 -0300

> At least for DNS, IPv6 is doing pretty good.

Modulo fragmentation? ;-)

Thanks,
-- 
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1