Subject: Re: [Int-area] [v6ops] Still need to know what has changed.... Re: IPv10 draft

From: Vasilenko Eduard <[email-masked]>
Date: Fri, 25 Sep 2020 18:21:31 +0000

Hi all,
I have looked to the draft. This hurricane is a little groundless.

Experts,
What Khaled was trying to invent is not a new IP protocol. It is just a mistake that it was called IPv10.
If you look inside the draft - you would see that it is additional version of IPv6 Stateless translation with IPv4-embedded addresses again.
Hence, billions of man-hours that is needed for development of new IP protocol is not needed. It is good news.

Khaled,
Your solution already exist. It is RFC 6144 - April 2011. Please, read this RFC. It has a bit more details then yours.
Just nobody before you was so brave to propose stateless translation directly from every host in the world. Everybody else was thinking about some gateways to keep the majority of hosts intact.
There is a logical hole in your proposal:
If it possible to upgrade every host from IPv4, then why not to upgrade it to IPv6 directly? That's it - problem solved.
Why anybody would need to upgrade hosts to combination of 2 protocols in the data plane? (second header is IPv10)
It is not logical. Does not make sense.

By the way, it is not possible to upgrade every host in the world out of IPv4 (nobody see money to do the job) - but it is the second problem that you would not face because of previous problem.

And what you propose to do in the next 20 years when part of host would already support IPv10, but other part does not?

Additionally I need to inform you that people are not satisfied with stateless translation, because long transition needs IPv4 per every host, but IPv4 is in shortage.
Hence, other translation technologies: 464XLAT, MAP-T/E, DS-lite, lw4o6.
If you trying to attack translation topic - you need to read all of these carefully.

Eduard

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 18:46:49 +0000

>> If you look inside the draft - you would see that it is additional version of IPv6 Stateless translation with IPv4-embedded addresses again.

Eduard, There are no any kind of translation used, it is just mixing the two version in the same header, one as a source the other as a destination.

>> Your solution already exist. It is RFC 6144 - April 2011. Please, read this RFC. It has a bit more details then yours.

This draft uses translators, where is the statement that two versions can exist in the same header and achieve the communication?!

>> And what you propose to do in the next 20 years when part of host would already support IPv10, but other part does not?

Good question, all the devices has to step by step be updated, then we can switch on a flag day to IPv10, so this will give time to developers to first write the code, then apply the code gradually on all OSs.

>> Additionally I need to inform you that people are not satisfied with stateless translation, because long transition needs IPv4 per every host, but IPv4 is in shortage.

We will not need more IPv4 addresses, as new hosts will be assigned IPv6 addresses and still be able to communicate with the IPv4 hosts.

Khaled Omar

-----Original Message-----
From: Vasilenko Eduard <[email-masked]> 
Sent: Friday, September 25, 2020 8:22 PM
To: Khaled Omar <[email-masked]>
Cc: IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: RE: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft

Hi all,

Experts,

Khaled,
Why anybody would need to upgrade hosts to combination of 2 protocols in the data plane? (second header is IPv10) It is not logical. Does not make sense.

Eduard

---

From: Khaled Omar <[email-masked]>
Date: Mon, 28 Sep 2020 11:21:33 +0000

>> You have IPv4 address inserted into IPv6.

This is in the IP mix draft, not the IPv10 draft, IPv10 has no IPv4 embedded address.

Khaled Omar

-----Original Message-----
From: Vasilenko Eduard <[email-masked]> 
Sent: Monday, September 28, 2020 10:12 AM
To: Khaled Omar <[email-masked]>
Cc: IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: RE: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft

Hi Khalid,
You have avoided to answer my primary question:
> If it possible to upgrade every host from IPv4, then why not to 
> upgrade it to IPv6 directly? That's it - problem solved.
> Why anybody would need to upgrade hosts to combination of 2 protocols 
> in the data plane? (second header is IPv10) It is not logical. Does not make sense.

You have IPv4 address inserted into IPv6.
Believe you or not - industry does use "stateless translation" name for such solutions.
You have invented 9th version of address translation, that is not fully specified.
I do not see advantages against RFC 6144.

Eduard
> From: Khaled Omar [mailto:[email-masked]]
> Sent: 25 сентября 2020 г. 21:47
> To: Vasilenko Eduard <[email-masked]>
> >> If you look inside the draft - you would see that it is additional 
> >> version of IPv6
> Stateless translation with IPv4-embedded addresses again.
> 
> Eduard, There are no any kind of translation used, it is just mixing 
> the two version in the same header, one as a source the other as a destination.
> 
> This draft uses translators, where is the statement that two versions 
> can exist in the same header and achieve the communication?!
> 
> >> And what you propose to do in the next 20 years when part of host 
> >> would
> already support IPv10, but other part does not?
> 
> Good question, all the devices has to step by step be updated, then we 
> can switch on a flag day to IPv10, so this will give time to 
> developers to first write the code, then apply the code gradually on all OSs.
> 
> >> Additionally I need to inform you that people are not satisfied 
> >> with stateless
> translation, because long transition needs IPv4 per every host, but 
> IPv4 is in shortage.
> 
> We will not need more IPv4 addresses, as new hosts will be assigned 
> IPv6 addresses and still be able to communicate with the IPv4 hosts.
> 
> Khaled Omar
> 
> 
> If you look inside the draft - you would see that it is additional 
> version of IPv6 Stateless translation with IPv4-embedded addresses again.
> Your solution already exist. It is RFC 6144 - April 2011. Please, read 
> this RFC. It has a bit more details then yours.
> Just nobody before you was so brave to propose stateless translation 
> directly from every host in the world. Everybody else was thinking 
> about some gateways to keep the majority of hosts intact.
> If it possible to upgrade every host from IPv4, then why not to 
> upgrade it to IPv6 directly? That's it - problem solved.
> Why anybody would need to upgrade hosts to combination of 2 protocols 
> in the data plane? (second header is IPv10) It is not logical. Does not make sense.
> 
> By the way, it is not possible to upgrade every host in the world out 
> of IPv4 (nobody see money to do the job) - but it is the second 
> problem that you would not face because of previous problem.
> 
> And what you propose to do in the next 20 years when part of host 
> would already support IPv10, but other part does not?
> 
> Additionally I need to inform you that people are not satisfied with 
> stateless translation, because long transition needs IPv4 per every 
> host, but IPv4 is in shortage.

---

From: Khaled Omar <[email-masked]>
Date: Mon, 28 Sep 2020 11:33:02 +0000

Not right, IPv6 took so "long" time so devices can migrate to, upper thing, IPv10 uses both types of communication, so it solves everything from the roots, if you will follow the draft step by step, you will find out that even with DNS it works fine.

Khaled Omar

-----Original Message-----
From: Vasilenko Eduard <[email-masked]> 
Sent: Monday, September 28, 2020 1:30 PM
To: Khaled Omar <[email-masked]>
Cc: IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: RE: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft

Khalid,
You still avoid to answer my primary question:
> > Why anybody would need to upgrade hosts to combination of 2 
> > protocols in the data plane? (second header is IPv10) It is not 
> > logical. Does not make
> sense.

If upgrade is so easy -then  we do not need any interim solution. Just IPv6. Right?

Eduard
> Sent: 28 сентября 2020 г. 14:22
> > Why anybody would need to upgrade hosts to combination of 2 
> > protocols in the data plane? (second header is IPv10) It is not 
> > logical. Does not make
> sense.
> 
> > >> If you look inside the draft - you would see that it is 
> > >> additional version of IPv6
> > This draft uses translators, where is the statement that two 
> > versions can exist in the same header and achieve the communication?!
> >
> > Good question, all the devices has to step by step be updated, then 
> > we can switch on a flag day to IPv10, so this will give time to 
> > Hence, billions of man-hours that is needed for development of new 
> > IP protocol is not needed. It is good news.
> >
> > Khaled,
> > Your solution already exist. It is RFC 6144 - April 2011. Please, 
> > read this RFC. It has a bit more details then yours.
> > Why anybody would need to upgrade hosts to combination of 2 
> > protocols in the data plane? (second header is IPv10) It is not 
> > logical. Does not make
> sense.
> >
> > By the way, it is not possible to upgrade every host in the world 
> > out of IPv4 (nobody see money to do the job) - but it is the second 
> > If you trying to attack translation topic - you need to read all of 
> > these
> carefully.
> >
> > Eduard

---

From: Khaled Omar <[email-masked]>
Date: Mon, 28 Sep 2020 11:37:32 +0000

As I'm here on the list discussing it, we should come to a final conclusion and start working on making it official, just to have a clear mind with good intention and everything will be fine.

Khaled Omar

-----Original Message-----
From: Vasilenko Eduard <[email-masked]> 
Sent: Monday, September 28, 2020 1:30 PM
To: Khaled Omar <[email-masked]>
Cc: IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: RE: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft

Khalid,

Eduard

---

From: Gert Doering <[email-masked]>
Date: Mon, 28 Sep 2020 14:03:40 +0200

Hi,

> As I'm here on the list discussing it, we should come to a final conclusion and start working on making it official, just to have a clear mind with good intention and everything will be fine.

We have come to a conclusion: you present some running code, and then we
start spending cycles on it.

Everybody who replied told you that it's not going to work the way you
envisage.  To counter that, bring proof, in the form of running code.

Gert Doering
        -- NetMaster
-- 
have you enabled IPv6 on something today...?

SpaceNet AG                      Vorstand: Sebastian v. Bomhard, Michael Emmer
Joseph-Dollinger-Bogen 14        Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen                 HRB: 136055 (AG Muenchen)
Tel: +49 (0)89/32356-444         USt-IdNr.: DE813185279

---

From: Khaled Omar <[email-masked]>
Date: Mon, 28 Sep 2020 12:12:28 +0000

As I mentioned, it is the duty of technology companies, I should be waiting that they write the code on their OS and make the experiment and I will follow their decision.

Khaled Omar

-----Original Message-----
From: Gert Doering <[email-masked]> 
Sent: Monday, September 28, 2020 2:04 PM
To: Khaled Omar <[email-masked]>
Cc: Vasilenko Eduard <[email-masked]>; IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: Re: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft

Hi,

> As I'm here on the list discussing it, we should come to a final conclusion and start working on making it official, just to have a clear mind with good intention and everything will be fine.

We have come to a conclusion: you present some running code, and then we start spending cycles on it.

Everybody who replied told you that it's not going to work the way you envisage.  To counter that, bring proof, in the form of running code.

Gert Doering
        -- NetMaster

---

From: [email-masked]
Date: Mon, 28 Sep 2020 14:12:35 +0200

Gert,

> envisage.  To counter that, bring proof, in the form of running code.

I think it needs a little more than that.
In my opinion it needs to show how it can be incrementally deployable.
And easier incrementally deployable than just deploying IPv6.

Cheers,
Ole

---

From: Gert Doering <[email-masked]>
Date: Mon, 28 Sep 2020 14:15:18 +0200

Hi,

> As I mentioned, it is the duty of technology companies, I should be waiting that they write the code on their OS and make the experiment and I will follow their decision.

Yes, you said that.  But it does not work that way.

If you want to prove that your ideas work, and are worth investing money
in, this is yours to do.

Gert Doering
        -- NetMaster

---

From: Khaled Omar <[email-masked]>
Date: Mon, 28 Sep 2020 12:15:52 +0000

Yes Ole, it is not just a matter of saying "it's not going to work", you have to read the draft till the end and guarantee that your comments are adding a value for all.

Khaled Omar

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Monday, September 28, 2020 2:13 PM
To: Gert Doering <[email-masked]>
Cc: Khaled Omar <[email-masked]>; IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: Re: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft

Gert,

Cheers,
Ole

---

From: Khaled Omar <[email-masked]>
Date: Mon, 28 Sep 2020 12:57:46 +0000

OMG, there is no translation, those are two different addresses from two different versions, 4 and 6.

The first 128 bit contains IPv4 address and because the new packet header contains 128-bit address, I added the MAC address and stream zeros.

This is in an older version of the draft, the last version explains using extension headers to the same v4 and v6 packet headers.

Khaled Omar

-----Original Message-----
From: Vasilenko Eduard <[email-masked]> 
Sent: Monday, September 28, 2020 2:52 PM
To: Khaled Omar <[email-masked]>
Cc: IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: RE: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft

And you believe that if you would reinvent Stateless IPv6-IPv4 translation, Then this translation would be adopted faster...

About your comment that I was looking to different draft. You have 3 drafts overall.
I am looking to https://tools.ietf.org/html/draft-omar-ipv10-12
Where 1/3 of the document is discussion how to properly put IPv6 inside IPv4:
   | V4  |            128-bit              |           128-bit           |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | Data| Source IPv4 Address MAC 000..0  |  Destination IPv6 Address   |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Yes, I know that you did rename IPv6 to IPv10, hence IPv6 mapping is easy.

Ed/
> Sent: 28 сентября 2020 г. 14:33
> Not right, IPv6 took so "long" time so devices can migrate to, upper 
> thing, IPv10 uses both types of communication, so it solves everything 
> from the roots, if you will follow the draft step by step, you will 
> find out that even with DNS it works fine.
> 
> Khaled Omar
> 
> > > Eduard, There are no any kind of translation used, it is just 
> > > mixing the two version in the same header, one as a source the 
> > > other as a
> > destination.
> > >
> > > >> Your solution already exist. It is RFC 6144 - April 2011. 
> > > >> Please, read this
> RFC.
> > > It has a bit more details then yours.
> > >
> > > >> And what you propose to do in the next 20 years when part of 
> > > >> host would
> > > Good question, all the devices has to step by step be updated, 
> > > then we can switch on a flag day to IPv10, so this will give time 
> > > to developers to first write the code, then apply the code gradually on all OSs.
> > >
> > > Just nobody before you was so brave to propose stateless 
> > > translation directly from every host in the world. Everybody else 
> > > was thinking about some gateways to keep the majority of hosts intact.
> > > out of IPv4 (nobody see money to do the job) - but it is the 
> > > second problem that you would not face because of previous problem.
> > >
> > > with stateless translation, because long transition needs IPv4 per 
> > > every host, but IPv4 is in shortage.
> > > If you trying to attack translation topic - you need to read all 
> > > of these
> > carefully.
> > >
> > > Eduard