Subject: [Int-area] Suggestion to move draft-olteanu-intarea-socks as Independent Submissions

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 15 Jan 2021 13:55:08 +0000

Vladimir, Dragos,

While there was some interest in adopting the SOCKv6 document as an INT-AREA WG document, the lukewarm interest and lack of reviewer volunteers [1] are preventing the actual adoption of this document as a WG document (my AD decision in agreement with the chairs). After discussions with the IESG and our chairs (Juan Carlos and Wassim in cc), I want to propose to the authors an easier way to publish this document as an RFC but in the Independent Submissions (ISE) stream rather than in the usual IETF stream.

The simple process is outlined at https://www.rfc-editor.org/about/independent/ and “ISE” is described in RFC 4846.

This should allow this document to move forward and be published as a RFC.

Hope this helps

-éric (with JC & Wassim)

[1] I tried to contact the previous AFT WG proponents, SOCKS authors, and some open source SOCKS implementors without any reply on this topic.

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 15 Jan 2021 09:42:52 -0600

Hi Eric,

I am sure you know, all independent Submission documents can only be
published as Informational.
I did not check what status the authors wish to have but it is good to
mention here.

Regards,
Behcet

On Fri, Jan 15, 2021 at 7:55 AM Eric Vyncke (evyncke) <evyncke=
[email-masked]> wrote:

> Vladimir, Dragos,
>
>
>
> While there was some interest in adopting the SOCKv6 document as an
> INT-AREA WG document, the lukewarm interest and lack of reviewer volunteers
> [1] are preventing the actual adoption of this document as a WG document
> (my AD decision in agreement with the chairs). After discussions with the
> IESG and our chairs (Juan Carlos and Wassim in cc), I want to propose to
> the authors an easier way to publish this document as an RFC but in the
> Independent Submissions (ISE) stream rather than in the usual IETF stream.
>
>
>
> The simple process is outlined at
> https://www.rfc-editor.org/about/independent/ and “ISE” is described in
> RFC 4846.
>
>
>
> [1] I tried to contact the previous AFT WG proponents, SOCKS authors, and
> some open source SOCKS implementors without any reply on this topic.
>
>
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 15 Jan 2021 15:52:02 +0000

Indeed, but as the current intended status is experimental ;-) it should not be a problem

-éric

From: Behcet Sarikaya <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Friday, 15 January 2021 at 16:43
To: Eric Vyncke <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Int-area] Suggestion to move draft-olteanu-intarea-socks as Independent Submissions

Hi Eric,

I am sure you know, all independent Submission documents can only be published as Informational.
I did not check what status the authors wish to have but it is good to mention here.

Regards,
Behcet

On Fri, Jan 15, 2021 at 7:55 AM Eric Vyncke (evyncke) <evyncke=[email-masked]<mailto:[email-masked]>> wrote:
Vladimir, Dragos,

Hope this helps

-éric (with JC & Wassim)

_______________________________________________
Int-area mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/int-area

---

From: Vladimir Olteanu <[email-masked]>
Date: Fri, 15 Jan 2021 18:08:47 +0200

Hello,

Yes, I agree that ISE is the sensible path to take.

The intended status was changed from Experimental to Standards Track in 
-11, but Informational is fine for the moment. When/if SOCKSv6 gains 
traction, we can issue a bis and change the intended status.

Thanks,

Vlad

On 1/15/21 5:52 PM, Eric Vyncke (evyncke) wrote:
> *From: *Behcet Sarikaya <[email-masked]>
> *Reply-To: *"[email-masked]" <[email-masked]>
> *Date: *Friday, 15 January 2021 at 16:43
> *To: *Eric Vyncke <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>, 
> "[email-masked]" <[email-masked]>, 
> "[email-masked]" <[email-masked]>
> *Subject: *Re: [Int-area] Suggestion to move 
> draft-olteanu-intarea-socks as Independent Submissions
>
> Hi Eric,
>
> On Fri, Jan 15, 2021 at 7:55 AM Eric Vyncke (evyncke) 
> <evyncke=[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Vladimir, Dragos,
>
>     While there was some interest in adopting the SOCKv6 document as
>     an INT-AREA WG document, the lukewarm interest and lack of
>     reviewer volunteers [1] are preventing the actual adoption of this
>     document as a WG document (my AD decision in agreement with the
>     chairs). After discussions with the IESG and our chairs (Juan
>     Carlos and Wassim in cc), I want to propose to the authors an
>     easier way to publish this document as an RFC but in the
>     https://www.rfc-editor.org/about/independent/
>     <https://secure-web.cisco.com/1VwxfkUlqi_v4NnCaNQ5FzVjfQE2GUrSvMLOxcSe6Y0M0xMMmMxe7ne-103fsoi52WuYjgzRpy_bw_cky7un2UPCEXhP84Ml0TWgCLUgoaLlDnT4nXtp9dR1xOi3hY6hRiWB52oHxmN79vKZJfF0f-HuUrN_g_sJb5h862O4eySFHPxckCXQEiz3LZBY7UfJW6Cph5sd6rIoHFW8FCYIHeNzCaU5gGvMCvkwoqEazcoFWSpPl5IrZkEy66aUabVqVM80g9Qeq1bOiaS8RVRPApCzxRoj-Cf3bSCz2VMAzEBs/https%3A%2F%2Fwww.rfc-editor.org%2Fabout%2Findependent%2F>
>     and “ISE” is described in RFC 4846.
>
>     [1] I tried to contact the previous AFT WG proponents, SOCKS
>     authors, and some open source SOCKS implementors without any reply
>     on this topic.
>
>     [email-masked] <mailto:[email-masked]>
>     <https://secure-web.cisco.com/1KB2NleJna66sVXsBDPV9nLQtvvS28j0c8kNZIsOvATOEJLXZsmjyrjSI_NkC6TAIIwhpdbUYJsH72kqcaczlHMkLF-lQXAPKQrrHjoC-Ioxca4cChkf69I41fycQP1Z2SXB6mDCHsZM1qNWLh-eYJdQZE2xEJtDfrF2Za447DuD85VMBbAkYH6zZA6eQaQZB0WlSmePeJi_jxkMLt0jFH_7hAszbaGiRVXAvmD1xdkH5J7U9cuWOBFAxXCBSqev-bfhZvqU7nbqTMPJiTWPY8-mx1et1rXQzLKpxrFy3dis/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fint-area>
>

---

From: Joseph Touch <[email-masked]>
Date: Fri, 15 Jan 2021 08:13:17 -0800

> On Jan 15, 2021, at 7:42 AM, Behcet Sarikaya <[email-masked]> wrote:
> 
> Hi Eric,
> 

They can also be experimental.

Joe

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 15 Jan 2021 18:38:09 -0000

Just to re-assert that the Independent Submissions Stream can publish Informational and Experimental RFCs.

I am usually saddened when a piece of work that is clearly relevant for the IETF is unable to get enough traction to be published through the IETF: adoption by a working group is not the only avenue to publication within the IETF. However, one of the reasons for the existence of the Independent Submissions Stream is to provide a way to publish relevant material as an RFC when the IETF is unable or unwilling to do so.

Best,

Adrian

From: Int-area <[email-masked]> On Behalf Of Eric Vyncke (evyncke)
Sent: 15 January 2021 15:52
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Int-area] Suggestion to move draft-olteanu-intarea-socks as Independent Submissions

-éric

From: Behcet Sarikaya <[email-masked] <mailto:[email-masked]> >
Reply-To: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Date: Friday, 15 January 2021 at 16:43
To: Eric Vyncke <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >, "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >, "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Subject: Re: [Int-area] Suggestion to move draft-olteanu-intarea-socks as Independent Submissions

Hi Eric,

Regards,

Behcet

On Fri, Jan 15, 2021 at 7:55 AM Eric Vyncke (evyncke) <evyncke=[email-masked] <mailto:[email-masked]> > wrote:

Vladimir, Dragos,

Hope this helps

-éric (with JC & Wassim)

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sat, 16 Jan 2021 14:24:26 +0000

Adrian,

I share your mood… The lukewarm call for adoption was both disappointing and a signal to use another path.

-éric

From: Adrian Farrel <[email-masked]>
Organization: Old Dog Consulting
Reply-To: "[email-masked]" <[email-masked]>
Date: Friday, 15 January 2021 at 19:38
To: Eric Vyncke <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Int-area] Suggestion to move draft-olteanu-intarea-socks as Independent Submissions

Best,
Adrian

-éric

From: Behcet Sarikaya <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Friday, 15 January 2021 at 16:43
To: Eric Vyncke <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Int-area] Suggestion to move draft-olteanu-intarea-socks as Independent Submissions

Hi Eric,

Regards,
Behcet

Hope this helps

-éric (with JC & Wassim)

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 18 Jan 2021 09:49:30 -0600

On Sat, Jan 16, 2021 at 8:24 AM Eric Vyncke (evyncke) <[email-masked]>
wrote:

> *From: *Adrian Farrel <[email-masked]>
> *Organization: *Old Dog Consulting
> *Reply-To: *"[email-masked]" <[email-masked]>
> *Date: *Friday, 15 January 2021 at 19:38
> *To: *Eric Vyncke <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>, "[email-masked]"
> <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *RE: [Int-area] Suggestion to move draft-olteanu-intarea-socks
> as Independent Submissions
>
>
>

Thanks for the correction, I thought Informational RFC was the only
possibility, as I have already used  it that way in the past.

Behcet

> I am usually saddened when a piece of work that is clearly relevant for
> the IETF is unable to get enough traction to be published through the IETF:
> adoption by a working group is not the only avenue to publication within
> the IETF. However, one of the reasons for the existence of the Independent
> Submissions Stream is to provide a way to publish relevant material as an
> RFC when the IETF is unable or unwilling to do so.
>
>
>
> Best,
>
> Adrian
>
>
>
> *From:* Int-area <[email-masked]> *On Behalf Of *Eric Vyncke
> (evyncke)
> *Sent:* 15 January 2021 15:52
> *To:* [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [Int-area] Suggestion to move draft-olteanu-intarea-socks
> as Independent Submissions
>
>
>
> *Cc: *"[email-masked]" <[email-masked]>, "[email-masked]"
> <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: [Int-area] Suggestion to move draft-olteanu-intarea-socks
> as Independent Submissions
>
>
>
> Hi Eric,
>
>
>