Subject: [Int-area] FW: [Apn] A new draft on APN for your review, thank you!

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Fri, 22 Jan 2021 02:08:12 +0000

Dear authors,

We have updated the APN BoF Proposal as attached. The suggestions in your draft and the discussions with you offline inspired us a lot. The support of the user/app group is explicitly shown in the text although it was implicitly included. We have made a lot of efforts on clarifying the scope of the work, introducing the basic solution, and describing the concrete use case. Please advise whether we are clear now and how we can improve further, especially on the privacy concerns. Thank you!

This posted draft, https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis, would be able to give you more complete information. Please also refer to the recent discussions in the archives https://mailarchive.ietf.org/arch/browse/apn/ if you have not subscribed the APN mailing list yet. Based on discussions and suggestions we received, we will update this draft accordingly. Your reviews and comments will be very much appreciated.

Thank you!

Best regards,
Shuping

From: Apn [mailto:[email-masked]] On Behalf Of Pengshuping (Peng Shuping)
Sent: Tuesday, December 15, 2020 11:12 AM
To: [email-masked]; [email-masked]
Subject: [Apn] A new draft on APN for your review, thank you!

Dear all,

A new draft on APN has been posted, https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis.

In this draft, we clarified the scope of the APN work in IETF, introduced an example use case and the basic solution. Moreover, we compared with the existing "similar" work/solutions and did corresponding gap analysis.

Your review and comments are very much appreciated. Thank you!

Best regards,

Shuping

A new version of I-D, draft-peng-apn-scope-gap-analysis-00.txt

has been successfully submitted by Shuping Peng and posted to the IETF repository.

Name:              draft-peng-apn-scope-gap-analysis

Revision: 00

Title:                 APN Scope and Gap Analysis

Document date:      2020-12-16

Group:              Individual Submission

Pages:              11

URL:            https://www.ietf.org/archive/id/draft-peng-apn-scope-gap-analysis-00.txt

Status:         https://datatracker.ietf.org/doc/draft-peng-apn-scope-gap-analysis/

Htmlized:       https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis

Htmlized:       https://tools.ietf.org/html/draft-peng-apn-scope-gap-analysis-00

Abstract:

   The APN work in IETF is focused on developing a framework and set of

   mechanisms to derive, convey and use an identifier to allow for

   implementing fine-grain user-, application-, and service-level

   requirements at the network layer.  This document describes the scope

   of the APN work and the solution gap analysis.

---

From: tom petch <[email-masked]>
Date: Sat, 23 Jan 2021 12:09:26 +0000

From: Int-area <[email-masked]> on behalf of Pengshuping (Peng Shuping) <[email-masked]>
Sent: 22 January 2021 02:08

Dear authors,

We have updated the APN BoF Proposal as attached. The suggestions in your draft and the 

<tp>

Whatever APN may stand for!  I looked at the I-D and the Abstract uses APN with no explanation of what it is:-(  It needs expanding on first use and while I could read on and perhaps find an explanation yet the idea is that the Abstract tells readers whether or not this is of interest to them and this Abstract does not.  The rest of the I-D may be clearer but I am not gong to spend time finding out:-)

Tom Petch

discussions with you offline inspired us a lot. The support of the user/app group is explicitly shown in the text although it was implicitly included. We have made a lot of efforts on clarifying the scope of the work, introducing the basic solution, and describing the concrete use case. Please advise whether we are clear now and how we can improve further, especially on the privacy concerns. Thank you!

Thank you!

Best regards,
Shuping

Dear all,

In this draft, we clarified the scope of the APN work in IETF, introduced an example use case and the basic solution. Moreover, we compared with the existing “similar” work/solutions and did corresponding gap analysis.

Best regards,

Shuping

Revision: 00

Pages:              11

Abstract:

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Sun, 24 Jan 2021 07:50:22 +0000

Dear Tom,

Thank you for your interest! 

First of all, APN stands for Application-aware Networking

I had attached a APN BoF proposal document in my last email but probably it was too big to be delivered successfully. The APN6 was also introduced in this draft in the intarea WG (https://tools.ietf.org/html/draft-per-app-networking-considerations). Sorry for any confusions caused. 

Please find the APN BoF proposal in the IETF wiki for more information. 
https://trac.tools.ietf.org/bof/trac/wiki/WikiStart

The archived discussions in this APN mailing list can be found here. 
https://mailarchive.ietf.org/arch/browse/apn/

To subscribe the APN Mailing list,
https://www.ietf.org/mailman/listinfo/apn

Here are some relevant drafts and materials for your reference. 

*	Scope & Gap analysis
https://tools.ietf.org/html/draft-peng-apn-scope-gap-analysis
*	Problem statement & Use cases
https://tools.ietf.org/html/draft-li-apn-problem-statement-usecases
https://tools.ietf.org/html/draft-liu-apn-edge-usecase
https://tools.ietf.org/html/draft-zhang-apn-acceleration-usecase
https://tools.ietf.org/html/draft-yang-apn-sd-wan-usecase
*	Framework
https://datatracker.ietf.org/doc/draft-li-apn-framework/
*	Security & Privacy
https://datatracker.ietf.org/doc/draft-peng-apn-security-privacy-consideration
*	APN Community
https://github.com/APN-Community
*	Per-Application Networking Considerations
https://tools.ietf.org/html/draft-per-app-networking-considerations

Thank you! 

Best regards, 
Shuping

> -----Original Message-----
> From: tom petch [mailto:[email-masked]]
> Sent: Saturday, January 23, 2021 8:09 PM
> To: Pengshuping (Peng Shuping) <[email-masked]>;
> draft-per-app-networking-considerations
> <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Apn] A new draft on APN for your review, thank you!
> 
> Whatever APN may stand for!  I looked at the I-D and the Abstract uses
> APN with no explanation of what it is:-(  It needs expanding on first use and
> while I could read on and perhaps find an explanation yet the idea is that the
> Abstract tells readers whether or not this is of interest to them and this
> Abstract does not.  The rest of the I-D may be clearer but I am not gong to
> spend time finding out:-)
> 
> Tom Petch
> 
> discussions with you offline inspired us a lot. The support of the user/app
> group is explicitly shown in the text although it was implicitly included. We
> have made a lot of efforts on clarifying the scope of the work, introducing
> the basic solution, and describing the concrete use case. Please advise
> whether we are clear now and how we can improve further, especially on
> the privacy concerns. Thank you!
> 
> This posted draft,
> https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis,
> would be able to give you more complete information. Please also refer to
> the recent discussions in the archives
> https://mailarchive.ietf.org/arch/browse/apn/ if you have not subscribed
> the APN mailing list yet. Based on discussions and suggestions we received,
> we will update this draft accordingly. Your reviews and comments will be
> very much appreciated.
> 
> Thank you!
> 
> Best regards,
> Shuping
> 
> 
> 
> A new draft on APN has been posted,
> https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis.
> 
> 
> 
> In this draft, we clarified the scope of the APN work in IETF, introduced an
> example use case and the basic solution. Moreover, we compared with the
> existing "similar" work/solutions and did corresponding gap analysis.
> 
> 
> 
> URL:
> https://www.ietf.org/archive/id/draft-peng-apn-scope-gap-analysis-00.txt
> 
> Status:
> https://datatracker.ietf.org/doc/draft-peng-apn-scope-gap-analysis/
> 
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis
> 
> Htmlized:
> https://tools.ietf.org/html/draft-peng-apn-scope-gap-analysis-00
> 
> 
> 
> 
> 
> Abstract:
>

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 25 Jan 2021 18:29:00 +0000

Shuping, 

Some comments to the draft-peng-apn-scope-gap-analysis-00:

I find Page 4 last sentence really hit the key purpose of APN: at the headend to steer into corresponding path, at the midpoint to collect corresponding performance measurement data, and at the service function to execute particular policies.
But all the labels and IDs described in Section 6 are for homogeneous network, APN ID is supposed to achieve the above purposes through different nodes. 

Is my understanding correct?  If yes, I recommend to write those key points in the Abstract and Introduction to make it more clear to people. 

The document stated in several places that APN Identifier is a Structured value. What structure is the APN ID?  Can the APN ID be mapped into  the labels described in Section 6? i.e. the SFC Service ID, Binding SID, FlowSpec Label, etc? 

Some minor comments:
Section 6.1:  IPv6 flow label is manipulated by application themselves. Network can not make changes to them, nor can network know the meaning of the flow labels inserted by the Applications (unless the Application controller has signals to the network controllers)

Linda

-----Original Message-----
From: Apn <[email-masked]> On Behalf Of Pengshuping (Peng Shuping)
Sent: Sunday, January 24, 2021 1:50 AM
To: tom petch <[email-masked]>; draft-per-app-networking-considerations <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Apn] A new draft on APN for your review, thank you!

Dear Tom,

I had attached a APN BoF proposal document in my last email but probably it was too big to be delivered successfully. The APN6 was also introduced in this draft in the intarea WG (https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-per-app-networking-considerations&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463026426%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=APYvMROCre177UK3puGuTPHB%2FfoyGTWWXFedDS6ZNHw%3D&amp;reserved=0). Sorry for any confusions caused. 

Please find the APN BoF proposal in the IETF wiki for more information. 
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.tools.ietf.org%2Fbof%2Ftrac%2Fwiki%2FWikiStart&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463026426%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=MqJnzeO5AJDOaZrouSSgE%2B0qpNOOcnuQ7f7Fw8rUnK0%3D&amp;reserved=0

The archived discussions in this APN mailing list can be found here. 
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fbrowse%2Fapn%2F&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463026426%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Y2GZzG%2FvD%2Fx3R79BB9ub%2BWe94PU9W6HetLSa%2BnbhKLk%3D&amp;reserved=0

To subscribe the APN Mailing list,
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fapn&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463026426%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=bJq8Gq9GLTuf3u9yxOH2AXTCWEOiTkQksuHuZ6RljgE%3D&amp;reserved=0

*	Scope & Gap analysis
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463026426%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=yOGg7DMeeocdWA%2FGV3xQyVnwpjwzcgMg113ZyvlbjZ4%3D&amp;reserved=0
*	Problem statement & Use cases
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-li-apn-problem-statement-usecases&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463026426%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=F0V7aEgDM66QDuuj7WpVcbbQCUPpboODOG7YWAUIAqI%3D&amp;reserved=0
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-liu-apn-edge-usecase&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=yyUVM4FRoXdcUrHqBDapxv4kWg9tVU1PVkQrPMcwsS4%3D&amp;reserved=0
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-zhang-apn-acceleration-usecase&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=boJWFr0HyVGOXbaEHWuxL1bGNzQZOcxtf1U8SSuqyus%3D&amp;reserved=0
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-yang-apn-sd-wan-usecase&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=%2FBjFyaRwiGHeFSYU35iGzWchFa62d9dDYoKjNMAz1VE%3D&amp;reserved=0
*	Framework
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-li-apn-framework%2F&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Ce%2FXfkJ8ha0%2BQOv8DT026VMXG08rqLKpLSxCH1KROBo%3D&amp;reserved=0
*	Security & Privacy
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-peng-apn-security-privacy-consideration&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=ykF6YreMnI7IzBn%2F1kxyRd9bvJybLd9DQj5GYcd5sl8%3D&amp;reserved=0
*	APN Community
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2FAPN-Community&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=JEJ%2FSzHnQ9VOQwndMgtFCovpYIZ08GYYL8ZkM9rA%2Bto%3D&amp;reserved=0
*	Per-Application Networking Considerations
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-per-app-networking-considerations&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=DdibzIJhpoDJpMKuI9VMn%2FtCnOqaEnqo%2BmTkv1wReOg%3D&amp;reserved=0

Thank you! 

Best regards,
Shuping

> From: Int-area <[email-masked]> on behalf of Pengshuping 
> (Peng
> Shuping) <[email-masked]>
> APN with no explanation of what it is:-(  It needs expanding on first 
> use and while I could read on and perhaps find an explanation yet the 
> idea is that the Abstract tells readers whether or not this is of 
> interest to them and this Abstract does not.  The rest of the I-D may 
> be clearer but I am not gong to spend time finding out:-)
> 
> Tom Petch
> 
> discussions with you offline inspired us a lot. The support of the 
> user/app group is explicitly shown in the text although it was 
> implicitly included. We have made a lot of efforts on clarifying the 
> scope of the work, introducing the basic solution, and describing the 
> concrete use case. Please advise whether we are clear now and how we 
> can improve further, especially on the privacy concerns. Thank you!
> 
> This posted draft,
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdata
> tracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&amp;
> data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8
> c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C6374707144630364
> 22%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI
> 6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=snNr80f38d4QiUx1UtvKMwAXm5GHQ
> 4IgoiJDwU0Wo5Y%3D&amp;reserved=0, would be able to give you more 
> complete information. Please also refer to the recent discussions in 
> the archives
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmail
> archive.ietf.org%2Farch%2Fbrowse%2Fapn%2F&amp;data=04%7C01%7Clinda.dun
> bar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b24
> 0189c753a1d5591fedc%7C1%7C0%7C637470714463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=OujoFq5BkZzTJcNAvjj8zHJf2xt7BiAd0pq24%2FU4%2FLE%3D&amp;reserved=0 if you have not subscribed the APN mailing list yet. Based on discussions and suggestions we received, we will update this draft accordingly. Your reviews and comments will be very much appreciated.
> 
> Thank you!
> 
> Best regards,
> Shuping
> 
> 
> 
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=snNr80f38d4QiUx1UtvKMwAXm5GHQ4IgoiJDwU0Wo5Y%3D&amp;reserved=0.
> 
> 
> 
> In this draft, we clarified the scope of the APN work in IETF, 
> introduced an example use case and the basic solution. Moreover, we 
> compared with the existing "similar" work/solutions and did corresponding gap analysis.
> 
> 
> 
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> ietf.org%2Farchive%2Fid%2Fdraft-peng-apn-scope-gap-analysis-00.txt&amp
> ;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d
> 8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463036
> 422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTi
> I6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=7mqepW8aF1FkP9Yf4uldFoEooDoa
> k%2BmmNLzEZlMj2RY%3D&amp;reserved=0
> 
> Status:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdata
> tracker.ietf.org%2Fdoc%2Fdraft-peng-apn-scope-gap-analysis%2F&amp;data
> =04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03c
> bfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463036422%7
> CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1
> haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=KVYBICPA%2FgvgBtn6vv3VaaypRavG8V%
> 2F2ZoSJfULGGLQ%3D&amp;reserved=0
> 
> Htmlized:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdata
> tracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&amp;
> data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8
> c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C6374707144630464
> 21%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI
> 6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=vUrvPtT9Oj3yHtleUAeljP1JeQ3Hr
> uTVz2hktBxulJk%3D&amp;reserved=0
> 
> Htmlized:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftool
> s.ietf.org%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis-00&amp;data=04%7
> C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%
> 7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463046421%7CUnkn
> own%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwi
> LCJXVCI6Mn0%3D%7C3000&amp;sdata=NLKsZz6esqGO6eUhLqp2hUoMstG1wds60HNYtj
> Gvi90%3D&amp;reserved=0
> 
> 
> 
> 
> 
> Abstract:
> 

--
Apn mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fapn&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463046421%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=he1%2F62XzA9JgoJd%2BKD%2FKZzGmksmKXNG4e03FeuYK8m0%3D&amp;reserved=0

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Tue, 26 Jan 2021 04:13:20 +0000

Dear Linda, 

Your suggestions are very good. I have updated the draft and uploaded it to the APN Github. Please feel free to make any further changes. Thank you!

https://github.com/APN-Community/APN-Scope-Gap-Analysis

Please find some more comments in line below. 

> From: Linda Dunbar [mailto:[email-masked]]
> Sent: Tuesday, January 26, 2021 2:29 AM
> To: Pengshuping (Peng Shuping) <[email-masked]>; tom petch
> <[email-masked]>; draft-per-app-networking-considerations
> Subject: RE: [Apn] A new draft on APN for your review, thank you!
> 
> Shuping,
> 
> I find Page 4 last sentence really hit the key purpose of APN: at the headend
> to steer into corresponding path, at the midpoint to collect corresponding
> performance measurement data, and at the service function to execute
> particular policies.
> But all the labels and IDs described in Section 6 are for homogeneous
> network, APN ID is supposed to achieve the above purposes through
> different nodes.
> 
> Is my understanding correct?  If yes, I recommend to write those key points
> in the Abstract and Introduction to make it more clear to people.
> 

Yes, it is correct. Your suggestions are great. I have explicitly put these information in the Abstract and Introduction. Please make further changes wherever needed. Thank you!

> The document stated in several places that APN Identifier is a Structured
> value. What structure is the APN ID?  Can the APN ID be mapped into  the
> labels described in Section 6? i.e. the SFC Service ID, Binding SID, FlowSpec
> Label, etc?

The APN ID structure design proposal and its encapsulation in IPv6 data plane are introduced in https://tools.ietf.org/html/draft-li-6man-app-aware-ipv6-network-02. More description is added in the updated version of the draft. The APN ID can be used to serve the functional purpose of all these labels.

> 
> Some minor comments:
> Section 6.1:  IPv6 flow label is manipulated by application themselves.
> Network can not make changes to them, nor can network know the meaning
> of the flow labels inserted by the Applications (unless the Application
> controller has signals to the network controllers)
> 

Yes, it is right. Just as far as I know, when the packets go into a tunnel, e.g. SRv6, generally the IPv6 flow label will be recalculated and encapsulated.

Best regards, 
Shuping

> To: tom petch <[email-masked]>;
> I had attached a APN BoF proposal document in my last email but probably it
> was too big to be delivered successfully. The APN6 was also introduced in
> this draft in the intarea WG
> (https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftoo
> ls.ietf.org%2Fhtml%2Fdraft-per-app-networking-considerations&amp;data=
> 04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d
> 8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C6374707
> 14463026426%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJ
> QIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=APY
> vMROCre177UK3puGuTPHB%2FfoyGTWWXFedDS6ZNHw%3D&amp;reserve
> d=0). Sorry for any confusions caused.
> 
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.
> tools.ietf.org%2Fbof%2Ftrac%2Fwiki%2FWikiStart&amp;data=04%7C01%7Cl
> inda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7
> C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463026426
> %7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiL
> CJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=MqJnzeO5AJDOaZ
> rouSSgE%2B0qpNOOcnuQ7f7Fw8rUnK0%3D&amp;reserved=0
> 
> archive.ietf.org%2Farch%2Fbrowse%2Fapn%2F&amp;data=04%7C01%7Clin
> da.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0
> fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463026426%
> 7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLC
> JBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Y2GZzG%2FvD%2Fx
> 3R79BB9ub%2BWe94PU9W6HetLSa%2BnbhKLk%3D&amp;reserved=0
> 
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fww
> w.ietf.org%2Fmailman%2Flistinfo%2Fapn&amp;data=04%7C01%7Clinda.dun
> bar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff
> 2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463026426%7CUnk
> nown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6I
> k1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=bJq8Gq9GLTuf3u9yxOH2A
> XTCWEOiTkQksuHuZ6RljgE%3D&amp;reserved=0
> 
> s.ietf.org%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&amp;data=04%7C
> 01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03c
> bfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463
> 026426%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV
> 2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=yOGg7DM
> eeocdWA%2FGV3xQyVnwpjwzcgMg113ZyvlbjZ4%3D&amp;reserved=0
> s.ietf.org%2Fhtml%2Fdraft-li-apn-problem-statement-usecases&amp;data=0
> 4%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8
> c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C63747071
> 4463026426%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQ
> IjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=F0V7
> aEgDM66QDuuj7WpVcbbQCUPpboODOG7YWAUIAqI%3D&amp;reserved=0
> s.ietf.org%2Fhtml%2Fdraft-liu-apn-edge-usecase&amp;data=04%7C01%7Cli
> nda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C
> 0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463036422
> %7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiL
> CJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=yyUVM4FRoXdcUr
> HqBDapxv4kWg9tVU1PVkQrPMcwsS4%3D&amp;reserved=0
> s.ietf.org%2Fhtml%2Fdraft-zhang-apn-acceleration-usecase&amp;data=04%
> 7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c0
> 3cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C6374707144
> 63036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjo
> iV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=boJWFr
> 0HyVGOXbaEHWuxL1bGNzQZOcxtf1U8SSuqyus%3D&amp;reserved=0
> s.ietf.org%2Fhtml%2Fdraft-yang-apn-sd-wan-usecase&amp;data=04%7C01
> %7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa
> 5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C63747071446303
> 6422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2lu
> MzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=%2FBjFyaRwi
> GHeFSYU35iGzWchFa62d9dDYoKjNMAz1VE%3D&amp;reserved=0
> *	Framework
> tracker.ietf.org%2Fdoc%2Fdraft-li-apn-framework%2F&amp;data=04%7C01
> %7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa
> 5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C63747071446303
> 6422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2lu
> MzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Ce%2FXfkJ8h
> a0%2BQOv8DT026VMXG08rqLKpLSxCH1KROBo%3D&amp;reserved=0
> *	Security & Privacy
> tracker.ietf.org%2Fdoc%2Fdraft-peng-apn-security-privacy-consideration&a
> mp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42f
> e274b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7
> C637470714463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjA
> wMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;
> sdata=ykF6YreMnI7IzBn%2F1kxyRd9bvJybLd9DQj5GYcd5sl8%3D&amp;reserv
> ed=0
> *	APN Community
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgith
> ub.com%2FAPN-Community&amp;data=04%7C01%7Clinda.dunbar%40futur
> ewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff2a3b240189
> c753a1d5591fedc%7C1%7C0%7C637470714463036422%7CUnknown%7CT
> WFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiL
> CJXVCI6Mn0%3D%7C3000&amp;sdata=JEJ%2FSzHnQ9VOQwndMgtFCovpYIZ
> 08GYYL8ZkM9rA%2Bto%3D&amp;reserved=0
> s.ietf.org%2Fhtml%2Fdraft-per-app-networking-considerations&amp;data=0
> 4%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe274b08d8
> c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C63747071
> 4463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQ
> IjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Ddibz
> IJhpoDJpMKuI9VMn%2FtCnOqaEnqo%2BmTkv1wReOg%3D&amp;reserved=
> 0
> 
> Thank you!
> 
> Best regards,
> Shuping
> 
> 0189c753a1d5591fedc%7C1%7C0%7C637470714463036422%7CUnknown%
> 7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haW
> wiLCJXVCI6Mn0%3D%7C3000&amp;sdata=OujoFq5BkZzTJcNAvjj8zHJf2xt7Bi
> Ad0pq24%2FU4%2FLE%3D&amp;reserved=0 if you have not subscribed the
> APN mailing list yet. Based on discussions and suggestions we received, we
> will update this draft accordingly. Your reviews and comments will be very
> much appreciated.
> >
> > Thank you!
> >
> > Best regards,
> > Shuping
> >
> >
> >
> tracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&amp
> ;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8aa274f07f8a42fe2
> 74b08d8c03cbfa5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C6
> 37470714463036422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwM
> DAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sda
> ta=snNr80f38d4QiUx1UtvKMwAXm5GHQ4IgoiJDwU0Wo5Y%3D&amp;reserv
> ed=0.
> >
> >
> >
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fww
> w.ietf.org%2Fmailman%2Flistinfo%2Fapn&amp;data=04%7C01%7Clinda.dun
> bar%40futurewei.com%7C8aa274f07f8a42fe274b08d8c03cbfa5%7C0fee8ff
> 2a3b240189c753a1d5591fedc%7C1%7C0%7C637470714463046421%7CUnk
> nown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6I
> k1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=he1%2F62XzA9JgoJd%2BK
> D%2FKZzGmksmKXNG4e03FeuYK8m0%3D&amp;reserved=0