Subject: Re: [Int-area] Suggestion to move draft-olteanu-intarea-socks as Independent Submissions

From: Toerless Eckert <[email-masked]>
Date: Mon, 1 Mar 2021 16:18:14 +0100

On Fri, Jan 15, 2021 at 06:38:09PM -0000, Adrian Farrel wrote:
> Just to re-assert that the Independent Submissions Stream can publish Informational and Experimental RFCs.

Just if its approriate to ask on a list where i could probably wade through rfcs to find
the answer: Whats the relevance/differentiation of "experimental" for independent stream ?

Other than that: 

- Is there anywhere information about the available SOCK implementations sufficiently
  detailed to understand their ability and use-case benefits to interoperate (between
  client SDK/shim-library and server ?

- For those existing or planned future implementations, is it possible to collect insight
  into how eager the implementers would be to adopt the draft proposed functionality ?

- For any implementer/implementations showing interest in adoption, where their names collected ?

If this did all happen in some discussions on int-area, i would still prefer to see this
salient information collected in a document. Even if it might not be this draft, but an -ops
draft, but especially when this goes ISE, it should be much less a problem to have
actual dadoption relevant information in a doc as opposed to jus the bare protocol details.

Even if his is built on the push model of "standardize it and they (implementers) will come",
it would (at last for me) still be highly useful to see a list of implementations, and whether
or not the authors of this document reached out to the implemenations to query about the
interest in this 'extension/version'.

Cheers
    Toerless

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 1 Mar 2021 15:47:38 -0000

Hi Toerless,

>> Just to re-assert that the Independent Submissions Stream can publish
Informational
>> and Experimental RFCs.
> the answer: Whats the relevance/differentiation of "experimental" for
independent
> stream ?

That's a question for the ISE, I think.
The answer is that the definition of the RFC categories is immutable across
the various RFC streams.
The difference is that "Informational" provides information, while
"Experimental" describes an on-going experiment (not usually an experiment
that has already completed).
The Independent Stream can only publish Informational, Experimental, and
Historic RFCs.

> Other than that: 

I leave the other questions to the discussion among the authors, but you
might find RFC 7942 useful and note that it recommends removing reports of
implementation status from RFCs before publication because the information
rarely retains currency (wiki pages, OTOH, can be helpful).

Cheers,
Adrian

>- For any implementer/implementations showing interest in adoption, where
their
> names collected ?

---

From: 'Toerless Eckert' <[email-masked]>
Date: Mon, 1 Mar 2021 17:14:46 +0100

Thanks, Adrian

Looking back at a lot of (multicast) RFCs that started as experimental i guess i had tied
the meaning of the word too much to "blessed by IETF for further adoption", but it
makes a lot of sense to apply it also to other (non IETF blessed/validated) experiments.
Just never thought of it that way.

Although: In that case though, i would love to see even more documentation of environmental
aspects such as implementation information.

Sure, removing implementation and any other process-how-we-got-here sections from
RFC is fine. The only gotcha i observed when just moving a draft into the RFC editor queue
was that my AD (also here on the thread ;-) felt that it was not even appropriate to 
leave in the RFC a breadcrumb sentence pointing to the existance of (outdated or not) additional
information in the last draft. I think such a breadcrub sentence would be a perfect
way to justify the effort to invest cycles into good tracking of process data during
the development. And reduce the amount of pain having to go back and sift such info
oout of mailing list archives (if it's there at all).

Cheers
    Toerless

-- 
---
[email-masked]

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 2 Mar 2021 12:23:40 +0000

Vlad, Dragos,

What are you plan to move forward with this document ? There were some recent emails about it, hence my question :-)

Do you intend to follow the Independent Submission stream (ISE) with intended experimental status ? If so, please contact Adrian Farrel [email-masked]<mailto:[email-masked]>

Regards

-éric

From: Vladimir Olteanu <[email-masked]>
Date: Friday, 15 January 2021 at 17:08
To: Eric Vyncke <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Int-area] Suggestion to move draft-olteanu-intarea-socks as Independent Submissions

Hello,

Yes, I agree that ISE is the sensible path to take.

The intended status was changed from Experimental to Standards Track in -11, but Informational is fine for the moment. When/if SOCKSv6 gains traction, we can issue a bis and change the intended status.

Thanks,

Vlad
On 1/15/21 5:52 PM, Eric Vyncke (evyncke) wrote:
Indeed, but as the current intended status is experimental ;-) it should not be a problem

-éric

From: Behcet Sarikaya <[email-masked]><mailto:[email-masked]>
Reply-To: "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Date: Friday, 15 January 2021 at 16:43
To: Eric Vyncke <[email-masked]><mailto:[email-masked]>
Cc: "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>, "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>, "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject: Re: [Int-area] Suggestion to move draft-olteanu-intarea-socks as Independent Submissions

Hi Eric,

I am sure you know, all independent Submission documents can only be published as Informational.
I did not check what status the authors wish to have but it is good to mention here.

Regards,
Behcet

On Fri, Jan 15, 2021 at 7:55 AM Eric Vyncke (evyncke) <evyncke=[email-masked]<mailto:[email-masked]>> wrote:
Vladimir, Dragos,

While there was some interest in adopting the SOCKv6 document as an INT-AREA WG document, the lukewarm interest and lack of reviewer volunteers [1] are preventing the actual adoption of this document as a WG document (my AD decision in agreement with the chairs). After discussions with the IESG and our chairs (Juan Carlos and Wassim in cc), I want to propose to the authors an easier way to publish this document as an RFC but in the Independent Submissions (ISE) stream rather than in the usual IETF stream.

The simple process is outlined at https://www.rfc-editor.org/about/independent/<https://secure-web.cisco.com/1VwxfkUlqi_v4NnCaNQ5FzVjfQE2GUrSvMLOxcSe6Y0M0xMMmMxe7ne-103fsoi52WuYjgzRpy_bw_cky7un2UPCEXhP84Ml0TWgCLUgoaLlDnT4nXtp9dR1xOi3hY6hRiWB52oHxmN79vKZJfF0f-HuUrN_g_sJb5h862O4eySFHPxckCXQEiz3LZBY7UfJW6Cph5sd6rIoHFW8FCYIHeNzCaU5gGvMCvkwoqEazcoFWSpPl5IrZkEy66aUabVqVM80g9Qeq1bOiaS8RVRPApCzxRoj-Cf3bSCz2VMAzEBs/https%3A%2F%2Fwww.rfc-editor.org%2Fabout%2Findependent%2F> and “ISE” is described in RFC 4846.

This should allow this document to move forward and be published as a RFC.

Hope this helps

-éric (with JC & Wassim)

[1] I tried to contact the previous AFT WG proponents, SOCKS authors, and some open source SOCKS implementors without any reply on this topic.

_______________________________________________
Int-area mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/int-area<https://secure-web.cisco.com/1KB2NleJna66sVXsBDPV9nLQtvvS28j0c8kNZIsOvATOEJLXZsmjyrjSI_NkC6TAIIwhpdbUYJsH72kqcaczlHMkLF-lQXAPKQrrHjoC-Ioxca4cChkf69I41fycQP1Z2SXB6mDCHsZM1qNWLh-eYJdQZE2xEJtDfrF2Za447DuD85VMBbAkYH6zZA6eQaQZB0WlSmePeJi_jxkMLt0jFH_7hAszbaGiRVXAvmD1xdkH5J7U9cuWOBFAxXCBSqev-bfhZvqU7nbqTMPJiTWPY8-mx1et1rXQzLKpxrFy3dis/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fint-area>

---

From: Vladimir Olteanu <[email-masked]>
Date: Tue, 2 Mar 2021 15:46:15 +0200

Hi Eric, Adrian,

We have two security-related changes in the works (as well as a few 
loose ends to wrap up). Our current plan is to submit one more version 
of the draft and solicit some feedback, and then move forward with it.

Thanks,

Vlad

On 3/2/21 2:37 PM, Adrian Farrel wrote:
>
> In fact, please contact me at [email-masked] 
> <mailto:[email-masked]> to make sure that any Independent 
> Stream business is not lost in my personal inbox.
>
> Thanks,
>
> Adrian
>
> *From:*Int-area <[email-masked]> *On Behalf Of *Eric Vyncke 
> (evyncke)
> *Sent:* 02 March 2021 12:24
> *To:* Vladimir Olteanu <[email-masked]>; [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [Int-area] Suggestion to move 
> draft-olteanu-intarea-socks as Independent Submissions
>
> Vlad, Dragos,
>
> What are you plan to move forward with this document ? There were some 
> recent emails about it, hence my question :-)
>
> Do you intend to follow the Independent Submission stream (ISE) with 
> intended experimental status ? If so, please contact Adrian Farrel 
> [email-masked] <mailto:[email-masked]>
>
> Regards
>
> -éric
>
> *From: *Vladimir Olteanu <[email-masked] 
> <mailto:[email-masked]>>
> *Date: *Friday, 15 January 2021 at 17:08
> *To: *Eric Vyncke <[email-masked] <mailto:[email-masked]>>, 
> "[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
> *Cc: *"[email-masked] <mailto:[email-masked]>" 
> <[email-masked] <mailto:[email-masked]>>, 
> "[email-masked] <mailto:[email-masked]>" 
> <[email-masked] <mailto:[email-masked]>>
> *Subject: *Re: [Int-area] Suggestion to move 
> draft-olteanu-intarea-socks as Independent Submissions
>
> Hello,
>
> The intended status was changed from Experimental to Standards Track 
> in -11, but Informational is fine for the moment. When/if SOCKSv6 
> gains traction, we can issue a bis and change the intended status.
>
> Thanks,
>
> Vlad
>
>     *From: *Behcet Sarikaya <[email-masked]>
>     <mailto:[email-masked]>
>     *Reply-To: *"[email-masked]" <mailto:[email-masked]>
>     <[email-masked]> <mailto:[email-masked]>
>     *Date: *Friday, 15 January 2021 at 16:43
>     *To: *Eric Vyncke <[email-masked]> <mailto:[email-masked]>
>     *Cc: *"[email-masked]" <mailto:[email-masked]>
>     <[email-masked]> <mailto:[email-masked]>,
>     "[email-masked]" <mailto:[email-masked]>
>     <[email-masked]> <mailto:[email-masked]>,
>     "[email-masked]" <mailto:[email-masked]>
>     <[email-masked]> <mailto:[email-masked]>
>     *Subject: *Re: [Int-area] Suggestion to move
>     draft-olteanu-intarea-socks as Independent Submissions
>
>     Hi Eric,
>
>     On Fri, Jan 15, 2021 at 7:55 AM Eric Vyncke (evyncke)
>     <evyncke=[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         Vladimir, Dragos,
>
>         While there was some interest in adopting the SOCKv6 document
>         as an INT-AREA WG document, the lukewarm interest and lack of
>         reviewer volunteers [1] are preventing the actual adoption of
>         this document as a WG document (my AD decision in agreement
>         with the chairs). After discussions with the IESG and our
>         chairs (Juan Carlos and Wassim in cc), I want to propose to
>         the authors an easier way to publish this document as an RFC
>         but in the Independent Submissions (ISE) stream rather than in
>         the usual IETF stream.
>
>         The simple process is outlined at
>         https://www.rfc-editor.org/about/independent/
>         <https://secure-web.cisco.com/1VwxfkUlqi_v4NnCaNQ5FzVjfQE2GUrSvMLOxcSe6Y0M0xMMmMxe7ne-103fsoi52WuYjgzRpy_bw_cky7un2UPCEXhP84Ml0TWgCLUgoaLlDnT4nXtp9dR1xOi3hY6hRiWB52oHxmN79vKZJfF0f-HuUrN_g_sJb5h862O4eySFHPxckCXQEiz3LZBY7UfJW6Cph5sd6rIoHFW8FCYIHeNzCaU5gGvMCvkwoqEazcoFWSpPl5IrZkEy66aUabVqVM80g9Qeq1bOiaS8RVRPApCzxRoj-Cf3bSCz2VMAzEBs/https%3A%2F%2Fwww.rfc-editor.org%2Fabout%2Findependent%2F>
>         and “ISE” is described in RFC 4846.
>
>         [1] I tried to contact the previous AFT WG proponents, SOCKS
>         authors, and some open source SOCKS implementors without any
>         reply on this topic.
>
>         [email-masked] <mailto:[email-masked]>
>         https://www.ietf.org/mailman/listinfo/int-area
>         <https://secure-web.cisco.com/1KB2NleJna66sVXsBDPV9nLQtvvS28j0c8kNZIsOvATOEJLXZsmjyrjSI_NkC6TAIIwhpdbUYJsH72kqcaczlHMkLF-lQXAPKQrrHjoC-Ioxca4cChkf69I41fycQP1Z2SXB6mDCHsZM1qNWLh-eYJdQZE2xEJtDfrF2Za447DuD85VMBbAkYH6zZA6eQaQZB0WlSmePeJi_jxkMLt0jFH_7hAszbaGiRVXAvmD1xdkH5J7U9cuWOBFAxXCBSqev-bfhZvqU7nbqTMPJiTWPY8-mx1et1rXQzLKpxrFy3dis/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fint-area>
>