Subject: [Int-area] IETF-112 Side meeting on "Service Routing and Addressing"

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 1 Nov 2021 10:13:38 -0000

Hi INT Area,

We'll be holding another side meeting at IETF-112 to bring important recent
research and discussion on Internet routing to the IETF. This one also has
an aspect of addressing, so you may be interested.

The topic will be "Service Routing and Addressing"

The meeting will be on Wednesday 10th November 2021 18.30-20.00 UTC and will
last 90 minutes.

We'll hold the meeting on WebEx
https://htf-paris.my.webex.com/htf-paris.my-en/j.php?MTID=m760a9ed9560f76ad3
1a54a64d945ca86

It will be live-streamed on YouTube
https://www.youtube.com/watch?v=cx2G5QxS9Eo

An ICS file is attached.

The agenda will be...

1. Moderator's Introduction
   Adrian Farrel, Old Dog Consulting
   5 minutes

2. The ties that un-bind: decoupling IP from web services and sockets for
robust addressing agility at CDN-scale
   Vasileios Giotsas, Cloudflare Inc. and Lancaster University
   https://dl.acm.org/doi/10.1145/3452296.3472922
   20 minutes

3. RICE: Remote Method Invocation in ICN
   Michal Krol, City University, London
   https://conferences.sigcomm.org/acm-icn/2018/proceedings/icn18-final9.pdf
   20 minutes

4. Centralization of service provisioning and the impact on routing
   Geoff Huston, Chief Scientist, APNIC
   20 minutes

5. Open Discussion
   20 minutes

All of these details can be found on github
https://github.com/danielkinguk/sarah/tree/main/conferences/ietf-112

We'll post slides and a recording of the meeting as they become available.

See you there.
Adrian

---

From: Uma Chunduri <[email-masked]>
Date: Tue, 2 Nov 2021 18:21:16 -0700

Hi Adrian,

Many thx for leading this side meeting with many thought provoking
sub-topics.

 I just wanted to ask
                       - If this is part of a series of side meetings on
this broader topic? ( I remember a couple of IETFs back one side meeting on
this topic but couldn't find it in the github pointer).
                       - Is this effort related to what Luigi posted in
this WG recently -
https://etherpad.wikimedia.org/p/routing.addressing.manifesto (btw, I
signed up there)

Are these two efforts related but seem independent (as service routing too
being covered) ? Is this correct understanding?

Apologies if I misunderstood this completely.

I strongly support having a mailing list (though this can still be
discussed in INT-AREA as being done now) to discuss this broader topic so
as not to confuse further.

Best!
--
Uma C.

On Mon, Nov 1, 2021 at 3:14 AM Adrian Farrel <[email-masked]> wrote:

> <https://htf-paris.my.webex.com/htf-paris.my-en/j.php?MTID=m760a9ed9560f76ad31a54a64d945ca86>
>
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 3 Nov 2021 10:30:40 +0100

In the 'addressing' part there is also the Dirk's invitation to side 
meeting "Problems and Gap Analysis for Internet Addressing" sent a few 
days ago.

While Dirk's meeting might talk 'ICN' addressing, this meeting might 
talk 'CDN' addressing.  Information-Centric Networking and Content 
Distribution Networks might be related.

Alex

> We'll post slides and a recording of the meeting as they become available.

Subject: [Int-area] Side meeting on Problems and Gap Analysis for Internet Addressing [WAS RE: I-D. Updates on Internet Addressing: Problem statement and Gap analysis]
From: Dirk Trossen <[email-masked]>
To: Jiayihao <[email-masked]>, "[email-masked]" <[email-masked]>
Date: Mon, 25 Oct 2021 15:56:39 +0000
List-Id: IETF Internet Area WG Mailing List <int-area.ietf.org>

Dear all,

You may have seen the update to our drafts on problem statement and gap analysis for Internet addressing, to be found at https://datatracker.ietf.org/doc/draft-jia-intarea-scenarios-problems-addressing/ and https://datatracker.ietf.org/doc/draft-jia-intarea-internet-addressing-gap-analysis/, respectively, as announced in the email below.

In order to further the engagement and feedback on this work, we are organizing a side meeting on Monday, the 8th of November, 2021 at 18.00 UTC (after the end of the regular sessions that day) that is focused on those drafts. After a brief introduction to set the stage, we will engage with a panel of experts on questions relating to the aspects raised in our drafts, those questions stemming from the viewpoints and work those experts have been doing in the past.

We expect to bring the ensuing discussions around those questions into the wider discussion on the INT area mailing list, helping us gauge the interest and support for the work we have been doing with those two drafts and understand possible ways forward for this work. To start this process, we will provide a summary of the side meeting in our presentation to the INT area WG on Tuesday, the 9th of November.

Further information on the detailed agenda, the list of experts confirmed, and any meeting material will be posted soon on the IETF side meeting wiki (https://trac.ietf.org/trac/ietf/meeting/wiki/112sidemeetings).

Please do consider participating in this event to contribute to this important discussion on how to advance Internet addressing.

Best,

Dirk (on behalf of the drafts co-authors)

From: Int-area [mailto:[email-masked]] On Behalf Of Jiayihao
Sent: 25 October 2021 09:59
To: [email-masked]
Subject: [Int-area] I-D. Updates on Internet Addressing: Problem statement and Gap analysis

Dear all,

2 drafts around "internet addressing" have been updated recently, namely:

- Internet Addressing: Problem statements (https://datatracker.ietf.org/doc/draft-jia-intarea-scenarios-problems-addressing/)
- Internet Addressing: Gap analysis (https://datatracker.ietf.org/doc/draft-jia-intarea-internet-addressing-gap-analysis/)

The first draft (Problem statements) provides various issues regarding addressing in a number of scenarios, while the second draft (Gap Analysis) provides an analysis of extensions to identified key properties of Internet addressing.

We are soliciting feedback from IETF community on the problems, issues, and gaps identified in those drafts, e.g., in terms of issues missed, extensions (to Internet addressing) to be added but also towards the aim of these drafts to stimulate discussion on how we can progress Internet addressing for future uses.

Any comments on this topic are, definitely, always appreciated.

Thanks,
Yihao Jia (on behalf of all authors)
_______________________________________________
Int-area mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-area

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 3 Nov 2021 09:44:13 -0000

Hi Uma,

>  - If this is part of a series of side meetings on this broader topic?

>    (I remember a couple of IETFs back one side meeting on this topic

>    but couldn't find it in the github pointer). 

Nothing so structured as “a series”. But this is the third such meeting related to routing research that we have organised.

The previous two were:

*	https://github.com/danielkinguk/sarah/tree/main/IETF-111

Routing research challenges arising from evolving beyond and revitalizing the Internet

*	https://github.com/danielkinguk/sarah/tree/main/conferences/security-workshop

Evolving Routing Security in the Internet

They were not much related to “addressing” so not shared on the INT Area list. But, the subject of this meeting includes addressing so that is why this email.

Do we have plans for more similar meetings? No nothing at the moment, but never say never.

> Is this effort related to what Luigi posted in this WG recently

>  <https://etherpad.wikimedia.org/p/routing.addressing.manifesto> https://etherpad.wikimedia.org/p/routing.addressing.manifesto 

> (btw, I signed up there)

Not directly related, no. Although you are right to observe that Luigi’s draft (https://datatracker.ietf.org/doc/draft-iannone-routing-and-addressing-manifesto) that promotes that sign-up is asking for a venue to discuss routing research. 

Best,

Adrian

From: Uma Chunduri <[email-masked]> 
Sent: 03 November 2021 01:21
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Int-area] IETF-112 Side meeting on "Service Routing and Addressing"

Hi Adrian,

Many thx for leading this side meeting with many thought provoking sub-topics.

 I just wanted to ask 

                       - If this is part of a series of side meetings on this broader topic? ( I remember a couple of IETFs back one side meeting on this topic but couldn't find it in the github pointer). 

                       - Is this effort related to what Luigi posted in this WG recently -  <https://etherpad.wikimedia.org/p/routing.addressing.manifesto> https://etherpad.wikimedia.org/p/routing.addressing.manifesto (btw, I signed up there)

Are these two efforts related but seem independent (as service routing too being covered) ? Is this correct understanding?

I strongly support having a mailing list (though this can still be discussed in INT-AREA as being done now) to discuss this broader topic so as not to confuse further. 

Best!

--

Uma C.

On Mon, Nov 1, 2021 at 3:14 AM Adrian Farrel <[email-masked] <mailto:[email-masked]> > wrote:

Hi INT Area,

We'll hold the meeting on WebEx
https://htf-paris.my.webex.com/htf-paris.my-en/j.php?MTID=m760a9ed9560f76ad3 <https://htf-paris.my.webex.com/htf-paris.my-en/j.php?MTID=m760a9ed9560f76ad31a54a64d945ca86> 
1a54a64d945ca86

An ICS file is attached.

The agenda will be...

5. Open Discussion
   20 minutes

See you there.
Adrian
_______________________________________________
Int-area mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/int-area

---

From: Dirk Trossen <[email-masked]>
Date: Wed, 3 Nov 2021 10:06:42 +0000

Hi Alex,

Indeed, the side meeting you refer to is more specifically discussing the evolution of Internet addressing, tying into the current drafts submitted to the INT area WG (the side meeting is meant to stimulate discussion on those drafts). We have asked Vasileios from CloudFlare to join this side meeting as a discussion participants, too, but have other insights and views represented as well beyond CDN and ICN. 

Please do join this side meeting and participate in this discussion!

Best,

Dirk

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: 03 November 2021 10:31
To: [email-masked]
Subject: Re: [Int-area] IETF-112 Side meeting on "Service Routing and Addressing"

In the 'addressing' part there is also the Dirk's invitation to side meeting "Problems and Gap Analysis for Internet Addressing" sent a few days ago.

While Dirk's meeting might talk 'ICN' addressing, this meeting might talk 'CDN' addressing.  Information-Centric Networking and Content Distribution Networks might be related.

Alex

Le 01/11/2021 à 11:13, Adrian Farrel a écrit :
> Hi INT Area,
> 
> We'll be holding another side meeting at IETF-112 to bring important 
> recent research and discussion on Internet routing to the IETF. This 
> one also has an aspect of addressing, so you may be interested.
> 
> The meeting will be on Wednesday 10th November 2021 18.30-20.00 UTC 
> and will last 90 minutes.
> 
> 2. The ties that un-bind: decoupling IP from web services and sockets 
> for robust addressing agility at CDN-scale

---

From: Uma Chunduri <[email-masked]>
Date: Wed, 3 Nov 2021 16:34:14 -0700

Hi Adrian,

Thank you for clarifying and providing relevant information (both IETF111
and Security-workshop). I did follow the draft-king-irtf-xxxx  work on
semantic routing and routing challenges in general.

Looking forward to the upcoming side meeting.

--
Uma C.

On Wed, Nov 3, 2021 at 2:44 AM Adrian Farrel <[email-masked]> wrote:

> Nothing so structured as “a series”. But this is the third such meeting
> related to routing research that we have organised.
>
> The previous two were:
>
>    - https://github.com/danielkinguk/sarah/tree/main/IETF-111
>
>    -
>    https://github.com/danielkinguk/sarah/tree/main/conferences/security-workshop
>
> They were not much related to “addressing” so not shared on the INT Area
> list. But, the subject of this meeting includes addressing so that is why
> this email.
>
>
>
> > https://etherpad.wikimedia.org/p/routing.addressing.manifesto
>
> > (btw, I signed up there)
>
>
>
> Not directly related, no. Although you are right to observe that Luigi’s
> draft (
> https://datatracker.ietf.org/doc/draft-iannone-routing-and-addressing-manifesto)
> that promotes that sign-up is asking for a venue to discuss routing
> research.
>
>
>
> Best,
>
> Adrian
>
>
>
> *From:* Uma Chunduri <[email-masked]>
> *Sent:* 03 November 2021 01:21
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: [Int-area] IETF-112 Side meeting on "Service Routing and
> Addressing"
>
>
>
> Hi Adrian,
>
>
>