Subject: [Int-area] Expanding Assignable IPv4 Public Address Re: 202112030945.AYC

From: "Abraham Y. Chen" <[email-masked]>
Date: Fri, 3 Dec 2021 18:09:59 -0500

Dear Colleagues:

0)    I was just made aware of a current IETF Draft discussion on 
reducing the 127/8 netblock allocated for Local Loopback to 127/16 in 
order to free up mostly unused resources in that portion of the IPv4 
address pool. In studying this lead, I discovered that there are at 
least a few similar ongoing IETF Drafts being proposed by the "IPv4 
Unicast Extensions Project":

     A.    Unicast Use of the Formerly Reserved 0/8 (Version 00: 
2021-11-07):

https://datatracker.ietf.org/doc/html/draft-schoen-intarea-unicast-0-00

     B.    Unicast Use of the Formerly Reserved 127/8 (Version 00: 
2021-11-08)

https://datatracker.ietf.org/doc/html/draft-schoen-intarea-unicast-127-00

     C.    Unicast Use of the Lowest Address in an IPv4 Subnet (Version 
00: 2021-10-20)
https://datatracker.ietf.org/doc/html/draft-schoen-intarea-unicast-lowest-address-01

     D.    Unicast Use of the Formerly Reserved 240/4 (Version 00: 
2021-10-19)

https://datatracker.ietf.org/doc/html/draft-schoen-intarea-unicast-240-01

1)    In particular, the last Draft deals with the same netblock that 
our team has been reporting since 2016:

         Adaptive IPv4 Address Space (Version 00: 2016-12-14)

https://datatracker.ietf.org/doc/html/draft-chen-ati-adaptive-ipv4-address-space 

Since we were advised several times in the past that IPv4 related topics 
were no longer active IETF tasks, we have been only updating our drafts 
as lab notes about our progress. Upon a quick scan, I believe that our 
scheme, nicknamed EzIP (Phonetic for Easy IPv4) is more concise and 
capable than, while avoiding most of the considerations expressed by,  
the other drafts.

2)    Now that the correlation have been established, may I request to 
include our proposal with the above discussions so that we can have a 
more efficient and productive use of our resources?

Regards,

Abe (2021-12-03 18:09 EST)
VP Engineering
Avinta Communications
Milpitas CA 95035 USA
eMail: [email-masked]
WebSite: www.Avinta.com

-- 
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 4 Dec 2021 14:27:03 +1300

Abe mentions "more efficient and productive use of our resources" and I think we all wish for that.

I think this WG should discuss the general question whether the minor wastage of IPv4 address space that this set of drafts addresses is an efficient and productive use of our resources. In other words, where are we with respect to conditions (1) - (5) in the WG charter (https://datatracker.ietf.org/wg/intarea/about/)?

Incidentally, the WG milestones look a bit OBE.

Regards
    Brian

On 04-Dec-21 12:09, Abraham Y. Chen wrote:
> Dear Colleagues:
> 
> 0)    I was just made aware of a current IETF Draft discussion on reducing the 127/8 netblock allocated for Local Loopback to 127/16 in order to free up mostly unused resources in that portion of the IPv4 address pool. In studying this lead, I discovered that there are at least a few similar ongoing IETF Drafts being proposed by the "IPv4 Unicast 
Extensions Project":
> 
>      A.    Unicast Use of the Formerly Reserved 0/8 (Version 00: 2021-11-07):
> 
>      B.    Unicast Use of the Formerly Reserved 127/8 (Version 00: 2021-11-08)
> 
>      C.    Unicast Use of the Lowest Address in an IPv4 Subnet (Version 00: 2021-10-20)
>      D.    Unicast Use of the Formerly Reserved 240/4 (Version 00: 2021-10-19)
> 
> 1)    In particular, the last Draft deals with the same netblock that our team has been reporting since 2016:
> 
> Since we were advised several times in the past that IPv4 related topics were no longer active IETF tasks, we have been only updating our drafts 
as lab notes about our progress. Upon a quick scan, I believe that our scheme, nicknamed EzIP (Phonetic for Easy IPv4) is more concise and capable 
than, while avoiding most of the considerations expressed by,  the other drafts.
> 
> 2)    Now that the correlation have been established, may I request to include our proposal with the above discussions so that we 
can have a more efficient and productive use of our resources?
> <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient&utm_term=icon> 	Virus-free. www.avast.com <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient&utm_term=link>
> 
> <#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
> 
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>