Subject: Re: [Int-area] Side meeting follow-up: What exact features do we want from the Internet?

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 8 Dec 2021 23:33:42 +0000

Dino, my response to your response is "MTU diversity everywhere, with 576 as the
minimum cell size". I know Joe won't like that, but I can't get him to give a straight
answer.

> -----Original Message-----
> From: Dino Farinacci [mailto:[email-masked]]
> Sent: Wednesday, December 08, 2021 3:20 PM
> To: Templin (US), Fred L <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Int-area] Side meeting follow-up: What exact features do we want from the Internet?
> 
> > Dino, the term "Bridge" used here refers to bridging at the adaptation layer; not at
> > the link layer. What is being bridged is the overlay; not the underlays. And, again this
> > is at the adaptation layer - the layer below IP but above the link layer.
> 
> It doesn't matter if your overlay is an L2 or L3 overlay, the MTU issue is the same.
> 
> > I am sorry if that comes across as confusing, but at the current time we don't have
> > a better term for it. Someone once long ago suggested "brouter", but I don't see
> > that term being used anymore.
> 
> Don't use "brouter", because the history of that device does both L2 bridging and L3 routing in the same physical device. These devices still
> exist today but are not called anything other than a "switch" or a "router". And a "switch", in this specific product case, is doing layer 3
> routing.
> 
> On these types of devices, bridging is done on a set of ports called switchports and appear to the router as an SVI (Switched Virtural
> Interface) that is viewed as a layer 3 port.
> 
> In any event, my response is the same "ifconfig eth0 mtu 1280".
> 
> Dino
> 
> >
> > Fred
> >
> >> -----Original Message-----
> >> From: Dino Farinacci [mailto:[email-masked]]
> >> Sent: Wednesday, December 08, 2021 2:50 PM
> >> To: Templin (US), Fred L <[email-masked]>
> >> Cc: [email-masked]; [email-masked]
> >> Subject: [EXTERNAL] Re: [Int-area] Side meeting follow-up: What exact features do we want from the Internet?
> >>
> >> EXT email: be mindful of links/attachments.
> >>
> >>
> >>
> >> It doesn't matter if you call them enterprise networks and if they are bridged or routed to the N2 Internet. This will make it all work in
> terms
> >> of MTU:
> >>
> >> 	ifconfig eth0 mtu 1280
> >>
> >> When you want to consider running both IPv4 and IPv6 over the topology you describe below.
> >>
> >> And you actually find networks that bridge from the enterprise to the Internet? That is a brain-dead and dangerous design and I never see
> >> that.
> >>
> >> Dino
> >>
> >>> On Dec 8, 2021, at 3:07 PM, Templin (US), Fred L <[email-masked]> wrote:
> >>>
> >>> Dino -see below:
> >>>
> >>>> -----Original Message-----
> >>>> From: Dino Farinacci [mailto:[email-masked]]
> >>>> Sent: Wednesday, December 08, 2021 12:19 PM
> >>>> To: Templin (US), Fred L <[email-masked]>
> >>>> Cc: [email-masked]; [email-masked]
> >>>> Subject: Re: [Int-area] Side meeting follow-up: What exact features do we want from the Internet?
> >>>>
> >>>>> On Dec 8, 2021, at 8:30 AM, Templin (US), Fred L <[email-masked]> wrote:
> >>>>>
> >>>>> Absolutely not talking about translation - talking about concatenation and adaptation.
> >>>>
> >>>> Those terms are too general. Please be more specific.
> >>>
> >>> OK, let's take an example of three independent Internetworks; call them N1, N2 and N3.
> >>> N2 could be the global Internet while N1, N3 could be (for example) a couple of enterprise
> >>> networks. The networks can be concatenated by joining them with Bridges, such as:
> >>>
> >>> H1 <-> N1 <-> B1/2 <-> N2 <-> B2/3 <-> N3 <-> H2
> >>>
> >>> So host H1 connected to N1 can communicate with H2 connected to N3 with both using
> >>> global IP addresses. Then, somewhere in N1 and N3 are nodes that configure an OMNI
> >>> interface that invokes the OMNI Adaptation Layer (OAL). The OAL wraps the H1<->H2 IP
> >>> packets in an IPv6 header, then wraps the IP-in-IPv6 packets in headers appropriate for
> >>> network N* and forwards them to the nearest Bridge. The Bridge only operates on the
> >>> adaptation layer IPv6 header and NOT on the inner IP header (that is why it is called
> >>> "Bridge" and not "Router"), and forwards the packets over the next N* hop toward the
> >>> final destination.
> >>>
> >>> You can concatenate as many networks as you like (and having diverse IP protocols)
> >>> and the Bridges operating at the adaptation layer allow hosts located in distant
> >>> networks to communicate at the IP layer.
> >>>
> >>> Fred
> >>>
> >>>
> >>>> Dino=
> >>>
> >

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 8 Dec 2021 17:57:50 -0600

> On Dec 8, 2021, at 5:33 PM, Templin (US), Fred L <[email-masked]> wrote:
> 

Does that mean no app should send more than 576? That would be a bug, a major performance bug. And you would be way too late to the table. If it was the minimum an app has to send, that is a bug too and tardy as well. 

So let’s move on to requirements again. I bet this list is bored with the topic. 

Dino