Subject: Re: [Int-area] Side meeting follow-up: What exact features do we want from the Internet?

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 8 Dec 2021 01:38:51 +0000

This conversation is missing some fundamental points – really the most important
points – which are the minimum sizes guaranteed to work everywhere. For IPv6,
the minimum MTU/MRU are 1280/1500. For IPv4, they are only 68/576 but since
the IPv4 network supports fragmentation we can nominally designate the IPv4
minimum MTU as 576 also if we clear the DF bit. It means that, without probing
or having some divine knowledge of paths that have not been previously visited,
the ONLY sizes guaranteed to work are 1280 for IPv6 and 576 for IPv4.

Now take the case of Multinet where a path may traverse multiple concatenated
IP networks of arbitrary IP protocol versions - remember “Catenet”? Since there
may be no advanced knowledge of network IP protocol versions, the most we can
absolutely and for sure count on across the entire path is 576.

What this gives us is not the *maximum packet size*; instead, it determines the
*minimum cell size*. We know that a 576 cell will traverse all paths, so we never
send a non-final cell smaller than this (which might trigger a tiny fragment alarm).
But, we can certainly send packets larger than the path MTU - *much* larger in
many cases. And for paths that support them, we can also send Brian’s jumbograms.

Speaking of jumbos, on a different list I made a point about how this all harkens back
to RFC1149 and RFC6214. But nowadays, we can imagine substituting a memory stick
for the slips of paper with whitestuff and blackstuff and those avian carriers will
transport jumbos just fine. Not quite unlimited MTU, but close enough.

Fred

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 8 Dec 2021 07:17:40 -0600

> the ONLY sizes guaranteed to work are 1280 for IPv6 and 576 for IPv4.

Well "ifconfig eth0 mtu 1400" makes all this work.

> absolutely and for sure count on across the entire path is 576.

Are you talking about 4to6 and 6to4 translation?

Then just "ifconfig eth0 mtu 1260".

> many cases. And for paths that support them, we can also send Brian’s jumbograms.

I believe you are over thinking this. Just my opinion, no offense intended.

Dino

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 8 Dec 2021 15:15:58 +0100

The advantage of talking 'minimum cell size' (MCS?) instead of 'maximum
transmission unit' (MTU) is in that it fits better to a preceding
'minimum' qualifier.

A 'minimum MTU' term expands to a 'minimum maximum transmission unit'.
That construct can be ambiguous to an implementer.  Is it a 'minimum
transmission unit'?  Or is it the smallest of all MTUs of all link designs?

On another hand, a 'minimum minimum cell size' is clearly just a minimum
cell size, just further accentuated in its minimization: a 'minimum
minimorum' if one wishes.  Where MCS is 576 a minimum MCS in IPv6 could
be 41: 40 bytes of header and 1 byte of payload.  Or maybe 40 if there
is no payload.  Or maybe 321 bits if there is just one bit of payload
(an on/off switch or flag in IoT speak).

Alex

Le 08/12/2021 à 02:38, Templin (US), Fred L a écrit :
> What this gives us is not the **maximum packet size**; instead, it 
> determines the
> 
> **minimum cell size**. We know that a 576 cell will traverse all 
> paths, so we never
> 
> But, we can certainly send packets larger than the path MTU - 
> **much** larger in
> 
> _______________________________________________ Int-area mailing
> list [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 8 Dec 2021 15:24:24 +0100

Le 08/12/2021 à 15:15, Alexandre Petrescu a écrit :
> The advantage of talking 'minimum cell size' (MCS?) instead of
> 'maximum transmission unit' (MTU) is in that it fits better to a
> preceding 'minimum' qualifier.
> 
> A 'minimum MTU' term expands to a 'minimum maximum transmission
> unit'. That construct can be ambiguous to an implementer.  Is it a
> 'minimum transmission unit'?  Or is it the smallest of all MTUs of
> all link designs?
> 
> On another hand, a 'minimum minimum cell size' is clearly just a
> minimum cell size, just further accentuated in its minimization: a
> 'minimum minimorum' if one wishes.  Where MCS is 576 a minimum MCS in
> IPv6 could be 41: 40 bytes of header and 1 byte of payload.  Or maybe
> 40 if there is no payload.  Or maybe 321 bits if there is just one
> bit of payload (an on/off switch or flag in IoT speak).

And, in the desiderata for exact features we want from the Internet, I
would add the following:

- one should not worry about an IPv6 minimum MCS be of size 321bit for
transmitting just 1bit of valuable information.  Because the structure
and working of the entire Internet is reflected in these 321bits: the
billions of nodes and billions of billions of working paths between all
of them is represented in just these 321bits.  Thanks to these 321bits
the 1bit IoT payload value can be sent or received between any of these
across any distance at any speed.

So, the feature requested is to not try to reduce the power of these
321bits by designing compression schemes in the Internet at large.

Compress one single bit of these 321bits and the Internet is reduced.

Alex

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 8 Dec 2021 14:30:28 +0000

Dino,

> -----Original Message-----
> From: Dino Farinacci [mailto:[email-masked]]
> Sent: Wednesday, December 08, 2021 5:18 AM
> To: Templin (US), Fred L <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Int-area] Side meeting follow-up: What exact features do we want from the Internet?
> 
> 

Good network administration cannot be guaranteed everywhere; all that can be
guaranteed everywhere is 576/1280 - it says so in the specs. And, for some links,
1400 may be too big (others not big enough).

> Are you talking about 4to6 and 6to4 translation?

Absolutely not talking about translation - talking about concatenation and adaptation.

> I believe you are over thinking this. Just my opinion, no offense intended.

Not overthinking - correctly thinking in observance of the specs.

Fred

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 8 Dec 2021 09:28:40 -0800

Hi, Fred,

> On Dec 7, 2021, at 5:38 PM, Templin (US), Fred L <[email-masked]> wrote:
> ...
> the minimum MTU/MRU are 1280/1500.

They work only because of source fragmentation at IP tunnels, e.g.

> For IPv4, they are only 68/576 but since
> minimum MTU as 576 also if we clear the DF bit.

But then those packets will fail through NATs.

> It means that, without probing

That’s the problem - they don’t. If they did, we wouldn’t be having this conversation ;-)

Joe

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 8 Dec 2021 14:18:53 -0600

> On Dec 8, 2021, at 8:30 AM, Templin (US), Fred L <[email-masked]> wrote:
> 

Those terms are too general. Please be more specific. 

Dino