Subject: Re: [Int-area] IP parcels

From: "Templin (US), Fred L" <[email-masked]>
Date: Sun, 19 Dec 2021 00:42:05 +0000

Joe, TCP will find a way to adapt – it always has. I also see that TCP is currently undergoing
a second edition revision so the timing seems right to consider IP parcels in the analysis.
I am Cc’ing the second edition editor for his information – Wesley, please consider this
new concept called “IP Parcels” as it relates to your document.

Here is the latest draft version – it expands on the “Motivation” section and adds a number
of important feature such as a new “Parcels Permitted” TCP option:

https://datatracker.ietf.org/doc/draft-templin-intarea-parcels/

Fred

From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 17, 2021 6:01 PM
To: Templin (US), Fred L <[email-masked]>
Cc: [email-masked]
Subject: Re: [Int-area] IP parcels

Hi, Fred,

I’m first concerned at the use of an IP option at all, due to the problems with *any* options forcing processing to slow-path.

From TCP’s viewpoint, it seems like you’ve just created a nightmare for SACK and ECN, basically because you will encourage drops of large bursts of packets.

This will also increase the bustiness of TCP, i.e., rather than letting the ACKs support pacing.

Any part of the system that currently coalesces TCP packets is likely to generate errors here, because they might see only the first TCP segment.

However, AFAICT the most significant consideration is that  the issue with per-packet performance is at the TCP and UDP layers, not as much at the IP layer.

So what problem is this trying to solve?

Joe
—
Joe Touch, temporal epistemologist
www.strayalpha.com<http://www.strayalpha.com>

On Dec 17, 2021, at 5:06 PM, Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> wrote:

Here's one that should help with shipping, just in time for Christmas. Thanks
to everyone for the past and future list exchanges.

Fred

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Friday, December 17, 2021 5:00 PM
To: [email-masked]<mailto:[email-masked]>
Subject: I-D Action: draft-templin-intarea-parcels-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

       Title           : IP Parcels
       Author          : Fred L. Templin
               Filename        : draft-templin-intarea-parcels-00.txt
               Pages           : 8
               Date            : 2021-12-17

Abstract:
  IP packets (both IPv4 and IPv6) are understood to contain a unit of
  data which becomes the retransmission unit in case of loss.  Upper
  layer protocols such as the Transmission Control Protocol (TCP)
  prepare data units known as "segments", with traditional arrangements
  including a single segment per packet.  This document presents a new
  construct known as the "IP Parcel" which permits a single packet to
  carry multiple segments.  The parcel can be opened at middleboxes on
  the path with the included segments broken out into individual
  packets, then rejoined into one or more repackaged parcels to be
  forwarded further toward the final destination.  Reordering of
  segments within parcels is unimportant; what matters is that the
  number of parcels delivered to the final destination should be kept
  to a minimum, and that loss or receipt of individual segments (and
  not parcel size) determines the retransmission unit.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-templin-intarea-parcels/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-templin-intarea-parcels-00

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

_______________________________________________
I-D-Announce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
Int-area mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/int-area

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 18 Dec 2021 16:57:19 -0800

Hi, Fred,

Regarding 793bis, new ideas are out of scope. It’s supposed to be a roll-in of existing items only. 

Nevermind the problems below, which “TCP will find a way” doesn’t magically fix.

The problem is this:
- end systems need to send larger transport segments (not just IP segments)
- if they can do that, they should, filling up to the largest IP payload

Having an IP packet have the opportunity to include lots of small transport packets assumes transport packets either work better or faster when they’re small. It’s the opposite.

Joe

—
www.strayalpha.com

> On Dec 18, 2021, at 4:42 PM, Templin (US), Fred L <[email-masked]> wrote:
> 
> https://datatracker.ietf.org/doc/draft-templin-intarea-parcels/ <https://datatracker.ietf.org/doc/draft-templin-intarea-parcels/>
>  
> Fred
>  
> From: [email-masked] <mailto:[email-masked]> [mailto:[email-masked] <mailto:[email-masked]>] 
> To: Templin (US), Fred L <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> www.strayalpha.com <http://www.strayalpha.com/>
> 
> 
> On Dec 17, 2021, at 5:06 PM, Templin (US), Fred L <[email-masked] <mailto:[email-masked]>> wrote:
>  
> From: I-D-Announce [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of [email-masked] <mailto:[email-masked]>
> To: [email-masked] <mailto:[email-masked]>
> https://datatracker.ietf.org/doc/draft-templin-intarea-parcels/ <https://datatracker.ietf.org/doc/draft-templin-intarea-parcels/>
> 
> https://datatracker.ietf.org/doc/html/draft-templin-intarea-parcels-00 <https://datatracker.ietf.org/doc/html/draft-templin-intarea-parcels-00>
> 
> 
> Internet-Drafts are also available by rsync at rsync.ietf.org <http://rsync.ietf.org/>::internet-drafts
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/i-d-announce <https://www.ietf.org/mailman/listinfo/i-d-announce>
> Internet-Draft directories: http://www.ietf.org/shadow.html <http://www.ietf.org/shadow.html>
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt <ftp://ftp.ietf.org/ietf/1shadow-sites.txt>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/int-area <https://www.ietf.org/mailman/listinfo/int-area>