Subject: [Int-area] IP parcels

From: "Templin (US), Fred L" <[email-masked]>
Date: Sat, 18 Dec 2021 01:06:44 +0000

Here's one that should help with shipping, just in time for Christmas. Thanks
to everyone for the past and future list exchanges.

Fred

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, December 17, 2021 5:00 PM
To: [email-masked]
Subject: I-D Action: draft-templin-intarea-parcels-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : IP Parcels
        Author          : Fred L. Templin
	Filename        : draft-templin-intarea-parcels-00.txt
	Pages           : 8
	Date            : 2021-12-17

Abstract:
   IP packets (both IPv4 and IPv6) are understood to contain a unit of
   data which becomes the retransmission unit in case of loss.  Upper
   layer protocols such as the Transmission Control Protocol (TCP)
   prepare data units known as "segments", with traditional arrangements
   including a single segment per packet.  This document presents a new
   construct known as the "IP Parcel" which permits a single packet to
   carry multiple segments.  The parcel can be opened at middleboxes on
   the path with the included segments broken out into individual
   packets, then rejoined into one or more repackaged parcels to be
   forwarded further toward the final destination.  Reordering of
   segments within parcels is unimportant; what matters is that the
   number of parcels delivered to the final destination should be kept
   to a minimum, and that loss or receipt of individual segments (and
   not parcel size) determines the retransmission unit.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-templin-intarea-parcels/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-templin-intarea-parcels-00

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 17 Dec 2021 18:01:13 -0800

Hi, Fred,

I’m first concerned at the use of an IP option at all, due to the problems with *any* options forcing processing to slow-path.

From TCP’s viewpoint, it seems like you’ve just created a nightmare for SACK and ECN, basically because you will encourage drops of large bursts of packets.

This will also increase the bustiness of TCP, i.e., rather than letting the ACKs support pacing.

Any part of the system that currently coalesces TCP packets is likely to generate errors here, because they might see only the first TCP segment.

However, AFAICT the most significant consideration is that  the issue with per-packet performance is at the TCP and UDP layers, not as much at the IP layer.

So what problem is this trying to solve?

Joe
—
Joe Touch, temporal epistemologist
www.strayalpha.com

> On Dec 17, 2021, at 5:06 PM, Templin (US), Fred L <[email-masked]> wrote:
> 
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sat, 18 Dec 2021 07:59:34 +0000

Fred,

Without any hat, I share Joe's concerns about the use of HbH (but I guess that those IP parcels are intended to be used on a set of collaborative nodes for some definitions of 'limited domains') and I will had another one for all devices on the path wanting to do something (from ACL to QoS or ...) based on the L4 information.

Anyway, if not yet done, then I suggest to cross post this announcement to the TSVWG as well.

Finally, thank you for keeping thinking out-of-the-box

Regards

-éric

From: Int-area <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Saturday, 18 December 2021 at 03:01
To: "Templin (US), Fred L" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Int-area] IP parcels

Hi, Fred,

Joe
—
Joe Touch, temporal epistemologist
www.strayalpha.com<http://www.strayalpha.com>

On Dec 17, 2021, at 5:06 PM, Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> wrote:

Fred

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Friday, December 17, 2021 5:00 PM
To: [email-masked]<mailto:[email-masked]>
Subject: I-D Action: draft-templin-intarea-parcels-00.txt

       Title           : IP Parcels
       Author          : Fred L. Templin

Abstract:

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 21 Dec 2021 16:02:57 +0100

The title and abstract are great.

About the title, just one little note.  This word 'parcel' is very well
adapted and suggestive for an English speaker.  I think I heard it very
well in US English, even though not sure about UK English - to they also
use 'parcel' to mean a package sent in mail?  Probably yes.

An 'IP Parcel' is a new concept, akin to an IP packet, IP datagram, or
to a TCP segment: it is also a delimited 'chunk' of data sent in the
network.  It is different than an IP packet in that it is made to be
able to carry more IP packets inside.  An IP tunnel also is known to
carry another IP packet which itself could carry another packet
(encapsulated tunnels); however an IP parcel would be different than an
IP tunnel in that there are less IP headers, presumably, and no trailers
at all (IP tunnel encapsulation involves trailers, IIRC).  Maybe I could
understand that if I read the draft.

The name 'parcel', to a French speaker, makes think it might be a
'parcelle'.  That 'parcelle' is a limited domain, like a part of land.
In our current discussions of 'limited domains' in the Internet, that
'parcelle' confuses me.  It is not an 'IP parcelle' limited domain, but
an 'IP parcel' packet, even though it is pronounced the same.

Le 18/12/2021 à 02:06, Templin (US), Fred L a écrit :
> Here's one that should help with shipping, just in time for 
> Christmas. Thanks to everyone for the past and future list 
> exchanges.
> 
> Fred
> 
> -----Original Message----- From: I-D-Announce 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked] Sent: Friday, December 17, 2021 5:00 PM To:
>  [email-masked] Subject: I-D Action: 
> draft-templin-intarea-parcels-00.txt
> 
> 
> Title           : IP Parcels Author          : Fred L. Templin 
> Filename        : draft-templin-intarea-parcels-00.txt Pages : 8
> Date : 2021-12-17
> 
> Abstract: IP packets (both IPv4 and IPv6) are understood to contain a
> unit of data which becomes the retransmission unit in case of loss.
> Upper layer protocols such as the Transmission Control Protocol (TCP)
> carry multiple segments.

It sounds interesting.

But I wonder whether the IP parcel carries multiple TCP segments (TCP
payloads that dont have IP headers) or rather multiple IP packets (an IP
packet might carry a TCP payload)?

Maybe it's written in the draft, I will have to look.

> The parcel can be opened at middleboxes on the path with the included
> segments broken out into individual packets, then rejoined into one
> or more repackaged parcels to be forwarded further toward the final
> destination.  Reordering of segments within parcels is unimportant;
> what matters is that the number of parcels delivered to the final
> destination should be kept to a minimum, and that loss or receipt of
> individual segments (and not parcel size) determines the 
> retransmission unit.

The _segment_ is retransmitted upon segment loss or the entire parcel is?

Alex

> _______________________________________________ I-D-Announce mailing
>  list [email-masked] 
> https://www.ietf.org/mailman/listinfo/i-d-announce Internet-Draft 
> directories: http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> _______________________________________________ Int-area mailing
> list [email-masked]

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 21 Dec 2021 10:55:23 -0500

This idea has been used in ethernet backplanes (as well as cell based) in switches/routers. The term is frequenty referred to as "super framing" and has been for at least 20 years.

Maybe a suggestion of "super-packet" would be more appropriate. 

The idea works well in short/higher-reliability paths (between cards inside a switch backplane/internal-switch-fabric) but not sure it can be scaled up to a packet network. Note making packets gratiusioly large creates more elephant flows and head-of-line-blocking considerations.

Dino

> On Dec 21, 2021, at 10:02 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
>> Here's one that should help with shipping, just in time for Christmas. Thanks to everyone for the past and future list exchanges.
>> Fred
>> -----Original Message----- From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked] Sent: Friday, December 17, 2021 5:00 PM To:
>> [email-masked] Subject: I-D Action: draft-templin-intarea-parcels-00.txt
>> Title           : IP Parcels Author          : Fred L. Templin Filename        : draft-templin-intarea-parcels-00.txt Pages : 8
>> Date : 2021-12-17
>> individual segments (and not parcel size) determines the retransmission unit.
> 
>> The IETF datatracker status page for this draft is: https://datatracker.ietf.org/doc/draft-templin-intarea-parcels/
>> There is also an htmlized version available at: https://datatracker.ietf.org/doc/html/draft-templin-intarea-parcels-00
>> 
>> 
>> 
>> list [email-masked] https://www.ietf.org/mailman/listinfo/i-d-announce Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt