Subject: Re: [Int-area] Where/How is the features innovation happening?

From: Luigi Iannone <[email-masked]>
Date: Tue, 18 Jan 2022 12:27:30 +0100

Hi All,
 
Thank you all for the fruitful discussion in this thread.
I am trying to summarize a bit the discussion and here is what I see:
 
·         The ”where” is a 2-dimensional space:
o   Horizontal: Internet edge vs core. The criticality, scale, investment on the core of the Internet makes it more difficult to introduce innovation, while at the edges there is more flexibility.  At the edge of the Internet, it easier to introduce innovation for several reasons: Economics, faster ROI because of faster deployment; No need of large scale deployment (and hence less standardization effort);  less stakeholders involved (sometimes just one, see following point).
o   Vertical: at which layer of the protocol stack. The difficulty to innovate varies as well depending at which layer the innovation takes place. One thing is to innovate at application layer where the app developer has large degree of freedom, another is to innovate at network layer, which is more constrained because of its central point in the architecture. Innovation at higher layer sometimes leads to walled gardens (aka limited domains [RFC8799]). Indeed because of the centralization phenomena, an actor offering a certain service may very well develop and deploy a custom technology that does not need to be actually standardized because it is done for its own internal usage.  
 
·         Horizontal vs Vertical Innovation
o   In the public Internet, core innovation at lower layer is harder, often reduced to app-level innovation or building an overlay limited domain (aka a walled garden).
o   At the edges it is easier to  innovate at lower layers (more vertical flexibility) but some form of adaptation is needed if global reachability is wanted.
 
·         How much unique and globally routable an address should be?
o   With the effect of centralization, edges communicate with (rather) local DCs, hence a unique address globally routable is not a requirement anymore. Dino statement looks well summarizing this point: “We may not need globally unique addresses. But I need a unique address for anyone I want to talk to and I don't care what transmission networks my packets traverse.”
 
·         Flexibility in terms of address properties with respect to the intended use
o   Connection between my phone and my smart watch vs connection between my laptop and a forum of sensitive topics. Having multiple addresses with different properties and/or semantics, to be used depending on the purpose of the communication seems desirable.
 
·         Address privacy
o   This topic comes as a relevant question (also related to the previous point). The use of IPv6 temporary addresses brings benefits that are hard to quantify, and at the moment the best solution seems to be NAT-based. Privacy seems important since has been mentioned in the previous thread.
 
Do folks believe that the text above well summarizes the discussion we had?
 
Let me know
 
Ciao
 
L.
> On 16 Dec 2021, at 10:09, Luigi Iannone <[email-masked]> wrote:
> 
> Dear all,
>  
> We have had a very nice discussion in the previous thread about what kind of features we would want from the Internet. 
>  
> We wanted to come back on another interesting point that has been raised during the side meeting held during IETF 112, namely is where the innovation happening? 
> During the discussion in the side meeting, there was a short exchange between Dino, arguing about “decentralization”, and Michael stating that we are “rebuilding the edges”; the importance of the role of overlays was also briefly mentioned.
>  
> This is not a simple question, and may lead to an architectural argument, in line with Dirk K.’s viewpoint that only such architecture discussion may lead to possible changes to addressing, but also something that emerged in the previous thread. However, let’s at least start from the addressing perspective.
> Rebuilding the edges and utilizing decentralization may point to some approach to addressing that is not governed by a common addressing scheme.
> For instance, could we instead see a diversity of limited domain specific addressing schemes with most effort in ‘addressing’ being placed into the context translation that will need to inevitably happen? Or shall we instead follow the current path that forces the same context (IP semantics) to all participating edges (which goes counter the ‘rebuilding the edges’ comment)?
>  
> Hence the question we would like to discuss with you on: how/where innovation, realizing the features discussed in the previous thread, should happen?
>  
> This can help in strengthening the conclusion of the Problem Statement document (https://datatracker.ietf.org/doc/draft-jia-intarea-scenarios-problems-addressing/ <https://datatracker.ietf.org/doc/draft-jia-intarea-scenarios-problems-addressing/>), in order to provide input on which way to tackle the problem. 
>  
> Luigi
>  
> (on behalf of the co-authors)
>  
>

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 18 Jan 2022 15:48:16 -0800

I think it does but leave it to others to comment if complete.

Dino

> On Jan 18, 2022, at 3:27 AM, Luigi Iannone <[email-masked]> wrote:
> 
> Hi All,
>  
>> This can help in strengthening the conclusion of the Problem Statement document (https://datatracker.ietf.org/doc/draft-jia-intarea-scenarios-problems-addressing/), in order to provide input on which way to tackle the problem. 
>>  
>> Luigi
>>  
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area