Subject: [Int-area] The IETF Will Continue Maintaining IPv4 (draft-schoen-intarea-ietf-maintaining-ipv4) Re: 202203190720.AYC

From: "Abraham Y. Chen" <[email-masked]>
Date: Sat, 19 Mar 2022 07:49:02 -0400

Hi, Seth:

0)    Thanks for sharing your effort. It is very prudent and not one day 
too soon.

1)    I am new to this mailing list. Our team has worked out a scheme 
called EzIP, whereby the long-reserved 240/4 netblock may be utilized to 
expand the assignable IPv4 address pool significantly by deploying an 
overlay network. So, there will be no interference between the two. EzIP 
does not need any new protocol, but just makes use of RFC791. It not 
only resolves the IPv4 depletion issue, but also mitigates the root 
cause to cyber insecurity, plus offers facilities to conduct new 
experiments. However, attempts to convey this finding to the Internet 
community met puzzling responses. We could not comprehend how the 
primarily utilized protocol in the worldwide communication 
infrastructure could be treated as past tense. It is totally irrational.

2)    This draft by your team is very important for everyone to maintain 
the Internet at its healthiest state as possible. So that we can conduct 
productive dialogs.

Regards,

Abe (2022-03-19 07:48 EDT)
VP Engineering
Avinta Communications, Inc.
Milpitas, CA 95035 USA
eMail: [email-masked]
WebSite: www.Avinta.com

On 2022-03-15 15:00, [email-masked] wrote:
> ----------------------------------------------------------------------
Re: Int-area Digest, Vol 199, Issue 14
> Message: 1
> Date: Tue, 15 Mar 2022 11:59:20 -0700
> From: Seth David Schoen<[email-masked]>
> To: IETF intarea WG<[email-masked]>
> Cc: John Gilmore<[email-masked]>, Dave Taht<[email-masked]>
> Subject: [Int-area] New draft: The IETF Will Continue Maintaining IPv4
> 	(draft-schoen-intarea-ietf-maintaining-ipv4)
> Message-ID:<[email-masked]>
> Content-Type: text/plain; charset=us-ascii
>
> Hi intarea,
>
> When we presented our reserved address space drafts at the previous IETF
> meeting, we noticed that the most common concern was not so much about
> the substance of our proposals as about the question of whether intarea
> and the IETF should be working on IPv4 fixes at all.
>
> This question has been discussed on and off over the past few years. It
> was, in a way, the subject of an entire now-concluded working group in
> its own right (sunset4).  We thought we should go to the heart of the
> matter and propose to confirm that the IETF intends to keep maintaining
> IPv4.
>
> As our draft notes, this is the opposite of a proposed consensus item
> from sunset4 which stated that the IETF would stop working on IPv4.  That
> notion raised many concerns for community members, and we now hope to
> see whether a consensus to continue maintaining IPv4 can be found.
>
> Our draft emphasizes that IPv4 is the most-used network layer protocol
> in the world, that it's expected to be widely used for the foreseeable
> future, that the IETF is the historic home of IPv4 standardization, and that
> there continue to be coordination tasks for IPv4 implementations which
> the IETF is best-suited to host.  Those include not only our own proposals
> about address space, but also numerous work items on various IPv4 topics
> that have arisen and become RFCs over the past decade.
>
> Our draft does not question or alter the community's consensus in favor
> of IPv6 adoption, but states that neglecting IPv4 is not a part of the
> IETF's transition plan.
>
> You can find it at
>
> https://datatracker.ietf.org/doc/draft-schoen-intarea-ietf-maintaining-ipv4/
>
> We invite discussion leading up to our presentation and Q&A at the
> intarea session (13:30 UTC) on Tuesday, March 22, during IETF113 in
> Vienna.  Please let us know if you have any questions after reading the
> draft.
>
>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>
>
> ------------------------------
>
> End of Int-area Digest, Vol 199, Issue 14
> *****************************************

-- 
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 19 Mar 2022 17:21:06 -0700

Whether this document is needed or not, it would be useful to have ti focus on IPv4 issues.

Many of the examples of protocol updates in Sec 6 are not related to IPv4, e.g., TCP and DNS. The only arguable inclusion would be multicast DNS, but there is a big difference between extensions that work equally well for IPv4 and IPv6 and those focused on IPv4.

These examples should be removed.

Joe

—
Dr. Joe Touch, temporal epistemologist
www.strayalpha.com

> On Mar 19, 2022, at 4:49 AM, Abraham Y. Chen <[email-masked]> wrote:
> 
> Hi, Seth:
> 
> 0)    Thanks for sharing your effort. It is very prudent and not one day too soon.
> 
> 1)    I am new to this mailing list. Our team has worked out a scheme called EzIP, whereby the long-reserved 240/4 netblock may be utilized to expand the assignable IPv4 address pool significantly by deploying an overlay network. So, there will be no interference between the two. EzIP does not need any new protocol, but just makes use of RFC791. It not only resolves the IPv4 depletion issue, but also mitigates the root cause to cyber insecurity, plus offers facilities to conduct new experiments. However, attempts to convey this finding to the Internet community met puzzling responses. We could not comprehend how the primarily utilized protocol in the worldwide communication infrastructure could be treated as past tense. It is totally irrational.
> 
> 2)    This draft by your team is very important for everyone to maintain the Internet at its healthiest state as possible. So that we can conduct productive dialogs.
> 
> Regards,
> 
> eMail: [email-masked] <mailto:[email-masked]>
> WebSite: www.Avinta.com <http://www.avinta.com/>
> 
> 
> 
> 
> 
> 
> 
> 
> On 2022-03-15 15:00, [email-masked] <mailto:[email-masked]> wrote:
>> From: Seth David Schoen <[email-masked]> <mailto:[email-masked]>
>> To: IETF intarea WG <[email-masked]> <mailto:[email-masked]>
>> Cc: John Gilmore <[email-masked]> <mailto:[email-masked]>, Dave Taht <[email-masked]> <mailto:[email-masked]>
>> Message-ID: <[email-masked]> <mailto:[email-masked]>
>> https://datatracker.ietf.org/doc/draft-schoen-intarea-ietf-maintaining-ipv4/ <https://datatracker.ietf.org/doc/draft-schoen-intarea-ietf-maintaining-ipv4/>
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/int-area <https://www.ietf.org/mailman/listinfo/int-area>
>> 
>> 
>  <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient&utm_term=icon>	Virus-free. www.avast.com <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient&utm_term=link> <x-msg://26/#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>_______________________________________________
> Int-area mailing list
> [email-masked]