Subject: Re: [Int-area] IntArea WG Minutes IETF 113

From: "Templin (US), Fred L" <[email-masked]>
Date: Fri, 1 Apr 2022 15:19:12 +0000

Juan Carlos & Wassim – see below for corrections to the minutes:

Thank you - Fred

  1.  IP Parcels - Fred Templin
draft-templin-intarea-parcels - 15 min
     *   Fred: packet is the retransmission unit in case of lost. Have a packet of packets.
>> This is incorrect; what I said was that a “segment” is the retransmission unit in case of loss,
>> and a Parcel may contain multiple segments. In that sense, it is a packet-of-packets.

     *   Add a jumbo payload option and not 0 in payload length.
     *   IP parcels are based on IP Jumbograms, it can be supported in IPv6 and IPv4.
     *   Can we adopt the document as a WG Item ?
     *   JCZ: need support on the list
     *   Lars: how can this increase performance?
     *   Fred: it reduced the numbers of interrupts and the overhead of the parcel.
     *   Lars: We already do it on the ends, we have already these efficiencies.
     *   Fred: There is no additional efficiency over GSO?
     *   Fred: The end systems see the same efficiency that we see with GSO GRO TCP segment offload.
>> Because a Parcel may contain multiple segments, end systems will see better performance
>> than just using GSO/GRO when the Parcel is sent intact over links that have sufficient MTU.
>> Also, GSO/GRO are not and cannot be standardized, whereas IP Parcels can be.

     *   Luigi: How will the network have the ability to know how to use the parcel.
     *   Lars: We start to send regular IP packets and then you send the probe. If the probe succeeds you can then start using parcels.
>> It was me (Fred) who provided this answer, and not Lars.

     *   Luigi: What happens if links in the middle suport IP Parcels but the end doesn't.
     *   Lars: Then, it will be like regular IP packets.
>> Again, it was me (Fred) and not Lars who provided the answer. But, it was not made clear
>> that there are two kinds of Parcel-capable links – edge network links that support Parcels
>> natively, and the OMNI link in the middle of the network that supports Parcels through
>> the OMNI Adaptation Layer. There is no need for links in the middle of the network that
>> support Parcels natively.

From: Int-area [mailto:[email-masked]] On Behalf Of Juan Carlos Zuniga (juzuniga)
Sent: Tuesday, March 29, 2022 9:14 AM
To: [email-masked]
Subject: [EXTERNAL] [Int-area] IntArea WG Minutes IETF 113

EXT email: be mindful of links/attachments.

Hi all,

The minutes of the meeting have been uploaded.

A special note to thank Laurent and Ivan for helping with the notes!

https://datatracker.ietf.org/doc/minutes-113-intarea/

As usual, any comments/corrections on the minutes are welcome.

Best,

Juan Carlos & Wassim

---

From: "Juan Carlos Zuniga (juzuniga)" <[email-masked]>
Date: Wed, 6 Apr 2022 22:44:58 +0000

Hi Fred,

Thanks for the review. The minutes have been corrected accordingly.

https://datatracker.ietf.org/meeting/113/materials/minutes-113-intarea-04

Best,

Juan Carlos & Wassim

From: Templin (US), Fred L <[email-masked]>
Date: Friday, April 1, 2022 at 11:19 AM
To: Juan Carlos Zuniga (juzuniga) <[email-masked]>, [email-masked] <[email-masked]>
Subject: RE: IntArea WG Minutes IETF 113
Juan Carlos & Wassim – see below for corrections to the minutes:

Thank you - Fred

1.       IP Parcels - Fred Templin
draft-templin-intarea-parcels - 15 min
o    Fred: packet is the retransmission unit in case of lost. Have a packet of packets.
>> and a Parcel may contain multiple segments. In that sense, it is a packet-of-packets.
o    Add a jumbo payload option and not 0 in payload length.
o    IP parcels are based on IP Jumbograms, it can be supported in IPv6 and IPv4.
o    Can we adopt the document as a WG Item ?
o    JCZ: need support on the list
o    Lars: how can this increase performance?
o    Fred: it reduced the numbers of interrupts and the overhead of the parcel.
o    Lars: We already do it on the ends, we have already these efficiencies.
o    Fred: There is no additional efficiency over GSO?
o    Fred: The end systems see the same efficiency that we see with GSO GRO TCP segment offload.
>> Also, GSO/GRO are not and cannot be standardized, whereas IP Parcels can be.
o    Luigi: How will the network have the ability to know how to use the parcel.
o    Lars: We start to send regular IP packets and then you send the probe. If the probe succeeds you can then start using parcels.
>> It was me (Fred) who provided this answer, and not Lars.
o    Luigi: What happens if links in the middle suport IP Parcels but the end doesn't.
o    Lars: Then, it will be like regular IP packets.

Hi all,

Best,

Juan Carlos & Wassim

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 7 Apr 2022 19:38:52 +0000

Thanks,

Fred

From: Juan Carlos Zuniga (juzuniga) [mailto:[email-masked]]
Sent: Wednesday, April 06, 2022 3:45 PM
To: Templin (US), Fred L <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Re: IntArea WG Minutes IETF 113

Hi Fred,

Best,

Juan Carlos & Wassim

From: Templin (US), Fred L <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 1, 2022 at 11:19 AM
To: Juan Carlos Zuniga (juzuniga) <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: RE: IntArea WG Minutes IETF 113
Juan Carlos & Wassim - see below for corrections to the minutes:

Thank you - Fred

>> This is incorrect; what I said was that a "segment" is the retransmission unit in case of loss,
>> that there are two kinds of Parcel-capable links - edge network links that support Parcels

From: Int-area [mailto:[email-masked]] On Behalf Of Juan Carlos Zuniga (juzuniga)
Sent: Tuesday, March 29, 2022 9:14 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [EXTERNAL] [Int-area] IntArea WG Minutes IETF 113

Hi all,

Best,

Juan Carlos & Wassim