Subject: [Int-dir] INTDIR Review of draft-ietf-i2nsf-nsf-monitoring-data-model-14

From: Donald Eastlake <[email-masked]>
Date: Tue, 8 Feb 2022 00:56:23 -0500

I am an assigned INT directorate reviewer for <
*draft-ietf-i2nsf-nsf-monitoring-data-model-14*>. These comments were
written primarily for the benefit of the Internet Area Directors. Document
editors and shepherd(s) should treat these comments just like they would
treat comments from any other IETF contributors and resolve them along with
any other Last Call comments that have been received. For more details on
the INT Directorate, see https://datatracker.ietf.org/group/intdir/about/ <
https://datatracker.ietf.org/group/intdir/about/>.

*Based on my review, if I was on the IESG I would ballot this document as
DISCUSS due to one item.*
*I have the following DISCUSS issue:*

It looks to me like Section 6.2.2 is just about notification of
configuration change but some of the subpoints under seem to be about
errors and/or seem to have been copied from 6.2.1 without change when they
should have been edited.

*The following are other issues I found with this document that SHOULD be
corrected before publication:*

Section 4, first sentence: I don't think "consuming" is the right word.
Perhaps "checking".

Section 4, 2nd paragraph: So, three domains of monitoring data are
"highlighted", which sounds like incomplete coverage. But in other places,
the word "comprehensive" is used. Does this document encompass all
monitoring data and if not can you describe the subset covered in some more
specific way than saying it is the "basic" data? This document should be
clear which it is.

Sections 6.3.1 through 6.3.5 discuss a number of types of events. Are those
the only events that can be reported? Does the document indicate whether
the list of event types is complete or not? To a lesser extent this comment
may apply to other 6.*.* sections.

*The following are minor issues with the document:*

Section 4.2, Should "*the information of sessions and** traffic flows"
be* "information
about sessions and traffic flows" ?

Section 4.3. Since they are called simply "push" and "pull" elsewhere in
the draft, why are these longer and more confusing "unsolicited poll" and
"solicited pull" used here?

Section 6: Uses of "unsolicited information" should probably be replaced by
wording using "push".

Sections 6.3.2, 6.3.3, 6.3.4, 6.3.5 all talk about reporting geographic
location. Who figures out what that information is? How accurate does it
need to be?

Numerous minor grammer things as marked on the attached document.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 9 Feb 2022 10:59:43 +0000

Thank you, Donald, for your review for the INT directorate.

As you may have seen, I have used your review for my DISCUSS ballot.

Regards

-éric

From: iesg <[email-masked]> on behalf of Donald Eastlake <[email-masked]>
Date: Tuesday, 8 February 2022 at 06:57
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: INTDIR Review of draft-ietf-i2nsf-nsf-monitoring-data-model-14

I am an assigned INT directorate reviewer for <draft-ietf-i2nsf-nsf-monitoring-data-model-14>. These comments were written primarily for the benefit of the Internet Area Directors. Document editors and shepherd(s) should treat these comments just like they would treat comments from any other IETF contributors and resolve them along with any other Last Call comments that have been received. For more details on the INT Directorate, see https://datatracker.ietf.org/group/intdir/about/ <https://datatracker.ietf.org/group/intdir/about/>.

Based on my review, if I was on the IESG I would ballot this document as DISCUSS due to one item.

I have the following DISCUSS issue:
It looks to me like Section 6.2.2 is just about notification of configuration change but some of the subpoints under seem to be about errors and/or seem to have been copied from 6.2.1 without change when they should have been edited.

The following are other issues I found with this document that SHOULD be corrected before publication:

Section 4, first sentence: I don't think "consuming" is the right word. Perhaps "checking".

Section 4, 2nd paragraph: So, three domains of monitoring data are "highlighted", which sounds like incomplete coverage. But in other places, the word "comprehensive" is used. Does this document encompass all monitoring data and if not can you describe the subset covered in some more specific way than saying it is the "basic" data? This document should be clear which it is.

Sections 6.3.1 through 6.3.5 discuss a number of types of events. Are those the only events that can be reported? Does the document indicate whether the list of event types is complete or not? To a lesser extent this comment may apply to other 6.*.* sections.

The following are minor issues with the document:

Section 4.2, Should "the information of sessions and traffic flows" be "information about sessions and traffic flows" ?

Section 4.3. Since they are called simply "push" and "pull" elsewhere in the draft, why are these longer and more confusing "unsolicited poll" and "solicited pull" used here?

Section 6: Uses of "unsolicited information" should probably be replaced by wording using "push".

Sections 6.3.2, 6.3.3, 6.3.4, 6.3.5 all talk about reporting geographic location. Who figures out what that information is? How accurate does it need to be?

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]<mailto:[email-masked]>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 16 Feb 2022 01:33:55 +0900

Hi Donald,
Here is the revised draft reflecting your comments:
https://datatracker.ietf.org/doc/html/draft-ietf-i2nsf-nsf-monitoring-data-model-15

I attach the revision letter to explain how the revision
is done by Patrick and me for your comments.

[Review by Donald E. Eastlake and Response by Authors] starts from page 16
in the revision letter.

Thanks for your valuable comments and help.

Best Regards,
Paul

On Wed, Feb 9, 2022 at 7:59 PM Eric Vyncke (evyncke) <[email-masked]>
wrote:

> *From: *iesg <[email-masked]> on behalf of Donald Eastlake <
> [email-masked]>
> *Date: *Tuesday, 8 February 2022 at 06:57
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *"[email-masked]" <
> [email-masked]>, "
> [email-masked]" <[email-masked]>
> *Subject: *INTDIR Review of draft-ietf-i2nsf-nsf-monitoring-data-model-14
>
>
>
> the INT Directorate, see https://datatracker.ietf.org/group/intdir/about/
> <https://datatracker.ietf.org/group/intdir/about/>.
>
>
>
>
> DISCUSS due to one item. *
> Sections 6.3.1 through 6.3.5 discuss a number of types of events. Are
> those the only events that can be reported? Does the document indicate
> whether the list of event types is complete or not? To a lesser extent this
> comment may apply to other 6.*.* sections.
>
>
> * The following are minor issues with the document:*
>
>
>
> Section 4.2, Should "*the information of sessions and traffic flows" be* "information