Subject: [Int-dir] FW: Proposed change to review assignment email subject

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 30 Mar 2022 06:08:45 +0000

Forwarding Robert's email just in case some filters were too paranoid and dropped it ;-)

-éric

-----Original Message-----
From: OPS-DIR <[email-masked]> on behalf of 	
Reply to: tools-discuss <[email-masked]>
Date: Tuesday, 29 March 2022 at 17:31
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [OPS-DIR] Proposed change to review assignment email subject

    Please take note of 
    https://github.com/ietf-tools/datatracker/discussions/3760. If the 
    change proposed there will cause problems for you, add a comment there, 
    or reply to [email-masked] to let us know.

    RjS

---

From: Tim Chown <[email-masked]>
Date: Wed, 30 Mar 2022 15:14:36 +0000

Hmm, I would avoid any instance of the draft name in the subject line.

Or do we have to say that in git? 

Tim

> On 30 Mar 2022, at 07:08, Eric Vyncke (evyncke) <evyncke=[email-masked]> wrote:
> 
> _______________________________________________
> Int-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-dir

---

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Mar 2022 12:43:41 -0400

That's my preference too, but we had one very strong objection. :(

It would probably be worth putting it in the github.

On Wed, Mar 30, 2022 at 11:14 AM Tim Chown <Tim.Chown=
[email-masked]> wrote:

> > To: "[email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>,
> "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>

---

From: Robert Sparks <[email-masked]>
Date: Wed, 30 Mar 2022 12:17:54 -0500

> Hmm, I would avoid any instance of the draft name in the subject line.

The draft name MUST be on the subject line.

Many people search the archives (using mailarchive) for messages related 
to drafts looking for the draft name in the subject line. The 
datatracker even assumes this with the searches it provides in the 
buttons on a document's page.

RjS

> Or do we have to say that in git?
Do you mean github? If so, then no - participating on lists is fine (but 
this really should have gone to tools-discuss).

---

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Mar 2022 13:29:19 -0400

Do notifications to reviewers go in the archive?  If so, why?  Could we
have one for the archive and one for the reviewer?  It seems to me that
these are two separate functions. I don’t understand the first, but don’t
object to it. I do object to the second being compromised in favor of the
first.

---

From: Robert Sparks <[email-masked]>
Date: Wed, 30 Mar 2022 12:42:26 -0500

On 3/30/22 12:29 PM, Ted Lemon wrote:
> Do notifications to reviewers go in the archive? If so, why?
Fair point - I'll look to confirm. But even if they don't, I know of 
users that have filters in their own mail processing chains that look 
for draft names in the subject line.
> Could we have one for the archive and one for the reviewer?  It seems 
> to me that these are two separate functions. I don’t understand the 
> first, but don’t object to it. I do object to the second being 
> compromised in favor of the first.
>
>     >> On 30 Mar 2022, at 07:08, Eric Vyncke (evyncke)
>     <evyncke=[email-masked]> wrote:
>     >>
>     >> To: "[email-masked]" <[email-masked]>,
>     "[email-masked]" <[email-masked]>,
>     "[email-masked]" <[email-masked]>, "[email-masked]"
>     <[email-masked]>, "[email-masked]"
>     <[email-masked]>, "[email-masked]" <[email-masked]>,
>     "[email-masked]" <[email-masked]>, "[email-masked]"
>     <[email-masked]>, "[email-masked]" <[email-masked]>,
>     "[email-masked]" <[email-masked]>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Mar 2022 13:43:45 -0400

Sure, but I would think that we /wouldn't/ want a review notification to
match that rule, right? Otherwise it's going to get filed in the bucket for
the draft and possibly not land on the reviewer's to-do list.

On Wed, Mar 30, 2022 at 1:42 PM Robert Sparks <[email-masked]> wrote:

> Fair point - I'll look to confirm. But even if they don't, I know of users
> that have filters in their own mail processing chains that look for draft
> names in the subject line.
>
> Could we have one for the archive and one for the reviewer?  It seems to
> me that these are two separate functions. I don’t understand the first, but
> don’t object to it. I do object to the second being compromised in favor of
> the first.
>
>> [email-masked]" <[email-masked]>, "[email-masked]" <
>> [email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <
>> [email-masked]>

---

From: Robert Sparks <[email-masked]>
Date: Wed, 30 Mar 2022 15:03:38 -0500

On 3/30/22 12:43 PM, Ted Lemon wrote:
> Sure, but I would think that we /wouldn't/ want a review notification 
> to match that rule, right? Otherwise it's going to get filed in the 
> bucket for the draft and possibly not land on the reviewer's to-do list.

Ted - Other people _want_ these to go into their draft buckets. People 
have their own workflows, and having draft names in these announcements 
are already part of them.

When I am scanning email, I _personally_  want to see the draft name in 
the subject - a long string of things with a semantic of "you have a new 
review assignment, read the message or click on some links to find out 
what it is" is not welcome. Further, if I had some reason to go back 
later and find the message that pertained to a particular draft, such 
mining would not be ok.

RjS

>     Fair point - I'll look to confirm. But even if they don't, I know
>     of users that have filters in their own mail processing chains
>     that look for draft names in the subject line.
>>     Could we have one for the archive and one for the reviewer?  It
>>     seems to me that these are two separate functions. I don’t
>>     understand the first, but don’t object to it. I do object to the
>>     second being compromised in favor of the first.
>>
>>         <[email-masked]>, "[email-masked]"
>>         <[email-masked]>, "[email-masked]" <[email-masked]>,
>>         "[email-masked]" <[email-masked]>, "[email-masked]"
>>         <[email-masked]>, "[email-masked]" <[email-masked]>

---

From: Tim Chown <[email-masked]>
Date: Thu, 31 Mar 2022 08:58:54 +0000

On 30 Mar 2022, at 21:03, Robert Sparks <[email-masked]> wrote:
>> Sure, but I would think that we /wouldn't/ want a review notification to match that rule, right? Otherwise it's going to get filed in the bucket for the draft and possibly not land on the reviewer's to-do list.
> Ted - Other people _want_ these to go into their draft buckets. People have their own workflows, and having draft names in these announcements are already part of them.

So send a separate alert to the reviewer, please, that is in a format least likely to be misfiled, parsed or spam foldered.

The subject can simply be “New INT-DIR assignment” or something simple like that.  Without any draft name.

That MUST be possible.

And I really think this should be discussable and resolved here and not require us to engage in the Git issue tracker.

> When I am scanning email, I _personally_  want to see the draft name in the subject - a long string of things with a semantic of "you have a new review assignment, read the message or click on some links to find out what it is" is not welcome. Further, if I had some reason to go back later and find the message that pertained to a particular draft, such mining would not be ok.

A search can include the message body.  The current problem is clean receipt.

Tim

---

From: Robert Sparks <[email-masked]>
Date: Thu, 31 Mar 2022 09:42:57 -0500

> So send a separate alert to the reviewer, please, that is in a format least likely to be misfiled, parsed or spam foldered.
That assumes that the likelihood function you point to is the same for 
everyone, and we're seeing already that it is not. Removing the draft 
name will introduce errors for some and apparently introduce them for 
others.
> The subject can simply be “New INT-DIR assignment” or something simple like that.  Without any draft name.
This is starting to sound like a need for personalized subject lines. 
Would the calendar subscription suggestion made earlier better fill the 
need?
>
> And I really think this should be discussable and resolved here and not require us to engage in the Git issue tracker
I already said that it was I thought? But this should move to 
tools-discuss so we can get all the concerned review team members on one 
thread (I've added a Reply-To).
> A search can include the message body.

Not really the right answer in modern mail clients with the volume of 
mail someone on the I* or who does work in many working groups has to 
see through.

>    The current problem is clean receipt.

And we're disagreeing on one part of what clean receipt requires.

---

From: Tim Chown <[email-masked]>
Date: Thu, 31 Mar 2022 15:18:19 +0000

Well, then just send two emails, one in old school format, one as a ‘flare’ for attention.

Then those who like it as it is have what they need, and those who are missing assignments have a greater chance of not doing so.

Tim

> On 31 Mar 2022, at 15:42, Robert Sparks <[email-masked]> wrote:
> 
> 
> That assumes that the likelihood function you point to is the same for everyone, and we're seeing already that it is not. Removing the draft name will introduce errors for some and apparently introduce them for others.
>> 
> This is starting to sound like a need for personalized subject lines. Would the calendar subscription suggestion made earlier better fill the need?
>> 
> I already said that it was I thought? But this should move to tools-discuss so we can get all the concerned review team members on one thread (I've added a Reply-To).
>> 
> Not really the right answer in modern mail clients with the volume of mail someone on the I* or who does work in many working groups has to see through.
>