Subject: [iola-wgcharter-tool] Fwd: Trial site available for WG Charter Tool

From: Robert Sparks <[email-masked]>
Date: Thu, 1 Sep 2011 16:07:16 -0500

I tried to test this tool this afternoon, and quickly ran into a crash - the traceback is attached.

Some questions/observations to help with my next attempt to test:

1) It was not obvious where the tool was - Henrik pointed me to the new "Working Groups" link under
the secretariat portion of the left navigation bar. Is that the only point of entry? 

2) I tried to create a new group from scratch leading to the attached crash - The crash happened before it
asked me for charter text - was that going to be on the next page? On the page that it did provide me, it asked
several questions that seem to be out of place (or at least fairly high-impedence) - asking for a mailing list,
the subscription link, and the archive link separately. It's also asking for chairs/advisors/etc at the very beginning.
In the normal case for a brand new working group, that's information that will come later. Is it the expectation that
the initial form will have lots of empty fields when submitted - if so, would it make more sense to design an initial
form that captured what would normally be populated, and an edit form that let you add these other things as they
became available?

3) How do you start an action on an existing working group? Is that integrated into the existing working group pages
in any way? (It's really not obvious that you should hit the "create WG" button if you're wanting to start a charter update
effort.)

4) You might consider offering a way to edit a charter version online instead of only through a file upload.

5) I tried to take the AUN group that's there through to approved so I could start a recharter effort on that
(to see if I could get a charter-ietf-aun-01-00). But I can't see how it's possible to do that. Can you describe the path
for me? (This might be the same answer as for 3).

6) Is there anything that the tool does when a charter is marked as in the approved state other than just capturing
that state? Does it touch any other tables/create or update the published wg charter/etc. or is it expected that is still
manual secretariat action?

RjS

Begin forwarded message:

> From: Russ Housley <[email-masked]>
> Date: August 30, 2011 5:20:30 PM CDT
> To: IESG <[email-masked]>
> Cc: Henrik Levkowetz <[email-masked]>
> Subject: Fwd: Trial site available for WG Charter Tool
> 
> Since ADs will be the users of this tool, I would like to have a few volunteers to make sure it does what we want.
> 
> Russ
> 
> 
> Begin forwarded message:
> 
>> From: Henrik Levkowetz <[email-masked]>
>> Date: August 30, 2011 11:25:49 AM EDT
>> To: [email-masked], Ray Pelletier <[email-masked]>
>> Subject: [iola-wgcharter-tool] Trial site available for WG Charter Tool
>> 
>> Hi,
>> 
>> The developer (Martin Qvist, IOLA) has now indicated that he's done with
>> the development of the WG Charter tool (as far as he can tell, from his
>> end of things).
>> 
>> There is a trial version of the tool available here:
>> 
>> http://beta.iola.dk:10003/
>> 
>> It would be helpful if we could get some testers to exercise the tool
>> now!
>> 
>> 
>> (There is one issue which I'll take up for discussion in a separate message;
>> and that's a possible issue with the specification rather than the code.)
>> 
>> 
>> Best regards,
>> 
>> 	Henrik
>

---

From: Martin Qvist <[email-masked]>
Date: Fri, 02 Sep 2011 11:24:13 +0200

Hi

> the secretariat portion of the left navigation bar. Is that the only

No, the main entry point is the "WG Records" entry under Other Documents 
in the main menu. This is also the place you can search through the WG 
records.

The thought behind separating normal WG info (what's found under /wg/) 
and the WG records (what's found under /wgrecord/) was to separate 
normal (active) WG work from the history and chartering processes of a 
WG. If you prefer we could merge the two more, e.g. under /wg/, or 
perhaps just put in some buttons for rechartering etc.

> asked me for charter text - was that going to be on the next page? On
> the page that it did provide me, it asked
> several questions that seem to be out of place (or at least fairly
> high-impedence) - asking for a mailing list,
> the subscription link, and the archive link separately. It's also asking
> for chairs/advisors/etc at the very beginning.
> In the normal case for a brand new working group, that's information
> that will come later. Is it the expectation that
> the initial form will have lots of empty fields when submitted - if so,
> would it make more sense to design an initial
> form that captured what would normally be populated, and an edit form
> that let you add these other things as they
> became available?

It was a bug in the urls field. It's fixed now. The submission of a 
charter text is done after the group is created (via submission of a 
.txt file). I made it this way because the RFC indicated that you should 
be able to create a WG with no other information than a name and an acronym.

The rest of the fields are optional (in fact the create and edit info 
pages run the same code). I guess we could make a special page for 
creation which has fewer fields. Which fields do you think it should 
contain?

> 3) How do you start an action on an existing working group? Is that
> integrated into the existing working group pages
> in any way? (It's really not obvious that you should hit the "create WG"
> button if you're wanting to start a charter update
> effort.)

No, the idea was to go through WG Records (in Other Documents), then 
search for the WG, and then change state accordingly (to e.g. Informal 
IESG Review). This starts the rechartering process. But you're right, 
there should be a "Recharter" button or some connection on the regular 
view under /wg/.

> instead of only through a file upload.

Sure, I could do that. Would you like both options, or only online?

> (to see if I could get a charter-ietf-aun-01-00). But I can't see how
> it's possible to do that. Can you describe the path

The revision would be set when you upload a new charter text. Until that 
happens the WG Record shows charter-ietf-aun-01 even though it might be 
in state Informal IESG Review.

> 6) Is there anything that the tool does when a charter is marked as in
> the approved state other than just capturing
> that state? Does it touch any other tables/create or update the
> published wg charter/etc. or is it expected that is still

There are two ways to "go" to an approved state. One way is to approve a 
ballot (on the ballot page). This copies the most recent proposed 
charter, e.g. revision 02-04, to an approved revision, e.g. 03, and sets 
that state of the charter to approved. The other way is to just set the 
state to approved. This does not copy the proposed charter, in the above 
case the active charter would remain revision 02. I made this option for 
when a rechartering process is abandoned.

Best,
Martin

---

From: Robert Sparks <[email-masked]>
Date: Tue, 13 Sep 2011 14:15:38 -0500

I haven't seen any response to this. 

I'd still like to help test the tool, but can't make progress without feedback.

RjS

On Sep 1, 2011, at 4:07 PM, Robert Sparks wrote:

> <AttributeError at _wgrecord_create_.html>
> 
> Begin forwarded message:
>