Subject: Re: address portability

From: Daniel Karrenberg <[email-masked]>
Date: Thu, 16 Jul 1998 11:43:31 +0200

[note that I am not on most of these lists, apologies iin case 
I repeat what others have said on the lists]

Steve Bellovin has summed it up quite nicely.  The issue is purely a
(technical) matter of routing complexity.  There is a large body of
technical discussion on the matter in the IETF (cidrd and other wgs) and
it is a closed case until somebody invents a novel way of doing IP
routing.  I might add that CIDR and its associated topology driven
address space distribution mechanisms were a 'just in time' development 
as serious routing problems were looming much closer than the horizon. 

Also it is important to realise that number portability is *only* an
issue because of the amount of engineering work associated with
renumbering.  It is not an issue because the numbers are visible to the
end-user and as such have recognition or other value, such as well known
telephone numbers. I am starting to hear less-than-clueful know-it-all
political types call for portable IP numbers 'because we have portable
800 numbers'. That is scary!

A more tenable technical soloution to the renumbering problem that does
not require invention but 'only' implementation is automatic renumbering
which, contrary to popular belief, can be implemented in IPv4 via DHCP. 
It just is not straightorward because doing it right needs a lot of
expertise about its interactions with various related things like DNS and
routing.  It has been done successfully at large sites.  Automatic
renumbering is also an integral part of the IPv6 design. 

Summary: This is a non issue which will be solved by automatic 
renumbering.

Kind regards

Daniel Karrenberg 
RIPE NCC Manager

---

From: "Jim Fleming" <[email-masked]>
Date: Thu, 16 Jul 1998 09:22:24 -0500

-----Original Message-----
From: Daniel Karrenberg <[email-masked]>
<snip>
>800 numbers'. That is scary!

Daniel,

I think that you are seeing and/or hearing the
discussions because of the double standards
being endorsed by the I* MLM community. On
one hand they want to restrain trade in the registry
industry by controlling TLD registries and the
domain name space and on the other hand
organizations inside the I* MLM pyramid are
encouraged to charge high fees for monopoly
services related to IP address allocations.

One of the reasons often used to attempt to
control the domain name space is that people
will be "locked-in" and subject to horrible
economic practices of the registries which
have yet to do those horrible things. It is only
natural that people interested in domain names
would point out that the I* MLM pyramid locks
people into the horrible economic practices
of the IP address allocation business (which
is really just the .ARPA TLD domain business).

The double standard is that people enjoying
the economic benefits of the I* MLM IP allocation
pyramid do not acknowledge that they are
practicing what they tell others needs to be
avoided or at least feared. The irony of all of
this is the I* community claims to be protecting
people from the horrible government bureaucracies
of the world, yet they have become a bureaucracy
worse than the government because they do
not have the support of all citizens, just a small
number of netizens who are clearly happy
when policies funnel the money into their pockets,
as they block the way for anyone else to develop
businesses that they do not pay "cyber-taxes" in
some manner.

The hypocrisy is clear and people are reacting.

Jim Fleming
Unir Corporation - http://www.unir.com