Subject: Re: (ION) IPng Over ATM - Opinions solicited

From: Vadim Antonov <[email-masked]>
Date: Tue, 31 Mar 1998 13:41:50 -0800 (PST)

With all my respect, you'd be much better off doing research
in vacuum acoustics.

Both ATM and IPv6 are firmly on OSI trajectory: from handwaving
to oblivion.

--vadim

>I am a graduate student of Computer Science in Temple Univ., Philadelphia.
>I am doing a independent study on the topic "IPng over ATM".
X-Info: To unsubscribe, email [email-masked]' with
X-Info: 'unsubscribe ion' in the body of the message.

---

From: Albert Manfredi <[email-masked]>
Date: Tue, 31 Mar 1998 17:39:50 -0500

> Both ATM and IPv6 are firmly on OSI trajectory: from handwaving

That's pretty cute, Vadim. Vacuum acoustics is in fact fascinating.
We use low-frequency photons to accomplish this seemingly impossible
feat.

You know, the dynamics of what you are describing is probably lost
in the derogatory reference to OSI (I assume you meant ISO
protocols). The real story is different, in my opinion.

When the ISO network protocols were being developed as a better way
to do this data stuff than IP, IP was the simple-but-it-works-now
incumbent. OSI became irrelevant not so much because it was overly
bureaucratic, but because it was an unnecessary change. Not "better
enough."

IP prided itself on its unbureaucratic success, but now that it's so
widely used, it's nearly impossible to upgrade it. In other words,
what folk dislike about the rigid telephone industry is what IP is
evolving into. For exactly the same reasons. Not because people are
stupid, but because a widely used standard becomes at the same time
an impediment to progress. Standards impede progress, eventually.
Happens every _single_ time. Yet, nothing in this business can
succeed without standards. Catch 22.

I know from past exchanges with you that you are of the school that
whatever IP cannot handle today it will be capable of tomorrow
anyway, simply because we will have a lot of excess bandwidth to
throw at it. Maybe so, probably not even close.

ATM is now being deployed by the telephone carriers, basically
according to their original plans. If ATM becomes deployed and
available to the degree that, for example, SONET has been, I would
predict that its ubiquitousness will make it quite useful and
certainly a credible aid to good old IPv4, in the WAN especially. In
my view, that is the only way ATM can succeed: as a universal
solution for the WAN. Because there's nothing else yet that can do
the job. Not today.

It's really up to the carriers. If they see their current n*64
structure as a liability for the future, they will implement ATM. In
my mind, they could _not_, however, implement IPv4 _instead_. And
that is the key point.

Bert
[email-masked]
X-Info: To unsubscribe, email [email-masked]' with
X-Info: 'unsubscribe ion' in the body of the message.

---

From: Vadim Antonov <[email-masked]>
Date: Tue, 31 Mar 1998 15:14:10 -0800

> protocols). The real story is different, in my opinion.

I meant Open System Interconnect architecture.

> bureaucratic, but because it was an unnecessary change. Not "better

 Yep.  It was demonstrated that IPv6 doesn't do anything which cannot be done now with IPv4 - check Yakov Rechter's and Tony Li's presentation at
 the last NANOG.  Similarly, ATM's only advantage is easy integration with
 legacy synchronous voice carriers - which becomes largely irrelevant with
 voice traffic becoming a minor part of overall traffic.

 In other words - both IPv6 and ATM not "better enough" but come at an
 enormous price.   Just like OSI.

> evolving into.

 Yawn.   If you have any worthy idea it'll be stolen and widely deployed in a year or so.  Examples are too numerous to enlist.  On the other
 hand Internet commuity at large is quite reluctant to change anything
 just for the sake of changing.

> For exactly the same reasons. Not because people are

 If you think that Internet works because of standards you're in a state
 of serious denial.  Most RFCs are just junk.  The "standard" ones typically
 either obsolete or require quite creative interpretation - if you want to end
 up with a working system.   Or try to find formal description of such critical
 things as TCP congestion avoidance (hint: it is not in RFCs) or the iBGP
 hack.

> throw at it. Maybe so, probably not even close.

 My VCs think otherwise.  They're the same people who funded WDM development, surprise, surprise.  And, oh, yeah, there are small carriers
 which have, like, 2+ Tbps capacity on their 16k miles of fiber.  Today.

> according to their original plans.

 With one small exception - profits are conspiciously absent.

> If ATM becomes deployed and
> certainly a credible aid to good old IPv4, in the WAN especially.

 One can hope that no carrier is going to be that silly.

> In my view, that is the only way ATM can succeed: as a universal

 Goodbye clue.  What exacty you cannot do with a native IP backbone? It is known for sure that it is _impiossible_ to build a global native-ATM
 network of a size comparable to the Internet.

> my mind, they could _not_, however, implement IPv4 _instead_. And

 How funny.  I talked to all major carriers - and all their data folks are quite sure that native IP is what they're going to do in the foreseeable future.
 Of course, their "strategic planning" propellerheads are all about ATM.

--vadim

---

From: Ramana Gollamudi <[email-masked]>
Date: Tue, 31 Mar 1998 19:52:29 -0500

>  Of course, their "strategic planning" propellerheads are all about ATM.

In Vadim's mail there is a reference to "voice traffic becoming a minor part of overall traffic". Are there any studies which show the ratio of voice and data
traffic in today's networks?.
Second, are there some any references to determine what will be ratio of future traffic in near and long term and how much the overall traffic will be?
As of now, data traffic is growing at a much higher rate than voice traffic. Will this continue to be true once there is lot of bandwidth and low costs to
customers for sending voice traffic too.

Ramana

---

From: Woo-June Kim <[email-masked]>
Date: Tue, 31 Mar 1998 09:48:24 -0500

> customers for sending voice traffic too.

Well, though I don't know about any specific studies (though I'm sure there are
plenty of them), it stands to reason that voice by itself will not be much of
contributer in pure volume. This is due to the fact that voice per person is at
most 64kbps (unless you go for stereo etc. which I shall ignore), with less than
16kbps looking likely for internet telephony. Compare this with the volume of
web traffic a single web user generates. Images etc. soon addup to Mbps or more.
So based on this sort of reasoning one could say that ATM is a dead end. 

But the reasoning between this fast and loose reasoning should be examined a bit
more carefully.

First, the impact of voice will not be through its volume, but its QOS
requirements, i.e. minimal delay and minimum bandwidth. Which may or may not be
solved simply by throwing more bandwidth. It may require sophisticated queueing
etc. in the routers. Of course all of these are currently being developed by the
IETF int-serv work group, but ATM supports these natively. (Or at least was
supposed to, VTOA doesn't seem to be doing to well lately :->)

Second, the other real-time traffic component of the future, is video. And this
service may be capable of generating Mbps of bandwidth usage. At the same time
it will have stringent real-time QOS requirements, similar but not the same as
voice. (In fact there might be some large differences due to their respective
tolerences to loss and delay etc.) Again as in voice, this is the sort of
traffic for which ATM is natural. (Well at least supposed to be.. )

bye

-- 
Woo-June Kim
Lucent Technologies
Rm 1A203 
600 Mountain Ave.
Murray Hill, NJ, 07974
tel : +1-908-582-5920
fax : +1-908-582-4633
e-mail : [email-masked]

---

From: Vadim Antonov <[email-masked]>
Date: Tue, 31 Mar 1998 19:35:32 -0800

Woo-June Kim wrote:

> supposed to, VTOA doesn't seem to be doing to well lately :-?)

 There's no need for overly fancy stuff in routers - it is sufficient to do simple
 per-packet prioritites which were in IP from the day one.  Needless to say, that
 functionality is already implemented in all real routers.

> voice.

 Video is not like voice.  Most of video traffic is likely to be "canned" content - i.e. something which doesn't require real-time guarantees.  Additionally, unlike voice,
 video has a lot more flexibility in accomodating reduced transmission rates.

> (In fact there might be some large differences due to their respective

 ATM is natural only for a bellhead's mind bent on per-minute charges.

--vadim

---

From: Albert Manfredi <[email-masked]>
Date: Wed, 01 Apr 1998 10:04:23 -0500

Ramana Gollamudi wrote:

> In Vadim's mail there is a reference to "voice traffic becoming a
> minor part of overall traffic". Are there any studies which show
> the ratio of voice and data traffic in today's networks?
>
> Second, are there some any references to determine what will be
> ratio of future traffic in near and long term and how much the
> overall traffic will be?
>
> As of now, data traffic is growing at a much higher rate than
> voice traffic. Will this continue to be true once there is lot of
> bandwidth and low costs to customers for sending voice traffic
> too.

In my opinion, Vadim is one of many who take a snapshot in time and
think it is the long-term trend. Let's look at the whole picture.

In the beginning of electric telecommunications was character-based
data: telegraph. That's all the state of the art would support.

Then came voice, with telephone and radio. It far outstripped volume
of character-based data communications.

Then data transfer became large again, primarily because the
electronics industry was getting into office automation.

The next big push is personal communication devices, voice and
video-based. Articles I've read indicate that those who worry about
these things predict a shift _away_ from keyboards. It makes perfect
sense. Keyboards work when you can concentrate on them only. You
can't walk through a mall or drive in traffic while using a
keyboard. But humans _can_ communicate with sound and can see while
doing other things with their hands. Amazing.

With voice and video, you will not be able to use the same solutions
as character-based data comms. So I don't think it's wise to assume
that just because you can browse the web, you've got all the
problems licked.

At least, though, Vadim is consistent. He doesn't believe in
VC-based commincations _or_ in the possible success of RSVP. Some
people are much less consistent (and therefore less credible).

Bert

---

From: [email-masked]
Date: Wed, 1 Apr 1998 10:33:00 -0500 (EST)

> doing other things with their hands. Amazing.

	I don't get it. Voice commands to electronic devices does not 
	necessarily equate to voice traffic on the net. 
> X-Info: 'unsubscribe ion' in the body of the message.

Ismat.

---

From: Albert Manfredi <[email-masked]>
Date: Wed, 01 Apr 1998 10:46:14 -0500

>         necessarily equate to voice traffic on the net.

Personal communication devices are primarily to transfer audio and
video information. Reception of voice commands by the device itself
is incidental; a means to an end. Not the end in itself.

Bert

---

From: [email-masked]
Date: Wed, 1 Apr 1998 11:18:19 -0500 (EST)

> So based on this sort of reasoning one could say that ATM is a dead end. 

	Don't for get that 40% of calls on the PSTN today counted as voice
	calls are actually for Fax and do not have any real time requirements.

Ismat.

---

From: Marvin A Sirbu <[email-masked]>
Date: Wed, 1 Apr 1998 15:52:11 -0500 (EST)

Excerpts from bboard.atm: 1-Apr-98 Re: (ION) IPng Over ATM - O..
[email-masked] (1500*)

> 	calls are actually for Fax and do not have any real time requirements.

I've seen estimates that 40% of *International* PSTN calls are fax. 
That makes sense given time and language differences.  However,
international calls are less than 0.2% of domestic local and toll
traffic in the U.S.*  Given the volume of residential calls which are
rarely fax, nearly 100% of business calls would have to be fax for this
alleged statistic to be correct.

Marvin Sirbu

*For the record, FCC 1996  Statistics show:

Local calls 504 billion
InterLata calls 73 billion
International calls 0.8 billion

---

From: Vadim Antonov <[email-masked]>
Date: Wed, 01 Apr 1998 13:11:43 -0800

> think it is the long-term trend. Let's look at the whole picture.

  Want to bet i spent more time with networks than you did?  I used to
  work for a telephone company, too.  And i still remember what IA-5 is
  about :)

> that just because you can browse the web, you've got all the

  There's a proof by existance of ability of best effort networks to carry voice  or video.  It is no magic, and was around for years.  Heck, there's an entire
  branch of porno idustry built around it.

> people are much less consistent (and therefore less credible).

  I'm consistent because i have an advantage of knowing some mathematics.
  At the current state of that art the problem of routing of virtual circuits of any
  kind (including RSVP) is considered NP-complete.  So all current research in
  multicommodity flows basically devoted to search of algorithms to do sub-optimal
  flow routing without taking forever.  There isn't much progress for networks bigger
  than few hundred nodes.   End of story.

  BTW, in the RSVP crowd you won't find anyone with any credible backgound in
  actual network engineering.  I basically consider RSVP folks juat a different breed
  of "specialists" who didn't bother to learn basics of science in the high school.

  Now, of course one can discuss advantages of ATM in carrying the CBR traffic for
  years and years - to which i can only say: "So what?"  You can't build a global data
  network based on any kind of fat-state gateways anyway.  I do not enjoy watching
  people engaged in mental masturbation to the tune of billions wasted on something
  which can work only by magic.   Isn't it better to accept the limitations of the laws of
  the nature and find another way to solve the problem instead of idly repeating the
  "PNNI will fix everything" mantra?

  BTW, the next time i hear someone telling that "telcos built VC-based global network"
  i'd challenge him to explain how exactly he thinks they did it.  Most likely the person
  wouldn't have a slightest clue about how telcos are working in the real life, and where
  90% of voice capacity go.

--vadim

---

From: Albert Manfredi <[email-masked]>
Date: Wed, 01 Apr 1998 16:44:46 -0500

Vadim Antonov wrote:

>   Want to bet i spent more time with networks than you did?

> I basically consider RSVP folks juat a different breed

Have we gotten the posturing out of the way? Good. (Not that
self-promotion is all bad ...)

>  So all current research in

What's "end of story?" What's wrong with sub-optimal solutions as
long as they are still the best solution?

>   network based on any kind of fat-state gateways anyway.

As long as I continue to measure, reliably, delays varying from 300
to 450 msec or so for transatlantic packet-switched comms, I know
that this solution isn't good enough for the hard stuff.
Fortunately, other options are already available.

>  I do not enjoy watching
>   which can work only by magic.

You apparently enjoy wishing the problem away, even though
sub-optimal solutions exist today.

>   i'd challenge him to explain how exactly he thinks they did it.

The telcos already built a VC-based global network. I challenge you
to live one day without making use of it.

Bert

---

From: Vadim Antonov <[email-masked]>
Date: Wed, 01 Apr 1998 16:43:08 -0800

Albert Manfredi wrote:

> ?  So all current research in
> ?   multicommodity flows basically devoted to search of algorithms to do sub-optimal
> ?   flow routing without taking forever.  There isn't much progress for networks bigger
> ?   than few hundred nodes.   End of story.
>

 Repeating: "There isn't much progress for networks bigger than few hundred nodes".

 Internet is way bigger.

 But it will work anyway, as soon as we all close eyes and wish real real hard, yeah?

--vadim

---

From: [email-masked]
Date: Thu, 2 Apr 1998 08:54:17 -0500 (EST)

> I've seen estimates that 40% of *International* PSTN calls are fax.

	Sorry. Failed to mention International. Thanks for pointing that out.

--Ismat.

---

From: Gary Hanson <[email-masked]>
Date: Thu, 2 Apr 1998 08:32:05 -0800 (PST)

Vadim,

While your comments have been highly entertaining to me and
probably to the whole ion working group, I doubt that they
have been particularly helpful to Sathya, who had originally
solicited opinions of this group with apparent earnestness.

Since you claim to not enjoy watching us waste time and money,
I suggest either that you spend your free time helping review
Sathya's material or finding some other forum to display your
evangelical polemics.

In the meantime, I would hope that if you wish to prolong your
unfocussed bashing of assorted technologies and the people who
choose to spend their time developing them, that you find some
way to state your intentions more clearly, so they could tie
in with the charter of this working group.

Regards,
Gary

P.S.

By the way, thank you for your comments.  While I assume that
they were not intended to be related to April Fools' day, they
were certainly every bit as amusing as if they were.