Subject: Re: [Iot-directorate] [6lo] Shipping RPL Unaware Leaves

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 11 Mar 2020 10:56:02 +0000

Looping to IoT-directorate

-éric

From: 6lo <[email-masked]> on behalf of "Pascal Thubert (pthubert)" <pthubert=[email-masked]>
Date: Wednesday, 11 March 2020 at 09:26
To: "[email-masked]" <[email-masked]>, Routing Over Low power and Lossy networks <[email-masked]>
Cc: Rahul Jadhav <[email-masked]>, Suresh Krishnan <[email-masked]>, Alvaro Retana <[email-masked]>
Subject: [6lo] Shipping RPL Unaware Leaves

Dear all :

As you may know, draft-ietf-roll-unaware-leaves is blocking the whole cluster C130 https://www.rfc-editor.org/cluster_info.php?cid=C310 and we want to ship it now (WG milestone: Mar 2020 - Initial submission). The issue we have with it is the fact that we allow encapsulate the ARO status in a RPL status and we need bits to signal that.

To free the necessary bits the proposal on the table is to reduce the possible values for the ARO status to 0-63.
This can be done by a simple IANA action that can be taken from draft-ietf-roll-unaware-leaves but we wanted to ensure that both ROLL and 6lo agree with the proposal:

12.1.  Resizing the ARO Status values

   IANA is requested to modify the Address Registration Option Status
   Values Registry as follows: The unassigned values range is reduced
   from 11-255 to 11-63.

NB: this will free 2 bits in the Extended Address Registration Option and the Extended Duplicate Address Message, could become handy in the future.

Is there an issue with this that we are missing?

Pascal

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Wed, 11 Mar 2020 15:12:43 +0100

Dear all,

The proposed update is fine with us (Shwetha and Carles), considering the
53 ARO status values that would still be available. There appear to be no
backwards issues either.

Would anyone in the 6Lo WG (or anyone receiving this email) have any
concerns with the proposal below by Pascal and folks?

If yes, please do chime in!

Thanks,

Shwetha and Carles

> Dear all :
>
> As you may know, draft-ietf-roll-unaware-leaves is blocking the whole
> cluster C130 https://www.rfc-editor.org/cluster_info.php?cid=C310 and we
> want to ship it now (WG milestone: Mar 2020 - Initial submission). The
> issue we have with it is the fact that we allow encapsulate the ARO status
> in a RPL status and we need bits to signal that.
>
> To free the necessary bits the proposal on the table is to reduce the
> possible values for the ARO status to 0-63.
> This can be done by a simple IANA action that can be taken from
> draft-ietf-roll-unaware-leaves but we wanted to ensure that both ROLL and
> 6lo agree with the proposal:
>
>
> NB: this will free 2 bits in the Extended Address Registration Option and
> the Extended Duplicate Address Message, could become handy in the future.
>
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo
>