Subject: Re: [Iot-directorate] IETF107 prep call agenda thoughts

From: Ari Keränen <[email-masked]>
Date: Thu, 5 Mar 2020 19:30:43 +0000

Hi Michael & directorate,

Here's what we would propose as updated agenda for the call. Starting with the overview set but keeping that very short, then continuing roughly as you suggested.

* Overview of the IETF/IRTF IoT groups (WG/RG chairs; 1-2 minutes per group)
* New/planned IETF/IRTF IoT activities
  - new IoT WGs / RGs
  - relevant BoFs & side meetings
* Updates from other IoT groups
 - OCF
 - OMA SpecWorks
 - W3C
 - OneDM
 - IoTSF
 - Zigbee/PCHIP
 - ETSI/NIST/other gov efforts
 - etc. 
* Outward advocacy/evangelism towards other groups
 - Presentation materials about IETF work
 - Activities
* General/common issues from IoT-directorate document reviews
* AOB

For the WG/RG overview part there's (usually) no need to go to single document level details, but chairs should focus on general direction (e.g., updated charter or major milestones) and issues that are of wider interest and/or require coordination across groups. We want to keep this part short to give sufficient time for the remaining agenda items.

Since the IoT directorate does not have official liaisons with other groups (IAB takes care of that) I called that agenda item "updates from other IoT groups" instead of liaison.

Sounds good?

Cheers,
Ari

> On 27. Feb 2020, at 16.44, Michael Richardson <[email-masked]> wrote:
> 
> 
> Ari Keränen <[email-masked]> wrote:
>> Absolutely. That would be included into what I was referring to with
>> "highlighting any issues that are of wider interest / require
>> coordination across groups". I was hoping the WG/RG chairs would be up
> 
> Yes, I figured you had this in mind, but I wanted to break us out of the
> inertia of just repeating what we had done before.
> I believe that there was value in the updates, but it is the discussion that
> matters, not the report.
> 
>> Did you have something specific in mind on how we should structure that
>> part of the discussion?
> 
> What I have in mind:
> 1) more explicit liason with/from other IoT groups.
>   * OCF
>   * OCF/Fairhair - (I don't know how integrated it is yet)
>   * IoTSF
>   * Zigbee/CHIP
>   * ETSI,NIST,other governmental efforts
>   * insert yours. Not sure we even have a list.
> 
> 2) outward advocacy/evangelism towards other groups.
>   - part of this was the collection of slides and icons and diagrams on github.
>   - I've pushed lots of things there, but I'm not sure others have been aware.
> 
> 3) general/common issues arising from IoT-DIR reviews of documents.
> 
> 4) discussion about BOFs/WG Chartering efforts that might be ongoing
>   (I'm not aware of any; but that might be ignorance)
> 
> ---
> Some of you may be aware of my push towards some kind of IoT (security)
> lifecycle work.  An emphasis is on the gaps where we either have no
> specification, or where we have too many (XKCD problem).
> 
> 
> Overall, how do we get from current siloed Web-Connected Things, to the
> Inter*NET* of Things that T2TRG/SENML envisions?
> 
> 
> --
> Michael Richardson <[email-masked]>, Sandelman Software Works
> -= IPv6 IoT consulting =-
> 
> 
> 
> -- 
> Iot-directorate mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iot-directorate

---

From: Michael Richardson <[email-masked]>
Date: Fri, 06 Mar 2020 17:45:30 -0500

Ari Keränen <[email-masked]> wrote:
    > Since the IoT directorate does not have official liaisons with other
    > groups (IAB takes care of that) I called that agenda item "updates from
    > other IoT groups" instead of liaison.

Do you have the right people lined up to speak about each group?
So, one item I'd like to cover is whether or not we would like the IAB to
"take care of that"

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 6 Mar 2020 22:48:22 +0000

Hiya,

> So, one item I'd like to cover is whether or not we would like the IAB to

Not sure what you mean? Are we missing some liaisons?
If so, the IAB can fix if asked but I'm not aware that
we've been asked. (Note that the people doing the
liaising from our side are appointed by the IAB but are
almost never IAB members.)

Cheers,
S.

---

From: Ari Keränen <[email-masked]>
Date: Mon, 9 Mar 2020 00:09:42 +0000

> On 7. Mar 2020, at 0.45, Michael Richardson <[email-masked]> wrote:
> 
> 

Given the short notice, I think it’s going to be best-effort reporting this time. I know many directorate members are active in many of these groups so we have at least some coverage, but I have not signed up specific persons for the groups.

If anyone would like to volunteer, please let me know (or put your name in the Etherpad after the group names). 

Cheers,
Ari

---

From: Michael Richardson <[email-masked]>
Date: Mon, 09 Mar 2020 20:38:09 -0400

> Given the short notice, I think it’s going to be best-effort reporting
    > this time. I know many directorate members are active in many of these
    > groups so we have at least some coverage, but I have not signed up
    > specific persons for the groups.

    > in the Etherpad after the group names).

I've done that for IoTSF.
I will write a paragraph to this list in the morning, and I'll post it to the
IoTSF basecamp so they know what I'm saying.

I hope we might have someone who can relate what CHIP is doing (I know
nothing authoritative).  Ditto for OCF/Fairhair.

---

From: Ari Keränen <[email-masked]>
Date: Tue, 10 Mar 2020 06:14:55 +0000

> On 10. Mar 2020, at 2.38, Michael Richardson <[email-masked]> wrote:
> 
> 

Thanks!

> nothing authoritative).  Ditto for OCF/Fairhair.

I asked Michael Koster to join who is well updated about many of the orgs on the list (CHIP, OneDM, IoT schema, etc.). 

Cheers,
Ari

---

From: Michael Richardson <[email-masked]>
Date: Tue, 10 Mar 2020 10:26:20 -0400

Ari, please confirm the IoT DIR meeting is starting in 30 minutes.
{Given North American DST change, I am not 100% certain I got the right thing}

IoTSF paragraph:

The UK IoT Security Foundation held a 1-day conference, the IoT Security Conference
just after IETF106.  There were a lot of interesting things presented.
In particular, an under-appreciated aspect of IoT security relates to partner
abuse. While devices can be used for spying, but a deeper problem is that
people often "outsource" their device setup to another person, and it is difficult
to be sure that the device has been "rekeyed" when that relationship ends.
There were presentations on BRSKI, SUIT, remote attestation (including an
interesting use of a shared ledger).
IoTSF held their quarterly plenary meeting February 13, outlining some
structural changes to how IoTSF organizes work.  Supply Chain Security
has become a very important process.
IoTSF has a building security WG, which has created four stakeholder groups:
Facilities, Manufacturers, Owners and Integrators.
IoTSF has a residential/security document which specifies an architecture,
but the document is not moving forward at this point.

---

From: Ari Keränen <[email-masked]>
Date: Tue, 10 Mar 2020 14:29:02 +0000

Yes. Talk to you in 30 min!

Cheers,
Ari

> On 10. Mar 2020, at 16.26, Michael Richardson <[email-masked]> wrote:
> 
>