Subject: [Iot-directorate] FW: [T2TRG] ASDF BOF (Fwd: [Asdf] New Non-WG Mailing List: asdf)

From: Ari Keränen <[email-masked]>
Date: Wed, 8 Jul 2020 11:33:36 +0000

IoT directorate,

Here's a heads-up from the T2TRG list about the upcoming ASDF BoF ("A Semantic Definition Format for Data and Interactions of Things"). We will hear more about this in the call tomorrow.

Cheers,
Ari

On 7.7.2020, 18.37, "T2TRG on behalf of Carsten Bormann" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

At IETF 108, there will be a BOF with the intent to make the OneDM SDF effort known to the IETF community, and ultimately to win support for taking this protocol to an Internet Standards document in the IETF.

Since much of the IRTF/IETF discussion of SDF so far happened here, I would like to point out that we plan to discuss this in earnest on the mailing list provided, [email-masked]<mailto:[email-masked]>, as described below.  Please subscribe if you want to be a part of this discussion (link below).

If you want to prepare yourself for this discussion, please also have a look at https://onedm.org/<https://protect2.fireeye.com/v1/url?k=3d4bf95d-63eb3b1b-3d4bb9c6-86fc6812c361-a7cab0b882190cfe&q=1&e=e9b7a36d-ae6c-4874-bd5c-7ce515ced9ac&u=https%3A%2F%2Fonedm.org%2F> .
This website is still in the process of being set up, but you will find the information needed to understand the SDF format and the desire to standardize it in ASDF.
(And it is about as no-nonsense as it gets, when it comes to websites like this.)

See you all at the BOF at Tuesday, 2020-07-28 11:00 UTC.
Info/Materials: https://datatracker.ietf.org/wg/asdf/meetings/
Calendar entry: https://datatracker.ietf.org/meeting/108/session/28223.ics
Your local time: https://www.timeanddate.com/worldclock/fixedtime.html?msg=ASDF%20BOF&iso=20200728T11&ah=2

Grüße, Carsten

Begin forwarded message:

Subject: [Asdf] New Non-WG Mailing List: asdf
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Archived-At: <https://mailarchive.ietf.org/arch/msg/asdf/fcpSGLCFRsPEYvLS6qM1AQVBd7k>

A new IETF non-working group email list has been created.

List address: [email-masked]<mailto:[email-masked]>
Archive: https://mailarchive.ietf.org/arch/browse/asdf/
To subscribe: https://www.ietf.org/mailman/listinfo/asdf

Purpose:
One of the hard problems of building large-scale IoT systems is the
lack of common data models for IoT and IoT devices. Each IoT standards
organization, and many IoT platform vendors, have created their own
version of an IoT data model framework, each with a bespoke meta-model
and representation language. To achieve the goal of arriving at a
common set of data and interaction models that describe IoT devices,
the first step to take was to have a common way how to write down a
model. The SDF (Semantic Description Format) has been created in the
One Data Model initiative to serve this purpose. SDF Version 1.0 has
been used to collect some 200 models describing various kinds of IoT
devices, the further development and harmonization of which is what
OneDM will now focus on. The OneDM participants are looking to IETF
to develop SDF to a fully specified, highly interoperable standard
that can serve the IoT community in building systems that cross the
established ecosystems.

This list belongs to IETF area: ART

For additional information, please contact the list administrators.

--
Asdf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/asdf

---

From: "Chakrabarti, Samita" <[email-masked]>
Date: Wed, 8 Jul 2020 10:42:08 -0400

Thanks Ari for sharing the ASDF BOF information.

Also note that going forward, we will need to add
 Drip ( Drone Remote ID protocol) into IOT-DIR view.

Drip is a newly chartered workgroup.  We hope someone will be able to
provide status on it (Daniel?).
https://datatracker.ietf.org/group/drip/about/

Best regards,
-Samita

On Wed, Jul 8, 2020 at 7:33 AM Ari Keränen <ari.keranen=
[email-masked]> wrote:

> IoT directorate,
>
>
>
> Here's a heads-up from the T2TRG list about the upcoming ASDF BoF ("A
> Semantic Definition Format for Data and Interactions of Things"). We will
> hear more about this in the call tomorrow.
>
>
>
>
>
> Cheers,
>
> Ari
>
>
>
> On 7.7.2020, 18.37, "T2TRG on behalf of Carsten Bormann" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>
>
> At IETF 108, there will be a BOF with the intent to make the OneDM SDF
> effort known to the IETF community, and ultimately to win support for
> taking this protocol to an Internet Standards document in the IETF.
>
>
>
> Since much of the IRTF/IETF discussion of SDF so far happened here, I
> would like to point out that we plan to discuss this in earnest on the
> mailing list provided, [email-masked], as described below.  Please
> subscribe if you want to be a part of this discussion (link below).
>
>
>
> If you want to prepare yourself for this discussion, please also have a
> look at https://onedm.org/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__protect2.fireeye.com_v1_url-3Fk-3D3d4bf95d-2D63eb3b1b-2D3d4bb9c6-2D86fc6812c361-2Da7cab0b882190cfe-26q-3D1-26e-3De9b7a36d-2Dae6c-2D4874-2Dbd5c-2D7ce515ced9ac-26u-3Dhttps-253A-252F-252Fonedm.org-252F&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=fxjotOP7pNkx9DUTnSALhpdW8N2WgCzVKqDybepccLI&s=T31KEndmsPWDkDbwMNpp2ccuyYUH4kselXePXtnGfhM&e=>
>  .
>
> This website is still in the process of being set up, but you will find
> the information needed to understand the SDF format and the desire to
> standardize it in ASDF.
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_wg_asdf_meetings_&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=fxjotOP7pNkx9DUTnSALhpdW8N2WgCzVKqDybepccLI&s=MiqtkeAXrKjTF9O8tkwU1cPyLTIaQCb3hGawmxigFN8&e=>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_meeting_108_session_28223.ics&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=fxjotOP7pNkx9DUTnSALhpdW8N2WgCzVKqDybepccLI&s=kkGGXGa_5YKWwPV7CqhtrVf8v5avqgnDBpgzTFrdqRw&e=>
>
> Your local time:
> https://www.timeanddate.com/worldclock/fixedtime.html?msg=ASDF%20BOF&iso=20200728T11&ah=2
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.timeanddate.com_worldclock_fixedtime.html-3Fmsg-3DASDF-2520BOF-26iso-3D20200728T11-26ah-3D2&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=fxjotOP7pNkx9DUTnSALhpdW8N2WgCzVKqDybepccLI&s=v8go0NUM1CH5tnc3KHfXLUpw07S4ttWACuScBYe-vog&e=>
>
>
>
> Grüße, Carsten
>
>
>
>
>
> Begin forwarded message:
>
>
>
> *Subject: [Asdf] New Non-WG Mailing List: asdf*
>
> *Cc: [email-masked], [email-masked], [email-masked]
>
> *Archived-At: *<
> https://mailarchive.ietf.org/arch/msg/asdf/fcpSGLCFRsPEYvLS6qM1AQVBd7k
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_asdf_fcpSGLCFRsPEYvLS6qM1AQVBd7k&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=fxjotOP7pNkx9DUTnSALhpdW8N2WgCzVKqDybepccLI&s=giMgeA0oMbtxpCzgy40H-SUQ89ykJqPKj269kYDfax0&e=>
> >
>
>
>
> List address: [email-masked]
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_browse_asdf_&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=fxjotOP7pNkx9DUTnSALhpdW8N2WgCzVKqDybepccLI&s=f3Pxf8A7Sm0dvtlqR2cLSRCfc1P-NUrxAR7etL7_x70&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_asdf&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=fxjotOP7pNkx9DUTnSALhpdW8N2WgCzVKqDybepccLI&s=ooJVATJlSLhnKySdk25Ice-eQT8LdGTbt28HiqEZ4fA&e=>
>
> Purpose:
> [email-masked]
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_asdf&d=DwQGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=fxjotOP7pNkx9DUTnSALhpdW8N2WgCzVKqDybepccLI&s=ooJVATJlSLhnKySdk25Ice-eQT8LdGTbt28HiqEZ4fA&e=>
>
>
> --
> Iot-directorate mailing list
> [email-masked]
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_iot-2Ddirectorate&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=fxjotOP7pNkx9DUTnSALhpdW8N2WgCzVKqDybepccLI&s=LQTImJkAeMF-loWhEazNR7aqFcwPZLNa0kjlQjKuAGA&e=
>