Subject: [Iot-directorate] Question on IETF IOT-devices scope

From: "Chakrabarti, Samita" <[email-masked]>
Date: Mon, 15 Mar 2021 17:55:49 -0400

Hello All:

In pre-IETF IOT-DIRECTORATE meeting, Ted Lemon has pointed to two documents
regarding connecting the Thread Mesh networks to the traditional IP
Infrastructure:
1) (https://datatracker.ietf.org/doc/draft-lemon-stub-networks-ps/)  -
Problem Statement
2) https://datatracker.ietf.org/doc/draft-lemon-stub-networks/         - A
possible solution

IoT-Directorate co-chairs and the responsible ADs would like to discuss if
it makes sense to extend the IOT-Directorate charter towards less
constrained devices such as some of the home devices considered as 'things'.

The charter of the directorate says : (
https://datatracker.ietf.org/group/iotdir/about/)

"The Internet of Things (IoT) refers to devices, that are often constrained
in communication and computation capabilities, now becoming more commonly
connected to the Internet, and various services that are built on top of
the capabilities these devices jointly provide. It is expected that this
development will usher in more machine-to-machine communication using the
Internet with no human user actively involved."

Should IoT-Directorate members consider Thread Mesh stub networks as one of
topics under IOT-DIR scope of discussion or part of IoT work?

Thanks,

-Samita

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 15 Mar 2021 23:09:44 +0100

On 2021-03-15, at 22:55, Chakrabarti, Samita <samita.chakrabarti=[email-masked]> wrote:
> 
> Should IoT-Directorate members consider Thread Mesh stub networks as one of topics under IOT-DIR scope of discussion or part of IoT work?

The intention of the IETF IoT work was always to enable networks that *include* constrained devices, not to limit the work to just the constrained devices.
So I see no contradiction to discuss less-constrained devices as well.

Grüße, Carsten

---

From: "Schooler, Eve M" <[email-masked]>
Date: Mon, 15 Mar 2021 22:10:19 +0000

For some time, I have been wanting the IETF’s definition of IoT to mean more than constrained devices (Carsten is probably tired of me raising this point in T2T!). While constrained devices are certainly an interesting class of IoT, so are (i) low-latency IoT domains and (ii) Edge IoT contexts that generate lots of data and disrupt where the compute, control, and data management need to reside.
My 2c’s,
Eve

From: Iot-directorate <[email-masked]> On Behalf Of Chakrabarti, Samita
Sent: Monday, March 15, 2021 2:56 PM
To: IETF IoT Directorate <[email-masked]>; Eric Vyncke (evyncke) <[email-masked]>; Ari Keränen <[email-masked]>; Ines Robles <[email-masked]>; Erik Kline <[email-masked]>
Subject: [Iot-directorate] Question on IETF IOT-devices scope

Hello All:

In pre-IETF IOT-DIRECTORATE meeting, Ted Lemon has pointed to two documents regarding connecting the Thread Mesh networks to the traditional IP Infrastructure:
1) (https://datatracker.ietf.org/doc/draft-lemon-stub-networks-ps/)  - Problem Statement
2) https://datatracker.ietf.org/doc/draft-lemon-stub-networks/         - A possible solution

IoT-Directorate co-chairs and the responsible ADs would like to discuss if it makes sense to extend the IOT-Directorate charter towards less constrained devices such as some of the home devices considered as 'things'.

The charter of the directorate says : (https://datatracker.ietf.org/group/iotdir/about/)

"The Internet of Things (IoT) refers to devices, that are often constrained in communication and computation capabilities, now becoming more commonly connected to the Internet, and various services that are built on top of the capabilities these devices jointly provide. It is expected that this development will usher in more machine-to-machine communication using the Internet with no human user actively involved."

Thanks,

-Samita

---

From: Barry Leiba <[email-masked]>
Date: Mon, 15 Mar 2021 18:13:59 -0400

To my sense, the Internet of things is quite broad, and must include
severely constrained devices such as remote sensors, trackers and
actuators, less constrained devices such as home devices (consider smart
TVs and thermostats), and unconstrained devices such as home gateways and
cloud services that support the system.  I consider parts of the
infrastructure such as my calendar to constitute part of the system,
coordinating activities and helping to schedule events.  Amazon Alexa and
that ilk of devices count as well, and aren’t very constrained.

Given that, my answer is “yes”: we need to look at IoT holistically, and
shouldn’t artificially say that we only look at issues involving
constrained devices.

Barry

On Mon, Mar 15, 2021 at 5:56 PM Chakrabarti, Samita <samita.chakrabarti=
[email-masked]> wrote:

> Hello All:
>
> In pre-IETF IOT-DIRECTORATE meeting, Ted Lemon has pointed to two
> documents regarding connecting the Thread Mesh networks to the traditional
> IP Infrastructure:
> "The Internet of Things (IoT) refers to devices, that are often
> constrained in communication and computation capabilities, now becoming
> more commonly connected to the Internet, and various services that are
> built on top of the capabilities these devices jointly provide. It is
> expected that this development will usher in more machine-to-machine
> communication using the Internet with no human user actively involved."
>
> Should IoT-Directorate members consider Thread Mesh stub networks as one
> of topics under IOT-DIR scope of discussion or part of IoT work?
>
> Thanks,
>
> -Samita
>
>
>
> --
> Iot-directorate mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iot-directorate
>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 15 Mar 2021 18:17:22 -0400

Samita, fwiw, Thread is an 802.15.4 6lowpan mesh using technology developed in the IETF, quite a bit of it in “IoT” working groups. I don’t think there’s really any question as to whether this work is IoT-relevant. We’d certainly appreciate review from the IoT directorate when the time is right. 

> On Mar 15, 2021, at 18:10, Schooler, Eve M <[email-masked]> wrote:
> 
> 
> IoT-Directorate co-chairs and the responsible ADs would like to discuss if it makes sense to extend the IOT-Directorate charter
>  towards less constrained devices such as some of the home devices considered as 'things'.
> 
> "The Internet of Things (IoT) refers to devices, that are often constrained in communication and computation capabilities, now becoming more commonly
>  connected to the Internet, and various services that are built on top of the capabilities these devices jointly provide. It is expected that this development will usher in more machine-to-machine communication using the Internet with no human user actively
>  involved."
>

---

From: <[email-masked]>
Date: Tue, 16 Mar 2021 07:36:51 +0000

Hello Samita,

My short answer : definitely “yes”.
My company and myself are interested in the interaction between IoT devices and home networks, and Thread is part of the solution space.
Best regards

Dominique

From: Iot-directorate [mailto:[email-masked]] On Behalf Of Chakrabarti, Samita
Sent: lundi 15 mars 2021 22:56
To: IETF IoT Directorate <[email-masked]>; Eric Vyncke (evyncke) <[email-masked]>; Ari Keränen <[email-masked]>; Ines Robles <[email-masked]>; Erik Kline <[email-masked]>
Subject: [Iot-directorate] Question on IETF IOT-devices scope

Hello All:

Thanks,

-Samita

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 16 Mar 2021 08:57:33 +0000

Exactly : ) 

At some point we'll find that some IoT devices weight and cost a lot more than your average PC. It's more that they have a different model for networking, provisioning, scaling, etc... which forced us to reconsider a number of things and lead so far to CoAP, RPL, 6lo , MUD, etc... If you ask me, DetNet and RAW have more vested interest in IoT than in IT and must remain in scope for the horizontal directorate.

Take care,

Pascal

> -----Original Message-----
> From: Iot-directorate <[email-masked]> On Behalf Of Carsten
> Bormann
> Sent: lundi 15 mars 2021 23:10
> To: Chakrabarti, Samita <samita.chakrabarti=[email-masked]>
> Cc: Erik Kline <[email-masked]>; IETF IoT Directorate <iot-
> [email-masked]>; Eric Vyncke (evyncke) <[email-masked]>; Ari
> Keränen <[email-masked]>; Ines Robles
> <[email-masked]>
> Subject: Re: [Iot-directorate] Question on IETF IOT-devices scope
> 
> On 2021-03-15, at 22:55, Chakrabarti, Samita
> <samita.chakrabarti=[email-masked]> wrote:
> >
> The intention of the IETF IoT work was always to enable networks that
> *include* constrained devices, not to limit the work to just the constrained
> devices.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 16 Mar 2021 09:02:34 +0000

Agreed,

I’m surprise that the question even comes up. Thread, like Wi-SUN, uses IETF (IPv6)  IoT (6LoWPAN) technology.

Certainly I’m sad that they did not go deeper, e.g., 6LoWPAN ND and RPL, like Wi-SUN did. Nonetheless, whether you choose a restrictive (battery operated, wireless, constrained) or a more open approach to what IoT is (including e.g.,  an infrastructure-assisted self-driving car), Thread is part of IoT in any fashion.

Keep safe;

Pascal

From: Iot-directorate <[email-masked]> On Behalf Of [email-masked]
Sent: mardi 16 mars 2021 8:37
To: Chakrabarti, Samita <samita.chakrabarti=[email-masked]>; IETF IoT Directorate <[email-masked]>; Eric Vyncke (evyncke) <[email-masked]>; Ari Keränen <[email-masked]>; Ines Robles <[email-masked]>; Erik Kline <[email-masked]>
Subject: Re: [Iot-directorate] Question on IETF IOT-devices scope

Hello Samita,

Dominique

From: Iot-directorate [mailto:[email-masked]] On Behalf Of Chakrabarti, Samita
Sent: lundi 15 mars 2021 22:56
To: IETF IoT Directorate <[email-masked]<mailto:[email-masked]>>; Eric Vyncke (evyncke) <[email-masked]<mailto:[email-masked]>>; Ari Keränen <[email-masked]<mailto:[email-masked]>>; Ines Robles <[email-masked]<mailto:[email-masked]>>; Erik Kline <[email-masked]<mailto:[email-masked]>>
Subject: [Iot-directorate] Question on IETF IOT-devices scope

Hello All:

Thanks,

-Samita

Thank you.

---

From: Emmanuel Baccelli <[email-masked]>
Date: Tue, 16 Mar 2021 11:47:35 +0100

> *include* constrained devices, not to limit the work to just the
> constrained devices.
>

+1

Concerning terminology: there was a time when the term "IoT device" was too
often misunderstood as *excluding* the microcontroller range.
(Hence docs like RFC7228 and others which needed to spell out some
constraints not to be forgotten.)
Now it seems we amazingly reversed this situation!

Concerning protocols: what is shown to work with less resources, can also
work when more resources are available...

--Emmanuel

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 16 Mar 2021 18:16:44 +0100

Carsten, *:

Imho, no good deed goes unpunished: Maybe because of rfc7228 there is a
little bit of the mis-perception in the IETF that Io(T)hings are primarily things
with such memory/bandwidth/power constraints. Of course, a lot of
low-power networking work the IETF will have overall contributed to this
biased thinking we may have.

I for once think that (T)hings like cars as a device itself constituted
from maybe multiple networks with sub(T)hings will evolve to be a very
nice counter-example: As an electric car its not really power constrained
(definition: if you can waste highly toxic battery stored energy to warm
some passenger buttock, you are not a power constrained device ? ;-). With
maybe even in excess of Gigabits worth of streaming telemetry/video being 
rocessed when autonomous, its also not bandwidth constrained. Arguably not
 in the sense of rfc7228 compute constrained (definition: more compute power
than a current cell-phone is not compute constrained ? ;-).

But such examples and fun with them aside: I think one important "constraint"
 that we have not formalized, but which might be a better/broader classifier for
'non-IT' (T)hings is the absence of a personal caretaker/user for the
device and/or typical user-interface elements through which such a caretaker
can normally or at last in key ops scenarios manage the device: keyboard, mouse,
screen, or even rs232/usb console. Maybe there is some nice new
terminology/classification to be written to amend rfc7228. "Interfacing constrained
devices".

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 16 Mar 2021 10:38:13 -0700

All--
  As someone who works on energy use of devices in buildings, we categorize
devices by their Primary Function - e.g. space conditioning, water heat,
light, etc.  I have long proposed a category of Electronics as devices
whose primary function is Information.  I have NOT studied various IoT
definitions.  To me, IoT are devices whose primary function is other than
Information - really everything not in Electronics - devices whose
primary function is to be interactive with the physical world.  This is
probably most useful as a possible supplement to another definition, not a
replacement.
  I do have an interest in device classification, e.g. from my web page:

   - *Device Classification*. Report on Simple Universal Device
   Classification
   <https://drive.google.com/open?id=0B8B9XW6B7prlc0pfWDNnUlU5dmc>
(2014), Internet
   Draft <http://tools.ietf.org/html/draft-nordman-classification-00> and
   Presentation <http://tools.ietf.org/agenda/82/slides/appsawg-8.pdf> from
   IETF 82. *Taxonomy*
   <https://drive.google.com/open?id=0B8B9XW6B7prlU0tWdVhENDE3ODg> of
   electronic and miscellaneous products (2006)

Thanks.
--Bruce

On Tue, Mar 16, 2021 at 10:17 AM Toerless Eckert <[email-masked]> wrote:

> > > Should IoT-Directorate members consider Thread Mesh stub networks as
> one of topics under IOT-DIR scope of discussion or part of IoT work?
> >

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
*nordman.lbl.gov <http://nordman.lbl.gov>*
[email-masked]
510-486-7089; m: 510-501-7943

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 16 Mar 2021 18:38:28 +0100

Samita:

To answer your question:

a) Like others on this thread, i think we never limited IoT to "constrained" devices.
We just did a lot more work for them than for other (T)hings (like cars and their
networks. I have not followed SUIT, but i could imagine that SUIT and BRSKI work
will reach far beyond constraint Io(T)hings already.

b) I already commented on earlier version(s) of Ted drafts, that i wonder
about the applicability of the work transcending the specific use-cases Ted
has in mind into other (T)hings. I just have not seen good feedback from
folks that could comment from more experience from other use cases, such as
in industrial (T)hings.

For example, from my limited understanding, there are a lot of networks
in industrial use where only IPv4 is used because they like the idea of
being able to achieve really very simple (T)hing software stack by using
fixed addresses, such as 10.0.0.x for the components of some machinery
connected by a simple ethernet and a "gateway" switch. These setups are
then also why you find a lot of static NAT functionality in indistrial
ethernet switches - to connect such stub networks to the next layer of networking.

With ULA in IPv6 we do not even allow for this "generic" addressing model
anymore because you are supposed to allocate a random ULA prefix, and NAT
is looked upon with despise by many IPv6 purists, whereas IPv6/IPv6 NAT6
did evolve though many use cases that evolved from the NAT mindset from that
IPv4 history IMHO. I remember the heated debate about ading IPv6 NAT to
OpenWRT several years back where purists said it shouldn't be done and
i think it exists now in OpenWRT but of course the debate goes on.

Yada yada: I feel that for broader use across various IoT use cases it would
certainly help to better understand addressing desires in more IoT network
types especially industrial. Don't be surprised if there is a lot more
interest in better IPv4 support and all types of NAT as well as "generic"
hard-coded addresses. And i am not making judgement calls 

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 16 Mar 2021 18:46:06 +0100

Nice. Have you checked work around https://tools.ietf.org/html/rfc7460 ?
Maybe thats of interest as well to you. If its missing what you need,
maybe it would still be a good basis to link off any additional information
you think is missing.

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 16 Mar 2021 18:52:43 +0100

> biased thinking we may have.

There is nothing wrong with RFC 7228 (except maybe that we haven’t obsoleted it yet with https://datatracker.ietf.org/doc/html/draft-bormann-lwig-7228bis-06):
It argues that scaling up to the number of Things(*) we actually need requires reducing both the cost of the device itself and the power consumption added by it.  That will maintain a long-term drive to Things that are on the less powerful side (think milliwatt), even if today, still at the bottom of the S-curve, there are lots of wasteful (think watt or more) devices.

Grüße, Carsten

(*) A definition of Thing is in https://www.ietf.org/archive/id/draft-ietf-asdf-sdf-05.html#name-terminology-and-conventions — there is some discussion about the word “device” here (which may be too narrow), but there is no discussion of constrainedness in that definition.

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 16 Mar 2021 11:06:48 -0700

I was co-chair of the EMAN committee that produced 7460 for several years.
  A major concern I had and continue to have is that perpaps 98% of devices
have vastly simpler needs than this standard defines.  By creating such a
complex system, it undermines interoperability and scares away people with
simple needs to use this document at all.  There is nothing wrong with
defining a complex system for niche applications, but that should be in
addition to and after defining a vastly simpler core in its own document.
My take on this topic is at:  ereporting.lbl.gov
  A few years ago we (LBNL) created a demonstration of about a dozen
devices that did Energy Reporting - some for sale today, some modified by
the mfr for us, some modified by LBNL, and some just simple external
metering.  I am hoping to put my data model into a revised version of
CTA-2047, and ideally at some future time revisit the topic within the IETF.
  I am aware that Amazon has recently added Energy Reporting to Alexa; if
anyone has a contact there, please let me know.
  If simple technology is available, then it could be incorporated into
specifications such as Energy Star, appliance standards, or utility rebate
programs.  If the tech is really complex, that will never happen. If it is
simple, there is a good chance.
--Bruce

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 16 Mar 2021 19:26:05 +0100

Thanks. And of course i did not mean that there was anything wrong with
rfc7228, i just think we had a lot more focus on rfc7228 type constrained
devices than other IoT devices, purely because of the work that was brought
to the IETF.

On Tue, Mar 16, 2021 at 06:52:43PM +0100, Carsten Bormann wrote:
> There is nothing wrong with RFC 7228 (except maybe that we haven???t obsoleted it yet with https://datatracker.ietf.org/doc/html/draft-bormann-lwig-7228bis-06):
> (*) A definition of Thing is in https://www.ietf.org/archive/id/draft-ietf-asdf-sdf-05.html#name-terminology-and-conventions ??? there is some discussion about the word ???device??? here (which may be too narrow), but there is no discussion of constrainedness in that definition.

-- 
---
[email-masked]

---

From: "Chakrabarti, Samita" <[email-masked]>
Date: Tue, 16 Mar 2021 17:16:36 -0400

Hi Eve,

That's exactly the point of discussion.
Increasingly more capable  things are communicating with each other. Edge
IoT, Industrial IoT devices are not always sensor like devices.
-Samita

On Mon, Mar 15, 2021 at 6:10 PM Schooler, Eve M <[email-masked]>
wrote:

> For some time, I have been wanting the IETF’s definition of IoT to mean
> more than constrained devices (Carsten is probably tired of me raising this
> point in T2T!). While constrained devices are certainly an interesting
> class of IoT, so are (i) low-latency IoT domains and (ii) Edge IoT contexts
> that generate lots of data and disrupt where the compute, control, and data
> management need to reside.
>
> My 2c’s,
>
> Eve
>
>
>
> *From:* Iot-directorate <[email-masked]> *On Behalf Of *Chakrabarti,
> Samita
> *Sent:* Monday, March 15, 2021 2:56 PM
> *To:* IETF IoT Directorate <[email-masked]>; Eric Vyncke
> (evyncke) <[email-masked]>; Ari Keränen <[email-masked]>;
> Ines Robles <[email-masked]>; Erik Kline <
> [email-masked]>
> *Subject:* [Iot-directorate] Question on IETF IOT-devices scope
>
>
>
> Hello All:
>
>
>
> 1) (https://datatracker.ietf.org/doc/draft-lemon-stub-networks-ps/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dlemon-2Dstub-2Dnetworks-2Dps_&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=U0x-fzru1Ujordzrgva7COkP5xn3GtwG5JhhS2qtIw4&s=VqPca7CSWsZrskHVb-INw1VeP32Dxf15qmYBF4rmxac&e=>)
> - Problem Statement
>
> 2) https://datatracker.ietf.org/doc/draft-lemon-stub-networks/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dlemon-2Dstub-2Dnetworks_&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=U0x-fzru1Ujordzrgva7COkP5xn3GtwG5JhhS2qtIw4&s=mAQ7UwXAQQoANvN4Y7RELbPXsvDPlevt24wcnpsvSq0&e=>
>        - A possible solution
>
>
>
> https://datatracker.ietf.org/group/iotdir/about/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_group_iotdir_about_&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=U0x-fzru1Ujordzrgva7COkP5xn3GtwG5JhhS2qtIw4&s=o0Owo7Uj2IPHX9RzrPvu0N3ChAjjoNLJPIZps8SL-_0&e=>
> )
>

---

From: "Chakrabarti, Samita" <[email-masked]>
Date: Tue, 16 Mar 2021 17:27:42 -0400

Yes, no doubt ThreadsMesh  was based on IEEE802.15.4 technologies.
Connecting them to the IP infrastructure  through some kind of gateway
perhaps should fall into IoT discussions as well. In addition,  these
documents will give us an excuse to find out whether the community thinks
if IoT@IETF should consider things beyond 'constrained nodes'. ( AR/VR
devices, video cameras, mobile robots etc.).

Thanks,
-Samita

On Mon, Mar 15, 2021 at 6:17 PM Ted Lemon <[email-masked]> wrote:

> Samita, fwiw, Thread is an 802.15.4 6lowpan mesh using technology
> developed in the IETF, quite a bit of it in “IoT” working groups. I don’t
> think there’s really any question as to whether this work is IoT-relevant.
> We’d certainly appreciate review from the IoT directorate when the time is
> right.
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dlemon-2Dstub-2Dnetworks-2Dps_&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=JmPuPyXeTxAqlOhoomieUSjR1F-J-7-eL4Ub7YpU6q8&s=EsbR7QFbAcsYvaomP7jcEG73FIvpFzimUpIdNwM9YaA&e=>)
> - Problem Statement
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dlemon-2Dstub-2Dnetworks_&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=JmPuPyXeTxAqlOhoomieUSjR1F-J-7-eL4Ub7YpU6q8&s=u3aYELf8UGT75ecqZrLh-3Pt2hErPna1AX8v0gkX9xk&e=>
>        - A possible solution
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_group_iotdir_about_&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=JmPuPyXeTxAqlOhoomieUSjR1F-J-7-eL4Ub7YpU6q8&s=0HMolfPtiinE0XngAgopm6NaScvoub4M65CdlAMFJD8&e=>
> )
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_iot-2Ddirectorate&d=DwQFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=JmPuPyXeTxAqlOhoomieUSjR1F-J-7-eL4Ub7YpU6q8&s=3_w4hICnJUQNS-UFffCngzwJR8Uv8ghTEwWBU-VBoUk&e=>
>
>

---

From: "Chakrabarti, Samita" <[email-masked]>
Date: Tue, 16 Mar 2021 17:29:17 -0400

Thanks Dominique!
-Samita

On Tue, Mar 16, 2021 at 3:36 AM <[email-masked]> wrote:

> My company and myself are interested in the interaction between IoT
> devices and home networks, and Thread is part of the solution space.
>
> Best regards
>
>
>
> Dominique
>
>
>
> *From:* Iot-directorate [mailto:[email-masked]] *On
> Behalf Of *Chakrabarti, Samita
> *Sent:* lundi 15 mars 2021 22:56
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dlemon-2Dstub-2Dnetworks-2Dps_&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=wqjqsMRMpDbUGneYWmqaHWvFiRPB8YhdotfwMsDaj4U&s=Ki2vDC0bHFBa0KwwObN4lRjo6cyEyWEGswXpMesiLUw&e=>)
> - Problem Statement
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dlemon-2Dstub-2Dnetworks_&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=wqjqsMRMpDbUGneYWmqaHWvFiRPB8YhdotfwMsDaj4U&s=7AFmn6VUTtBu9HCj8_NBGVtgRoABc8YNMel6j1YcSDY&e=>
>        - A possible solution
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_group_iotdir_about_&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=wqjqsMRMpDbUGneYWmqaHWvFiRPB8YhdotfwMsDaj4U&s=LCy5Jv-f0hjYsTfWr3fYjkHykWna1tayAo5wD4JSGqg&e=>
> )
>

---

From: "Chakrabarti, Samita" <[email-masked]>
Date: Tue, 16 Mar 2021 17:49:49 -0400

Hi Toerless,

Thanks for your analysis on IETF IoT related work so far. Agreed.
Industrial devices are indeed an interesting ones. Interestingly enough
they can use multiple different access technologies (cellular or  shared
wireless technologies) . It would be interesting to find out if they can
use existing IETF constrained or non-constrained protocols (  Pascal
mentioned about RAW and detnet) and communicate over multiple access
technologies.

Thanks,
-Samita

On Tue, Mar 16, 2021 at 1:38 PM Toerless Eckert <[email-masked]> wrote:

> documents
> > 1) (
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dlemon-2Dstub-2Dnetworks-2Dps_&d=DwIBAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=5VO3FbRsXyVfbb4laHvJRZD3JUjwaKuKLuLPezbwk3s&s=lJPDOR3qTbNYy6iNNVtgqc3aCXvA3RRo8I9tpwPpfgc&e=
> )  -
> > Problem Statement
> > 2)
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dlemon-2Dstub-2Dnetworks_&d=DwIBAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=5VO3FbRsXyVfbb4laHvJRZD3JUjwaKuKLuLPezbwk3s&s=rtYUJ0dekrVK3F_NKaSPl1Rgyn6HSsYQtmslFc7durE&e=
>         - A
> > possible solution
> >
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_group_iotdir_about_&d=DwIBAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=5VO3FbRsXyVfbb4laHvJRZD3JUjwaKuKLuLPezbwk3s&s=_fPrQ_9s3HeUgcjnyu8MfBtCli6IrS4RVxsEV-RaWS4&e=
> )
> >
> constrained
> of
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_iot-2Ddirectorate&d=DwIBAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=5VO3FbRsXyVfbb4laHvJRZD3JUjwaKuKLuLPezbwk3s&s=8jeH3ZPxfcuFv-zEDNpiyoRm-lw4SWUJHM0000PL_zs&e=
>
>
> --
> ---
> [email-masked]
>

---

From: "Chakrabarti, Samita" <[email-masked]>
Date: Tue, 16 Mar 2021 17:56:29 -0400

Thanks Barry, for your comments.

>From the list discussions, it appears that IoT@IETF definition is not
confined to 'low-power constrained' devices any more.

Thanks to all for the feedback.
-Samita

On Mon, Mar 15, 2021 at 6:14 PM Barry Leiba <[email-masked]> wrote:

>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dlemon-2Dstub-2Dnetworks-2Dps_&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=hHN-lkRuhgkC8QGwa5IclnCoOqQJxuq-cLUiGdX6kC0&s=-wgXAAFXs38XMsB3tJg6ctUm3gQy8yfcCCaj_L__85k&e=>)
>> - Problem Statement
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dlemon-2Dstub-2Dnetworks_&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=hHN-lkRuhgkC8QGwa5IclnCoOqQJxuq-cLUiGdX6kC0&s=Rp-ITDKuq38e_cbSRd1BuQw6pCRdcfS23A-2YSpDAGU&e=>
>>        - A possible solution
>>
>> IoT-Directorate co-chairs and the responsible ADs would like to discuss
>> if it makes sense to extend the IOT-Directorate charter towards less
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_group_iotdir_about_&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=hHN-lkRuhgkC8QGwa5IclnCoOqQJxuq-cLUiGdX6kC0&s=cZ3B7VYgVUFL3QEIz7elvDeZjsWvZ1UzO4aGykm0xg4&e=>
>> )
>>
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_iot-2Ddirectorate&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=pWMzx7FsqijEJPyfMBfn-HJss-wVVTf0K5y-cxCTXL8&m=hHN-lkRuhgkC8QGwa5IclnCoOqQJxuq-cLUiGdX6kC0&s=gA7ZOVLWQumNoue5I06xHsyxZkxCgTOYLajjSc_zWcA&e=>
>>
>