Subject: Re: [Iotops] can we create protocols that securely transfer ownership?

From: Michael Richardson <[email-masked]>
Date: Sun, 01 Nov 2020 11:00:28 -0500

William_J_G Overington <wjgo_10009=[email-masked]> wrote:
    > I am wondering if the issue of being able to recover the original software
    > for a thing could be solved by some infrastructure something like it being
    > good practice for the manufacturer of the thing to produce a hexadecimal dump
    > of the software and publish it in a PDF (Portable Document Format) document
    > and for that PDF document to be deposited at The British Library in
    > accordance with the legal deposit regulations together with a note permitting
    > The British Library to supply a copy to anyone for a fee. The document could
    > also be made available on the manufacturer's website, yet legal deposit at
    > The British Library would mean that the document would still be available
    > even if the manufacturer went out of business and the website was no longer
    > available.

While there is an issue of how to maintain software beyond the lifetime of
the (interest of the marketing department) of the manufacturer, the bigger
picture is that the device is cryptographically locked to running on software
approved (digitally signed) by the manufacturer.

We actually *need* this kind of lockdown in order to keep malware out.
But, one person's weed is another person's wild-flower.

Having the hexdump doesn't help us much.  We basically already have that.
Often we have the entire source code, but we still can't load it into the
device because we don't have the keys that are baked (literally: by laser
blown fuses into the silicon) into the device.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Toerless Eckert <[email-masked]>
Date: Sun, 1 Nov 2020 17:51:25 +0100

> But, one person's weed is another person's wild-flower.

Many ways to cut the cake:

IMHO, devices MUST permit to override TA for secure boot/software with
owner TA, so i can securely allow for it to only run software i as the
owner sign. And those TA ultimately would be what identifies the owner.
More so, then any certificate (because the TA designate who can do something
with the device).

In addition, i would want vouchers that sign with my own TA the cert
of a vendor signed piece of software, so i can install such software.

Most classical use-case: Do not permit arbitrary staff to install
random vendor software versions, but only those that have been verified
and approved by some testing department. And those vouchers might
be short-lived, so that installation can only happen in a time window
before a likely better updated software version would be preferrable.
Or later downgrade without permission.

> blown fuses into the silicon) into the device.

Laser blown fuses sounds expensive. We had OTP memory forever.

Cheers
    Toerless

> -- 
> Iotops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iotops

-- 
---
[email-masked]

---

From: William_J_G Overington <[email-masked]>
Date: Mon, 2 Nov 2020 08:03:22 +0000 (GMT)

Could it be the custom and practice of this mailing list that upon first 
use of an abbreviation in a post that the meaning is stated in full 
please?
Recently I had to look up OTP, I think I found the correct meaning but I 
am not congruently sure.
I am still trying to find out what TA means.
When, in another venue, I included mention of a
PDF (Portable Document Format) document
I was informed that readers would know what PDF meant.
So it is a balance. My training was to always explain an acronym the 
first time one uses it, because some readers might not know the meaning 
of the acronym.
So, I am retired, at home, just trying to take an interest and 
participate, I am not "at" an organization and I am "not representing an 
organization", but hopefully that is fine with the people who are "at" 
or are "representing an organization".
William Overington
Monday 2 November 2020

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 2 Nov 2020 11:45:47 +0100

Hello William,

thank you for chiming in and speaking out. Sometimes conversations 
migrate to a place - hitting the road running - and that can make it 
more difficult to join such conversations.

TA typically refers to a Trust Anchor in this context. That word is 
given a well-scoped meaning in RFC4949.

Viele Grüße,

Henk

On 02.11.20 09:03, William_J_G Overington wrote:
> use of an abbreviation in a post that the meaning is stated in full please?
>

---

From: William_J_G Overington <[email-masked]>
Date: Mon, 2 Nov 2020 12:38:39 +0000 (GMT)

Hello Henk

Thank you.

Best regards,

William

------ Original Message ------
From: "Henk Birkholz" <[email-masked]>
To: "William_J_G Overington" 
<wjgo_10009=[email-masked]>; [email-masked]
Sent: Monday, 2020 Nov 2 At 10:45
Subject: Re: [Iotops] Use of abbreviations
Hello William,

Viele Grüße,

Henk

William Overington

Monday 2 November 2020

-- 
Iotops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iotops 
<https://www.ietf.org/mailman/listinfo/iotops>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 3 Nov 2020 08:45:14 +1300

FYI, the RFC Editor maintains a list of abbreviations. A few of them are marked as "well known" and can be used in RFCs (and by implication in drafts) without expansion. Otherwise, the policy is that abbreviations should be expanded when first used or in a Terminology section.

The list is at https://www.rfc-editor.org/materials/abbrev.expansion.txt

TA and OTP are both listed, but without an asterisk, so they should be expanded in drafts. However, it's a big ask for people to expand them in emails, IMHO.

Regards
   Brian Carpenter

On 03-Nov-20 01:38, William_J_G Overington wrote:
>     To: "William_J_G Overington" <wjgo_10009=[email-masked]>; [email-masked]
>     thank you for chiming in and speaking out. Sometimes conversations migrate to a place - hitting the road running - and that can make it more difficult to join such conversations.
> 
> 
> 
>     TA typically refers to a Trust Anchor in this context. That word is given a well-scoped meaning in RFC4949.
> 
> 
> 
> 
> 
>     Viele Grüße,
> 
> 
> 
>     Henk
> 
> 
> 
>     			Could it be the custom and practice of this mailing list that upon first use of an abbreviation in a post that the meaning is stated in full please?
> 
> 
> 
>     Recently I had to look up OTP, I think I found the correct meaning but I am not congruently sure.
> 
> 
> 
>     So it is a balance. My training was to always explain an acronym the first time one uses it, because some readers might not know the meaning of the acronym.
> 
> 
> 
>     So, I am retired, at home, just trying to take an interest and participate, I am not "at" an organization and I am "not representing an organization", but hopefully that is fine with the people who are "at" or are "representing an organization".
> 
> 
> 
>     William Overington
> 
> 
> 
>     Monday 2 November 2020
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
>     -- 
> 
>     Iotops mailing list
> 
>     [email-masked]
>