Subject: [Iotops] Fwd: I-D Action: draft-iotops-km-iiot-frwk-00.txt

From: Kiran Makhijani <[email-masked]>
Date: Mon, 25 Oct 2021 13:37:27 -0700

Hello iotops,
As per the feedback from last meeting, we came up with a sketch of framework for Industrial networks. We hope to have more discussions and receive feedback on this document.

If you are interested in improving or contributing to the text, please reach out to us.
Cheers,
Kiran

---------- Forwarded Message ---------
From: [email-masked]
Subject: I-D Action: draft-iotops-km-iiot-frwk-00.txt
Date: Oct 25 2021, at 1:05 pm
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Title : Framework For Integrated Industrial Networks
Authors : Kiran Makhijani
Lijun Dong
Filename : draft-iotops-km-iiot-frwk-00.txt
Pages : 16
Date : 2021-10-25

Abstract:
Industry control networks host a diverse set of non-internet
protocols supporting Industrial-IoT and legacy device connections.
The integration between traditional information technology (IT) and
operational technology (OT) so far has centered around collection of
real-time data from devices in OT environment for consumption within
the enterprise IT networks. However, improvements in process control
and automation require a far better interworking between the OT and
IT applications. This document provides a reference framework for
integrated industry networks (IIN). It highlights interfaces and
their characteristics required for interconnecting components of OT
and IT that maybe moved to the cloud or edges. It suggests the use
of IIN to bridge the differences between OT and IETF technologies.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-iotops-km-iiot-frwk/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-iotops-km-iiot-frwk-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Michael Richardson <[email-masked]>
Date: Tue, 26 Oct 2021 13:25:11 -0400

Kiran Makhijani <[email-masked]> wrote:
    > As per the feedback from last meeting, we came up with a sketch of
    > framework for Industrial networks. We hope to have more discussions and
    > receive feedback on this document.

Last time, we were discussing:
     I-D.draft-km-industrial-internet-requirements

I have reviewed the "iiot-frwk" document, but I don't really know what you
intend to do with it.  You've described a whole bunch of pieces, but I can't
really see a proposal in that satisfies:

from your abstract:
    > It suggests the use

Section 5 deals with this, but if you intend to propose something, I've
missed it.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide