Subject: [Iotsi] Open Translators to Things

From: "Jean Paoli (MS OPEN TECH)" <[email-masked]>
Date: Tue, 5 Apr 2016 18:47:21 +0000

I was not able to come to IETF 95 in Buenos Aires but I hope to see many of you in other venues and online.

At the workshop, a few weeks ago, I said that we were doing some initial work on Translation (per our paper<https://www.iab.org/wp-content/IAB-uploads/2016/03/IoT-Information-Model-Interoperability-IAB-Workshop-March-2016-Jean-Paoli-Taqi-Jaffri.pdf>) and that I will share this work to inform the conversation that we started in Santa Clara so here it is:
We released today, as alpha code,  Open Translators to Things<http://www.opentranslatorstothings.org/> as an open source project on GitHub: Blog<http://blogs.windows.com/buildingapps/2016/04/04/open-translators-to-things-an-open-approach-for-accessing-similar-things/>, Website<http://www.opentranslatorstothings.org/>, GitHub<http://www.github.com/opent2t>, Channel9 end user<https://channel9.msdn.com/series/opent2t/Open-Translators-to-Things-Introduction-for-Users> and developer<https://channel9.msdn.com/series/opent2t/Getting-Started-with-Open-Translators-to-Things> videos and we welcome contributions. As an alpha code, we tested on Windows, OS X, Azure, Amazon and are almost there for Android (a few days). The goal is to work for Things in both the consumer and industry areas.

The open source project is cross-platforms and cross-protocols - We defined very little in the project : we used open standards everywhere and schema creation for Things is not the goal of this project. We hope the industry will create schemas (many participants in the workshop are already doing this) and, as discussed in the workshop, we also hope schema syntaxes (we called them models in the workshop) converge and progress is done (per the workshop) on defining common terms for  semantic interop.

Our project is focusing on Translation and is introducing this 3 steps concept I described in the paper<https://www.iab.org/wp-content/IAB-uploads/2016/03/IoT-Information-Model-Interoperability-IAB-Workshop-March-2016-Jean-Paoli-Taqi-Jaffri.pdf> where we treat in a disconnected way schemas and APIs of real Things and connect them through open source translators. Obviously, native implementation of schemas by Things will always be preferable but we believe that the reality of the industry is making Translation a very practical solution to provide common APIs (a common schema) for developers accessing Things. In the project, we want to use cross-platform JavaScript/Node libraries (other languages later, per community feedback) for each protocol to map similar things to a schema (a Bluetooth light or HTTP light to a Light schema). And as mentioned earlier, we hope schemas are created by the industry (not in this project) but Translations are creating in the project.

Again, this is alpha code so we are looking to shape the project on GitHub with the community and with the participants of the workshop. We would love feedback/discussions/passionate disagreements or agreements :) and most importantly code contributions as we truly care about cross-platform semantic interop for Things.

-Jean Paoli

---

From: "Jean Paoli (MS OPEN TECH)" <[email-masked]>
Date: Tue, 5 Apr 2016 19:02:28 +0000

Blog at https://blogs.windows.com/buildingapps/2016/04/05/open-translators-to-things-an-open-approach-for-accessing-similar-things/

From: Jean Paoli (MS OPEN TECH)
Sent: Tuesday, April 5, 2016 11:47 AM
To: [email-masked]
Subject: Open Translators to Things

-Jean Paoli