Subject: Re: IP only on the default channel?

From: "Hattig, Myron" <[email-masked]>
Date: Wed, 7 Oct 1998 09:56:32 -0700

Heejin,

On Tuesday, October 06, 1998 5:35 PM, Lee, Hee-Jin
[SMTP:[email-masked]] wrote:
> Isochronous stream is not serving IP unicast, you mean?
> Would you tell me the reason?

It could be used for unicast, but It creates a performance problem. All IP
devices look at all
packets on the broadcast channel.
If a unicast packet is put on the IP broadcast channel, the recipient would
receive it correctly.
However, the problem is all other IP devices would have to examine this IP
packet, determine it is not
destined for them, then toss the packet. This would most likely be done in
software, where as
usually hardware (link chip) examines the address to determine if the packet
received should
be passed up the protocol stack. This limits the number of times the
software must process
interrupts.

> I believe IP unicast over stream service is really useful.

Please expand on this thought.

-myron

---

From: Kenji Fujisawa <[email-masked]>
Date: Thu, 8 Oct 1998 09:40:08 +0900

Myron,

>> Isochronous stream is not serving IP unicast, you mean?
   ==================

>devices look at all packets on the broadcast channel.
                                    =================

It seems there is a mis-communication.

:   8.2 Isochronous IP unicast
:
:   Unicast IP datagrams that require quality of service shall be contained
:   within the data payload of 1394 isochronous stream packets.
:   The details of coordination between nodes with respect to allocation of
:   channel number(s) and bandwidth are beyond the scope of this standard.

Regards,

Kenji Fujisawa

---

From: "Lee, Hee-Jin" <[email-masked]>
Date: Thu, 8 Oct 1998 11:47:25 +0900

Hattig, Myron wrote:

> It could be used for unicast, but It creates a performance problem.
>All IP devices look at all packets on the broadcast channel.

On the IP braodcast channel?  Well...
How about "IP unicast over any of normal channels" for various purpose?
Suppose IEC 1883-CMP is used.

1. establishing point to point connection
If IP-capable-node can allocate a channel number and bandwidth like any
other nodes,
it will let the next-hop destination, a 1394 node, know the channel
number.
This means destination's hardware comparator was set to determine the
channel.

2. send and receive
After point to point connection established, the sender strats
transmission and
the link-layer-control(LLC) determines streams while the PHY relays
stream data.

3. breaking the connection

> destined for them, then toss the packet.

If one iso-channel is used for a IP-unicast, h/w can cover all
dtermination!

        +------1394 link------+
        |  +---------------+  |
        |  |    Bus I/F    |  |
        |  +---------------+  |
        |  +---------------+  |
        |  |      DMA      |  |
        |  +---------------+  |
        |  +---------------+  |
        |  |     FIFO      |  |
        |  +------^--------+  |
        |  +------|--------+  |
        |  | LLC  ^   x    |  |
        |  +------|---|----+  |
        +---------|---|-------+
                  |   |
        +-------- |---|-------+
        |  PHY    |   |       |
        |         |   |       |
        |         |   |       |
 CH#2-->|---------|---+------>|---->
 CH#1-->|---------+---------->|---->
        +---------------------+

+------------------------------LLC------------------------------------+
|(comparitor1) (comparitor2) (comparitor3) (comparitor4) (comparitor5)|
+---------------------------------------------------------------------+

>This would most likely be done in
> software, where as