Subject: Re: Ignore ARP requests from remote buses

From: "Hattig, Myron" <[email-masked]>
Date: Thu, 15 Oct 1998 12:15:52 -0700

Kenji,

Thanks for the comments. I'm not sure what Peter's latest thinking is
on the clause. What is your latest thinking? I thought the clause
would say something like the following:

"ARP packets (requests or responses) will be ignored if the node ID
(source or target) does not have the most significant 10 bits matching
the most significant 10 bits of the Node_id register of the node
receiving the ARP packet."

-myron

> -----Original Message-----
> From: Kenji Fujisawa [mailto:[email-masked]]
> Sent: Thursday, October 15, 1998 9:49 AM
> To: [email-masked]
> Subject: Re: Ignore ARP requests from remote buses
>
> > Here are three possible next steps:
> > 1) Add the clause suggested by Peter, move forward with the draft.
> > 2) Delay the draft until we have a clear understanding of
> what coexistences
> > of IP and bridges requires from both IP devices and bridges.
> > 3) Do not add the clause suggested by Peter and move
> forward with the draft.

<deleted>

>
> So, I think option (1) will be the safe way we can choose at this
> moment.
> As others mention, this clause will not prevent IP routing
> between 1394
> busses.
>
> Kenji Fujisawa
> # All opinions are my own and do not reflect my employers

---

From: Kenji Fujisawa <[email-masked]>
Date: Fri, 16 Oct 1998 10:16:25 +0900

>What is your latest thinking? I thought the clause

I think it is sufficient with respect to ARP.

I noticed another thing in section "5. NETWORK PROTOCOL MANAGER (NPM)".
In step g) and i), there are desctiptions of "a broadcast write request"
for the NETWORK_CHANNELS register.
This "broadcast write request" SHALL NOT be propageted across the
bridge. I think it's better to add a note like the following:

   NOTE: The broadcast write request for the NETWORK_CHANNELS
   register SHALL NOT be propageted across the bridge. The NPM SHALL
   either
     set the most significant 10 bits of the NODE_IDS register
     in the destination_bus_ID,
   or
     set 0x3FF in the source_bus_ID.

This issue is irrelevant to the virtual node ids.

Best Regards,

Kenji Fujisawa