Subject: Re: DHCP use of Node ID

From: "Hattig, Myron" <[email-masked]>
Date: Tue, 1 Dec 1998 10:23:45 -0800

Kenji,
> -----Original Message-----
> From: Kenji Fujisawa [mailto:[email-masked]]

...

> Even if the server is aware of bus resets, the server can not know
> the new nodeID since the server can not use ARP yet.

This brings up another issue with the DHCP document, should it
include a discussion of what a server should do after a bus
reset when the server sits on the 1394 link?

...

> All we have to consider is, the case when the server (or the
> relay agent) will wish to use the 'chaddr'.
>
>         Client ---(broadcast)--> Server
>                <---- ???? ------
>
>         Client ---(broadcast)--> Relay ---(unicast)---> Server
>                <---- ???? ------       <--(unicast)----
>
>                                 (Note: Relay and Server may exist
>                                                  on another 1394)
>
> My idea is,
>     DHCP client on the 1394 does not put its hardware address
>     in the DHCP request. 'hlen' equals zero.
>     Set BROADCAST flag to request the server (or the relay) to
>     send a broadcast reply.
>
> This will eliminate the burden of handlling a link header at
> the DHCP server or the relay agent, and this does not break the
> DHCP(RFC2131) context.
>
> What do you think of?

Does this mean never use chaddr in 1394 networks?
Does this mean always use broadcast?

If the answer is yes to either question, the proposed solution seems
too restrictive. Instead it is better to explain the problems with
some recommendations, then let the implementer decide.

-myron

---

From: Kenji Fujisawa <[email-masked]>
Date: Wed, 2 Dec 1998 10:11:55 +0900

>reset when the server sits on the 1394 link?

I don't see any issue unless the server holds nodeID in 'chaddr'
field.
I'd like to avoid 1394-specific action as far as I can,

>Does this mean never use chaddr in 1394 networks?

Yes.

>Does this mean always use broadcast?

No.
It is descrived in RFC2131 which DHCP messages should be an unicast.
For example,
  DHCP messages between the relay agents and the DHCP server
  DHCPINFORM and its response
  DHCPOFFER/DHCPACK if 'ciaddr' in corresponding DHCP request is non-zero
  DHCPREQUEST during RENEWING state
  DHCPRELEASE
  etc.
In these case, ARP can/should be used to get the link-layer address.

I don't wish to re-write the DHCP spec itself.

Kenji Fujisawa