Subject: Unit Directory

From: "Hattig, Myron" <[email-masked]>
Date: Mon, 21 Dec 1998 12:24:26 -0800

If there are proposals for the unit directory, please post.
These are the things I've come up with so far ...

Use IANA OUI for Spec Unit ID. Value is 0x000054.

Use concatenation of EtherType and ARP Hardware Type
for Unit_Sw_version. EtherType identifes either IPv4
or IPv6, the 1394 hardware Type (0x18) provides further
identification to the specs we are producing.

For future issues, we may want to consider a Node_Capabilities
entry for each RFC supported by the node. The value
could be the ascii representation of the RFC number.
We know there will be an RFC for IPv4 over 1394. There
may be RFCs for IPv6/1394, SNMP, and DHCP. We may
also have another IPv4/1394 for bridge aware devices.

Other stuff to consider is the 1394 info in the ARP
packet of node_speed, max_rec, and offset.

-myron

---

From: Kenji Fujisawa <[email-masked]>
Date: Thu, 24 Dec 1998 11:07:59 +0900

>Use IANA OUI for Spec Unit ID. Value is 0x000054.

It must be a typo. 0x00005e.

>identification to the specs we are producing.

I think that a hardware type can be found by bus_info_block
and just an EtherType is enough.
One octet reserved field may be used to identify a future revision.

>packet of node_speed, max_rec, and offset.

I don't think we need these entries in the unit_directory.
(A link_spd and a max_rec is in the bus_info_block)

Regards,

Kenji Fujisawa

---

From: Myron Hattig <[email-masked]>
Date: Sun, 27 Dec 1998 00:11:41 -0800

> It must be a typo. 0x00005e.

Yup 0x00005e is the correct number.

-myron