Subject: OHCI query

From: Vasudev Mulchandani <[email-masked]>
Date: Thu, 10 Jun 1999 02:37:17 MDT

OHCI gurus !

We came across an event code while transferring data.

We have connected a Windows NT5.0 w/s to our OHCI adapter on an
embedded system. The NT w/s recognizes our card but when we try
to issue a read request for a CSR Register, our Device Driver
builds a Response and transmits it. On starting the DMA engine
for AT Response, we get an event code of 0xA (event_timeout) .. which means a
timeout has occured and then the active bit of the context is
cleared but the run bit is still set !! To be precise.. the contents
of the OHCI AT Response context register (offset 0x1a0) is 0x800A.

Why does this event timeout occur .. does it have anything to do with the
link to link ack not being exchanged ??

Note that when we issue a read to Config Rom, it succeeds because this
request is serviced by PRU and not the s/w..

SOS !!

--vasu

____________________________________________________________________
Get free e-mail and a permanent address at http://www.netaddress.com/?N=1

---

From: Nagaraj G <[email-masked]>
Date: Thu, 10 Jun 1999 16:42:36 +0530

Hi Vasu,

You need to program the "TimeStamp" value in the *Immediate descriptor. The
explanation on how to program his is given in the spec.

Raj

-----Original Message-----
From: IETF IP over 1394 Working Group
[mailto:[email-masked]]On Behalf Of Vasudev Mulchandani
Sent: Thursday, June 10, 1999 2:07 PM
To: [email-masked]
Subject: OHCI query

OHCI gurus !

for AT Response, we get an event code of 0xA (event_timeout) .. which means
a

SOS !!

--vasu