Subject: Re: IP over 1394 isoc useful?

From: Takeshi Saito <[email-masked]>
Date: Mon, 14 Jun 1999 01:22:10 +0900

Tom,

Tom> Although doing video over IP over 139 is nice as experiment, I don't see
Tom> the real need for it in the near future in the home if we already have
Tom> video over 61883 over 1394. The 61883 formats (MPEG) will be the main
Tom> (and only?) digital real-time streaming video format deliverered to and
Tom> existing in the home for entertainment purposes for a long time. Whether
Tom> we need to work on a video over IP standard should be determined by the
Tom> need of an application for which no solution yet exists. Non-real time
Tom> transfers can be solved today with existing protocols including SBP-2,
Tom> DPP, (non-isoch) IP over 1394, ...

Two things.

Video (and Audio) applications do not limited to what is defined on 61883.
MPEG4, MP3, H263, and so on. We have already had many "Internet AV"
applications (including IP based MPEG2 server), therefore to bind them and
1394-iso-capability is necessary.

Second point is that the AV data can transfer via several networks, like
from 1394 to ethernet. Maybe 61883/RTP gateway is another idea to consider.

(What I am concering is what happend on ATM. ATM forum defined many
"AV over ATM" formats, but many are still using "AV over IP over ATM",
instead of "AV over ATM". I know the situation is different
(many CE venders have already shipped 61883 based systems), but I
also believe "AV over IP" over iso1394 will be needed sometime.

Tom> If this group decides to do the isoch-IP over 1394 work, at least the
Tom> 61883 CIP format and CMP protocols should be used as the basis to
Tom> prevent that new real-time protocols (and hardware) are needed.

Please note that our draft also proposes how IP application controls
61883 AV flows.

Regards.

--
Takeshi "Ken" Saito

Toshiba R&D center      [email-masked]

---

From: ikob <[email-masked]>
Date: Mon, 14 Jun 1999 02:11:03 +0900

Saito-san,

I believe many people regards AV over IP over 1394 as you said as QoS.
The things you said seems to be treated in the RSVP and ISSLE frame work.
If QoS control is done within local firewire network, there is no worth in
heterogenious IP world.

                                              [email-masked]

From: Takeshi Saito <[email-masked]>
Subject: Re: IP over 1394 isoc useful?
Date: Mon, 14 Jun 1999 01:22:10 +0900
Message-ID: <[email-masked]>

saiken> Tom,
saiken>
saiken> Tom> Although doing video over IP over 139 is nice as experiment, I don't see
saiken> Tom> the real need for it in the near future in the home if we already have
saiken> Tom> video over 61883 over 1394. The 61883 formats (MPEG) will be the main
saiken> Tom> (and only?) digital real-time streaming video format deliverered to and
saiken> Tom> existing in the home for entertainment purposes for a long time. Whether
saiken> Tom> we need to work on a video over IP standard should be determined by the
saiken> Tom> need of an application for which no solution yet exists. Non-real time
saiken> Tom> transfers can be solved today with existing protocols including SBP-2,
saiken> Tom> DPP, (non-isoch) IP over 1394, ...
saiken>
saiken> Two things.
saiken>
saiken> Video (and Audio) applications do not limited to what is defined on 61883.
saiken> MPEG4, MP3, H263, and so on. We have already had many "Internet AV"
saiken> applications (including IP based MPEG2 server), therefore to bind them and
saiken> 1394-iso-capability is necessary.
saiken>
saiken> Second point is that the AV data can transfer via several networks, like
saiken> from 1394 to ethernet. Maybe 61883/RTP gateway is another idea to consider.
saiken>
saiken> (What I am concering is what happend on ATM. ATM forum defined many
saiken> "AV over ATM" formats, but many are still using "AV over IP over ATM",
saiken> instead of "AV over ATM". I know the situation is different
saiken> (many CE venders have already shipped 61883 based systems), but I
saiken> also believe "AV over IP" over iso1394 will be needed sometime.
saiken>
saiken> Tom> If this group decides to do the isoch-IP over 1394 work, at least the
saiken> Tom> 61883 CIP format and CMP protocols should be used as the basis to
saiken> Tom> prevent that new real-time protocols (and hardware) are needed.
saiken>
saiken> Please note that our draft also proposes how IP application controls
saiken> 61883 AV flows.
saiken>
saiken> Regards.
saiken>
saiken> --
saiken> Takeshi "Ken" Saito
saiken>
saiken> Toshiba R&D center      [email-masked]
saiken>