Subject: InterOp issues

From: "Aditya Dube (Exchange)" <[email-masked]>
Date: Thu, 18 Nov 1999 13:47:29 -0800

1) Tag Value in AsyncStream Packets:

            The latest spec for 1394a specifies that the header of an
AsyncStream Packet will be set to 3.
            The older specs mention that this value is to be set to 1.
            To be in accordance with the latest draft, we will use 3, but
can change it to 1 in the debugger if required to get past this issue.

        2) Config Rom support:
            As we reported previously, our stack currently expects that any
IP-1394 device will support the new config rom as specified by the
            draft. If this is an issue, please let us know and we can try to
work around this.

       Thanks
       Aditya Dube

---

From: Nagaraj G <[email-masked]>
Date: Fri, 19 Nov 1999 08:19:57 +0530

Hi Aditya,

1) I don't think the tag value should be a problem for a transmitter. The
only problem is for a receiver if he has filtering setup for tags other than
tag3. We support both ways. In case the tag is different in the receive
side, the listener can differentiate by the first two quadlets of the data
that specify the type of packet.

2) On this, do you require other default information in the root directory
like Node Capabilities entry, Node Vendor ID entry, Vendor text leaf which
you normally expect to identify the capabilities of the destination device?

Thanks

G. Nagaraj
Senior Software Engineer
EnThink Inc.
37, Castle Street, Ashok Nagar,
Bangalore - 560 025, India
Phone: +91-80-536-7297 Ext: 211
Fax: +91-80-557-6032
www.EnThink.com

-----Original Message-----
From: IETF IP over 1394 Working Group
[mailto:[email-masked]]On Behalf Of Aditya Dube (Exchange)
Sent: Friday, November 19, 1999 3:17 AM
To: [email-masked]
Subject: InterOp issues

        2) Config Rom support:

       Thanks
       Aditya Dube