Subject: RE: Per SFID counters in CMTS

From: Jason Schnitzer <[email-masked]>
Date: Tue, 24 Aug 1999 11:29:07 -0600

Hi Guenter,

SIDs are already mapped to admitted or active SFIDs in the
docsQosServiceFlowTable... Is it such a stretch to count SFID octets? 

Bottom line, MSOs need CM octet counters in both upstream and downstream
implemented in the CMTS. Per SFID granularity makes the most sense.

Jason

-----Original Message-----
From: Guenter Roeck [mailto:[email-masked]]
Sent: Tuesday, August 24, 1999 10:53 AM
To: [email-masked]
Subject: Re: Per SFID counters in CMTS

per sid was easy, as the hw provides it.
does the hw provide the sfid ?

guenter

> 
> Folks,
> 
> The RF MIB currently includes per CM/SID upstream octet counters in the
CMTS
> service table and downstream counters in the CM ifTable -- good for
counting
> upstream octets, somewhat cumbersome for determining per CM downstream
> volume.
> 
> Forgive me if I've missed something, but have we defined per SFID up/down
> octet counters (in CMTS) for 1.1 yet?
> 
> Cheers,
> Jason
>

---

From: Guenter Roeck <[email-masked]>
Date: Tue, 24 Aug 1999 10:43:00 -0700 (PDT)

If there is a direct way to get the SFID, it is ok.

If the SFID has somehow to be determined from the 
packet contents (e.g., by analyzing IP addr/udp port etc,
things get nasty. Essentially, everyting that depends
on some kind of search algorithm gets nasty and will kill
performance (and/or cost), no matter how much CPU or HW
you throw into it.

I did not follow things close enough to know for sure.
All I know is that I keep shaking my head (and I am
constantly trying to find some wall to bang my head against)
when our engineers try to explain why the DOCSIS 1.1 code
has to be that complicated.

[ That something is mapped in some MIB does not explain
  how the mapping is created in the first place.
  Does the docsQosServiceFlowTable explain how the 
  mapping is created ? ]

Anyway, this is just a minor detail anyway, given the complexity
of DOCSIS 1.1. No need to bother about.

Thanks,
Guenter