Subject: (IPng 7522) Yet another Dynamic Tunnel Configuration Protocol

From: Peter Tattam <[email-masked]>
Date: Thu, 13 May 1999 14:27:48 +1000 (EST)

I am publishing a draft specification of a tunnel configuration protocol that I
have designed and implemented.  Another implementation was quickly
developed by the KAME group, to which we obtained good interoperability.

HTTP://jazz-1.trumpet.com.au/ipv6-draft/dtcp-draft-prt-13-may-1999.htm

Comments either to me or to the lists.

I will be using this protocol or further derivations of it to roll out IPv6 to
our regular IPv4 internet customers. 

Apologies if this is sent to the wrong lists, or if I have duplicated the work
of others.  I did review the tunnel broker model and I believe that this
protocol can only serve to complement it.

Peter

--
Peter R. Tattam                            [email-masked]
Managing Director,    Trumpet Software International Pty Ltd
Hobart, Australia,  Ph. +61-3-6245-0220,  Fax +61-3-62450210

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Jeff Williams <[email-masked]>
Date: Thu, 13 May 1999 02:23:42 +0100

Peter and all,

  The URL you are listing does not resolve either.  "No DNS Entry".
Do you possibly have a URL with this information on your
Trumpet.com domain?

> protocol can only serve to complement it.

Regards,

--
Jeffrey A. Williams
CEO/DIR. Internet Network Eng/SR. Java/CORBA Development Eng.
Information Network Eng. Group. INEG. INC.
E-Mail [email-masked]
Contact Number:  972-447-1894
Address: 5 East Kirkwood Blvd. Grapevine Texas 75208

---

From: Bill Manning <[email-masked]>
Date: Thu, 13 May 1999 04:25:32 -0700 (PDT)

Odd, it resolves just fine.

; <<>> DiG 8.1 <<>> jazz-1.trumpet.com.au 
;; res options: init recurs defnam dnsrch
;; got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 8, ADDITIONAL: 7
;; QUERY SECTION:
;;      jazz-1.trumpet.com.au, type = A, class = IN

;; ANSWER SECTION:
jazz-1.trumpet.com.au.  1D IN A         203.5.119.62

-- 
--bill

---

From: Magnus Ahltorp <[email-masked]>
Date: 13 May 1999 14:52:08 +0200

> Comments either to me or to the lists.

"Once a tunnel is established, the client may use normal tunnel
protocols for IPv6 tunnelling using the endpoints supplied by the
server, typically over IP port 41."

I would suggest using the term "IP protocol 41" instead of "IP port
41".

"It is important to note that in this protocol, the <empty string> is
a valid command and should result in a -ERR response."

If it is a valid command, why should the command result in a -ERR
response? Why is the <empty string> a valid command?

"Unrecognized commands should invoke a -ERR response."

"Any other commands are totally ignored by the tunnel server, and no
response must be sent."

It is just me, or is this inconsistent? The latter tells me that
unrecognized commands must result in no response, but the former tells
me that it should result in a -ERR response.

The quit command response is actually specified to be "+OK tunnel
server quitting" which I think should be "+OK <optional comment>"
which is consistent with the example in the appendix.

/Magnus

---

From: Peter Tattam <[email-masked]>
Date: Fri, 14 May 1999 09:12:19 +1000 (EST)

A fresh draft with corrections is now available.

HTTP://jazz-1.trumpet.com.au/ipv6-draft/dtcp-draft-prt-14-may-1999.htm

---

From: Jeff Williams <[email-masked]>
Date: Thu, 13 May 1999 22:11:11 +0100

Peter and all,

  maybe this is why your listed URL is showing partly lame here
Peter.

 http://www.aunic.net/cgi-bin/whois?trumpet.com.au shows
No match for "TRUMPET.COM.AU"

Also:
however, http://www.aunic.net/cgi-bin/whois.aunic?trumpet.com.au
shows the following for trumpet.com.au :

domain:      trumpet.com.au
descr:       Trumpet Software International
descr:       GPO Box 1649
descr:       Hobart
descr:       TAS 7001
admin-c:     PT1-AU
tech-c:      SDB200-AU
zone-c:      PT1-AU
remarks:     Created 19950731
changed:     [email-masked] 19970120
source:      AUNIC

person:      Peter Tattam
address:     GPO Box 1649
address:     Hobart
address:     TASMANIA 7001
phone:       +61 02 450220
fax-no:      +61 02 450210
e-mail:      [email-masked]
nic-hdl:     PT1-AU
remarks:     (Organisation) Trumpet Software International
remarks:     Created 19960409
changed:     [email-masked] 19981105
source:      AUNIC

person:      Simon David de Bomford
address:     24 Cambridge Road
address:     Bellerive
address:     TAS 7018
phone:       +61 3 6245 0220
fax-no:      +61 3 6245 0210
e-mail:      [email-masked]
nic-hdl:     SDB200-AU
remarks:     (Organisation) Trumpet Software International
remarks:     (position) Network Manager
remarks:     Created 19961029
changed:     [email-masked] 19961029
source:      AUNIC

Regards,