Subject: Re: (ngtrans) what pieces are actually missing

From: Marc Blanchet <[email-masked]>
Date: Wed, 09 Jun 1999 09:10:24 -0400

Randy,
	This is a good short list and a good food of thoughts.

	I would like to make a small comment about application support, where the
iesg is saying "essentially non-existent". Well, it is true that in the MS
world, it is "essentially non-existent", but if you look at the ports done
by the Kame people, it has everything you need and more! you can run a
complete IPv6 unix workstation or server with about everything you need:
web, mail, telnet, ssh, multicast tool, even a MP3 player and server!
	here is an abstract of a recent kame ports directory:

Makefile        ethereal        inn             mrt             python
    squid11         v6tun
XFree86         fetchmail       kaffe           ncftp3          qmail
    ssh             vat6
altq            fwtk6           libident6       newbie
rev_v6_address  tcp_wrapper     vnc
apache12        gated-ipv6      lynx            perl5           rsync
    tcpd6           wbd
apache13        geta            mediator        pident6d        ruby
    tcptrace        wget
bind8           heimdal         mozilla         popper          sendmail6
    ucd-snmp        wu-ftpd
ct              icecast         mpg123          ppp             socks64
    v6eval          zebra

	so I would propose to change the iesg statement to: "application support:
very good on some platforms, essentially non-existent on others".

Regards, Marc. 

At 23:43 99-06-08 -0700, Randy Bush wrote:
>in an iesg discussion, we started to wonder what pieces were missing if one
>wanted to do widescale ipv6 deployment.  we came up with some guesses which
>are appended.
>
>we also thought about what would happen if we merely wanted to make an ietf
>terminal room ipv6-only.
>
>wg comments on both would be appreciated.
>
>randy
>
>
>IPv6 - what it does, and what does moving forward without deployment mean
>-  IPv6 is at draft
>-  IPv6 addressing is at Proposed
>-  Sequence of what we need
>   1 DNS    AAAA               - Proposed
>            A6                 - I-D
>   2 IP
>     - IPV6                    - Draft
>       (TCP, UDP)
>     - ICMP                    - Draft
>     - Neighour Discovery      - Draft
>     - Path MTU                - Draft
>     - Stateless Addr Autocfg  - Draft
>   3 IP over foo               - Proposed
>   4 MIBs                      - Proposed
>   5 Routing
>     - BGP extensions          - Proposed (but run on IPv4)
>     - RIPng                   - Proposed
>     - OSPF extensions         - I-D
>     - IBGP                    -
>     - ISIS                    - ??
>   6 IPsec                     - Proposed
>     Kerberos no (carries addresses)
>   7 SNMP mostly
>   8 Applications
>     FTP                       - Proposed
>     domain/address Literals   - ???
>     Fax
>   9 DHCPv6 ??
>   10 Multicast ?? (PIM spec I-D??)
>
>- Implementation status
>  - Host  - IP stack support
>    available for some 30 platforms (not many as product)
>  - Router - CPE equipment avilable off-the-shelf
>             (obsolete equipment/code, code is not off-the-shelf)
>    no 7500-class router available
>    viable to route IPv6 using MPLS?
>  - Application support
>    essentially not existent
>  - RDNS support (Bind 8.2 - AAAA - over v4 only)
>  - SNMP support (none)
>  - Ping and Traceroute exist
>

-----------------------------------------------------------
Marc Blanchet			| [email-masked]
Viagénie inc.			| http://www.viagenie.qc.ca
3107 des hôtels		| tél.: 418-656-9254 
Ste-Foy, Québec		| fax.: 418-656-0183
Canada, G1W 4W5		| radio: VA2-JAZ
------------------------------------------------------------
Internet Engineering Standards/Normes d'ingénierie Internet
               http://www.normos.org
------------------------------------------------------------

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Randy Bush <[email-masked]>
Date: Wed, 9 Jun 1999 09:02:00 -0700 (PDT)

> if you look at the ports done by the Kame people, it has everything you
> need and more! you can run a complete IPv6 unix workstation or server with
> about everything you need: web, mail, telnet, ssh, multicast tool, even a
> MP3 player and server!

excellent!  thanks marc.

randy

---

From: "’·“‡@•ü‰p" <[email-masked]>
Date: Thu, 10 Jun 1999 15:28:11 +0900

> web, mail, telnet, ssh, multicast tool, even a MP3 player and server!

I think there are some projects in MS world.For example, Hitachi supplies
Toolnet6 by which we can run   IPv4 application to  IPv6 .

For more infomation, http://www.hitachi.co.jp/Prod/comp/network/pexv6-e.htm
.

Thanks.