Subject: RE: IPv6 for mobile telephony

From: Thomas Eklund <[email-masked]>
Date: Mon, 28 Jun 1999 15:53:48 +0200

> -----Original Message-----
> From: Lloyd Wood [mailto:[email-masked]]
> Sent: Monday, June 28, 1999 3:14 PM
> To: Thomas Eklund
> Cc: 'Hossam Afifi'; [email-masked]; [email-masked]'
> Subject: RE: IPv6 for mobile telephony
> 
> 
> On Mon, 28 Jun 1999, Thomas Eklund wrote:
> 
> > Chapter4:
> > You will NEVER use IPsec over GSM or GPRS due to the 
> overhead! You already
> > have ciphering today over the air and that does not introduce any
> > overhead... This is handeled at layer 2 in GSM/GPRS....
> 
> Er, what overhead?
> 
> The only real security is end-to-end security. Air-interface-only
And I dont argue you on that e-2-e security is the only way but in GSM and
GPRS it dont work that way...:-(

> encryption provided by someone else isn't security. How can you claim
> that ciphering over the air not introduce any overhead, when you claim
> that IPsec does?
You will never use IPsec for securing the air... Because that is already
done at Layer 2 in GSM and the ciphering mechanism used to NOT add any bits
compared to IPsec that at least add a ESP or AH header... In other words if
you use IP as switching mechanism you will never have it over the air...

If you want e-2-e security for your app that is a totally different
question... And not part of the GSM system... 

> 
> IPSec _will_ be increasingly used over GSM and GPRS. Any drafts in
> this area should address this.
What do you actually mean here... In GPRS and GSM there is NO way a user can
have e-2-e security! The security offered is for securing the network access
over radio and securing the handovers in a MSC area... And if you use IP and
IP sec over GPRS/GSM I dont care,but the thing is you dont use it in GPRSand
GSM over the radio,you CAN use it in GPRS between SGSN:s (i.e between
different Radio access networks) in the GPRS Tunnel Protocol (GTP) which is
similar to mobileIP but on L2. But GPRS still uses GSM ciphering over the
air and NOT IPsec...

Regards 
 Thomas Eklund, SwitchCore

Perhaps a clarifying picture:

     GMSC          GGSN
       |            |
      MSC          SGSN
       |            |
(Voice)|____ _______|(packet)
           | |
           BSC
     ______ |___________
     |                 |
    BS                 BS
    |                   |
GSM  terminal     GPRS terminal

This is how it looks like in GSM and in GPRS, The thing is that they use the
same radio access network (i.e. GSM) and GPRS allocates timeslots from GSM
for datatraffic... But they still use the same radio access networks and
they do not use ipsec between the terminals and MSC, SGSN...

> 
> L.
> 
> 
> If you want secure voice communications over GSM, you might buy two of
> these mobile handsets: http://www.crypto.ch/product/hc2000_e.html#end
If you have security in the handset its a different thing and its up to the
user what kind of security he/she wants...

> 
> > > -----Original Message-----
> > > From: Hossam Afifi [mailto:[email-masked]]
> > > Sent: Thursday, June 24, 1999 7:53 PM
> > > To: [email-masked]
> > > Subject: IPv6 for mobile telephony
> > > 
> > > 
> > > 
> > >  A draft has been sent to the internet draft secretary on 
> > > IPv6 in Mobile
> > > Telephony
> > >  the document is also available from
> > > http://www.rennes.enst-bretagne.fr/~afifi/e164ipv6.asc
> > > 
> > >  your comments are welcomed.
> > > 
> > > Hossam
> 
> <[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>
> 
> 
> 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Lloyd Wood <[email-masked]>
Date: Mon, 28 Jun 1999 15:02:49 +0100 (BST)

On Mon, 28 Jun 1999, Thomas Eklund wrote:

> Lloyd Wood wrote: 

You will. 

It will simply be tunnelled within the GSM air security. You can
tunnel crypto just as you can tunnel anything else.

L.

'over the air' means different things to different people.