Subject: KAME stable release 19990809

From: [email-masked]
Date: Tue, 10 Aug 1999 12:49:03 +0900

As usual, KAME Project has released "stable" packages of IPv6/IPsec
network code for FreeBSD 2.2.8/3.2, NetBSD 1.4, and BSD/OS 3.1.

These packages are free of charge but absolutely no warranty. They are
avaiable from the following web site:

        http://www.kame.net/

NOTE: IF YOU GAIN ACCESS TO THIS WEB PAGE OVER IPv6, THE TURTLE WILL
DANCE.

The changes from the previous official release are shown below. These
packages have been tested by the TAHI team(http://www.tahi.org).

--KAME Project

---from here
Here are summary of recent changes prior to this STABLE kit (19990802).

<<IPv4>>

<<IPv6>>
- More spec-conformant source address selection for NA output.
- ND6 IsRouter behavior against redirect packet is fixed.
- On router, ND6 code wrongly generated too many redirects toward source.
  It is now fixed.
- NetBSD now uses single source code for tcp4/6.
- IPv6 path mtu discovery for NetBSD.
- Kernel data structure for prefix management is splitted to router (advertise)
  side and host (receive) side.

<<IPv6 API>>
- Partly sync'ed to new advanced API, 2292bis.
- IPV6_CKSUM now works correctly against jumbograms.

<<IPsec>>
- New IPsec policy engine on all the platforms.
- IPv4 tunnel/transport mode, and IPv6 tunnel/transport mode can be
  generated.  IPv6 tunnel mode cannot be imposed on a packet forwarding
  case at this moment so there's no router use for it, though.
- IPsec code was too strict about SA direction (inbound, outbound or
  bidirectional).
- Separated IPSEC_ESP from IPSEC kernel config option for countries where
  crypto export is restricted (for example, united states).
- IPComp (IP payload compression) support.

<<Userland>>
- rtsol: timing parameter fixed to conform to ND6 draft.
- bgpd: properly handle an empty AS path.
- ftp: protection against bogus return code from some of ftp daemons.
- pim6dd: filtering (configured pruning) of multicast routing-capable
  interfaces.
- Various additions, such as pim6sd (PIM multicast routing on IPv6, sparse
  mode), tftp/tftpd on NetBSD, and so forth.
- net.inet6.ip6.kame_version sysctl MIB (which shows the KAME version you
  are using).

<<Others>>
- ATM PVC pseudo interface support in KAME/NetBSD.
- ALTQ is upgraded.
- ports/pkgsrc: upgraded base version for many items in the collection.
- ports/pkgsrc additions: pfs, rsync
- ports/pkgsrc removals: IM
---to here

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: [email-masked]
Date: Thu, 12 Aug 1999 09:28:09 +0900

Hi there,

TAHI Project has opened the IPv6 Conformance Test Packages and test reports
about KAME IPv6 network code (http://www.kame.net/)
at the following web site:

	http://www.tahi.org/report/

Changes from the previous release of the IPv6 Conformance Test Packages:

      The Test Tool (Release-0.3): 
        - support the definition of TCP Header
        - ported FreeBSD 3.2
      The Test Program (Release-0.3): 
        - Neighbor Discovery : Redirect messages for a host
        - IPv6 Specificatoin : (new)
        - stateless-addrconf : Many documents were refined

The following test report done with the Test Packages were opened: 

        - freebsd228-stable-19990809

---
TAHI Project